APT-GET [RESOLVIDO]

1. APT-GET [RESOLVIDO]

Frederico
koi45

(usa Ubuntu)

Enviado em 01/03/2015 - 18:36h

Sempre que tento instalar algo resulta nisso
E: Cannot get debconf version. Is debconf installed?
debconf: apt-extracttemplates falhou : Arquivo ou diretório não encontrado
dpkg: problemas com dependências impedem a configuração de libc6:amd64:
libc6:amd64 depende de libgcc1; porém:
Pacote libgcc1 não está instalado.

dpkg: erro ao processar o pacote libc6:amd64 (--configure):
problemas de dependência - deixando desconfigurado
dpkg: problemas com dependências impedem a configuração de multiarch-support:
multiarch-support depende de libc6 (>= 2.3.6-2); porém:
Pacote libc6:amd64 não está configurado ainda.

dpkg: erro ao processar o pacote multiarch-support (--configure):
problemas de dependência - deixando desconfigurado
Erros foram encontrados durante o processamento de:
libc6:amd64
multiarch-support
E: Sub-process /usr/bin/dpkg returned an error code (1)




  


2. MELHOR RESPOSTA

Gustavo Nascimento
marcianoloko

(usa Manjaro Linux)

Enviado em 01/03/2015 - 19:36h

Você deve ter editado o arquivo de forma incorreta.
É necessário remover todo o bloco de texto sobre o arquivo defeituoso e atualizar o cache para corrigir.
Imagem: http://i.imgur.com/HWBtkQZ.png

PS.: E realmente o Ubuntu está muito instável.

3. Re: APT-GET

Gustavo Nascimento
marcianoloko

(usa Manjaro Linux)

Enviado em 01/03/2015 - 19:20h

Eu tive o mesmo erro ao tentar instalar um driver da Epson. Acredito que seja um erro comum, pois encontrei muitos casos em outros fóruns.
Não sei exatamente qual é a causa do problema, mas eu resolvi alterando um arquivo do gerenciador e atualizando-o.




Primeiro tente da maneira mais simples:
sudo apt-get clean
sudo apt-get autoremove
sudo apt-get update
sudo apt-get upgrade

Caso não funcione, tente da seguinte maneira:
sudo gedit /var/lib/dpkg/status 
- Procure pelo bloco de informações do pacote defeituoso (no seu caso o libgcc1) e apague-o.
- Salve o arquivo e feche.
- Agora volte ao Terminal e atualize.
sudo apt-get update
sudo apt-get upgrade




4. Re: APT-GET [RESOLVIDO]

Clodoaldo Santos
clodoaldops

(usa Linux Mint)

Enviado em 01/03/2015 - 19:21h

Qual ubuntu VC está usando?

Seu ubuntu está atualizado,?


5. Re: APT-GET [RESOLVIDO]

Frederico
koi45

(usa Ubuntu)

Enviado em 01/03/2015 - 19:25h

marcianoloko escreveu:

Eu tive o mesmo erro ao tentar instalar um driver da Epson. Acredito que seja um erro comum, pois encontrei muitos casos em outros fóruns.
Não sei exatamente qual é a causa do problema, mas eu resolvi alterando um arquivo do gerenciador e atualizando-o.




Primeiro tente da maneira mais simples:
sudo apt-get clean
sudo apt-get autoremove
sudo apt-get update
sudo apt-get upgrade

Caso não funcione, tente da seguinte maneira:
sudo gedit /var/lib/dpkg/status 
- Procure pelo bloco de informações do pacote defeituoso (no seu caso o libgcc1) e apague-o.
- Salve o arquivo e feche.
- Agora volte ao Terminal e atualize.
sudo apt-get update
sudo apt-get upgrade




Hey, fiz todo o processo e no final deu isso
Lendo listas de pacotes... Erro!
E: Encountered a section with no Package: header
E: Problem with MergeList /var/lib/dpkg/status
E: As listas de pacotes ou os arquivos de estado não puderam ser analisados ou abertos.




6. Re: APT-GET

Frederico
koi45

(usa Ubuntu)

Enviado em 01/03/2015 - 19:26h

clodoaldops escreveu:

Qual ubuntu VC está usando?

Seu ubuntu está atualizado,?




14.10. Estou tendo problemas para atualizar.


7. Re: APT-GET [RESOLVIDO]

Clodoaldo Santos
clodoaldops

(usa Linux Mint)

Enviado em 01/03/2015 - 19:32h


Esse 14.10 está bugado demais... Ficou 1 semana meu HD ... Voltei para 14.04


8. Re: APT-GET [RESOLVIDO]

Clodoaldo Santos
clodoaldops

(usa Linux Mint)

Enviado em 01/03/2015 - 19:34h

Já testou estes comandos:
sudo rm /var/lib/apt/lists/lock
sudo rm /var/lib/dpkg/lock
sudo apt-get update
sudo apt-get upgrade



9. Re: APT-GET [RESOLVIDO]

Frederico
koi45

(usa Ubuntu)

Enviado em 01/03/2015 - 19:40h

marcianoloko escreveu:

Você deve ter editado o arquivo de forma incorreta.
É necessário remover todo o bloco de texto sobre o arquivo defeituoso e atualizar o cache para corrigir.
Imagem: http://i.imgur.com/HWBtkQZ.png

PS.: E realmente o Ubuntu está muito instável.


TInha pensado que deveria excluir apenas as partes com o titulo do arqv.
Obrigado aos dois!


10. Agradecimento

Luciano
luciano_scsp

(usa Ubuntu)

Enviado em 05/09/2016 - 23:13h

Passei por um problema parecido e com as dicas deste tópico consegui resolver.
Valeu, mesmo!


11. Mesmo erro no Antix(Debian Jessie)

Uéliton Alves dos Santos
AlvesUeliton

(usa Debian)

Enviado em 18/01/2017 - 14:23h

Linux antix1 4.4.10-antix.1-amd64-smp #1 SMP PREEMPT Mon May 16 15:56:14 EEST 2016 x86_64 GNU/Linux
Encountered a section with no Package: header
Problem with MergeList /var/lib/dpkg/status
As listas de pacotes ou os arquivos de estado não puderam ser analisados ou abertos.
Can't call method "policy" on an undefined value at /usr/bin/apt-show-versions line 56.
E: Problem executing scripts APT::Update::Post-Invoke-Success 'test -x /usr/bin/apt-show-versions || exit 0 ; apt-show-versions -i'

Resolvi desta forma:
sudo mv /var/lib/dpkg/status /var/lib/dpkg/status-RENAMED
sudo cp /var/lib/dpkg/status-old /var/lib/dpkg/status
sudo apt-get update && sudo apt-get upgrade

fonte: https://ubuntuforums.org/showthread.php?t=863742&page=3






Patrocínio

Site hospedado pelo provedor RedeHost.
Linux banner
Linux banner

Destaques

Artigos

Dicas

Tópicos

Top 10 do mês

Scripts