Scanner da Multifuncional Canon 3110 não é reconhecido

1. Scanner da Multifuncional Canon 3110 não é reconhecido

Leonardo Lemos
lemions

(usa XUbuntu)

Enviado em 12/06/2020 - 16:30h

Instalei o Zorin OS Lite no meu PC e conectei a impressora. A parte de impressão foi uma maravilha, mas o scanner da impressora não é reconhecido nem a pau. Já entrei no site da Canon pra ver se tinha os drivers dela, mas não tem.
Alguém com uma multifuncional sabe se tem como fazer o scanner funcionar?
Obrigado desde já!


  


2. Re: Scanner da Multifuncional Canon 3110 não é reconhecido

Stanislaus K
StanislausK

(usa FreeBSD)

Enviado em 12/06/2020 - 18:24h

Ola,

como o Zorin OS é baseado no Ubuntu/Debian... eu uso Epson... basta instalar o drive da Epson, que vale tanto para impressão como scanner... tente usar outro programa para scanner, como xSane... no terminal digite o comando sudo apt install xsane

De acordo com esse tutorial para instalar Canon, o seu modelo é suportado:

Drivers da Canon – veja como instalar o suporte a impressora ou scanner
https://www.edivaldobrito.com.br/drivers-da-canon-veja-como-instalar/

veja também esse tópico no VOL:

Impressora Canon G3100 no linux mint [RESOLVIDO]
https://www.vivaolinux.com.br/topico/Novo-no-Linux/Impressora-Canon-G3100-no-linux-mint

Para imprimir e scannear você esta usando usb ou wifi?


3. Re: Scanner da Multifuncional Canon 3110 não é reconhecido

Leonardo Lemos
lemions

(usa XUbuntu)

Enviado em 12/06/2020 - 21:15h

StanislausK escreveu:

Ola,

como o Zorin OS é baseado no Ubuntu/Debian... eu uso Epson... basta instalar o drive da Epson, que vale tanto para impressão como scanner... tente usar outro programa para scanner, como xSane... no terminal digite o comando sudo apt install xsane

De acordo com esse tutorial para instalar Canon, o seu modelo é suportado:

Drivers da Canon – veja como instalar o suporte a impressora ou scanner
https://www.edivaldobrito.com.br/drivers-da-canon-veja-como-instalar/

veja também esse tópico no VOL:

Impressora Canon G3100 no linux mint [RESOLVIDO]
https://www.vivaolinux.com.br/topico/Novo-no-Linux/Impressora-Canon-G3100-no-linux-mint

Para imprimir e scannear você esta usando usb ou wifi?


Valeu mano, mas esses tutoriais também não deram certo.
Eu já testei o xsane mas ele também não mostrou o scanner.
No site da Canon não tem os drivers da minha impressora para Linux, e os drivers do Windows também não deram certo (eu pelo menos não sei se dá pra instalar driver do Windows no Linux).
Também não encontrei nada pelo Synaptic. Tem alguma coisa errada com esse repositório indicado no tutorial do Edivaldo
sudo add-apt-repository ppa:inameiname/stable 
Parece que ele não funciona mais, alguma coisa assim.
A impressora está conectada pelo usb mesmo



4. Re: Scanner da Multifuncional Canon 3110 não é reconhecido

Stanislaus K
StanislausK

(usa FreeBSD)

Enviado em 12/06/2020 - 23:36h

Ola,

"eu pelo menos não sei se dá pra instalar driver do Windows no Linux"

não é possível fazer isso...

"Tem alguma coisa errada com esse repositório indicado no tutorial do Edivaldo"

correto... verifiquei agora e esta faltando um trecho do comando... esse repositório somente suporta duas versões do Ubuntu: 14.04 e 16.04... eu precisaria saber mais detalhes do Zorin OS, em qual distro ela é baseada.

mas antes, veja esse tutorial (se resolver, ok):

How to Install Canon Printer Driver on Zorin OS Easy Guide
https://tutorialforlinux.com/how-to-install-canon-printer-driver-on-zorin-os-easy-guide/

se você não conseguir instalar com esse tutorial, acesse o terminal e digite os comandos (e mostre o que aparece para ambos):

cat /etc/apt/sources.list

e

ls -al /etc/apt/sources.list.d


preciso saber como estão os repositorios do Zorin OS... o Zorin OS é baseado no Ubuntu e Debian, e preciso saber mais detalhes dos repositórios.




5. Re: Scanner da Multifuncional Canon 3110 não é reconhecido

Leonardo Lemos
lemions

(usa XUbuntu)

Enviado em 15/06/2020 - 10:39h


How to Install Canon Printer Driver on Zorin OS Easy Guide
https://tutorialforlinux.com/how-to-install-canon-printer-driver-on-zorin-os-easy-guide/


nossa mano, esse site que você mandou ajudou muito, mas alguma coisa deu errado quando eu tentei instalar o pacote do scanner com o sudo ./install.sh


apareceu isso:

==================================================

ScanGear MP
Version 3.30
Copyright CANON INC. 2007-2016

==================================================
Command executed = sudo dpkg -iG ./packages/scangearmp2_3.30-1_amd64.deb
A seleccionar pacote anteriormente não seleccionado scangearmp2.
(Lendo banco de dados ... 367101 ficheiros e directórios actualmente instalados.)
A preparar para desempacotar .../scangearmp2_3.30-1_amd64.deb ...
A descompactar scangearmp2 (3.30-1) ...
dpkg: problemas com dependências impedem a configuração de scangearmp2:
scangearmp2 depende de libpango1.0-0 (>= 1.14.0); porém:
Pacote libpango1.0-0 não está instalado.

dpkg: erro ao processar o pacote scangearmp2 (--install):
problemas de dependência - deixando desconfigurado
Erros foram encontrados durante o processamento de:
scangearmp2
Command executed = sudo dpkg -P scangearmp2
(Lendo banco de dados ... 367120 ficheiros e directórios actualmente instalados.)
A remover scangearmp2 (3.30-1) ...
A purgar os ficheiros de configuração para scangearmp2 (3.30-1) ...




6. Re: Scanner da Multifuncional Canon 3110 não é reconhecido

Stanislaus K
StanislausK

(usa FreeBSD)

Enviado em 15/06/2020 - 12:00h

Ola,

"dpkg: problemas com dependências impedem a configuração de scangearmp2:
scangearmp2 depende de libpango1.0-0 (>= 1.14.0); porém:
Pacote libpango1.0-0 não está instalado."


voce já usou o comando: sudo apt install libpango1.0-0
Como voce esta usando um arquivo .deb, pode ser necessário instalar as dependências...






Patrocínio

Site hospedado pelo provedor RedeHost.
Linux banner
Linux banner
Linux banner

Destaques

Artigos

Dicas

Tópicos

Top 10 do mês

Scripts