Instalação de impressora l3150 no sistema elementary os 5.1.2 hera [RESOLVIDO]

1. Instalação de impressora l3150 no sistema elementary os 5.1.2 hera [RESOLVIDO]

davi souza silva
PisomD

(usa Outra)

Enviado em 01/04/2020 - 13:59h

Olá estou tentando instalar pacotes deb. officiais da epsom, porém não estou conseguindo
estes são os pacotes:
epson-inkjet-printer-escpr_1.7.7-1lsb3.2_i386.deb
epson-printer-utility_1.1.1-1lsb3.2_i386.deb

O problema:sudo dpkg -i epson-inkjet-printer-escpr_1.7.7-1lsb3.2_i386.deb
A seleccionar pacote anteriormente não seleccionado epson-inkjet-printer-escpr:i386.
(Lendo banco de dados ... 233835 ficheiros e directórios actualmente instalados.)
A preparar para desempacotar epson-inkjet-printer-escpr_1.7.7-1lsb3.2_i386.deb ...
A descompactar epson-inkjet-printer-escpr:i386 (1.7.7-1lsb3.2) ...
dpkg: problemas com dependências impedem a configuração de epson-inkjet-printer-escpr:i386:
epson-inkjet-printer-escpr:i386 depende de lsb (>= 3.2).

dpkg: erro ao processar o pacote epson-inkjet-printer-escpr:i386 (--install):
problemas de dependência - deixando desconfigurado
Erros foram encontrados durante o processamento de:
epson-inkjet-printer-escpr:i386

soluções que já tentei
-------------------------------------------------------
sudo apt-get install lsb
Lendo listas de pacotes... Pronto
Construindo árvore de dependências
Lendo informação de estado... Pronto
lsb is already the newest version (9.20170808ubuntu1+elementary4~ubuntu18.04.1).
Você pode querer executar 'apt --fix-broken install' para corrigí-los.
Os pacotes a seguir têm dependências desencontradas:
epson-inkjet-printer-escpr:i386 : Depende: lsb:i386 (>= 3.2) mas não é instalável
E: Dependências desencontradas. Tente 'apt --fix-broken install' sem nenhum pacote (ou especifique uma solução).
------------------------------------------------------------------------------
e depois:
sudo apt --fix-broken install
Lendo listas de pacotes... Pronto
Construindo árvore de dependências
Lendo informação de estado... Pronto
Corrigindo dependências... Pronto
Os pacotes a seguir serão REMOVIDOS:
epson-inkjet-printer-escpr:i386
0 pacotes atualizados, 0 pacotes novos instalados, 1 a serem removidos e 0 não atualizados.
1 pacotes não totalmente instalados ou removidos.
Depois desta operação, 5.344 kB de espaço em disco serão liberados.
Você quer continuar? [S/n] s
(Lendo banco de dados ... 234419 ficheiros e directórios actualmente instalados.)
A remover epson-inkjet-printer-escpr:i386 (1.7.7-1lsb3.2) ...
A processar 'triggers' para libc-bin (2.27-3ubuntu1) ...
-------------------------------------------------------------------------
tentei também sudo dpkg -i --force-all

consegui instalar o driver com esse comando porém a impressora não conseguia imprimir então desconsiderei
--------------------------------------------------------------------------
Obs: no linux ubuntu foi bem facíl istalar essa impressora, unica coisa que fiz foi baixar os arquivos e instalar o lsb
--------------------------------------------------------------------------
Por favor me ajudem agradeço muito!



  


2. MELHOR RESPOSTA

sergio dias
aja

(usa Outra)

Enviado em 03/04/2020 - 15:26h

Instale o Digitalizador de documentos do Gnome. Depois vá ao arquivo /etc/sane.d/epson2.conf e no final do arquivo acrescente o comando net e o IP da sua impressora! No caso como exemplo ficaria: "net 192.168.0.25".
Para descobrir o IP da Impressora você pode identificá-lo no seu roteador.


3. minha maquina

davi souza silva
PisomD

(usa Outra)

Enviado em 01/04/2020 - 14:11h

Dual Core Intel® Core™ i5-7200U CPU @ 2.50GHz
Intel Corporation HD Graphics 620 (rev 02)
NVIDIA Corporation GM108M [GeForce 920MX] (rev a2)
8,1 GB memória
450,7 GB armazenamento (HDD)

sobre o processador
http://www.cpu-world.com/CPUs/Core_i5/Intel-Core%20i5%20i5-7200U.html
sobre a impressora
https://epson.com.br/Suporte/Impressoras/Impressoras-multifuncionais/Epson-L/Epson-L3150/s/SPT_C11CG...
sobre o sistema
elementary OS 5.1.2 Hera
Construído sobre Ubuntu 18.04.3 LTS
Linux 5.3.0-45-generic
GTK 3.22.30


4. Re: Instalação de impressora l3150 no sistema elementary os 5.1.2 hera [RESOLVIDO]

Stanislaus K
StanislausK

(usa FreeBSD)

Enviado em 01/04/2020 - 15:08h

Ola,

como o Elementary OS 5.1 é baseado no Ubuntu 18.04 LTS, basta apenas usar os seguintes comandos:

sudo apt-get update
sudo apt-get install printer-driver-escpr


e depois use o CUPS para instalar manualmente a impressora (ou qualquer outro aplicativo que venha com o seu sistema), isso se não for reconhecido automaticamente ao plugar a impressora. Verifique se há a necessidade de instalar o cups em seu sistema!

Fonte:
https://ubuntu.pkgs.org/18.04/ubuntu-universe-amd64/printer-driver-escpr_1.6.17-2_amd64.deb.html

Como é uma multifuncional, para usar o scanner instale o XSane, por exemplo...


5. Re: Instalação de impressora l3150 no sistema elementary os 5.1.2 hera [RESOLVIDO]

davi souza silva
PisomD

(usa Outra)

Enviado em 01/04/2020 - 20:30h

StanislausK escreveu:

Ola,

como o Elementary OS 5.1 é baseado no Ubuntu 18.04 LTS, basta apenas usar os seguintes comandos:

sudo apt-get update
sudo apt-get install printer-driver-escpr


e depois use o CUPS para instalar manualmente a impressora (ou qualquer outro aplicativo que venha com o seu sistema), isso se não for reconhecido automaticamente ao plugar a impressora. Verifique se há a necessidade de instalar o cups em seu sistema!

Fonte:
https://ubuntu.pkgs.org/18.04/ubuntu-universe-amd64/printer-driver-escpr_1.6.17-2_amd64.deb.html

Como é uma multifuncional, para usar o scanner instale o XSane, por exemplo...


Obrigado pela ajuda, infelizmente esse pacote não tem os drivers para essa impressora em especifico.

porém consegui resolver, vou colocar a solução para esse caso aqui:

Baixei outros pacotes no site da epson
epson-printer-utility_1.1.1-1lsb3.2_amd64.deb
epson-inkjet-printer-escpr_1.7.7-1lsb3.2_amd64.deb

usei os seguintes comandos
sudo apt get update 

sudo apt-get install lsb 


fui até a pasta de Downloads
cd Downloads/ 


e instalei os pacotes
sudo dpkg -i epson-inkjet-printer-escpr_1.7.7-1lsb3.2_amd64.deb 

sudo dpkg -i epson-printer-utility_1.1.1-1lsb3.2_amd64.deb 


toda essa solução fez ela conectar pela internet normalmente selecionando o driver da impressora.
só que o scanner...
esse ai eu consegui fazer funcionar via cabo, como não uso muito não tem problema mas vou tentar achar uma solução, a epson tem um aplicativo proprio "image-scan" fiz a instalação dele para a unica opção mais proxima "ubuntu 18.04" e o maximo que consegui foi scanner via cabo.

Obrigado pela ajuda!!! espero que eu consiga ajudar alguem também ;)






Patrocínio

Site hospedado pelo provedor RedeHost.
Linux banner
Linux banner
Linux banner

Destaques

Artigos

Dicas

Tópicos

Top 10 do mês

Scripts