Pacotes quebrados: perl-modules-5.24

1. Pacotes quebrados: perl-modules-5.24

Nicolas Bauermann
UmMeroUsuario

(usa Kali)

Enviado em 19/10/2021 - 15:43h

tentei atualizar o sistema, mas apareceu isso (colei a saida dos comandos que tentei usar para atualizar e arrumar):

# apt upgrade                                                                                                                                                         
Lendo listas de pacotes... Pronto
Construindo árvore de dependências... Pronto
Lendo informação de estado... Pronto
Calculando atualização... Pronto
Alguns pacotes não puderam ser instalados. Isto pode significar que
você solicitou uma situação impossível ou, se você está usando a
distribuição instável, que alguns pacotes requeridos não foram
criados ainda ou foram retirados da "Incoming".
A informação a seguir pode ajudar a resolver a situação:

Os pacotes a seguir têm dependências desencontradas:
perl : Quebra: perl-modules-5.24 mas 5.24.1-3+deb9u7 está para ser instalado
Quebra: perl-modules-5.24:i386
E: Pacotes quebrados


$ sudo apt install -f                                                                                                                                                 
Lendo listas de pacotes... Pronto
Construindo árvore de dependências... Pronto
Lendo informação de estado... Pronto
0 pacotes atualizados, 0 pacotes novos instalados, 0 a serem removidos e 1624 não atualizados.


$ sudo apt install perl-modules-5.24                                                                                                                         
Lendo listas de pacotes... Pronto
Construindo árvore de dependências... Pronto
Lendo informação de estado... Pronto
Alguns pacotes não puderam ser instalados. Isto pode significar que
você solicitou uma situação impossível ou, se você está usando a
distribuição instável, que alguns pacotes requeridos não foram
criados ainda ou foram retirados da "Incoming".
A informação a seguir pode ajudar a resolver a situação:

Os pacotes a seguir têm dependências desencontradas:
mime-support : Depende: mailcap mas não será instalado
E: Erro, pkgProblemResolver::Resolve gerou falhas, isto pode ser causado por pacotes mantidos (hold).


# apt purge perl-modules-5.24 mailcap mime-support 
Lendo listas de pacotes... Pronto
Construindo árvore de dependências... Pronto
Lendo informação de estado... Pronto
O pacote 'perl-modules-5.24' não está instalado, por isso não será removido
Os seguintes pacotes foram instalados automaticamente e já não são necessários:
apache2-data apache2-utils libart-2.0-2 libc-devtools libndpi3.4 libpython2.7-minimal libwebpmux2 php-sqlite3 php7.4-json php7.4-opcache php7.4-readline
php7.4-sqlite3 python2-minimal python2.7-minimal python3-qrcode recode
Utilize 'sudo apt autoremove' para os remover.
The following additional packages will be installed:
apache2-bin apache2-data apache2-utils fakechroot libc-bin libc-dev-bin libc-l10n libc6 libc6:i386 libc6-dbg libc6-dev libc6-i386 libfakechroot libpython2.7-minimal
locales python2.7-minimal rpcsvc-proto
Pacotes sugeridos:
apache2-doc apache2-suexec-pristine | apache2-suexec-custom glibc-doc libnss-nis libnss-nisplus glibc-doc:i386 locales:i386
Pacotes recomendados:
libc-devtools libpython2.7-stdlib python2.7
Os pacotes a seguir serão REMOVIDOS:
apache2* kali-linux-default* kali-linux-everything* kali-linux-headless* kali-linux-large* kali-linux-nethunter* kali-tools-exploitation* kali-tools-forensics*
kali-tools-social-engineering* kali-tools-web* libapache2-mod-php* libapache2-mod-php7.4* libpython2-stdlib* libpython2.7-stdlib* mailcap* mime-support*
offsec-awae-python2* php* php7.4* php7.4-cli* phpggc* python-cairo* python-cffi* python-cffi-backend* python-dbus* python-dbus.mainloop.pyqt5* python-gobject-2*
python-gtk2* python-imaging* python-is-python2* python-notify* python-numpy* python-pil* python-pkg-resources* python-renderpm* python-reportlab*
python-reportlab-accel* python-virtualenv* python2* python2.7* set* xplico*
Os NOVOS pacotes a seguir serão instalados:
rpcsvc-proto
Os pacotes a seguir serão atualizados:
apache2-bin apache2-data apache2-utils fakechroot libc-bin libc-dev-bin libc-l10n libc6 libc6:i386 libc6-dbg libc6-dev libc6-i386 libfakechroot libpython2.7-minimal
locales python2.7-minimal
16 pacotes atualizados, 1 pacotes novos instalados, 42 a serem removidos e 1596 não atualizados.
É preciso baixar 27,8 MB de arquivos.
Depois desta operação, 106 MB de espaço em disco serão liberados.
Você quer continuar? [S/n] n
Abortar.


o mais estranho é que o pacote com erro não está instalado... no sistema existe perl-modules-5.32, mas o com erro é o 24... alguma dica?


  






Patrocínio

Site hospedado pelo provedor RedeHost.
Linux banner
Linux banner

Destaques

Artigos

Dicas

Tópicos

Top 10 do mês

Scripts