Hd kernel panic [RESOLVIDO]

1. Hd kernel panic [RESOLVIDO]

Fernanda de oliveira Cassi
nandakassi

(usa Deepin)

Enviado em 05/02/2017 - 11:28h

Bom eu tenho um hd de 160GB que nao ê sata é aqueles mais antigos e comprei outro de 1TB que é sata.
Quando eu ligo os dois hds o meu slackware da kernelpanic.
Se eu retiro este novo sata o slackware liga normal, alguém sabe o que pode ser?



  


2. MELHOR RESPOSTA

Jefferson Rocha
slackjeff

(usa Slackware)

Enviado em 05/02/2017 - 15:33h

O mauricio está certo, o que esta acontecendo é que seu HD IDE é o SDA e o boot está por exemplo no SDA1, quando inicia a máquina o sistema troca, mandando o HD IDE como SDB1 e o SATA para SDA.
Ou seja, da conflito, mas eu resolvi.
Bom eu tenho um pc antigo aqui com 2 hds tambem IDE e Sata e fiz um teste, literalmente entrei em seu problema.
Quando iniciei deu o mesmo problema... então eu consegui resolver, vamos lá.

Vamos ver qual o seu PARTUUID abra o terminal e rode o comando:
# blkid
Identifique qual a sua partição, em meu caso é está:
/dev/sdb1: UUID="b7cb6af6-7c85-46e6-8976-204a5971a17d" TYPE="ext4" PARTUUID="4480a36a-01"
Copie o seu PARTUUID sem as aspas.
PARTUUID=4480a36a-01

Vamos agora para segunda parte, entre no lilo.conf
# nano /etc/lilo.conf
Vá até até a linha:
ROOT = /dev/sda1 (Provelmente está assim ou algo parecido.)
Vamos apagar está linha e mudar para:
addappend = " root=PARTUUID=4480a36a-01"

Agora reinicie e tudo certo!


configure complete, now type 'make' and pray.
Meu Blog: http://area355.blogspot.com.br
Tradutor PT-BR da Distribuição: Calculate Linux
Tradutor PT-BR da Distribuição: Arya-Linux







3. Re: Hd kernel panic [RESOLVIDO]

Fernanda de oliveira Cassi
nandakassi

(usa Deepin)

Enviado em 05/02/2017 - 12:35h

NInguem?


4. Re: Hd kernel panic [RESOLVIDO]

Jefferson Rocha
slackjeff

(usa Slackware)

Enviado em 05/02/2017 - 13:20h

Provavelmente nao tem a flag boot.
Muitos esquecem apos particionar o hd, marcam a opcao swap e esquecem do bootable, e normal eu ja fiz isso e muito fizeram e vao fazer.
Para resolver o problema faca o seguinte entre com um live cd que tenha gparted, abra o gparted selecione o HD que esta o slackware, se nao sabe abra o terminal e digite LSBLK apos identificar continuamos, va ate MANAGE FLAGS e adicione o boot na particao selecionada...
Isso provavelmente ira funcionar.




configure complete, now type 'make' and pray.
Meu Blog: http://area355.blogspot.com.br
Tradutor PT-BR da Distribuição: Calculate Linux
Tradutor PT-BR da Distribuição: Arya-Linux








5. Re: Hd kernel panic [RESOLVIDO]

Mauriciodez
Mauriciodez

(usa Debian)

Enviado em 05/02/2017 - 13:33h

Eu fiquei aqui imaginando que pudesse ser troca de letra ao ADD o Hd ... o q era 'sda' virou 'sdb' e deu ruim no fstab !!!
mas porém entretanto é só um chute !!!
_______________________________________________________________
" Nem sempre é amigo aquele que te tira do buraco !!! ( Saddam Hussein )"


6. Re: Hd kernel panic [RESOLVIDO]

Fernanda de oliveira Cassi
nandakassi

(usa Deepin)

Enviado em 05/02/2017 - 14:03h

slackjeff escreveu:

Provavelmente nao tem a flag boot.
Muitos esquecem apos particionar o hd, marcam a opcao swap e esquecem do bootable, e normal eu ja fiz isso e muito fizeram e vao fazer.
Para resolver o problema faca o seguinte entre com um live cd que tenha gparted, abra o gparted selecione o HD que esta o slackware, se nao sabe abra o terminal e digite LSBLK apos identificar continuamos, va ate MANAGE FLAGS e adicione o boot na particao selecionada...
Isso provavelmente ira funcionar.




configure complete, now type 'make' and pray.
Meu Blog: http://area355.blogspot.com.br
Tradutor PT-BR da Distribuição: Calculate Linux
Tradutor PT-BR da Distribuição: Arya-Linux





Não estava marcado mesmo, porem nao funcionou! mesmo assim obrigada.




7. Re: Hd kernel panic

Fernanda de oliveira Cassi
nandakassi

(usa Deepin)

Enviado em 05/02/2017 - 14:03h

Já testei todos os encaixes SATA que são 4 no total e nada ;/
Já instalei o debian neste HD SATA para ver se funcionava e funcionou teclando no boot a tecla F12 e selecionando o HD está indo, o problema mesmo é o Slackware que não funciona com o HD SATA quando está engatado.
ERRO: no working init not found
Vamos ver, tenho o dia todo para quebrar a cabeça, quem ter ideias me ajude!


8. Re: Hd kernel panic [RESOLVIDO]

Mauriciodez
Mauriciodez

(usa Debian)

Enviado em 05/02/2017 - 14:40h

nandakassi escreveu:

Já testei todos os encaixes SATA que são 4 no total e nada ;/
Já instalei o debian neste HD SATA para ver se funcionava e funcionou teclando no boot a tecla F12 e selecionando o HD está indo, o problema mesmo é o Slackware que não funciona com o HD SATA quando está engatado.
ERRO: no working init not found
Vamos ver, tenho o dia todo para quebrar a cabeça, quem ter ideias me ajude!


outra coisa passou pela minha cabeça aqui, foi q talvez o LILO pudesse estar referenciando o hd errado pois este novo hd "pegou" a letra do antigo, logo aventurei a idéia de vc substituir o LILO pelo GRUB .. talvez assim o init fosse gravado corretamente com o novo hd .

https://www.vivaolinux.com.br/dica/Slackware-com-o-GRUB

Mas porém entretanto é só chute.

_______________________________________________________________
" Nem sempre é amigo aquele que te tira do buraco !!! ( Saddam Hussein )"


9. Re: Hd kernel panic [RESOLVIDO]

Fernanda de oliveira Cassi
nandakassi

(usa Deepin)

Enviado em 05/02/2017 - 15:47h

Obrigada!!!!!!!!!!!!
Funcionou!






Patrocínio

Site hospedado pelo provedor RedeHost.
Linux banner
Linux banner

Destaques

Artigos

Dicas

Tópicos

Top 10 do mês

Scripts