erro na atualização no gentoo [RESOLVIDO]

1. erro na atualização no gentoo [RESOLVIDO]

Perfil removido
removido

(usa Nenhuma)

Enviado em 15/08/2020 - 19:21h

olá
meu gentoo tava tudo normal e não fiz nenhuma bizarrice nele mas veio uma atualização do pacote sys-libs/ldb-2.0.12-r1 e fica falhando na compilação
veja aqui a saida
emerge -auDN sys-libs/ldb

* IMPORTANT: 9 news items need reading for repository 'gentoo'.
* Use eselect news read to view new items.


These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild U ] sys-libs/ldb-2.0.12-r1 [2.0.12]

Would you like to merge these packages? [Yes/No] y

>>> Verifying ebuild manifests

>>> Emerging (1 of 1) sys-libs/ldb-2.0.12-r1::gentoo
* ldb-2.0.12.tar.gz BLAKE2B SHA512 size ;-) ... [ ok ]
>>> Unpacking source...
>>> Unpacking ldb-2.0.12.tar.gz to /var/tmp/portage/sys-libs/ldb-2.0.12-r1/work
>>> Source unpacked in /var/tmp/portage/sys-libs/ldb-2.0.12-r1/work
>>> Preparing source in /var/tmp/portage/sys-libs/ldb-2.0.12-r1/work/ldb-2.0.12 ...
* Applying ldb-1.5.2-optional_packages.patch ... [ ok ]
* Applying ldb-1.1.31-fix_PKGCONFIGDIR-when-python-disabled.patch ... [ ok ]
* Will copy sources from /var/tmp/portage/sys-libs/ldb-2.0.12-r1/work/ldb-2.0.12
* abi_x86_64.amd64: copying to /var/tmp/portage/sys-libs/ldb-2.0.12-r1/work/ldb-2.0.12-abi_x86_64.amd64
>>> Source prepared.
>>> Configuring source in /var/tmp/portage/sys-libs/ldb-2.0.12-r1/work/ldb-2.0.12 ...
* abi_x86_64.amd64: running multilib-minimal_abi_src_configure
* EPYTHON is unset while calling waf-utils. This most likely means that
* the ebuild did not call the appropriate eclass function before calling waf.
* Please ensure that python-single-r1_pkg_setup is called in pkg_setup().
*
* ERROR: sys-libs/ldb-2.0.12-r1::gentoo failed (configure phase):
* Invalid use of waf-utils.eclass
*
* Call stack:
* ebuild.sh, line 125: Called src_configure
* environment, line 3544: Called multilib-minimal_src_configure
* environment, line 2211: Called multilib_foreach_abi 'multilib-minimal_abi_src_configure'
* environment, line 2444: Called multibuild_foreach_variant '_multilib_multibuild_wrapper' 'multilib-minimal_abi_src_configure'
* environment, line 2141: Called _multibuild_run '_multilib_multibuild_wrapper' 'multilib-minimal_abi_src_configure'
* environment, line 2139: Called _multilib_multibuild_wrapper 'multilib-minimal_abi_src_configure'
* environment, line 419: Called multilib-minimal_abi_src_configure
* environment, line 2205: Called multilib_src_configure
* environment, line 2675: Called waf-utils_src_configure '--disable-rpath' '--disable-rpath-install' '--bundled-libraries=NONE' '--with-modulesdir=/usr/lib64/samba' '--builtin-libraries=NONE' '--disable-python'
* environment, line 4326: Called die
* The specific snippet of code:
* [[ -n ${fail} ]] && die "Invalid use of waf-utils.eclass";
*
* If you need support, post the output of `emerge --info '=sys-libs/ldb-2.0.12-r1::gentoo'`,
* the complete build log and the output of `emerge -pqv '=sys-libs/ldb-2.0.12-r1::gentoo'`.
* The complete build log is located at '/var/tmp/portage/sys-libs/ldb-2.0.12-r1/temp/build.log'.
* The ebuild environment file is located at '/var/tmp/portage/sys-libs/ldb-2.0.12-r1/temp/environment'.
* Working directory: '/var/tmp/portage/sys-libs/ldb-2.0.12-r1/work/ldb-2.0.12-abi_x86_64.amd64'
* S: '/var/tmp/portage/sys-libs/ldb-2.0.12-r1/work/ldb-2.0.12'

>>> Failed to emerge sys-libs/ldb-2.0.12-r1, Log file:

>>> '/var/tmp/portage/sys-libs/ldb-2.0.12-r1/temp/build.log'

* Messages for package sys-libs/ldb-2.0.12-r1:

* EPYTHON is unset while calling waf-utils. This most likely means that
* the ebuild did not call the appropriate eclass function before calling waf.
* Please ensure that python-single-r1_pkg_setup is called in pkg_setup().
*
* ERROR: sys-libs/ldb-2.0.12-r1::gentoo failed (configure phase):
* Invalid use of waf-utils.eclass
*
* Call stack:
* ebuild.sh, line 125: Called src_configure
* environment, line 3544: Called multilib-minimal_src_configure
* environment, line 2211: Called multilib_foreach_abi 'multilib-minimal_abi_src_configure'
* environment, line 2444: Called multibuild_foreach_variant '_multilib_multibuild_wrapper' 'multilib-minimal_abi_src_configure'
* environment, line 2141: Called _multibuild_run '_multilib_multibuild_wrapper' 'multilib-minimal_abi_src_configure'
* environment, line 2139: Called _multilib_multibuild_wrapper 'multilib-minimal_abi_src_configure'
* environment, line 419: Called multilib-minimal_abi_src_configure
* environment, line 2205: Called multilib_src_configure
* environment, line 2675: Called waf-utils_src_configure '--disable-rpath' '--disable-rpath-install' '--bundled-libraries=NONE' '--with-modulesdir=/usr/lib64/samba' '--builtin-libraries=NONE' '--disable-python'
* environment, line 4326: Called die
* The specific snippet of code:
* [[ -n ${fail} ]] && die "Invalid use of waf-utils.eclass";
*
* If you need support, post the output of `emerge --info '=sys-libs/ldb-2.0.12-r1::gentoo'`,
* the complete build log and the output of `emerge -pqv '=sys-libs/ldb-2.0.12-r1::gentoo'`.
* The complete build log is located at '/var/tmp/portage/sys-libs/ldb-2.0.12-r1/temp/build.log'.
* The ebuild environment file is located at '/var/tmp/portage/sys-libs/ldb-2.0.12-r1/temp/environment'.
* Working directory: '/var/tmp/portage/sys-libs/ldb-2.0.12-r1/work/ldb-2.0.12-abi_x86_64.amd64'
* S: '/var/tmp/portage/sys-libs/ldb-2.0.12-r1/work/ldb-2.0.12'




  


2. MELHOR RESPOSTA

Lucas C.S.
AdiosKid

(usa Funtoo)

Enviado em 15/08/2020 - 19:27h

Erro na eclass 'waf-utils.eclass', confere no pagina de bugs se esse arquivo foi alterado.

3. Re: erro na atualização no gentoo [RESOLVIDO]

Perfil removido
removido

(usa Nenhuma)

Enviado em 15/08/2020 - 21:32h

não sei se fiz direito mas não achei isso no bugzilla do gentoo


4. Re: erro na atualização no gentoo [RESOLVIDO]

Perfil removido
removido

(usa Nenhuma)

Enviado em 15/08/2020 - 23:06h

deve ter sido um bug pois ao atualizar o banco de dados do portage a compilação foi bem sucedida


5. Re: erro na atualização no gentoo [RESOLVIDO]

Lucas C.S.
AdiosKid

(usa Funtoo)

Enviado em 16/08/2020 - 22:55h

Deve ter sido algum erro de sintaxe da staff em alguma atualização, as vezes acontece.