Remover Grub e instalar LILO (Ajuda)

1. Remover Grub e instalar LILO (Ajuda)

Perfil removido
removido

(usa Nenhuma)

Enviado em 21/02/2020 - 19:50h

Quero remover o Grub e instalar o LILO,e a primeira vez que instalo o Gentoo DVD 64 bits,porque o comando # grub-install /dev/sda nao esta funcionando,da mensagem de erro,alguem pode me ajudar?


  


2. Re: Remover Grub e instalar LILO (Ajuda)

João Cláudio de Alcântara
aguamole

(usa Lubuntu)

Enviado em 21/02/2020 - 20:57h

Cade a saída de erro?

CPU i5-8400 GTX 750 SofRaid 4xSSD 16GB DDR4 mesmo assim uso Lubuntu.


3. Re: Remover Grub e instalar LILO (Ajuda)

edps
edps

(usa Slackware)

Enviado em 21/02/2020 - 22:07h


BuiuLinuxer escreveu:

Quero remover o Grub e instalar o LILO,e a primeira vez que instalo o Gentoo DVD 64 bits,porque o comando # grub-install /dev/sda nao esta funcionando,da mensagem de erro,alguem pode me ajudar?


Assim fica difícil, tu não diz se é GPT (porque precisa de uma partição /boot separada, formatada em VFAT e montada né) ou MBR, onde deveria funcionar seja com partição /boot separada ou não.

Mas vai a pergunta já que V. Sª não mostrou nada:

Executou:

# grub-mkconfig -o /boot/grub/grub.cfg 


???

Não lembro se é no Gentoo, mas talvez seja necessário criar o diretório /boot/grub/

# mkdir -p /boot/grub
# grub-mkconfig -o /boot/grub/grub.cfg
# grub-install /dev/sda


Para sua diversão:

https://wiki.gentoo.org/wiki/Handbook:AMD64/Installation/Bootloader
https://wiki.gentoo.org/wiki/LILO

Quando vi sua pergunta pensei que fosse algum Slacker, só esses doidos para preferir LILO ao Grub.



4. Re: Remover Grub e instalar LILO (Ajuda)

Leomar de Oliveira
Leo CCB

(usa Slackware)

Enviado em 21/02/2020 - 23:38h



Quando vi sua pergunta pensei que fosse algum Slacker, só esses doidos para preferir LILO ao Grub.

kkk tive que rir







5. Re: Remover Grub e instalar LILO (Ajuda)

Perfil removido
removido

(usa Nenhuma)

Enviado em 22/02/2020 - 00:25h

edps escreveu:


BuiuLinuxer escreveu:

Quero remover o Grub e instalar o LILO,e a primeira vez que instalo o Gentoo DVD 64 bits,porque o comando # grub-install /dev/sda nao esta funcionando,da mensagem de erro,alguem pode me ajudar?


Assim fica difícil, tu não diz se é GPT (porque precisa de uma partição /boot separada, formatada em VFAT e montada né) ou MBR, onde deveria funcionar seja com partição /boot separada ou não.

Mas vai a pergunta já que V. Sª não mostrou nada:

Executou:

# grub-mkconfig -o /boot/grub/grub.cfg 





???

Não lembro se é no Gentoo, mas talvez seja necessário criar o diretório /boot/grub/

# mkdir -p /boot/grub
# grub-mkconfig -o /boot/grub/grub.cfg
# grub-install /dev/sda


Para sua diversão:

https://wiki.gentoo.org/wiki/Handbook:AMD64/Installation/Bootloader
https://wiki.gentoo.org/wiki/LILO

Quando vi sua pergunta pensei que fosse algum Slacker, só esses doidos para preferir LILO ao Grub.

O Comando era esse mesmo grub-mkconfig -o /boot/grub/grub.cfg e no:
grub-install /dev/sda, dava a seguinte mensagem de erro:

Command not found.

Tem isso ainda:
(chroot) livecd / # emerge -ask --verbose sys-boot/grub:2
Failed to validate a sane '/dev'.
bash process substitution doesn't work; this may be an indication of a broken '/dev/fd'.





6. Re: Remover Grub e instalar LILO (Ajuda)

João Cláudio de Alcântara
aguamole

(usa Lubuntu)

Enviado em 22/02/2020 - 00:32h

BuiuLinuxer escreveu:

Command not found.


Então instale o pacote do Grub no seu sistema com o seu gerenciador de pacotes Apt.

Cara eu não sei mexer com o Lilo isso já foi abandonado a muito tempo já faz mais de 12 anos.
Deve ter alguma documentação do Lilo perdido na internet.

CPU i5-8400 GTX 750 SofRaid 4xSSD 16GB DDR4 mesmo assim uso Lubuntu.


7. Re: Remover Grub e instalar LILO (Ajuda)

Perfil removido
removido

(usa Nenhuma)

Enviado em 22/02/2020 - 00:39h

aguamole escreveu:

BuiuLinuxer escreveu:

Command not found.


Então instale o pacote do Grub no seu sistema com o seu gerenciador de pacotes Apt.

Cara eu não sei mexer com o Lilo isso já foi abandonado a muito tempo já faz mais de 12 anos.
Deve ter alguma documentação do Lilo perdido na internet.

CPU i5-8400 GTX 750 SofRaid 4xSSD 16GB DDR4 mesmo assim uso Lubuntu.


Instalar com o APT engraçadinho,estou no Gentoo e nao vou desistir,mas preciso de ajuda para a primeira instalacao.




8. Re: Remover Grub e instalar LILO (Ajuda)

João Cláudio de Alcântara
aguamole

(usa Lubuntu)

Enviado em 22/02/2020 - 09:44h

Atualiza a sua distro do perfil do site esta Debian.

CPU i5-8400 GTX 750 SofRaid 4xSSD 16GB DDR4 mesmo assim uso Lubuntu.


9. Re: Remover Grub e instalar LILO (Ajuda)

Matheus
pylm

(usa Gentoo)

Enviado em 22/02/2020 - 09:59h

Tópico de qualidade é isso aí, já começa errado na incapacidade de comunicação do OP.

De qualquer modo, tens que montar o /dev do sistema host no chroot, dá uma olhada na documentação sobre chroot.


10. Re: Remover Grub e instalar LILO (Ajuda)

João Cláudio de Alcântara
aguamole

(usa Lubuntu)

Enviado em 22/02/2020 - 10:37h

A veio eu não sei de nada do Gentoo download do código fonte do Grub2:
https://ftp.gnu.org/gnu/grub/
Através do código fonte da para instalar em qualquer sistema.
Se eu soubesse que era Gentoo teria nem respondido esse tópico foi mal eu não sei nada do Gentoo.
boa sorte !

CPU i5-8400 GTX 750 SofRaid 4xSSD 16GB DDR4 mesmo assim uso Lubuntu.


11. Re: Remover Grub e instalar LILO (Ajuda)

edps
edps

(usa Slackware)

Enviado em 22/02/2020 - 16:12h


Leo CCB escreveu:



Quando vi sua pergunta pensei que fosse algum Slacker, só esses doidos para preferir LILO ao Grub.

kkk tive que rir



ria meu filho... é sério, software ridículo, mas que atende ao seu propósito de bootar somente um Slackware, mas quem usa outros sistemas a cada atualização de kernel tem que editar essa bagaça de lilo.conf, o ELILO é outro lixo.

É a primeira coisa que faço num pós-install do Slack, mas parece que as coisas estão mudando, tanto o os-prober quanto o grub2 já vem instalados por padrão, antes tinhamos que instalar manualmente.



12. Re: Remover Grub e instalar LILO (Ajuda)

edps
edps

(usa Slackware)

Enviado em 22/02/2020 - 16:17h

pylm escreveu:

Tópico de qualidade é isso aí, já começa errado na incapacidade de comunicação do OP.

De qualquer modo, tens que montar o /dev do sistema host no chroot, dá uma olhada na documentação sobre chroot.


E também não disse (de novo vou perguntar), é GPT ou MBR?

Aqui é GPT e tenho isso em meu /etc/portage/make.conf:

GRUB_PLATFORMS="emu efi-32 efi-64 pc" 


E para o os-prober (responsável por catar as entradas de outros sistemas),no arquivo /etc/portage/package.use/zz-autounmask:

# required by sys-boot/os-prober-1.76-r1::gentoo
# required by os-prober (argument)
>=sys-boot/grub-2.02-r4 mount


EDIT:

bola de cristal só quem tinha era o finado @irado_furioso, ele iria adorar seu tópico.



01 02



Patrocínio

Site hospedado pelo provedor RedeHost.
Linux banner
Linux banner
Linux banner

Destaques

Artigos

Dicas

Tópicos

Top 10 do mês

Scripts