Problema na instalação do kde 4.5.1 no Gentoo [RESOLVIDO]

1. Problema na instalação do kde 4.5.1 no Gentoo [RESOLVIDO]

monica neopomuceno
[email protected]

(usa Ubuntu)

Enviado em 24/09/2010 - 13:34h

# emerge kde-meta

* IMPORTANT: 4 news items need reading for repository 'gentoo'.
* Use eselect news to read news items.

Calculating dependencies... done!

emerge: there are no ebuilds built with USE flags to satisfy ">=dev-python/PyQt4-4.7[dbus,sql,svg,webkit,X]".
!!! One of the following packages is required to complete your request:
- dev-python/PyQt4-4.7.7 (Change USE: +webkit)
(dependency required by "kde-base/pykde4-4.5.1-r1" [ebuild])
(dependency required by "kde-base/marble-4.5.1" [ebuild])
(dependency required by "kde-base/kdeedu-meta-4.5.1" [ebuild])
(dependency required by "kde-base/kde-meta-4.5.1" [ebuild])
(dependency required by "kde-meta" [argument])

* IMPORTANT: 4 news items need reading for repository 'gentoo'.
* Use eselect news to read news items.

Quando tento instalar fico nesse erro, procurando na net não encontrei grandes coisas.
Tentei incluir as flags no meu make.conf, mais não resolveu .
Tentei recompilar o pacote PyQt4 incluindo a flags [dbus,sql,svg,webkit,X], mais nada.
Se alguém puder me ajudar, agradeço !



  


2. MELHOR RESPOSTA

Thiago Ramos Fanfoni
thiagofanfoni

(usa Gentoo)

Enviado em 24/09/2010 - 14:45h

Oi Monica , a questão do overlay pode até funcionar, mas pela quantidade de pacotes que tem que ser instalado , possivelmente haverá efeitos colaterais.
Esse problema que você está passando é bastante comum com "N" pacotes e o portage está inclusive avisando sobre ele na linha:

dev-python/PyQt4-4.7.7 (Change USE: +webkit)

Certos pacotes precisam de algumas useflags de outros pacotes para poderem ser instalados.

A melhor solução para o seu problema é adicionar a linha "dev-python/PyQt4-4.7.7 webkit" (sem aspas) no arquivo /etc/portage/package.use (se o diretório não existir, crie ele e o arquivo).

e rodar um emerge -DuN world

Abs



3. Re: Problema na instalação do kde 4.5.1 no Gentoo [RESOLVIDO]

Alberto Federman Neto.
albfneto

(usa Sabayon)

Enviado em 24/09/2010 - 14:04h

parece que ele não acha o ebuild adequado, parece ser a versão de pyqt.
eu tentaria duas coisas:

1) mais fácil. adicionar o overlay completo do kde, para ver se lá tem o pacote adequado:

# layman -a kde
# layman -S
# emerge --sync

aí tentava emergir o kde, primeiro com opção pretend, para ver como está:

$ emerge -p kde-meta

se estiver tudo em ordem:

# LINGUAS="pt_BR" emerge -av kde-meta

2) atualizar pyqt, apesar que eu acho que 4.7.7 é o mais novo, ou fazer downgrade do pyqt apenas:

# emerge -av --nodeps =dev-python/PyQt4

3) se 1 e 2 não funfarem, tentar de outro jeito fazer upgrade dos pacotes qt e python (cuidado com
atualizar python, fazer primeiro com opção pretend)

$ emerge -p qt python
# emerge -v qt python
# LINGUAS="pt_BR" emerge -av kde-meta

ops. não tinha visto a linha change use, tinha reparado só a use flags, eue que sempre digo que o Portage FALA com o usuário..
poie é, ele fala e a gente as vezes não ouve....rsrssrsrsrs








4. Re: Problema na instalação do kde 4.5.1 no Gentoo [RESOLVIDO]

monica neopomuceno
[email protected]

(usa Ubuntu)

Enviado em 24/09/2010 - 15:21h

albfneto, obrigado.
thiagofanfoni, fiz como você falou e deu certo, obrigado.