LightDM não inicia no Gentoo [RESOLVIDO]

1. LightDM não inicia no Gentoo [RESOLVIDO]

Natsu Dragneel
Natsu_Dragneel

(usa XUbuntu)

Enviado em 24/01/2019 - 14:38h

Olá, eu estava instalando o gentoo via chroot, do meu computador.
Então, a instalação ocorreu bem, mais, o lightdm não inicia.

[b] /var/log/lightdm/lightdm-log

[+0.01s] DEBUG: Logging to /var/log/lightdm/lightdm.log
[+0.01s] DEBUG: Starting Light Display Manager 1.26.0, UID=0 PID=3968
[+0.01s] DEBUG: Loading configuration dirs from /usr/share/lightdm/lightdm.conf.d
[+0.01s] DEBUG: Loading configuration dirs from /usr/local/share/lightdm/lightdm.conf.d
[+0.01s] DEBUG: Loading configuration dirs from /etc/xdg/lightdm/lightdm.conf.d
[+0.01s] DEBUG: Loading configuration from /etc/lightdm/lightdm.conf
[+0.01s] DEBUG: Registered seat module local
[+0.01s] DEBUG: Registered seat module xremote
[+0.01s] DEBUG: Registered seat module unity
[+0.01s] DEBUG: Using D-Bus name org.freedesktop.DisplayManager
[+0.02s] WARNING: Failed to get list of logind seats: GDBus.Error:org.freedesktop.DBus.Error.ServiceUnknown: The name org.freedesktop.login1 was not provided by any .service files
[+0.02s] DEBUG: Adding default seat
[+0.02s] DEBUG: Seat seat0: Loading properties from config section Seat:*
[+0.02s] DEBUG: Seat seat0: Starting
[+0.02s] DEBUG: Seat seat0: Creating greeter session
[+0.03s] DEBUG: Seat seat0: Creating display server of type x
[+0.03s] DEBUG: Could not run plymouth --ping: Failed to execute child process “plymouth” (No such file or directory)
[+0.03s] DEBUG: Using VT 7
[+0.03s] DEBUG: Seat seat0: Starting local X display on VT 7
[+0.03s] DEBUG: XServer 0: Logging to /var/log/lightdm/x-0.log
[+0.05s] DEBUG: XServer 0: Writing X server authority to /var/run/lightdm/root/:0
[+0.05s] DEBUG: XServer 0: Launching X Server
[+0.05s] DEBUG: Launching process 4033: /usr/bin/X :0 -seat seat0 -auth /var/run/lightdm/root/:0 -nolisten tcp vt7 -novtswitch
[+0.05s] DEBUG: XServer 0: Waiting for ready signal from X server :0
[+0.05s] DEBUG: Acquired bus name org.freedesktop.DisplayManager
[+0.05s] DEBUG: Registering seat with bus path /org/freedesktop/DisplayManager/Seat0
[+0.72s] DEBUG: Loading users from org.freedesktop.Accounts
[+0.72s] DEBUG: User /org/freedesktop/Accounts/User1000 added
[+2.54s] DEBUG: Got signal 10 from process 4033
[+2.54s] DEBUG: XServer 0: Got signal from X server :0
[+2.54s] DEBUG: XServer 0: Connecting to XServer :0
[+2.54s] DEBUG: Seat seat0: Display server ready, starting session authentication
[+2.54s] DEBUG: Session pid=4188: Started with service 'lightdm-greeter', username 'root'
[+2.74s] DEBUG: Session pid=4188: Authentication complete with return value 0: Success
[+2.74s] DEBUG: Seat seat0: Session authenticated, running command
[+2.74s] DEBUG: Session pid=4188: Running command /usr/sbin/lightdm-gtk-greeter
[+2.74s] DEBUG: Creating shared data directory /var/lib/lightdm-data/root
[+2.74s] DEBUG: Session pid=4188: Logging to /var/log/lightdm/seat0-greeter.log
[+3.28s] DEBUG: Activating VT 7
[+3.28s] DEBUG: Activating ConsoleKit session localhost.localdomain-1548346122.256416-1328951785
[+4.47s] DEBUG: Greeter closed communication channel
[+4.47s] DEBUG: Session pid=4188: Exited with return value 1
[+4.47s] DEBUG: Seat seat0: Session stopped
[+4.47s] DEBUG: Seat seat0: Stopping; failed to start a greeter
[+4.47s] DEBUG: Seat seat0: Stopping
[+4.47s] DEBUG: Seat seat0: Stopping display server
[+4.47s] DEBUG: Sending signal 15 to process 4033
[+4.72s] DEBUG: Process 4033 exited with return value 0
[+4.72s] DEBUG: XServer 0: X server stopped
[+4.72s] DEBUG: Releasing VT 7
[+4.72s] DEBUG: XServer 0: Removing X server authority /var/run/lightdm/root/:0
[+4.72s] DEBUG: Seat seat0: Display server stopped
[+4.72s] DEBUG: Seat seat0: Stopped
[+4.72s] DEBUG: Required seat has stopped
[+4.72s] DEBUG: Stopping display manager
[+4.72s] DEBUG: Display manager stopped
[+4.72s] DEBUG: Stopping daemon
[+4.73s] DEBUG: Exiting with return value 1




  


2. Re: LightDM não inicia no Gentoo [RESOLVIDO]

Lucas C.S.
AdiosKid

(usa Funtoo)

Enviado em 24/01/2019 - 14:49h

o startx funciona ?

mostra o print do seu rc-update ai


3. Re: LightDM não inicia no Gentoo [RESOLVIDO]

Natsu Dragneel
Natsu_Dragneel

(usa XUbuntu)

Enviado em 24/01/2019 - 14:57h

Otaku escreveu:

o startx funciona ?

mostra o print do seu rc-update ai


Sim, o startx funciona, e inclusive, se eu logar como root, e dar o comando "lightdm", ele inicia normalmente.
o rc-update

NetworkManager | default
binfmt | boot
bootmisc | boot
cgroups | sysinit
cronie | default
dbus | default
devfs | sysinit
dmesg | sysinit
fsck | boot
hostname | boot
hwclock | boot
keymaps | boot
killprocs | shutdown
kmod-static-nodes | sysinit
local | default nonetwork
localmount | boot
loopback | boot
modules | boot
mount-ro | shutdown
mtab | boot
netmount | default
procfs | boot
root | boot
savecache | shutdown
swap | boot
sysctl | boot
sysfs | sysinit
sysklogd | default
termencoding | boot
udev | sysinit
udev-trigger | sysinit
urandom | boot
xdm | default



Entity Spawn ID: 54576c6b59584d3d


4. Re: LightDM não inicia no Gentoo [RESOLVIDO]

Lucas C.S.
AdiosKid

(usa Funtoo)

Enviado em 24/01/2019 - 15:33h

tenta adicionar o consolekit no boot


5. Re: LightDM não inicia no Gentoo [RESOLVIDO]

Natsu Dragneel
Natsu_Dragneel

(usa XUbuntu)

Enviado em 24/01/2019 - 16:01h

Otaku escreveu:

tenta adicionar o consolekit no boot


Continua dando o mesmo erro, ele não abre.
lightdm.log

[+0.05s] DEBUG: Logging to /var/log/lightdm/lightdm.log
[+0.05s] DEBUG: Starting Light Display Manager 1.26.0, UID=0 PID=4003
[+0.05s] DEBUG: Loading configuration dirs from /usr/share/lightdm/lightdm.conf.d
[+0.05s] DEBUG: Loading configuration dirs from /usr/local/share/lightdm/lightdm.conf.d
[+0.05s] DEBUG: Loading configuration dirs from /etc/xdg/lightdm/lightdm.conf.d
[+0.05s] DEBUG: Loading configuration from /etc/lightdm/lightdm.conf
[+0.05s] DEBUG: Registered seat module local
[+0.05s] DEBUG: Registered seat module xremote
[+0.05s] DEBUG: Registered seat module unity
[+0.05s] DEBUG: Using D-Bus name org.freedesktop.DisplayManager
[+0.05s] WARNING: Failed to get list of logind seats: GDBus.Error:org.freedesktop.DBus.Error.ServiceUnknown: The name org.freedesktop.login1 was not provided by any .service files
[+0.05s] DEBUG: Adding default seat
[+0.05s] DEBUG: Seat seat0: Loading properties from config section Seat:*
[+0.05s] DEBUG: Seat seat0: Starting
[+0.05s] DEBUG: Seat seat0: Creating greeter session
[+0.06s] DEBUG: Seat seat0: Creating display server of type x
[+0.06s] DEBUG: Could not run plymouth --ping: Failed to execute child process “plymouth” (No such file or directory)
[+0.06s] DEBUG: Using VT 7
[+0.06s] DEBUG: Seat seat0: Starting local X display on VT 7
[+0.06s] DEBUG: XServer 0: Logging to /var/log/lightdm/x-0.log
[+0.07s] DEBUG: XServer 0: Writing X server authority to /var/run/lightdm/root/:0
[+0.07s] DEBUG: XServer 0: Launching X Server
[+0.08s] DEBUG: Launching process 4052: /usr/bin/X :0 -seat seat0 -auth /var/run/lightdm/root/:0 -nolisten tcp vt7 -novtswitch
[+0.08s] DEBUG: XServer 0: Waiting for ready signal from X server :0
[+0.08s] DEBUG: Acquired bus name org.freedesktop.DisplayManager
[+0.08s] DEBUG: Registering seat with bus path /org/freedesktop/DisplayManager/Seat0
[+0.70s] DEBUG: Loading users from org.freedesktop.Accounts
[+0.70s] DEBUG: User /org/freedesktop/Accounts/User1000 added
[+3.10s] DEBUG: Got signal 10 from process 4052
[+3.10s] DEBUG: XServer 0: Got signal from X server :0
[+3.10s] DEBUG: XServer 0: Connecting to XServer :0
[+3.11s] DEBUG: Seat seat0: Display server ready, starting session authentication
[+3.11s] DEBUG: Session pid=4222: Started with service 'lightdm-greeter', username 'root'
[+3.31s] DEBUG: Session pid=4222: Authentication complete with return value 0: Success
[+3.31s] DEBUG: Seat seat0: Session authenticated, running command
[+3.31s] DEBUG: Session pid=4222: Running command /usr/sbin/lightdm-gtk-greeter
[+3.31s] DEBUG: Creating shared data directory /var/lib/lightdm-data/root
[+3.31s] DEBUG: Session pid=4222: Logging to /var/log/lightdm/seat0-greeter.log
[+3.58s] DEBUG: Activating VT 7
[+3.58s] DEBUG: Activating ConsoleKit session localhost.localdomain-1548352469.861697-1362435656
[+4.75s] DEBUG: Greeter closed communication channel
[+4.75s] DEBUG: Session pid=4222: Exited with return value 1
[+4.75s] DEBUG: Seat seat0: Session stopped
[+4.75s] DEBUG: Seat seat0: Stopping; failed to start a greeter
[+4.75s] DEBUG: Seat seat0: Stopping
[+4.75s] DEBUG: Seat seat0: Stopping display server
[+4.75s] DEBUG: Sending signal 15 to process 4052
[+4.99s] DEBUG: Process 4052 exited with return value 0
[+4.99s] DEBUG: XServer 0: X server stopped
[+4.99s] DEBUG: Releasing VT 7
[+4.99s] DEBUG: XServer 0: Removing X server authority /var/run/lightdm/root/:0
[+4.99s] DEBUG: Seat seat0: Display server stopped
[+4.99s] DEBUG: Seat seat0: Stopped
[+4.99s] DEBUG: Required seat has stopped
[+4.99s] DEBUG: Stopping display manager
[+4.99s] DEBUG: Display manager stopped
[+4.99s] DEBUG: Stopping daemon
[+4.99s] DEBUG: Exiting with return value 1



Entity Spawn ID: 54576c6b59584d3d


6. Re: LightDM não inicia no Gentoo [RESOLVIDO]

Lucas C.S.
AdiosKid

(usa Funtoo)

Enviado em 24/01/2019 - 16:10h

Seu usuário esta no grupo de vídeo ?


7. Re: LightDM não inicia no Gentoo [RESOLVIDO]

Natsu Dragneel
Natsu_Dragneel

(usa XUbuntu)

Enviado em 24/01/2019 - 16:20h

Otaku escreveu:

Seu usuário esta no grupo de vídeo ?

Sim.


Entity Spawn ID: 54576c6b59584d3d


8. Re: LightDM não inicia no Gentoo [RESOLVIDO]

Lucas C.S.
AdiosKid

(usa Funtoo)

Enviado em 24/01/2019 - 16:40h

loga no tty como seu usuário e tenta abrir o lightdm manualmente se não for testar o startx como usuário e não root.


9. Re: LightDM não inicia no Gentoo [RESOLVIDO]

Natsu Dragneel
Natsu_Dragneel

(usa XUbuntu)

Enviado em 24/01/2019 - 17:08h

Otaku escreveu:

loga no tty como seu usuário e tenta abrir o lightdm manualmente se não for testar o startx como usuário e não root.

Sim, logando em modo tty ele funciona, mais, quando eu inicio o sistema não.

Testei com slim:



slim: waiting for X server to begin accepting connections.
slim: waiting for X server to begin accepting connections.
slim: waiting for X server to begin accepting connections...
slim: unexpected signal 15
slim: waiting for X server to begin accepting connections.
Giving up.
slim: unable to connect to X server
slim: waiting for X server to shut down
slim: waiting for X server to begin accepting connections...
slim: unexpected signal 15
slim: waiting for X server to begin accepting connections.
slim: pam_authentication(): Authentication failure
slim: pam_authentication(): Authentication failure
slim: unexpected signal 15

slim: waiting for X server to shut down
slim: waiting for X server to begin accepting connections.
slim: pam_authentication(): Authentication failure
slim: get_x11_device: cannot open display



Entity Spawn ID: 54576c6b59584d3d


10. Re: LightDM não inicia no Gentoo [RESOLVIDO]

Lucas C.S.
AdiosKid

(usa Funtoo)

Enviado em 24/01/2019 - 17:25h

Você não esta dando detalhes, recapitula o que você fez e lista aqui os passos e as configurações relacionadas.


11. Re: LightDM não inicia no Gentoo [RESOLVIDO]

Natsu Dragneel
Natsu_Dragneel

(usa XUbuntu)

Enviado em 24/01/2019 - 17:36h

Bom, começou assim:

Eu coloquei o consolekit como você disse, para rodar no boot.
 rc-update:        NetworkManager |      default                           
binfmt | boot
bootmisc | boot
cgroups | sysinit
consolekit | boot default
cronie | default
dbus | default
devfs | sysinit
dmesg | sysinit
fsck | boot
hostname | boot
hwclock | boot
keymaps | boot
killprocs | shutdown
kmod-static-nodes | sysinit
local | default nonetwork
localmount | boot
loopback | boot
modules | boot
mount-ro | shutdown
mtab | boot
netmount | default
procfs | boot
root | boot
savecache | shutdown
swap | boot
sysctl | boot
sysfs | sysinit
sysklogd | default
termencoding | boot
udev | sysinit
udev-trigger | sysinit
urandom | boot
xdm | default

Depois, você mandou eu checar se o usuário estava no grupo: "video", e ele estava, mais
para ter certeza, criei outro usuário, com ele no grupo "video", e exclui o antigo, e o problema continuou.

Depois, você mandou eu testar no tty, e ele funciona, mais, não quando a init ta rodando.
Apos isso, pensei em testar o slim, e o output do log e esse:

 LOG do Slim:
slim: waiting for X server to begin accepting connections.
slim: waiting for X server to begin accepting connections.
slim: waiting for X server to begin accepting connections...
slim: unexpected signal 15
slim: waiting for X server to begin accepting connections.
Giving up.
slim: unable to connect to X server
slim: waiting for X server to shut down
slim: waiting for X server to begin accepting connections...
slim: unexpected signal 15
slim: waiting for X server to begin accepting connections.
slim: pam_authentication(): Authentication failure
slim: pam_authentication(): Authentication failure
slim: unexpected signal 15

slim: waiting for X server to shut down
slim: waiting for X server to begin accepting connections.
slim: pam_authentication(): Authentication failure
slim: get_x11_device: cannot open display



O estranho e que, apos eu mudar o usuário, o lightdm e o slim, funcionaram, mais, apos eu logar, eles voltam ao tty.
Entity Spawn ID: 54576c6b59584d3d


12. Re: LightDM não inicia no Gentoo [RESOLVIDO]

Lucas C.S.
AdiosKid

(usa Funtoo)

Enviado em 24/01/2019 - 19:10h

Recapitula o que tu fez antes de testar o lightdm, durante a instalação, tenta reinstalar o lightdm e se mostra algum erro.



01 02



Patrocínio

Site hospedado pelo provedor RedeHost.
Linux banner
Linux banner
Linux banner

Destaques

Artigos

Dicas

Tópicos

Top 10 do mês

Scripts