UEFI do notebook não detecta mais o HD [RESOLVIDO]

1. UEFI do notebook não detecta mais o HD [RESOLVIDO]

Gustavo Fernandes Moreira
Gustavo_fm

(usa Debian)

Enviado em 23/09/2019 - 00:53h

Salve pessoal.
Seguinte, atualmente uso o debian no meu note, mas estava curioso e resolvi testar o fedora. Fui no site, baixei a iso, gravei no pen drive, mudei no SETUP para bootar primeiro o usb (estava em UEFI), entrei no fedora e instale numa partição do HD. Aí que surgiu o problema. Agora a UEFI não detecta mais o HD nem a partição que tem os executáveis, no caso o do GRUB e o do Windows (Também tenho ele instalado, mas raramente eu uso). Quando dou boot no usb do fedora e uso o utilitário do gnome para ver os discos, aparece que está tudo certo, o disco está e sempre foi GPT, a partição com os executáveis UEFI está intacta bem como os executáveis dentro dela. Daí eu uso o efibootmgr para ver as entradas da EFI e não aparece nada relacionado com o HD. Quando adiciono a entrada para dar boot no GRUB, aparece tudo certo, mas ao reiniciar a máquina as entradas são apagadas e não dá boot no GRUB. Tente também o rEFInd, mas não reconhece o HD também. Usando o modo legacy eu consigo dar boot num GRUB que por sorte estava instalado no HD, mas usando ele não consigo acessar o windows. Parece que a UEFI do meu note corrompeu. Alguém tem algum palpite para o que pode ter ocorrido ? Já tentei de tudo o que falaram na net, mas nada deu certo.
Grato.


  


2. MELHOR RESPOSTA

Clodoaldo Santos
clodoaldops

(usa Linux Mint)

Enviado em 23/09/2019 - 08:23h

Se seu laptop veio originalmente com Windows 8 ou 10 siga a dica com qualquer Linux

https://www.vivaolinux.com.br/artigo/Instalacao-dual-boot-UEFI-Linux-MintUbuntu-com-Windows-8110

3. Re: UEFI do notebook não detecta mais o HD [RESOLVIDO]

Gustavo Fernandes Moreira
Gustavo_fm

(usa Debian)

Enviado em 25/09/2019 - 09:00h


Obrigado. Consegui resolver o problema reinstalando o fedora seguindo os passos que você passou. Na primeira vez, tinha desmarcado para deixar o disco bootavel, achando que ele apagaria as entradas antigas, mas na segunda vez deixei marcado e deu certo. Também descobri porque não estava dando certo usar o efibootmgr para adicionar uma nova entrada, eu estava usando a sintaxe do caminho do arquivo errada.






Patrocínio

Site hospedado pelo provedor RedeHost.
Linux banner
Linux banner
Linux banner

Artigos

Dicas

Tópicos

Top 10 do mês

Scripts