erro na actualizacao via apt

1. erro na actualizacao via apt

Paulo Aziel Abilio Matusse
BillyMatrix2

(usa Outra)

Enviado em 10/09/2010 - 11:21h

espero que esteja tudo bem por ai!

de tanto ouvir falar bem do linux, specialmente do debian, decidi testar o sistema, consegui instalar, o sistema, contudo, n sei instalar software, de nenhum modo. tentei pelo apt, mas da um erro que n sei o que significa. ajudem-me por favor. abaixo indco o erro:


2xirtam:/home/aziel# apt-get update
Ign cdrom://[Debian GNU/Linux 5.0.5 _Lenny_ - Official i386 CD Binary-1 20100626-17:37] lenny Release.gpg
Ign cdrom://[Debian GNU/Linux 5.0.5 _Lenny_ - Official i386 CD Binary-1 20100626-17:37] lenny/main Translation-pt_PT
Ign cdrom://[Debian GNU/Linux 5.0.5 _Lenny_ - Official i386 CD Binary-1 20100626-17:37] lenny Release
Ign cdrom://[Debian GNU/Linux 5.0.5 _Lenny_ - Official i386 CD Binary-1 20100626-17:37] lenny/main Packages/DiffIndex
A ler as listas de pacotes... Pronto




  


2. Re: erro na actualizacao via apt

Luan Kleber
luanyata

(usa Ubuntu)

Enviado em 10/09/2010 - 11:48h

Cara use um editor de texto ( vim,nano,gedit )

e abra a sources.list com um dos comandos:

sudo vim /etc/apt/sources.list

sudo nano /etc/apt/sources.list

ou

sudo gedit /etc/apt/sources.list

em seguida comente a linha que começa com deb-cdrom com o simbolo #

como eu estou usando o Ubuntu ele tava assim:

deb cdrom:[Ubuntu 10.04 LTS _Lucid Lynx_ - Release i386 (20100429)]/ lucid main restricted

agora está assim:
#deb cdrom:[Ubuntu 10.04 LTS _Lucid Lynx_ - Release i386 (20100429)]/ lucid main restricted

salve e mande atualizar novamente, que ira resolver

;)



3. Re: erro na actualizacao via apt

Perfil removido
removido

(usa Nenhuma)

Enviado em 10/09/2010 - 12:12h

O que você postou aí indica que só existe o CD no seu sources.list.

digita aí:

sudo cat /etc/apt/sources.list

Cola o resultado aqui (se quiser).

#

Ou adicione as entradas dos repositórios do Lenny no sources.list:

$ sudo gedit /etc/apt/sources.list

### INÍCIO DO TEXTO

## Debian 5.0.6 'Lenny/Stable' (Espelhos Brasileiros).
deb http://ftp.br.debian.org/debian/ lenny main contrib non-free
deb http://ftp.br.debian.org/debian-security/ lenny/updates main contrib non-free
deb http://ftp.br.debian.org/debian-multimedia lenny main non-free

## Debian 5.0.6 'Lenny/Stable' (Espelhos Oficiais).
deb http://ftp.debian.org/debian/ lenny main contrib non-free
deb http://security.debian.org/ lenny/updates main contrib non-free
deb http://www.debian-multimedia.org/ lenny main non-free

## Debian 5.0.6 'Lenny/Stable' (Volatile).
deb http://volatile.debian.org/debian-volatile lenny/volatile main contrib non-free

### FIM DO TEXTO

Atualize as listas e instale as chaves GPG:

$ sudo apt-get update
$ sudo apt-get install debian-archive-keyring debian-keyring debian-multimedia-keyring


Para instalar programas:

$ sudo apt-get install nome-do-programa


Para procurar por programas:

$ sudo apt-cache search nome-do-programa
$ sudo apt-cache show nome-do-programa


Para remover programas:

$ sudo apt-get remove nome-do-programa


Para Expurgar programas (remove arquivos e configurações):

$ sudo apt-get --purge remove nome-do-programa


Ou faça tudo pelo Synaptic:

$ sudo apt-get install gksu synaptic
$ gksu synaptic

* o ícone fica em Sistema > Administração


Para entender melhor o gerenciamento de pacotes no Debian:

$ sudo apt-get install debian-reference-pt-br

* o ícone fica em Acessórios > Referência Debian.

Boa sorte e bem-vindo!






Patrocínio

Site hospedado pelo provedor RedeHost.
Linux banner
Linux banner
Linux banner

Destaques

Artigos

Dicas

Tópicos

Top 10 do mês

Scripts