Emacs não inicia no Slackware 14.0 [RESOLVIDO]

1. Emacs não inicia no Slackware 14.0 [RESOLVIDO]

WEDER ALVES RIBAS
wederribas

(usa Slackware)

Enviado em 10/11/2013 - 14:53h

Olá!

Estou com um problema com o Emacs, após executar um slackpkg update o Emacs não inicia mais via KDE. Tentei iniciar pelo terminal e aparece o seguinte erro:

emacs: error while loading shared libraries: libIlmImf.so.7: cannot open shared object file: No such file or directory

Ainda sou iniciante no Slackware (e consequentemente em Linux) mas, acho que deve ser a falta da biblioteca libIlmImf.so.7. Já tentei procurar no SlackBuilds mas não encontro esta librarie.

Alguém, por favor, pode me ajudar a encontrar essa biblioteca ou a resolver este problema?


  


2. Re: Emacs não inicia no Slackware 14.0 [RESOLVIDO]

Jose Mario
zezaocapoeira

(usa Slackware)

Enviado em 10/11/2013 - 17:55h

wederribas escreveu:

Olá!

Estou com um problema com o Emacs, após executar um slackpkg update o Emacs não inicia mais via KDE. Tentei iniciar pelo terminal e aparece o seguinte erro:

emacs: error while loading shared libraries: libIlmImf.so.7: cannot open shared object file: No such file or directory

Ainda sou iniciante no Slackware (e consequentemente em Linux) mas, acho que deve ser a falta da biblioteca libIlmImf.so.7. Já tentei procurar no SlackBuilds mas não encontro esta librarie.

Alguém, por favor, pode me ajudar a encontrar essa biblioteca ou a resolver este problema?


Salve mano .Dá uma olhada aqui http://search.slackware.eu/cgi-bin/search.cgi?rm=search&needle=libIlmImf.so.6&haystack=1&... . E a versão current http://search.slackware.eu/cgi-bin/search.cgi?rm=search&needle=libIlmImf.so.7&haystack=1&... .

OBS: Altere para sua versão do Slackware na caixa de busca!!!




3. Re: Emacs não inicia no Slackware 14.0 [RESOLVIDO]

WEDER ALVES RIBAS
wederribas

(usa Slackware)

Enviado em 11/11/2013 - 18:07h

Valeu mano! Não conhecia esse repositório não... bem, como disse eu sou iniciante ainda... e como todo bom iniciante ainda tenho uma dúvida:
Eu baixei o pacote openexr-1.7.0-i486-1.txz e o instalei via installpkg.
Então verifiquei e o arquivo libIlmImf.so.7 está em /usr/lib/ só que mesmo assim quando chamo o emacs ele não inicia e ainda aparece o mesmo erro no terminal.
Eu tenho que colocar o arquivo em outra pasta, ou adicionar um caminho até onde ele está?

Desculpe por ser tão noob... estou aprendendo nos trancos aqui...




4. Re: Emacs não inicia no Slackware 14.0 [RESOLVIDO]

WEDER ALVES RIBAS
wederribas

(usa Slackware)

Enviado em 12/11/2013 - 16:40h

Consegui resolver... após atualizar a librarie que estava faltando removi o emacs e o reinstalei via SlackBuilds... muito obrigado pela ajuda!






Patrocínio

Site hospedado pelo provedor RedeHost.
Linux banner
Linux banner
Linux banner

Destaques

Artigos

Dicas

Tópicos

Top 10 do mês

Scripts