Erro ao instalar o gdebi

1. Erro ao instalar o gdebi

Breno dos Santos Gomes
MrVPolar

(usa Linux Mint)

Enviado em 08/03/2021 - 08:56h

Olá! (Desculpa se eu tiver posto meu problema numa categoria errada, mas acho quê vocês não se importam muito com isso...) Eu estou usando o Linux Mint, e quando eu uso o seguinte código:
sudo apt install gdebi
ele dá o seguinte erro:
E: Malformed entry 1 in list file /etc/apt/sources.list.d/microsoft-edge-dev.list ([option] not assignment)
E: A lista de fontes não pode ser lida.
E: Malformed entry 1 in list file /etc/apt/sources.list.d/microsoft-edge-dev.list ([option] not assignment)
E: A lista de fontes não pode ser lida.
alguém poderia me ajudar?



  


2. Re: Erro ao instalar o gdebi

leandro peçanha scardua
leandropscardua

(usa Ubuntu)

Enviado em 08/03/2021 - 10:41h

Parece que tem erro em /etc/apt/sources.list.d/microsoft-edge-dev.list


3. Re: Erro ao instalar o gdebi

Breno dos Santos Gomes
MrVPolar

(usa Linux Mint)

Enviado em 08/03/2021 - 10:56h


leandropscardua escreveu:

Parece que tem erro em /etc/apt/sources.list.d/microsoft-edge-dev.list

Tá, isso eu já sei, e como é quê eu resolvo esse erro?



4. Re: Erro ao instalar o gdebi

leandro peçanha scardua
leandropscardua

(usa Ubuntu)

Enviado em 08/03/2021 - 15:19h

MrVPolar escreveu:


leandropscardua escreveu:

Parece que tem erro em /etc/apt/sources.list.d/microsoft-edge-dev.list

Tá, isso eu já sei, e como é quê eu resolvo esse erro?


Compare c o conteúdo de um arquivo válido ou exclua esse repositório


5. Re: Erro ao instalar o gdebi

Mauriciodez
Mauriciodez

(usa Debian)

Enviado em 08/03/2021 - 17:33h


MrVPolar escreveu:

Tá, isso eu já sei, e como é quê eu resolvo esse erro?


exclui o arquivo e vida que segue

sudo rm -v /etc/apt/sources.list.d/microsoft-edge-dev.list 


sudo apt update &&  sudo apt install gdebi 



------------------------------------------------------| Linux User #621728 |------------------------------------------------------

" Nem sempre é amigo aquele que te tira do buraco !!! ( Saddam Hussein )"

------------------------------------------------------| Linux User #621728 |------------------------------------------------------




6. Re: Erro ao instalar o gdebi

Ryuk Shinigami
Ryuk

(usa Nenhuma)

Enviado em 08/03/2021 - 18:06h

Mostre-nos o conteúdo do arquivo, com o comando abaixo:
cat /etc/apt/sources.list.d/microsoft-edge-dev.list 


Ou você pode tentar logo esse comando para "consertar" o problema:
echo "deb [arch=amd64] https://packages.microsoft.com/repos/edge stable main" | sudo tee /etc/apt/sources.list.d/microsoft-edge-dev.list && sudo apt update 



7. Re: Erro ao instalar o gdebi

Ricardo Groetaers
ricardogroetaers

(usa Linux Mint)

Enviado em 08/03/2021 - 19:45h

MrVPolar escreveu: Eu estou usando o Linux Mint, e quando eu uso o seguinte código:
sudo apt install gdebi

Edge e Microsoft a parte, voce está tentando instalar aquilo que já vem instalado de fábrica no Linux Mint?
Ele, o Gdebi, não aparece no análogo do "Menu iniciar" para ser lançado individualmente, mas aparece no "menu de contexto" quando se clica com o botão direito do mouse num arquivo .deb.

Observação: O Gerenciador gráfico de pacotes Synaptic existe no Mint para instalar pacotes (que estão nos repositórios oficiais ou adicionados pelo usuário) ou remover pacotes instalados (independente da origem). Bem mais simples que usar o apt em linha de comando.



8. Novo erro, olha só!

Breno dos Santos Gomes
MrVPolar

(usa Linux Mint)

Enviado em 08/03/2021 - 21:32h

Muitos me recomendaram excluir o bagaço que tava com problema, mas quando excluo e tento dar o seguinte comando(Que foi recomendado pelo Mauriciodez):
sudo apt get update && sudo apt install gdebi 

Depois de uns 5 segundos de instalação normal, me deparo com um erro gigantesco(Levou uns 10 segundos para copiar tudo):
W: Erro GPG: http://dl.google.com/linux/chrome/deb stable InRelease: As assinaturas a seguir não puderam ser verificadas devido à chave pública não estar disponível: NO_PUBKEY 78BD65473CB3BD13
E: The repository 'http://dl.google.com/linux/chrome/deb stable InRelease' is no longer signed.
N: Updating from such a repository can't be done securely, and is therefore disabled by default.
N: See apt-secure(8) manpage for repository creation and user configuration details.
W: An error occurred during the signature verification. The repository is not updated and the previous index files will be used. GPG error: http://repository.spotify.com stable InRelease: As assinaturas a seguir não puderam ser verificadas devido à chave pública não estar disponível: NO_PUBKEY D1742AD60D811D58
W: An error occurred during the signature verification. The repository is not updated and the previous index files will be used. GPG error: http://dl.google.com/linux/chrome-remote-desktop/deb stable Release: As assinaturas a seguir não puderam ser verificadas devido à chave pública não estar disponível: NO_PUBKEY 78BD65473CB3BD13

Desculpa ser chato, mas é que esse o único site que me ajuda, então fazer o quê né :/


9. Re: Erro ao instalar o gdebi

Mauriciodez
Mauriciodez

(usa Debian)

Enviado em 08/03/2021 - 21:52h

MrVPolar escreveu:

Muitos me recomendaram excluir o bagaço que tava com problema, mas quando excluo e tento dar o seguinte comando(Que foi recomendado pelo Mauriciodez):
sudo apt get update && sudo apt install gdebi 

Depois de uns 5 segundos de instalação normal, me deparo com um erro gigantesco(Levou uns 10 segundos para copiar tudo):
W: Erro GPG: http://dl.google.com/linux/chrome/deb stable InRelease: As assinaturas a seguir não puderam ser verificadas devido à chave pública não estar disponível: NO_PUBKEY 78BD65473CB3BD13
E: The repository 'http://dl.google.com/linux/chrome/deb stable InRelease' is no longer signed.
N: Updating from such a repository can't be done securely, and is therefore disabled by default.
N: See apt-secure(8) manpage for repository creation and user configuration details.
W: An error occurred during the signature verification. The repository is not updated and the previous index files will be used. GPG error: http://repository.spotify.com stable InRelease: As assinaturas a seguir não puderam ser verificadas devido à chave pública não estar disponível: NO_PUBKEY D1742AD60D811D58
W: An error occurred during the signature verification. The repository is not updated and the previous index files will be used. GPG error: http://dl.google.com/linux/chrome-remote-desktop/deb stable Release: As assinaturas a seguir não puderam ser verificadas devido à chave pública não estar disponível: NO_PUBKEY 78BD65473CB3BD13

Desculpa ser chato, mas é que esse o único site que me ajuda, então fazer o quê né :/


toda vez que vc coloca um repositório "não oficial" vc tem que instalar tb a chave para descripografar .. como vc não fez é por isso que vc está com erro ... essa é uma forma de instalar as chaves
sudo apt-key adv --keyserver keyserver.ubuntu.com --recv-keys D1742AD60D811D58 78BD65473CB3BD13 



https://www.vivaolinux.com.br/dica/APT-Corrigir-erro-de-chave-publica-W-Erro-GPG/

------------------------------------------------------| Linux User #621728 |------------------------------------------------------

" Nem sempre é amigo aquele que te tira do buraco !!! ( Saddam Hussein )"

------------------------------------------------------| Linux User #621728 |------------------------------------------------------




10. Agradecimento

Breno dos Santos Gomes
MrVPolar

(usa Linux Mint)

Enviado em 08/03/2021 - 22:08h

Muito obrigado, agradeço a todos vocês(Principalmente ao Mauriciodez) por ajudar, agora está funcionando perfeitamente.


11. Re: Erro ao instalar o gdebi

Mauriciodez
Mauriciodez

(usa Debian)

Enviado em 08/03/2021 - 22:10h



bom que resolveu ... agora marque seu tópico como "RESOLVIDO" e depois eleja uma "MELHOR RESPOSTA".



------------------------------------------------------| Linux User #621728 |------------------------------------------------------

" Nem sempre é amigo aquele que te tira do buraco !!! ( Saddam Hussein )"

------------------------------------------------------| Linux User #621728 |------------------------------------------------------




12. Re: Erro ao instalar o gdebi

Clodoaldo Santos
clodoaldops

(usa Linux Mint)

Enviado em 09/03/2021 - 17:33h

https://www.vivaolinux.com.br/dica/O-que-fazer-apos-instalar-Linux-Mint-20
Gdebi já vem instalado no LinuxMint-20








Patrocínio

Site hospedado pelo provedor RedeHost.
Linux banner
Linux banner
Linux banner

Destaques

Artigos

Dicas

Tópicos

Top 10 do mês

Scripts