Erro ao Iniciar gdm / X

1. Erro ao Iniciar gdm / X

Guilherme Carvalho
Gui Carvalho

(usa Debian)

Enviado em 20/03/2012 - 22:44h

Boa noite!

Pessoal, estou com um problema para iniciar o Debian Squeeze, ocorre o seguinte:

- Ao iniciar pelo modo normal, a máquina trava em uma tela preta com um cursor piscando no canto superior esquerdo;
- Pelo recovery mode, consigo entrar normalmente no modo texto, mas ao tentar subir o modo gráfico com o comando "startx" é exibido um erro (Fatal Error, Screens not Found);
- Ao tentar iniciar o GMD3, ele também vai para a tela preta com o cursor piscando e não sai disso;

Andei pesquisando e um dos problemas poderia ser referente ao módulo de disquete que estava subindo com o sistema... Acrescentei esse modulo (floppy) ao blacklist e reiniciei a máquina subindo no modo normal. Dessa vez ele subiu (sem ser pelo recovery mode), mas apenas em modo texto. Reinstalei o Xorg, reinstalei o GDM, e quando reinicei a máquina, não subiu mais pelo modo normal nem em modo texto... Voltou a travar como antes... Agora só em recovery mode!

Observações:

1º - Esse Kernel que estou tentando subir foi "customizado" para ter suporte ao Layer 7 (Netfilter), recompilei utilizando o Tutorial: http://www.vivaolinux.com.br/artigo/Kernel-atualizado-no-Debian-Parte-II (Nos comentários próximo ao final da página, informo sobre esse problema e o Edps me da algumas dicas)

2º - Não sei se isso pode influenciar em alguma coisa, mas consigo acessar essa máquina pelo VNC em modo gráfico normalmente, porém quando faço isso, nela (a maquina acessada) fica repetindo o seguinte erro: end_request: I/O error, dev fd0, sector 0 - Buffer I/O error on device fd0, logical block 0.

A versão desse Kernel é a 2.6.32.58

Segue log (não-completo) do Xorg:

...

(II) VESA(0): Total Memory: 4096 64KB banks (262144kB)
(II) VESA(0): Monitor0: Using hsync range of 31.50--1849.09 kHz
(II) VESA(0): Monitor0: Using vrefresh range of 56.00-61.73 Hz
(II) VESA(0): Not using built-in mode "1024x768" (no mode of this name)
(II) VESA(0): Not using built-in mode "800x600" (no mode of this name)
(II) VESA(0): Not using built-in mode "640x480" (no mode of this name)
(II) VESA(0): Not using built-in mode "1600x1200" (no mode of this name)
(II) VESA(0): Not using built-in mode "1400x1050" (no mode of this name)
(II) VESA(0): Not using built-in mode "1280x1024" (no mode of this name)
(II) VESA(0): Not using built-in mode "640x400" (no mode of this name)
(II) VESA(0): Not using built-in mode "320x400" (no mode of this name)
(II) VESA(0): Not using built-in mode "320x240" (illegal horizontal timings)
(II) VESA(0): Not using built-in mode "320x200" (illegal horizontal timings)
(WW) VESA(0): No valid modes left. Trying aggressive sync range...
(II) VESA(0): Monitor0: Using hsync range of 31.50--1849.09 kHz
(II) VESA(0): Monitor0: Using vrefresh range of 50.00-61.73 Hz
(II) VESA(0): Not using built-in mode "1024x768" (hsync out of range)
(II) VESA(0): Not using built-in mode "800x600" (hsync out of range)
(II) VESA(0): Not using built-in mode "640x480" (hsync out of range)
(II) VESA(0): Not using built-in mode "1600x1200" (hsync out of range)
(II) VESA(0): Not using built-in mode "1400x1050" (hsync out of range)
(II) VESA(0): Not using built-in mode "1280x1024" (hsync out of range)
(II) VESA(0): Not using built-in mode "640x400" (hsync out of range)
(II) VESA(0): Not using built-in mode "320x400" (hsync out of range)
(II) VESA(0): Not using built-in mode "320x240" (illegal horizontal timings)
(II) VESA(0): Not using built-in mode "320x200" (illegal horizontal timings)
(EE) VESA(0): No valid modes
(II) UnloadModule: "vesa"
(II) UnloadModule: "int10"
(II) Unloading /usr/lib/xorg/modules/libint10.so
(II) UnloadModule: "vbe"
(II) Unloading /usr/lib/xorg/modules/libvbe.so
(EE) Screen(s) found, but none have a usable configuration.

Fatal server error:
no screens found

Please consult the The X.Org Foundation support
at http://wiki.x.org
for help.
Please also check the log file at "/var/log/Xorg.0.log" for additional informat$


Desculpa por criar um tópico tão grande, é que quis colocar o máximo de detalhes possível para que vcs possam entender melhor o que está ocorrendo... Estou com esse problema desde o ultimo sábado... Agradeço desde já a atenção!




  


2. Re: Erro ao Iniciar gdm / X

Guilherme Carvalho
Gui Carvalho

(usa Debian)

Enviado em 20/03/2012 - 23:34h

Alguém aí pode dar um help?

Por favor avisem se eu não categorizei o Tópico na Comunidade correta...

Obrigado!


3. Re: Erro ao Iniciar gdm / X

Josue de Jesus Santos
JJSantos

(usa Gentoo)

Enviado em 21/03/2012 - 03:30h

# cat /etc/X11/xorg.conf

Os log estão em /var/log*


4. Re: Erro ao Iniciar gdm / X

Alex Miranda
Axel Kid

(usa Ubuntu)

Enviado em 21/03/2012 - 09:59h

Estranho, parece ser algum erro no proprio gdm

Tente remover o gdm e instalar de novo...


5. Re: Erro ao Iniciar gdm / X

Guilherme Carvalho
Gui Carvalho

(usa Debian)

Enviado em 21/03/2012 - 13:41h

Josue,
Nao entendi...

Axel,
Ontem a noite eu desinstalei e reinstalei o GDM, porem nao tive sucesso... Fiz o mesmo com o Xorg.


6. Re: Erro ao Iniciar gdm / X

Guilherme Carvalho
Gui Carvalho

(usa Debian)

Enviado em 21/03/2012 - 13:57h

Nao tem alguma forma de copiar as configuracoes validas do Kernel que esta ok para esse?
Desculpem se eu estiver falando besteiras... rs! To iniciando no mundo Linux ainda... rs


7. Re: Erro ao Iniciar gdm / X

Josue de Jesus Santos
JJSantos

(usa Gentoo)

Enviado em 21/03/2012 - 14:51h

Gui Carvalho escreveu:

Josue,
Nao entendi...

Axel,
Ontem a noite eu desinstalei e reinstalei o GDM, porem nao tive sucesso... Fiz o mesmo com o Xorg.


No terminal cole isso e post a saída:

# cat /etc/X11/xorg.conf


8. Re: Erro ao Iniciar gdm / X

Guilherme Carvalho
Gui Carvalho

(usa Debian)

Enviado em 21/03/2012 - 19:43h

Section "ServerLayout"
Identifier "X.org Configured"
Screen 0 "Screen0" 0 0
InputDevice "Mouse0" "CorePointer"
InputDevice "Keyboard0" "CoreKeyboard"
EndSection

Section "InputDevice"
Identifier "Keyboard0"
Driver "kbd"
Option "XkbModel" "abnt2"
Option "XkbLayout" "br"
EndSection

Section "InputDevice"
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "auto"
Option "Device" "/dev/input/mice"
Option "Device" "/dev/input/mice"
Option "ZAxisMapping" "4 5 6 7"
EndSection

Section "Monitor"
Identifier "Monitor0"
EndSection

Section "Device"
Identifier "Card0"
Driver "vesa"
EndSection

Section "Screen"
Identifier "Screen0"
Device "Card0"
Monitor "Monitor0"
DefaultDepth 16
SubSection "Display"
Depth 16
Modes "1024x768" "800x600" "640x480"
EndSubSection
EndSection


Segue o Arquivo Xorg.conf...

OBS.: Eu não tinha esse arquivo, nem mesmo utilizando os comandos para criá-lo, ele não era criado! O Edps aqui do VOL me mandou o link desse arquivo, joguei ele na pasta mas mesmo assim não funcionou...




9. Re: Erro ao Iniciar gdm / X

Perfil removido
removido

(usa Nenhuma)

Enviado em 21/03/2012 - 20:39h

Em sua mensagem há uma referência ao floopy ( fd0 ), simples adicione-o ao blacklist:

# nano /etc/modprob.d/blacklist.conf

especificamente isso aqui:

blacklist floopy


#


sobre o Xorg, meu caro... você disse ter instalado os drivers Nvidia e não há menção alguma a esses drivers em seu log, seguinte, você pode gerar um xorg.conf de diferentes maneiras:

# X -configure
# mv xorg.conf.new /etc/X11/xorg.conf

ou com o nvidia-xconfig (se instalado obviamente):

# nvidia-xconfig -A

ou

# nvidia-xconfig --add-argb-glx-visuals --allow-glx-with-composite --composite --no-logo --nvagp=1 --render-accel -o /etc/X11/xorg.conf

* este último já adiciona as opções para aceleração gráfica, composite, etc.

#

Você também pode reinstalar o Xorg e Gdm3:

# apt-get install --reinstall xorg xserver-xorg gdm3


Ou pode simplesmente remover esse xorg.conf, reiniciar, cruzar os dedos para que inicie normalmente, já que este arquivo não é mais necessário em nenhuma distro Linux.

# rm /etc/X11/xorg.conf
# reboot


Se na ausência do arquivo o sistema não iniciar é sinal que algum driver está faltando.


10. Re: Erro ao Iniciar gdm / X

Guilherme Carvalho
Gui Carvalho

(usa Debian)

Enviado em 21/03/2012 - 21:04h

Então meu Caro, anteriormente nem mesmo com esses comando ele gerava o xorg.conf.new!

Efetuei a reintalação do Xorg, e ao executar o comando para gerar o xorg.conf, no final da execução é exibida uma mensagem de erro:

[email protected]:~# Xorg :1 -configure

X.Org X Server 1.7.7
Release Date: 2010-05-04
X Protocol Version 11, Revision 0
Build Operating System: Linux 2.6.32-5-amd64 i686 Debian
Current Operating System: Linux gafc-desk 2.6.32.58-l7 #1 SMP Mon Mar 19 20:58:37 BRT 2012 i686
Kernel command line: BOOT_IMAGE=/boot/vmlinuz-2.6.32.58-l7 root=UUID=6b4ba170-d5ee-4fe9-b04a-4f9616aa5611 ro quiet
Build Date: 30 October 2011 08:56:49PM
xorg-server 2:1.7.7-14 (Julien Cristau <[email protected]>)
Current version of pixman: 0.16.4
Before reporting problems, check http://wiki.x.org
to make sure that you have the latest version.
Markers: (--) probed, (**) from config file, (==) default setting,
(++) from command line, (!!) notice, (II) informational,
(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.1.log", Time: Wed Mar 21 20:59:23 2012
List of video drivers:
tdfx
siliconmotion
geode
apm
openchrome
vmware
nouveau
neomagic
cirrus
chips
mga
mach64
tseng
s3virge
ark
sisusb
i128
ati
voodoo
savage
ztv
vmwlegacy
sis
s3
i740
trident
intel
r128
radeon
nv
rendition
fbdev
vesa
vmware: Please ignore above "FATAL: Module vmwgfx not found."
(++) Using config file: "/root/xorg.conf.new"
(==) Using system config directory "/usr/share/X11/xorg.conf.d"
(EE) [drm] No DRICreatePCIBusID symbol
Number of created screens does not match number of detected devices.
Configuration failed.

OBS.: Tentei subir sem esse arquivo mas mesmo assim não inicia interface grafica...

A diferença agora é que eu removi o GDM e instalei o SLIM e agora ele sobe (em modo texto) na opção normal do Kernel (não apenas pelo recovery mode como anteriormente)...

Creio que podemos estar perto de uma solução (torço por isso, rs!)

Tens mais alguma dica?

Obrigado pela atenção!




11. Re: Erro ao Iniciar gdm / X

Guilherme Carvalho
Gui Carvalho

(usa Debian)

Enviado em 23/03/2012 - 19:24h

Pessoal,

Alguém aí pode me dar um help? O problema ainda continua... tah cruel... rs!

Fiz um teste ontem, customizando um Kernel da versão padrão do Debian Squeeze (2.6.32.5), para verificar se derrepente não se tratava de alguma incompatibilidade do Kernel customizado com o chipset da minha máquina... Mas o problema apresentado é o mesmo!


12. Re: Erro ao Iniciar gdm / X

Josue de Jesus Santos
JJSantos

(usa Gentoo)

Enviado em 23/03/2012 - 21:35h

Gui Carvalho escreveu:

Pessoal,

Alguém aí pode me dar um help? O problema ainda continua... tah cruel... rs!

Fiz um teste ontem, customizando um Kernel da versão padrão do Debian Squeeze (2.6.32.5), para verificar se derrepente não se tratava de alguma incompatibilidade do Kernel customizado com o chipset da minha máquina... Mas o problema apresentado é o mesmo!


Como você instalou esse Debian? Full, minamal, etc.



01 02



Patrocínio

Site hospedado pelo provedor RedeHost.
Linux banner
Linux banner
Linux banner

Destaques

Artigos

Dicas

Tópicos

Top 10 do mês

Scripts