Debian é instalado mas o sistema trava no início do login

1. Debian é instalado mas o sistema trava no início do login

Andriele Oliveira
drebian

(usa Outra)

Enviado em 24/12/2020 - 16:29h

Instalei o Debian no notebook Ideapad Gamingi3, com placa de vídeo NvideaGtxforce, durante a instalação houve um problema de ausência de alguns arquivos de firmware, mas durante a instalação eu prossegui já que eu tinha colocado internet pelo cabo do celular roteando via USB, e então deu tudo certo aparentemente, mas quando o grub inicia o login ele trava e não dá acesso a interface Gnome, vi alguns erros no sistema, segue as imagens, alguém sabe como resolvê-los? (sou nova no Debian)


  


2. Re: Debian é instalado mas o sistema trava no início do login

Ruan
ru4n

(usa Debian)

Enviado em 24/12/2020 - 17:01h

Erro com o gerenciamento de energia (ACPI). É o tipo de erro mais complicado de lidar no Linux, e geralmente está associado com notebooks com suporte híbrido (vídeo intel + nvidia na mesma máquina).

Sugiro vc testar outra distribuição que ofereça um kernel mais recente. O Debian 10 vem com o kernel 4.19 (antigo), e vc pode atualizá-lo para uma versão mais recente, porém dá um certo trabalho para quem é iniciante.

Opções que vc pode testar: PopOS (iso com o driver nvidia incluso), Ubuntu 20.10, Fedora, e o Manjaro.

obs: se quiser persistir no Debian, vc pode passar a opção acpi=off no grub para desativar o gerenciamento de energia. Porém isso não é uma solução definitiva, precisa analisar e ver uma forma de solucionar esse problema com o ACPI (cada modelo de notebook tem uma forma diferente)...



3. Re: Debian é instalado mas o sistema trava no início do login

leandro peçanha scardua
leandropscardua

(usa Ubuntu)

Enviado em 24/12/2020 - 17:12h

Nem todo erro de acpi é grave. A maioria dos erros acontece pq o fabricante sai do padrão por causa do windows. Em relação ao acpi o recomendável é atualizar a bios, se for possível. Se não for, tente atualizar o microcode
http://unixuniverse.com.br/linux/atualizar-bios
No caso do boot sua placa é nvidia. Vc pode tentar
https://tricks.readthedocs.io/en/latest/docs/ubuntu/ubuntu.html#graphics-card-repair-black-screen


4. Re: Debian é instalado mas o sistema trava no início do login

LinuxWalker
Delusion

(usa Debian)

Enviado em 24/12/2020 - 17:14h

Olá amigo;
No meu note amd-ryzen também acontece algo parecido, existem outras formas de atacar esse "problema", mas o que faço é instalar um kernel mais atual e reiniciar. Pronto, loga normal.
se quiser fazer isso, aí vão os passos detalhados:

1. entre em modo texto.
pra isso, depois de dar boot, passar do grub, basta apertar ctl alt f1, ou f2 ou f3... depende do teclado, testa aí.

2. faça login em modo texto
digita usuário e senha
ou root + senha.

3. abra o sources.list.
nano /etc/sources.list
(se você logou como usuário, digite su, antes desse passo + senha)

4. adicione o backports (esse é um repo mais atual, suportado pelo debian stable)
cole essa linha logo abaixo das que você vê como http://deb...blablabla
deb http://deb.debian.org/debian buster-backports main

5. salve a mudança: ctrl O
6. feche o arquivo: ctrl X

7. atualize: apt update

8. instale um kernel mais novo:
nesse momento, o mais atual no backports é o 5.9....
supondo que sua arquitetura seja 64bits o comando seria:
apt install linux-image-5.9.0-0.bpo.2-amd64

você pode verificar outros kernels digitando: apt search linux-image

depois de instalado é só reiniciar e voilá, aparece a tela de login.


PS.: teria pelo menos mais 2 métodos de resolver, mas esse acho o mais fácil/definitivo.

Linux User # 624552


5. Re: Debian é instalado mas o sistema trava no início do login

Ruan
ru4n

(usa Debian)

Enviado em 24/12/2020 - 17:23h


leandropscardua escreveu:

Nem todo erro de acpi é grave. A maioria dos erros acontece pq o fabricante sai do padrão por causa do windows. Em relação ao acpi o recomendável é atualizar a bios, se for possível. Se não for, tente atualizar o microcode
http://unixuniverse.com.br/linux/atualizar-bios
No caso do boot sua placa é nvidia. Vc pode tentar
https://tricks.readthedocs.io/en/latest/docs/ubuntu/ubuntu.html#graphics-card-repair-black-screen


Um tempo atrás peguei um Avell de um colega para instalar o Ubuntu, e o notebook era híbrido. Nenhuma distro ficava boa, por causa do bendito ACPI.
A solução foi esperar sair a versão 18.04 do Ubuntu (essa situação ocorreu em 2017), que aparentemente resolveu o congelamento aleatório. Porém só rodava com o driver nouveau, e sem chance de fazer switch com a placa intel...

Na minha concepção, o problema é "grave" quando necessita atualizar a bios... pois é um processo muito arriscado, onde precisa tomar todos os cuidados possíveis.


6. Re: Debian é instalado mas o sistema trava no início do login

leandro peçanha scardua
leandropscardua

(usa Ubuntu)

Enviado em 25/12/2020 - 19:02h

ru4n escreveu:


leandropscardua escreveu:

Nem todo erro de acpi é grave. A maioria dos erros acontece pq o fabricante sai do padrão por causa do windows. Em relação ao acpi o recomendável é atualizar a bios, se for possível. Se não for, tente atualizar o microcode
http://unixuniverse.com.br/linux/atualizar-bios
No caso do boot sua placa é nvidia. Vc pode tentar
https://tricks.readthedocs.io/en/latest/docs/ubuntu/ubuntu.html#graphics-card-repair-black-screen


Um tempo atrás peguei um Avell de um colega para instalar o Ubuntu, e o notebook era híbrido. Nenhuma distro ficava boa, por causa do bendito ACPI.
A solução foi esperar sair a versão 18.04 do Ubuntu (essa situação ocorreu em 2017), que aparentemente resolveu o congelamento aleatório. Porém só rodava com o driver nouveau, e sem chance de fazer switch com a placa intel...

Na minha concepção, o problema é "grave" quando necessita atualizar a bios... pois é um processo muito arriscado, onde precisa tomar todos os cuidados possíveis.


Eu concordo. A maioria dos erros não é erro, é código fora do padrão acpi q a microsoft aceita, mas o linux não. Atualizar a bios seria na esperança de q o fabricante corrigiu o código. Dá p tapear o bios passando a variável acpi_name (ou os_name) e fazendo o linux se passar por windows, mas tem de ser o windows "original" da máquina e o código conforme tabela abaixo.
https://maximumhoyt.blogspot.com/2009/06/spoofing-os-to-bios.html?m=1


7. Re: Debian é instalado mas o sistema trava no início do login

Cézar Augusto
cizordj

(usa Debian)

Enviado em 31/12/2020 - 00:04h

Meu PC também tem esse problema de ACPI no Debian e placa de video da nvidia, mas até hoje não deu problema. Atualizei a BIOS e tudo. Será que é isso mesmo que está causando o problema? Porque o driver da nouveau também trava no login


8. Re: Debian é instalado mas o sistema trava no início do login

leandro peçanha scardua
leandropscardua

(usa Ubuntu)

Enviado em 31/12/2020 - 11:53h

drebian escreveu:

Instalei o Debian no notebook Ideapad Gamingi3, com placa de vídeo NvideaGtxforce, durante a instalação houve um problema de ausência de alguns arquivos de firmware, mas durante a instalação eu prossegui já que eu tinha colocado internet pelo cabo do celular roteando via USB, e então deu tudo certo aparentemente, mas quando o grub inicia o login ele trava e não dá acesso a interface Gnome, vi alguns erros no sistema, segue as imagens, alguém sabe como resolvê-los? (sou nova no Debian)


Tente passar nomodeset como parâmetro para o kernel no grub. Se funcionar vc tem q ajustar algumas variáveis.






Patrocínio

Site hospedado pelo provedor RedeHost.
Linux banner
Linux banner
Linux banner

Destaques

Artigos

Dicas

Tópicos

Top 10 do mês

Scripts