Debian Lenny, pacotes desatualizados [RESOLVIDO]

1. Debian Lenny, pacotes desatualizados [RESOLVIDO]

Felipe Alexandre Rodrigues
felipe.far

(usa Debian)

Enviado em 15/06/2010 - 09:09h

Olá, estou querendo instalar debian lenny na minha máquina. Já usei debian squeeze e atualmente estou utilizando openSuse.

O debian squeeze apresentava alguns bugs na minha máquina que me deixava um pouco triste e eu quero voltar a usar o debian, mas desta vez o stable.

Minha dúvida é a respeito da desatualização do lenny. Eu quero a segurança do lenny, mas não quero perder a possibilidade de utilizar aplicativos mais recentes (Ex: OpenOffice, GIMP, brasero e até mesmo nautilus).

Se eu instalar o lenny vou conseguir instalar estes programas separadamente sem problemas? Ou vou ficar preso no passado sem muita possibilidade de usar aplicativos atuais.


  


2. Re: Debian Lenny, pacotes desatualizados [RESOLVIDO]

Rodolfo Marcondes Dias
Rodolfo_RR

(usa Ubuntu)

Enviado em 15/06/2010 - 10:06h

Entaum felipe vc pode usar o lenny, com repositorios do squeeze, mais isso as vezes da muito problema entao o pessoal criou o repositorio backports

da uma olhada nesse link

http://www.guiadohardware.net/tutoriais/debian-desktop/pagina3.html

ele fala do backports e sua facilidade, pois muitas pessoas abandonam o stable por causa de pacotes obsoletos, ja com o link do backports em seu sources.list vc pode ter um sistema robusto mais com pacotes atuais, como eh o meu caso

blz




3. Re: Debian Lenny, pacotes desatualizados [RESOLVIDO]

Perfil removido
removido

(usa Nenhuma)

Enviado em 15/06/2010 - 10:19h

Eu não costumo ter problemas usando o Squeeze, o segredo é não misturar releases (Stable, Testing e Unstable).

Como sugerido use o Lenny com o Backports, uma sources.list mínima:

deb ftp://ftp.debian.org/debian/ lenny main contrib non-free
deb http://security.debian.org/ lenny/updates main contrib
deb http://www.debian-multimedia.org/ lenny main non-free
deb http://www.backports.org/debian lenny-backports main contrib non-free

Quando quiser instalar um programa (exemplo broffice.org):

sudo apt-get -t lenny-backports install broffice.org

No Lenny o BrOffice está na versão 2.4 se não me engano, no Backports na 3.2.


4. Re: Debian Lenny, pacotes desatualizados [RESOLVIDO]

Felipe Alexandre Rodrigues
felipe.far

(usa Debian)

Enviado em 15/06/2010 - 10:25h

Olá, muito obrigado por me responder.

Bem interessante este negocio de backports. No exemplo do gdh ele cita utilizar backports para o openoffice. Se eu entrar no site do openOffice, fazer o download e instalar os .deb vai funcionar normalmente?. No caso do openOffice é bem padrão, mas por exemplo, se eu entrar no site do gnome e baixar o algum pacote .tar.gz (ex: brasero, nautilus) de algum aplicativo e instalar (./configure, make, instal)

Vai acontecer algum problema?


5. Re: Debian Lenny, pacotes desatualizados [RESOLVIDO]

Perfil removido
removido

(usa Nenhuma)

Enviado em 15/06/2010 - 11:10h

Se você baixar o .deb do site do OpenOffice, instale-o com:

sudo dpkg -i nome-do-pacote.deb
sudo apt-get -f install

O último comando é para corrigir algum problema de dependência se existir. Se o erro persistir rode:

sudo apt-get update
sudo apt-get -f install


6. Re: Debian Lenny, pacotes desatualizados [RESOLVIDO]

ronnie peterson bacelar martins
dbahiaz

(usa OpenSuSE)

Enviado em 15/06/2010 - 11:51h

Cara, o squeeze em pouco tempo será a versão estável do Debian e o Lenny será old(mais do que já é), a dica que dou é segurar um pouco a ansiedade, continuar no openSUSE e esperar a versão final estável do Squeeze. Usar repositórios diferentes em Debian, nem sempre é uma boa escolha, pense nisso!


7. Re: Debian Lenny, pacotes desatualizados [RESOLVIDO]

Felipe Alexandre Rodrigues
felipe.far

(usa Debian)

Enviado em 15/06/2010 - 12:32h

Bom, vou instalar o lenny, mexer o minimo possível e usar as backports! Obrigado a todos :)

:)