Aptitude com problemas de dependência

1. Aptitude com problemas de dependência

flipe
flipe

(usa Debian)

Enviado em 21/04/2011 - 20:21h

Estou tentando instalar alguns pacotes do GNOME, porém estou tendo um problema de dependência, os pacotes python-gobject e python-gobject-dev não instalam e com isso não permite que os outros sejam instalados, já tentei várias ações como "aptitude -f install", já removi os pacotes para instalar novamente, já tentei reinstalar, já tentei usando o dpkg, já tentei o purge, já atualizei meu repositório, mas nada resolve.


estou usando o repositório "deb http://ftp.br.debian.org/debian unstable main contrib non-free" e já tentei outros, mas a mesma mensagem persiste e os pacotes não são instalados.

aptitude install gimp gnome-session gnome-panel gnome-applets gnome-about gtk-recordmydesktop fusion-icon compizconfig-settings-manager gnome-menus gnome-control-center

Os NOVOS pacotes a seguir serão instalados: do
alacarte{a} compizconfig-settings-manager deskbar-applet{a} fusion-icon gimp gnome-about gnome-applets gnome-control-center gnome-menus
gnome-panel gnome-session gtk-recordmydesktop python-compizconfig{a} python-gconf{ab} python-glade2{a} python-gmenu{a} python-gnome2{ab}
python-gnomeapplet{a} python-gnomedesktop{a} python-gnomekeyring{a} python-gobject{a} python-gobject-cairo{a} python-gtk2{a}
python-wnck{a}
Os pacotes a seguir serão atualizados:
python-cairo
1 pacotes atualizados, 24 novos instalados, 0 a serem removidos e 1097 não atualizados.
É preciso obter 6736 kB/12,4 MB de arquivos. Depois do desempacotamento, 41,7 MB serão usados.
Os pacotes a seguir possuem dependências não satisfeitas:
python-gnome2: Depende: python2.5-gobject o qual é um pacote virtual.
Depende: python2.5-gtk2 o qual é um pacote virtual.
python-gconf: Depende: python2.5-gobject o qual é um pacote virtual.
As seguintes ações resolverão estas dependências:

Manter os pacotes a seguir em suas versões atuais:
1) deskbar-applet [Não Instalado]
2) gnome-about [Não Instalado]
3) gnome-applets [Não Instalado]
4) gnome-panel [Não Instalado]
5) gnome-session [Não Instalado]
6) python-gconf [Não Instalado]
7) python-gnome2 [Não Instalado]
8) python-gnomeapplet [Não Instalado]

Manter as seguintes dependências não resolvidas:
9) alacarte recomenda gnome-panel
10) gnome-control-center recomenda gnome-session
11) gnome-applets recomenda deskbar-applet
12) gnome-applets recomenda python-gconf


Aceitar esta solução? [Y/n/q/?]
Os NOVOS pacotes a seguir serão instalados:
compizconfig-settings-manager fusion-icon gimp gnome-control-center gnome-menus gtk-recordmydesktop python-compizconfig{a}
python-gmenu{a} python-gobject{a} python-gobject-cairo{a} python-gtk2{a}
Os pacotes a seguir serão atualizados:
python-cairo
Os pacotes a seguir foram RECOMENDADOS mas NÃO serão instalados:
gnome-session
1 pacotes atualizados, 11 novos instalados, 0 a serem removidos e 1097 não atualizados.
É preciso obter 6708 kB/9239 kB de arquivos. Depois do desempacotamento, 29,6 MB serão usados.
Você deseja continuar? [Y/n/?]
Obter:1 http://ftp.br.debian.org/debian/ unstable/main python-cairo i386 1.8.8-1+b2 [73,5 kB]
Obter:2 http://ftp.br.debian.org/debian/ unstable/main python-gobject i386 2.28.3-3 [582 kB]
Obter:3 http://ftp.br.debian.org/debian/ unstable/main python-gtk2 i386 2.17.0-4+b2 [1416 kB]
Obter:4 http://ftp.br.debian.org/debian/ unstable/main gimp i386 2.6.11-2 [4524 kB]
Obter:5 http://ftp.br.debian.org/debian/ unstable/main python-gobject-cairo i386 2.28.3-3 [112 kB]
Buscados 6708 kB em 16s (418 kB/s)
(Lendo banco de dados ... 191771 ficheiros e directórios actualmente instalados.)
Preparando para substituir python-cairo 1.8.8-1+b1 (usando .../python-cairo_1.8.8-1+b2_i386.deb) ...
Desempacotando substituto python-cairo ...
Selecionando pacote previamente não selecionado python-gobject.
Desempacotando python-gobject (de .../python-gobject_2.28.3-3_i386.deb) ...
Selecionando pacote previamente não selecionado python-gtk2.
Desempacotando python-gtk2 (de .../python-gtk2_2.17.0-4+b2_i386.deb) ...
Selecionando pacote previamente não selecionado python-compizconfig.
Desempacotando python-compizconfig (de .../python-compizconfig_0.8.4-2_i386.deb) ...
Selecionando pacote previamente não selecionado fusion-icon.
Desempacotando fusion-icon (de .../fusion-icon_0.1.0-2_all.deb) ...
Selecionando pacote previamente não selecionado gimp.
Desempacotando gimp (de .../gimp_2.6.11-2_i386.deb) ...
Selecionando pacote previamente não selecionado python-gmenu.
Desempacotando python-gmenu (de .../python-gmenu_2.30.3-2_i386.deb) ...
Selecionando pacote previamente não selecionado gnome-menus.
Desempacotando gnome-menus (de .../gnome-menus_2.30.3-2_i386.deb) ...
Selecionando pacote previamente não selecionado gnome-control-center.
Desempacotando gnome-control-center (de .../gnome-control-center_1%3a2.30.1-3_i386.deb) ...
Selecionando pacote previamente não selecionado gtk-recordmydesktop.
Desempacotando gtk-recordmydesktop (de .../gtk-recordmydesktop_0.3.8-4_all.deb) ...
Selecionando pacote previamente não selecionado python-gobject-cairo.
Desempacotando python-gobject-cairo (de .../python-gobject-cairo_2.28.3-3_i386.deb) ...
Selecionando pacote previamente não selecionado compizconfig-settings-manager.
Desempacotando compizconfig-settings-manager (de .../compizconfig-settings-manager_0.8.4-2_i386.deb) ...
Processando gatilhos para python-support ...
/usr/lib/python2.6/site.py:143: Warning: 'with' will become a reserved keyword in Python 2.6
'import site' failed; use -v for traceback
Processando gatilhos para menu ...
Processando gatilhos para desktop-file-utils ...
Processando gatilhos para hicolor-icon-theme ...
Configurando python-cairo (1.8.8-1+b2) ...
Configurando python-gobject (2.28.3-3) ...
/usr/lib/python2.6/site.py:143: Warning: 'with' will become a reserved keyword in Python 2.6
'import site' failed; use -v for traceback
/usr/lib/python2.6/runpy.py:105: Warning: 'as' will become a reserved keyword in Python 2.6
Could not import runpy module
dpkg: erro processando python-gobject (--configure):
sub-processo script post-installation instalado retornou estado de saída de erro 255
dpkg: problemas de dependência impedem a configuração de python-gtk2:
python-gtk2 depende de python-gobject (>= 2.15.3); porém:
Pacote python-gobject não está configurado ainda.
python-gtk2 depende de python2.6-gobject; porém:
Pacote python2.6-gobject não está instalado.
Pacote python-gobject, o qual fornece python2.6-gobject ainda não está configurado.
python-gtk2 depende de python2.7-gobject; porém:
Pacote python2.7-gobject não está instalado.
Pacote python-gobject, o qual fornece python2.7-gobject ainda não está configurado.
dpkg: erro processando python-gtk2 (--configure):
problemas de dependência - deixando desconfigurado
Configurando python-compizconfig (0.8.4-2) ...
configured to not write apport reports
configured to not write apport reports
dpkg: problemas de dependência impedem a configuração de fusion-icon:
fusion-icon depende de python-gtk2 | python-qt4; porém:
Pacote python-gtk2 não está configurado ainda.
Pacote python-qt4 não está instalado.
dpkg: erro processando fusion-icon (--configure):
problemas de dependência - deixando desconfigurado
dpkg: problemas de dependência impedem a configuração de gimp:
gimp depende de python-gtk2 (>= 2.8.0); porém:
Pacote python-gtk2 não está configurado ainda.
dpkg: erro processando gimp (--configure):
problemas de dependência - deixando desconfigurado
dpkg: problemas de dependência impedem a configuração de python-gmenu:
python-gmenu depende de python-gtk2; porém:
Pacote python-gtk2 não está configurado ainda.
dpkg: erro processando python-gmenu (--configure):
problemas de dependência - deixando desconfigurado
dpkg: problemas de dependência impedem a configuração de gnome-menus:
gnome-menus depende de python-gmenu (= 2.30.3-2); porém:
Pacote pconfigured to not write apport reports
configured to not write apport reports
configured to not write apport reports
configured to not write apport reports
configured to not write apport reports
configured to not write apport reports
ython-gmenu não está configurado ainda.
dpkg: erro processando gnome-menus (--configure):
problemas de dependência - deixando desconfigurado
dpkg: problemas de dependência impedem a configuração de gnome-control-center:
gnome-control-center depende de gnome-menus (>= 2.12.0); porém:
Pacote gnome-menus não está configurado ainda.
dpkg: erro processando gnome-control-center (--configure):
problemas de dependência - deixando desconfigurado
dpkg: problemas de dependência impedem a configuração de gtk-recordmydesktop:
gtk-recordmydesktop depende de python-gtk2; porém:
Pacote python-gtk2 não está configurado ainda.
dpkg: erro processando gtk-recordmydesktop (--configure):
problemas de dependência - deixando desconfigurado
Configurando python-gobject-cairo (2.28.3-3) ...
dpkg: problemas de dependência impedem a configuração de compizconfig-settings-manager:
compizconfig-settings-manager depende de python-gtk2; porém:
Pacote python-gtk2 não está configurado ainda.
dpkg: erro processando compizconfig-settings-manager (--configure):
problemas de dependência - deixando desconfigurado
Processando gatilhos para python-support ...
configured to not write apport reports
/usr/lib/python2.6/site.py:143: Warning: 'with' will become a reserved keyword in Python 2.6
'import site' failed; use -v for traceback
Erros foram encontrados durante o processamento de:
python-gobject
python-gtk2
fusion-icon
gimp
python-gmenu
gnome-menus
gnome-control-center
gtk-recordmydesktop
compizconfig-settings-manager
E: Sub-process /usr/bin/dpkg returned an error code (1)
A instalação de um pacote falhou. Tentando recuperar:
Configurando python-gobject (2.28.3-3) ...
/usr/lib/python2.6/site.py:143: Warning: 'with' will become a reserved keyword in Python 2.6
'import site' failed; use -v for traceback
/usr/lib/python2.6/runpy.py:105: Warning: 'as' will become a reserved keyword in Python 2.6
Could not import runpy module
dpkg: erro processando python-gobject (--configure):
sub-processo script post-installation instalado retornou estado de saída de erro 255
dpkg: problemas de dependência impedem a configuração de python-gtk2:
python-gtk2 depende de python-gobject (>= 2.15.3); porém:
Pacote python-gobject não está configurado ainda.
python-gtk2 depende de python2.6-gobject; porém:
Pacote python2.6-gobject não está instalado.
Pacote python-gobject, o qual fornece python2.6-gobject ainda não está configurado.
python-gtk2 depende de python2.7-gobject; porém:
Pacote python2.7-gobject não está instalado.
Pacote python-gobject, o qual fornece python2.7-gobject ainda não está configurado.
dpkg: erro processando python-gtk2 (--configure):
problemas de dependência - deixando desconfigurado
dpkg: problemas de dependência impedem a configuração de gtk-recordmydesktop:
gtk-recordmydesktop depende de python-gtk2; porém:
Pacote python-gtk2 não está configurado ainda.
dpkg: erro processando gtk-recordmydesktop (--configure):
problemas de dependência - deixando desconfigurado
dpkg: problemas de dependência impedem a configuração de fusion-icon:
fusion-icon depende de python-gtk2 | python-qt4; porém:
Pacote python-gtk2 não está configurado ainda.
Pacote python-qt4 não está instalado.
dpkg: erro processando fusion-icon (--configure):
problemas de dependência - deixando desconfigurado
dpkg: problemas de dependência impedem a configuração de gimp:
gimp depende de python-gtk2 (>= 2.8.0); porém:
Pacote python-gtk2 não está configurado ainda.
dpkg: erro processando gimp (--configure):
problemas de dependência - deixando desconfigurado
dpkg: problemas de dependência impedem a configuração de python-gmenu:
python-gmenu depende de python-gtk2; porém:
Pacote python-gtk2 não está configurado ainda.
dpkg: erro processando python-gmenu (--configure):
problemas de dependência - deixando desconfigurado
dpkg: problemas de dependência impedem a configuração de gnome-menus:
gnome-menus depende de python-gmenu (= 2.30.3-2); porém:
Pacote python-gmenu não está configurado ainda.
dpkg: erro processando gnome-menus (--configure):
problemas de dependência - deixando desconfigurado
dpkg: problemas de dependência impedem a configuração de gnome-control-center:
gnome-control-center depende de gnome-menus (>= 2.12.0); porém:
Pacote gnome-menus não está configurado ainda.
dpkg: erro processando gnome-control-center (--configure):
problemas de dependência - deixando desconfigurado
dpkg: problemas de dependência impedem a configuração de compizconfig-settings-manager:
compizconfig-settings-manager depende de python-gtk2; porém:
Pacote python-gtk2 não está configurado ainda.
dpkg: erro processando compizconfig-settings-manager (--configure):
problemas de dependência - deixando desconfigurado
Erros foram encontrados durante o processamento de:
python-gobject
python-gtk2
gtk-recordmydesktop
fusion-icon
gimp
python-gmenu
gnome-menus
gnome-control-center
compizconfig-settings-manager