A interface do debian nao abre

1. A interface do debian nao abre

marcos roberto
white-rabbit

(usa Debian)

Enviado em 18/08/2019 - 10:57h

Acabei de instalar o debian no modo grafico msm pra nao ter erros(sou novo no linux) porém nao inicia nem o gestor de login
meu pc é um ryzen 2700 16GB ram rtx 2060 2 ssd's de 240(sem raid) o log do xorg >>
[   137.375] 
X.Org X Server 1.20.4
X Protocol Version 11, Revision 0
[ 137.377] Build Operating System: Linux 4.9.0-8-amd64 x86_64 Debian
[ 137.378] Current Operating System: Linux deb 4.19.0-5-amd64 #1 SMP Debian 4.19.37-5+deb10u2 (2019-08-08) x86_64
[ 137.378] Kernel command line: BOOT_IMAGE=/boot/vmlinuz-4.19.0-5-amd64 root=UUID=1ced744b-7b62-4a3f-a119-d31b45a9935a ro quiet
[ 137.380] Build Date: 05 March 2019 08:11:12PM
[ 137.381] xorg-server 2:1.20.4-1 (https://www.debian.org/support)
[ 137.381] Current version of pixman: 0.36.0
[ 137.383] Before reporting problems, check http://wiki.x.org
to make sure that you have the latest version.
[ 137.383] Markers: (--) probed, (**) from config file, (==) default setting,
(++) from command line, (!!) notice, (II) informational,
(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[ 137.386] (==) Log file: "/var/log/Xorg.0.log", Time: Sun Aug 18 10:45:30 2019
[ 137.386] (==) Using system config directory "/usr/share/X11/xorg.conf.d"
[ 137.386] (==) No Layout section. Using the first Screen section.
[ 137.386] (==) No screen section available. Using defaults.
[ 137.386] (**) |-->Screen "Default Screen Section" (0)
[ 137.386] (**) | |-->Monitor "<default monitor>"
[ 137.387] (==) No monitor specified for screen "Default Screen Section".
Using a default monitor configuration.
[ 137.387] (==) Automatically adding devices
[ 137.387] (==) Automatically enabling devices
[ 137.387] (==) Automatically adding GPU devices
[ 137.387] (==) Max clients allowed: 256, resource mask: 0x1fffff
[ 137.387] (WW) The directory "/usr/share/fonts/X11/cyrillic" does not exist.
[ 137.387] Entry deleted from font path.
[ 137.387] (==) FontPath set to:
/usr/share/fonts/X11/misc,
/usr/share/fonts/X11/100dpi/:unscaled,
/usr/share/fonts/X11/75dpi/:unscaled,
/usr/share/fonts/X11/Type1,
/usr/share/fonts/X11/100dpi,
/usr/share/fonts/X11/75dpi,
built-ins
[ 137.387] (==) ModulePath set to "/usr/lib/xorg/modules"
[ 137.387] (II) The server relies on udev to provide the list of input devices.
If no devices become available, reconfigure udev or disable AutoAddDevices.
[ 137.387] (II) Loader magic: 0x5562f800ee20
[ 137.387] (II) Module ABI versions:
[ 137.387] X.Org ANSI C Emulation: 0.4
[ 137.387] X.Org Video Driver: 24.0
[ 137.387] X.Org XInput driver : 24.1
[ 137.387] X.Org Server Extension : 10.0
[ 137.387] (++) using VT number 2

[ 137.389] (II) systemd-logind: took control of session /org/freedesktop/login1/session/_33
[ 137.391] (--) PCI:*([email protected]:0:0) 10de:1f08:1043:869d rev 161, Mem @ 0xf5000000/16777216, 0xe0000000/268435456, 0xf0000000/33554432, I/O @ 0x0000e000/128, BIOS @ 0x????????/131072
[ 137.391] (II) LoadModule: "glx"
[ 137.392] (II) Loading /usr/lib/xorg/modules/extensions/libglx.so
[ 137.392] (II) Module glx: vendor="X.Org Foundation"
[ 137.392] compiled for 1.20.4, module version = 1.0.0
[ 137.392] ABI class: X.Org Server Extension, version 10.0
[ 137.516] (==) Matched nouveau as autoconfigured driver 0
[ 137.516] (==) Matched nv as autoconfigured driver 1
[ 137.516] (==) Matched modesetting as autoconfigured driver 2
[ 137.516] (==) Matched fbdev as autoconfigured driver 3
[ 137.516] (==) Matched vesa as autoconfigured driver 4
[ 137.516] (==) Assigned the driver to the xf86ConfigLayout
[ 137.516] (II) LoadModule: "nouveau"
[ 137.517] (II) Loading /usr/lib/xorg/modules/drivers/nouveau_drv.so
[ 137.517] (II) Module nouveau: vendor="X.Org Foundation"
[ 137.517] compiled for 1.20.3, module version = 1.0.16
[ 137.517] Module class: X.Org Video Driver
[ 137.517] ABI class: X.Org Video Driver, version 24.0
[ 137.517] (II) LoadModule: "nv"
[ 137.517] (WW) Warning, couldn't open module nv
[ 137.517] (EE) Failed to load module "nv" (module does not exist, 0)
[ 137.517] (II) LoadModule: "modesetting"
[ 137.517] (II) Loading /usr/lib/xorg/modules/drivers/modesetting_drv.so
[ 137.517] (II) Module modesetting: vendor="X.Org Foundation"
[ 137.517] compiled for 1.20.4, module version = 1.20.4
[ 137.517] Module class: X.Org Video Driver
[ 137.517] ABI class: X.Org Video Driver, version 24.0
[ 137.517] (II) LoadModule: "fbdev"
[ 137.517] (II) Loading /usr/lib/xorg/modules/drivers/fbdev_drv.so
[ 137.517] (II) Module fbdev: vendor="X.Org Foundation"
[ 137.517] compiled for 1.20.0, module version = 0.5.0
[ 137.517] Module class: X.Org Video Driver
[ 137.517] ABI class: X.Org Video Driver, version 24.0
[ 137.517] (II) LoadModule: "vesa"
[ 137.518] (II) Loading /usr/lib/xorg/modules/drivers/vesa_drv.so
[ 137.518] (II) Module vesa: vendor="X.Org Foundation"
[ 137.518] compiled for 1.20.1, module version = 2.4.0
[ 137.518] Module class: X.Org Video Driver
[ 137.518] ABI class: X.Org Video Driver, version 24.0
[ 137.518] (II) NOUVEAU driver Date: Mon Jan 28 23:25:58 2019 -0500
[ 137.518] (II) NOUVEAU driver for NVIDIA chipset families :
[ 137.518] RIVA TNT (NV04)
[ 137.518] RIVA TNT2 (NV05)
[ 137.518] GeForce 256 (NV10)
[ 137.518] GeForce 2 (NV11, NV15)
[ 137.518] GeForce 4MX (NV17, NV18)
[ 137.518] GeForce 3 (NV20)
[ 137.518] GeForce 4Ti (NV25, NV28)
[ 137.518] GeForce FX (NV3x)
[ 137.518] GeForce 6 (NV4x)
[ 137.518] GeForce 7 (G7x)
[ 137.518] GeForce 8 (G8x)
[ 137.518] GeForce 9 (G9x)
[ 137.518] GeForce GTX 2xx/3xx (GT2xx)
[ 137.518] GeForce GTX 4xx/5xx (GFxxx)
[ 137.518] GeForce GTX 6xx/7xx (GKxxx)
[ 137.518] GeForce GTX 9xx (GMxxx)
[ 137.518] GeForce GTX 10xx (GPxxx)
[ 137.518] (II) modesetting: Driver for Modesetting Kernel Drivers: kms
[ 137.518] (II) FBDEV: driver for framebuffer: fbdev
[ 137.518] (II) VESA: driver for VESA chipsets: vesa
[ 137.643] (EE) [drm] Failed to open DRM device for pci:0000:08:00.0: -19
[ 137.643] (EE) open /dev/dri/card0: No such file or directory
[ 137.643] (WW) Falling back to old probe method for modesetting
[ 137.643] (EE) open /dev/dri/card0: No such file or directory
[ 137.643] (II) Loading sub module "fbdevhw"
[ 137.643] (II) LoadModule: "fbdevhw"
[ 137.643] (II) Loading /usr/lib/xorg/modules/libfbdevhw.so
[ 137.643] (II) Module fbdevhw: vendor="X.Org Foundation"
[ 137.643] compiled for 1.20.4, module version = 0.0.2
[ 137.643] ABI class: X.Org Video Driver, version 24.0
[ 137.643] (EE) Unable to find a valid framebuffer device
[ 137.643] (WW) Falling back to old probe method for fbdev
[ 137.643] (II) Loading sub module "fbdevhw"
[ 137.643] (II) LoadModule: "fbdevhw"
[ 137.643] (II) Loading /usr/lib/xorg/modules/libfbdevhw.so
[ 137.643] (II) Module fbdevhw: vendor="X.Org Foundation"
[ 137.643] compiled for 1.20.4, module version = 0.0.2
[ 137.643] ABI class: X.Org Video Driver, version 24.0
[ 137.644] (II) FBDEV(2): using default device
[ 137.644] (EE) Screen 0 deleted because of no matching config section.
[ 137.644] (II) UnloadModule: "modesetting"
[ 137.644] (EE) Screen 0 deleted because of no matching config section.
[ 137.644] (II) UnloadModule: "fbdev"
[ 137.644] (II) UnloadSubModule: "fbdevhw"
[ 137.644] (EE)
Fatal server error:
[ 137.644] (EE) Cannot run in framebuffer mode. Please specify busIDs for all framebuffer devices
[ 137.644] (EE)
[ 137.644] (EE)
Please consult the The X.Org Foundation support
at http://wiki.x.org
for help.
[ 137.644] (EE) Please also check the log file at "/var/log/Xorg.0.log" for additional information.
[ 137.644] (EE)
[ 137.648] (EE) Server terminated with error (1). Closing log file.



  


2. Re: A interface do debian nao abre

Ryuk Shinigami
Ryuk

(usa Nenhuma)

Enviado em 18/08/2019 - 12:46h

Tive um problema parecido e resolvi assim:

1- Boot em "modo de recuperação" pelo GRUB

2- Digite os comandos abaixo:
Xorg -configure
mkdir /etc/X11/xorg.conf.d
cp xorg.conf.new /etc/X11/xorg.conf.d/xorg.conf

3- Reinicie
reboot 




3. Re: A interface do debian nao abre

Cézar Augusto
cizordj

(usa Debian)

Enviado em 28/08/2019 - 10:57h

Isso é problema na placa de vídeo, o kernel não está conseguindo carregar os drivers


________________________________________________
O programador tem a mania de achar que tudo é objeto


4. Re: A interface do debian nao abre

Ricardo Fabiano Silva
madrugada

(usa Gentoo)

Enviado em 28/08/2019 - 11:15h

O sistema está tentando carregar o módulo nv(que é para NVídia):
"Warning, couldn't open module nv"

Você instalou o AMDGPU?
Se não instalou, instale.






Patrocínio

Site hospedado pelo provedor RedeHost.
Linux banner
Linux banner

Destaques

Artigos

Dicas

Tópicos

Top 10 do mês

Scripts