Me tirem essa dúvida por favor! [RESOLVIDO]

1. Me tirem essa dúvida por favor! [RESOLVIDO]

Sandro Souza
novatterra

(usa Arch Linux)

Enviado em 03/07/2017 - 16:35h

ola pessoal, boa tarde a todos

estou com uma duvida me consumindo os neuronios aqui, dessa vez so quero entender algo.
nesse netbook q instalei o funtoo, eu ja tinha uma instalaçao do Slackware nele bootando com o lilo e o kernel 4.4.38, tudo bonitinho, numa boa. inclusive foi de dentro dele q instalei o funtoo, e tudo ocorreu bem, (to instalando o firefox-bin nesse momento)
a duvida q me consome é a seguinte:
qdo terminei a base da instalação do funtoo, achei mais pratico inclui-lo no lilo (q ja esta rodando bem) do q colocar o grub, ate pq ainda nao configurei a internet e usei o chroot pelo slack, so q na hora do startx ele nao reconheceu minha placa de video, entao segui uns tutos e recompilei o kernel, alterei o make.conf e tudo bem, o startx funfou legal, lxqt rodando bonitinho, desliguei e fuir dormir, agora de manha, o funtoo ta bootando usando o kernel do SLACK!!!! 4.4.38,
qdo o kernel do funtoo era 4.8.15-1, e eu so percebi isso pq o startx nao funcionou, eu consegui concertar, instalando o grub (infelizmente ainda nao consegui incluir a entrada do slack no grub), mas pelo menos agora ta com o kernel certo,
mas por que isso? dois linux numa mesma maquina podem compartilhar o mesmo kernel? e pq esse dito cujo (4.4.38) no slack roda legal e no funtoo nao reconhece minha placa de video?
to desesperado querendo enteder isso, alguem sabe me dizer algo pfv?


  


2. MELHOR RESPOSTA

Alberto Federman Neto.
albfneto

(usa Sabayon)

Enviado em 14/07/2017 - 18:06h

Não sei se entendí bem sua dúvida.

Mas, se vc tinha o boot do Funtoo, no LILO do slackware e funcionando. aí, instalou funtoo sem colocar GRUB, certo?

se foi isso, após trocar o kernel do funtoo.... Vc editou a config do LILO, as linhas, para usar o kernel NOVO do Funtoo?

quanto ao driver de vídeo no funtoo, precisa reinstalar o driver, após trocar o kernel. Pq em Sabayon e Gentoo, precisa.

Não uso slackware nem LILO. mas estou me baseado no Sabayon e no Gentoo, pq parecem um pouco com Funtoo.

Por exemplo, aqui eu tenho Sabayon, mas o GRUB meu é do openSUSE. Quando eu atualizo o kernel do Sabayon, ex de 4.10 para 4.11, eu tenho que trocar o "10" pelo ''11" lá no GRUB do openSUSE, senão não funciona... senão ele boota o kernel antigo do Sabayon.

Pq que eu saiba, kernel do slacware é um, do funtoo é outro! e o driver de vídeo, se não o reinstalar no funtoo, no kernel novo, vai sim ficar se X.... o driver funciona junto ao kernel dele, nos Gentoos e assemelhados.

Acho que nos Linux, no geral, o kernel do slackware está numa partição dele, e o do Funtoo, noutra; Ou vc tem uma única partição de boot, com os dois Linux? Pq eu sempre faço partições Raiz separadas, /home separadas

e nunca uso partição /boot separada, sempre gravo GRUB na MBR ou na Raiz dos Linux.


¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨
Albfneto,
Ribeirão Preto, S.P., Brasil.
Usuário Linux, Linux Counter: #479903.
Distros Favoritas: Sabayon, Gentoo, openSUSE, Mageia e OpenMandriva.

3. Re: Me tirem essa dúvida por favor!

Luiz Santos
luiztux

(usa Gentoo)

Enviado em 03/07/2017 - 16:39h

novatterra escreveu:

ola pessoal, boa tarde a todos

estou com uma duvida me consumindo os neuronios aqui, dessa vez so quero entender algo.
nesse netbook q instalei o funtoo, eu ja tinha uma instalaçao do Slackware nele bootando com o lilo e o kernel 4.4.38, tudo bonitinho, numa boa. inclusive foi de dentro dele q instalei o funtoo, e tudo ocorreu bem, (to instalando o firefox-bin nesse momento)
a duvida q me consome é a seguinte:
qdo terminei a base da instalação do funtoo, achei mais pratico inclui-lo no lilo (q ja esta rodando bem) do q colocar o grub, ate pq ainda nao configurei a internet e usei o chroot pelo slack, so q na hora do startx ele nao reconheceu minha placa de video, entao segui uns tutos e recompilei o kernel, alterei o make.conf e tudo bem, o startx funfou legal, lxqt rodando bonitinho, desliguei e fuir dormir, agora de manha, o funtoo ta bootando usando o kernel do SLACK!!!! 4.4.38,
qdo o kernel do funtoo era 4.8.15-1, e eu so percebi isso pq o startx nao funcionou, eu consegui concertar, instalando o grub (infelizmente ainda nao consegui incluir a entrada do slack no grub), mas pelo menos agora ta com o kernel certo,
mas por que isso? dois linux numa mesma maquina podem compartilhar o mesmo kernel? e pq esse dito cujo (4.4.38) no slack roda legal e no funtoo nao reconhece minha placa de video?
to desesperado querendo enteder isso, alguem sabe me dizer algo pfv?


A única lógica que me vem à cabeça no momento é a mesma imagem na partição /boot. Õ.o

Você tem que gerar um .config pro Funtoo também... ;)


EDIT: Curioso ou não, em algum destes tópicos de hoje perguntaram sobre o kernel do Slack no Funtoo. Você sem querer tem a resposta pra isto..rsrsr.

-----------------------------------''----------------------------------

Larry, The Cow, uses Gentoo GNU/Linux

^__^
(oo)
(__)

"If it moves, compile it."




4. Re: Me tirem essa dúvida por favor! [RESOLVIDO]

Sandro Souza
novatterra

(usa Arch Linux)

Enviado em 03/07/2017 - 16:54h

ola luiz

A única lógica que me vem à cabeça no momento é a mesma imagem na partição /boot. Õ.o


na vdd, esse hd esta particionado assim:
/dev/sda1 swap
/dev/sda2 funtoo
/dev/sda3 slack
/dev/sda4 /home

cada partição tem seu respectivo /boot, inclusive na config do lilo ta bem explicito /dev/sda2

EDIT: Curioso ou não, em algum destes tópicos de hoje perguntaram sobre o kernel do Slack no Funtoo. Você sem querer tem a resposta pra isto..rsrsr.


bom, se alguem quiser saber se funciona, parece q descobri sem querer querendo, funciona sim, no meu caso nao rodou pq minha placa é intel i915 e colocar no make.con simplesmente "intel" nao funcionou


5. Re: Me tirem essa dúvida por favor! [RESOLVIDO]

Ricardo Fabiano Silva
madrugada

(usa Gentoo)

Enviado em 03/07/2017 - 18:06h

Eu sei que o kernel do Slack funciona no Funtoo, porque já testei.

O lilo é muito mais simples de usar que o grub, quando se fala de boot para um único sistema. Para dualboot,triboot,etc... o melhor ainda é o grub. Além de ter a ferramenta do grub-rescue quando apresenta algum problema.

Posta o conteúdo do arquivo /etc/lilo.conf, talvez ajude a enxergar o problema.


6. Re: Me tirem essa dúvida por favor! [RESOLVIDO]

Sandro Souza
novatterra

(usa Arch Linux)

Enviado em 14/07/2017 - 17:48h


# Linux bootable partition config begins
# image = /boot/vmlinuz
# root = /dev/sda3
# label = Slack
# read-only
# Linux bootable partition config ends
# Linux bootable partition config
# Linux bootable partition config begins
image = /mnt/funtoo/boot/vmlinuz-4.8.15-1
root = /dev/sda2
label = Funtoo-4.8.15-1
read-only
# Linux bootable partition config ends
# Linux bootable partiiton config begins
image = /boot/vmlinuz
root = /dev/sda3
label = Slackware-14.2
read-only
# Linux bootable partition config ends


desculpe a demora nesses dias, mas essas sao as linhas finais de meu lilo.conf


7. Re: Me tirem essa dúvida por favor! [RESOLVIDO]

Sandro Souza
novatterra

(usa Arch Linux)

Enviado em 16/07/2017 - 01:00h

Mas, se vc tinha o boot do Funtoo, no LILO do slackware e funcionando. aí, instalou funtoo sem colocar GRUB, certo?


nao, alberto, na vdd eu so tinha o slack rodando nessa maquina em /dev/sda3 rodando com o lilo
entao decidi instalar o funtoo no /dev/sda2 e compartilharem o mesmo swap em /dev/sda2 e home em /dev/sda4

instalei o funtoo tudo legal, e consegui colocar ele pra bootar no lilo, blz, so que mesmo estando explicito o caminho do kernel do funtoo, ainda assim ele bootava com o kernel do slack, bootou o sistema base tudo certinho, bonitinho, so q na hora do startx o funtoo com kernel slack nao reconheceu minha placa de video, entao recompilei o kernel do Funtoo com as devidas opçoes q eu chekei la no site (intel i965) e nao simplesmente (intel) no make.conf e no kernel, qdo terminei a compilaçao eu saquei q ele tava botando o kernel errado, instalei o grub no funtoo e ele ta botando o kernel certo, inclusive o startx funcionando legal (so nao sei se o startx funciona pq eu recompilei o kernel funtoo ou pq nao to mais usando o kernel do slack)
na msg anterior vc pode conferir as ultimas linhas do meu lilo.conf
eu ja to usando ele quase completo, a uns dias, ta legalzinho ate, ainda tens uns ajustes pra fazer mas o basico ta legal
eu so queria entender, pq nao consigo bootar o kernel funtoo pelo lilo do slack mesmo com o caminho estando tao explicito


8. Re: Me tirem essa dúvida por favor! [RESOLVIDO]

Sandro Souza
novatterra

(usa Arch Linux)

Enviado em 16/07/2017 - 01:05h

eu queria usar o lilo pq achei super facil de configurar ele e o tema do slack ate q fica legal, o grub2 ta super chato de configurar, sem falar naquela tela azul horrorosa dele, nao to conseguindo mudar os nomes dos sistemas na tela de escolha (eu queria por somente Funtoo Linux, e nao como ele mostra: Funtoo Linux kernel debian source, blablabla) mas mudo o /boot/grub/grub.cfg e o /etc/boot.conf, salvo os docs como root, confiro a mudança,alterado, ok, digito boot-update e a joça nao troca, affff






Patrocínio

Site hospedado pelo provedor RedeHost.
Linux banner
Linux banner
Linux banner

Destaques

Artigos

Dicas

Tópicos

Top 10 do mês

Scripts