Funtoo não atualiza. [RESOLVIDO]

1. Funtoo não atualiza. [RESOLVIDO]

tiago k pereira
koppix

(usa Funtoo)

Enviado em 25/03/2015 - 10:29h

Bom dia a todos.
Ao rodar emerge -auDN @world para atualizar o funtoo tenho recebido a seguinte mensagem:
emerge -auDN @world

* IMPORTANT: 3 news items need reading for repository 'gentoo'.
* Use eselect news to read news items.


These are the packages that would be merged, in order:

Calculating dependencies... done!

emerge: there are no ebuilds to satisfy ">=dev-cpp/glibmm-2.36.0:2[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?]".
(dependency required by "dev-cpp/pangomm-2.34.0-r1" [ebuild])
(dependency required by "dev-cpp/gtkmm-3.14.0" [installed])
(dependency required by "media-sound/pavucontrol-2.0.20141217" [installed])
(dependency required by "@selected" [set])
(dependency required by "@world" [argument])


O que posso fazer para consertar isso?

Obrigado


  


2. Re: Funtoo não atualiza.

3. Re: Funtoo não atualiza. [RESOLVIDO]

Igor Felipe
Felipeigor

(usa Funtoo)

Enviado em 26/03/2015 - 01:58h



Gentoo/Funtoo e seus problemas cabeludos kkkkk

Como ta a sua lista de profiles?
$eselect profile list

Igor Felipe
Cadastrado desde: 25/09/2009

If it moves , compile it.


4. Re: Funtoo não atualiza. [RESOLVIDO]

tiago k pereira
koppix

(usa Funtoo)

Enviado em 26/03/2015 - 17:44h

As saidas:
funtoo prkopp # eselect profile show

Currently set profiles:
arch: gentoo:funtoo/1.0/linux-gnu/arch/x86-64bit
build: gentoo:funtoo/1.0/linux-gnu/build/current
flavor: gentoo:funtoo/1.0/linux-gnu/flavor/desktop
mix-ins: gentoo:funtoo/1.0/linux-gnu/mix-ins/lxde

Automatically enabled profiles:
mix-ins: gentoo:funtoo/1.0/linux-gnu/mix-ins/print
mix-ins: gentoo:funtoo/1.0/linux-gnu/mix-ins/X
mix-ins: gentoo:funtoo/1.0/linux-gnu/mix-ins/audio
mix-ins: gentoo:funtoo/1.0/linux-gnu/mix-ins/dvd
mix-ins: gentoo:funtoo/1.0/linux-gnu/mix-ins/media
mix-ins: gentoo:funtoo/1.0/linux-gnu/mix-ins/console-extras

funtoo prkopp # eselect profile list
Currently available arch profiles:
[1] funtoo/1.0/linux-gnu/arch/x86-64bit *
[2] funtoo/1.0/linux-gnu/arch/pure64
Currently available build profiles:
[3] funtoo/1.0/linux-gnu/build/stable
[4] funtoo/1.0/linux-gnu/build/current *
[5] funtoo/1.0/linux-gnu/build/experimental
Currently available flavor profiles:
[6] funtoo/1.0/linux-gnu/flavor/minimal
[7] funtoo/1.0/linux-gnu/flavor/core
[8] funtoo/1.0/linux-gnu/flavor/desktop *
[9] funtoo/1.0/linux-gnu/flavor/workstation
[10] funtoo/1.0/linux-gnu/flavor/hardened
Currently available mix-ins profiles:
[11] funtoo/1.0/linux-gnu/mix-ins/audio (auto)
[12] funtoo/1.0/linux-gnu/mix-ins/cinnamon
[13] funtoo/1.0/linux-gnu/mix-ins/console-extras (auto)
[14] funtoo/1.0/linux-gnu/mix-ins/dvd (auto)
[15] funtoo/1.0/linux-gnu/mix-ins/gnome
[16] funtoo/1.0/linux-gnu/mix-ins/kde
[17] funtoo/1.0/linux-gnu/mix-ins/mate
[18] funtoo/1.0/linux-gnu/mix-ins/media (auto)
[19] funtoo/1.0/linux-gnu/mix-ins/media-pro
[20] funtoo/1.0/linux-gnu/mix-ins/mediadevice-audio-consumer
[21] funtoo/1.0/linux-gnu/mix-ins/mediadevice-audio-pro
[22] funtoo/1.0/linux-gnu/mix-ins/mediadevice-base
[23] funtoo/1.0/linux-gnu/mix-ins/mediadevice-video-consumer
[24] funtoo/1.0/linux-gnu/mix-ins/mediadevice-video-pro
[25] funtoo/1.0/linux-gnu/mix-ins/mediaformat-audio-common
[26] funtoo/1.0/linux-gnu/mix-ins/mediaformat-audio-extra
[27] funtoo/1.0/linux-gnu/mix-ins/mediaformat-gfx-common
[28] funtoo/1.0/linux-gnu/mix-ins/mediaformat-gfx-extra
[29] funtoo/1.0/linux-gnu/mix-ins/mediaformat-video-common
[30] funtoo/1.0/linux-gnu/mix-ins/mediaformat-video-extra
[31] funtoo/1.0/linux-gnu/mix-ins/lxde *
[32] funtoo/1.0/linux-gnu/mix-ins/lxqt
[33] funtoo/1.0/linux-gnu/mix-ins/no-emul-linux-x86
[34] funtoo/1.0/linux-gnu/mix-ins/no-systemd
[35] funtoo/1.0/linux-gnu/mix-ins/print (auto)
[36] funtoo/1.0/linux-gnu/mix-ins/python3-only
[37] funtoo/1.0/linux-gnu/mix-ins/X (auto)
[38] funtoo/1.0/linux-gnu/mix-ins/xfce
[39] funtoo/1.0/linux-gnu/mix-ins/vmware-guest
[40] funtoo/1.0/linux-gnu/mix-ins/hardened

Sim com seus problemas cabeludos como o teclado que funcionava em abnt2 bem de boa e do nada parou, e ainda nao consegui resolver. hehe. Mas o bicho roda lisinho ainda mais que to aprendendo a usar o I3.


5. Re: Funtoo não atualiza. [RESOLVIDO]

Igor Felipe
Felipeigor

(usa Funtoo)

Enviado em 26/03/2015 - 18:36h

koppix escreveu:

As saidas:
funtoo prkopp # eselect profile show

Currently set profiles:
arch: gentoo:funtoo/1.0/linux-gnu/arch/x86-64bit
build: gentoo:funtoo/1.0/linux-gnu/build/current
flavor: gentoo:funtoo/1.0/linux-gnu/flavor/desktop
mix-ins: gentoo:funtoo/1.0/linux-gnu/mix-ins/lxde

Automatically enabled profiles:
mix-ins: gentoo:funtoo/1.0/linux-gnu/mix-ins/print
mix-ins: gentoo:funtoo/1.0/linux-gnu/mix-ins/X
mix-ins: gentoo:funtoo/1.0/linux-gnu/mix-ins/audio
mix-ins: gentoo:funtoo/1.0/linux-gnu/mix-ins/dvd
mix-ins: gentoo:funtoo/1.0/linux-gnu/mix-ins/media
mix-ins: gentoo:funtoo/1.0/linux-gnu/mix-ins/console-extras

funtoo prkopp # eselect profile list
Currently available arch profiles:
[1] funtoo/1.0/linux-gnu/arch/x86-64bit *
[2] funtoo/1.0/linux-gnu/arch/pure64
Currently available build profiles:
[3] funtoo/1.0/linux-gnu/build/stable
[4] funtoo/1.0/linux-gnu/build/current *
[5] funtoo/1.0/linux-gnu/build/experimental
Currently available flavor profiles:
[6] funtoo/1.0/linux-gnu/flavor/minimal
[7] funtoo/1.0/linux-gnu/flavor/core
[8] funtoo/1.0/linux-gnu/flavor/desktop *
[9] funtoo/1.0/linux-gnu/flavor/workstation
[10] funtoo/1.0/linux-gnu/flavor/hardened
Currently available mix-ins profiles:
[11] funtoo/1.0/linux-gnu/mix-ins/audio (auto)
[12] funtoo/1.0/linux-gnu/mix-ins/cinnamon
[13] funtoo/1.0/linux-gnu/mix-ins/console-extras (auto)
[14] funtoo/1.0/linux-gnu/mix-ins/dvd (auto)
[15] funtoo/1.0/linux-gnu/mix-ins/gnome
[16] funtoo/1.0/linux-gnu/mix-ins/kde
[17] funtoo/1.0/linux-gnu/mix-ins/mate
[18] funtoo/1.0/linux-gnu/mix-ins/media (auto)
[19] funtoo/1.0/linux-gnu/mix-ins/media-pro
[20] funtoo/1.0/linux-gnu/mix-ins/mediadevice-audio-consumer
[21] funtoo/1.0/linux-gnu/mix-ins/mediadevice-audio-pro
[22] funtoo/1.0/linux-gnu/mix-ins/mediadevice-base
[23] funtoo/1.0/linux-gnu/mix-ins/mediadevice-video-consumer
[24] funtoo/1.0/linux-gnu/mix-ins/mediadevice-video-pro
[25] funtoo/1.0/linux-gnu/mix-ins/mediaformat-audio-common
[26] funtoo/1.0/linux-gnu/mix-ins/mediaformat-audio-extra
[27] funtoo/1.0/linux-gnu/mix-ins/mediaformat-gfx-common
[28] funtoo/1.0/linux-gnu/mix-ins/mediaformat-gfx-extra
[29] funtoo/1.0/linux-gnu/mix-ins/mediaformat-video-common
[30] funtoo/1.0/linux-gnu/mix-ins/mediaformat-video-extra
[31] funtoo/1.0/linux-gnu/mix-ins/lxde *
[32] funtoo/1.0/linux-gnu/mix-ins/lxqt
[33] funtoo/1.0/linux-gnu/mix-ins/no-emul-linux-x86
[34] funtoo/1.0/linux-gnu/mix-ins/no-systemd
[35] funtoo/1.0/linux-gnu/mix-ins/print (auto)
[36] funtoo/1.0/linux-gnu/mix-ins/python3-only
[37] funtoo/1.0/linux-gnu/mix-ins/X (auto)
[38] funtoo/1.0/linux-gnu/mix-ins/xfce
[39] funtoo/1.0/linux-gnu/mix-ins/vmware-guest
[40] funtoo/1.0/linux-gnu/mix-ins/hardened

Sim com seus problemas cabeludos como o teclado que funcionava em abnt2 bem de boa e do nada parou, e ainda nao consegui resolver. hehe. Mas o bicho roda lisinho ainda mais que to aprendendo a usar o I3.


O primeiro problema vc conseguiu resolver? se não tenta o seguinte: no make.conf mude "amd64" para "~amd64" e depois, #emerge --sync e emerge -auND @world e veja se resolve.

quanto ao teclado veja como esta o arquivo em /etc/conf.d/keymaps e deixe apenas o keymap="br-abnt2"
Qualquer coisa posta ai.


Igor Felipe
Cadastrado desde: 25/09/2009

If it moves , compile it.


6. Re: Funtoo não atualiza. [RESOLVIDO]

tiago k pereira
koppix

(usa Funtoo)

Enviado em 27/03/2015 - 10:48h

Bom dia.
O primeiro problema resolvi fazendo o que pediu trocando no make.conf o "amd64" por "~amd64". Ai apareceu um problema com o pipelight mas como nao estou usando removi ai apareceu outro problema :

[blocks B ] <=x11-libs/libfm-1.2.3 ("<=x11-libs/libfm-1.2.3" is hard blocking x11-libs/libfm-extra-1.2.3)

* Error: The above package list contains packages which cannot be
* installed at the same time on the same system.

(x11-libs/libfm-extra-1.2.3::gentoo, ebuild scheduled for merge) pulled in by
~x11-libs/libfm-extra-1.2.3 required by (x11-libs/libfm-1.2.3-r1::gentoo, ebuild scheduled for merge)


For more information about Blocked Packages, please refer to the following
section of the Gentoo Linux x86 Handbook (architecture is irrelevant):

http://www.gentoo.org/doc/en/handbook/handbook-x86.xml?full=1#blocked


The following USE changes are necessary to proceed:
(see "package.use" in the portage(5) man page for more details)
# required by x11-wm/i3-4.9.1[pango]
# required by @selected
# required by @world (argument)
=x11-libs/cairo-1.14.2 xcb

Hehe. Vi que se trata de pacote mascarado, mas pela correria de hoje nao vo conseguir ver isso, mas se os `jurassicos` puderem ajudar, agradeco. Como da pra perceber o problema do teclado persiste, mas e so quando sobe a interface grafica que nao funciona no modo texto ta normal.
Abrax


7. Re: Funtoo não atualiza. [RESOLVIDO]

tiago k pereira
koppix

(usa Funtoo)

Enviado em 13/04/2015 - 21:19h

Boa noite. Bom primeiro desculpem aos que me ajudaram pela demora em dar um parecer.
Motivos da demora tava sem o bendito do notebook pois em menos de 1 ano de uso já tive que trocar a placa mãe, e a fonte do bendito queimou. Agora está tudo normal. Espero que continue assim. Vo passar o que fiz e "resolveu" o problema:
1: renomei todos os arquivos packges. e criei novos em branco com quando se instala o Funtoo.
2: fiz o que o felipeigor pediu coloquei o "~amd64" no make.conf
3: quando aconteceu o erro no pipelight como não estava usando o mesmo removi o mesmo e "pronto".

Ta deixa eu explicar o porque do "resolveu" e "pronto" entre aspas. Estou com outro problema esse:
__________________________________________________________________________
* Messages for package x11-proto/glproto-1.4.17-r1:

* This package will overwrite one or more files that may belong to other
* packages (see list below). You can use a command such as `portageq
* owners / <filename>` to identify the installed package that owns a
* file. If portageq reports that only one package owns a file then do
* NOT file a bug report. A bug report is only useful if it identifies at
* least two or more packages that are known to install the same file(s).
* If a collision occurs and you can not explain where the file came from
* then you should simply ignore the collision since there is not enough
* information to determine if a real problem exists. Please do NOT file
* a bug report at http://bugs.gentoo.org unless you report exactly which
* two packages install the same file(s). Once again, please do NOT file
* a bug report unless you have completely understood the above message.
*
* package x11-proto/glproto-1.4.17-r1 NOT merged
*
* Detected file collision(s):
*
* /usr/include/GL/glxtokens.h
* /usr/include/GL/glxproto.h
* /usr/include/GL/glxmd.h
*
* Searching all installed packages for file collisions...
*
_________________________________________________________________
Vi que tem pacotes em colisão estou atrás da solução.
Qualquer ajuda é bem vinda.
Abrax a todos


8. Re: Funtoo não atualiza. [RESOLVIDO]

LinuxWalker
Delusion

(usa Debian)

Enviado em 13/04/2015 - 22:55h

por que voces usam funtoo?



9. Re: Funtoo não atualiza.

Glauber GF
mcnd2

(usa Debian)

Enviado em 13/04/2015 - 23:05h

A procura de adrenalina , eu acho, rs!

Eu também estou com problema no FreeBSD que está instalado no desk ao loado do Windows Server 2008, Debian e XUbuntu. O problema é de não subir a interface gráfica. Como ando sem tempo, ele continua lá, só esperando a falta de adrenalina aparecer junto com o tempo...


10. Re: Funtoo não atualiza. [RESOLVIDO]

tiago k pereira
koppix

(usa Funtoo)

Enviado em 14/04/2015 - 19:49h

wudze escreveu:

por que voces usam funtoo?

mcnd2 escreveu:
A procura de adrenalina , eu acho, rs!


É isso ai caro colega, que alegrias teríamos em iniciar um sistema que roda tudo redondo. kkkkk
E nesse tópico tem mais respostas a sua pergunta:
http://www.vivaolinux.com.br/topico/Gentoo-Linux/Por-que-vcs-usam-o-Gentoo?pagina=03
Abraço.




11. Re: Funtoo não atualiza. [RESOLVIDO]

tiago k pereira
koppix

(usa Funtoo)

Enviado em 09/11/2015 - 23:37h

koppix escreveu:

Boa noite. Bom primeiro desculpem aos que me ajudaram pela demora em dar um parecer.
Motivos da demora tava sem o bendito do notebook pois em menos de 1 ano de uso já tive que trocar a placa mãe, e a fonte do bendito queimou. Agora está tudo normal. Espero que continue assim. Vo passar o que fiz e "resolveu" o problema:
1: renomei todos os arquivos packges. e criei novos em branco com quando se instala o Funtoo.
2: fiz o que o felipeigor pediu coloquei o "~amd64" no make.conf
3: quando aconteceu o erro no pipelight como não estava usando o mesmo removi o mesmo e "pronto".

Ta deixa eu explicar o porque do "resolveu" e "pronto" entre aspas. Estou com outro problema esse:
__________________________________________________________________________
* Messages for package x11-proto/glproto-1.4.17-r1:

* This package will overwrite one or more files that may belong to other
* packages (see list below). You can use a command such as `portageq
* owners / <filename>` to identify the installed package that owns a
* file. If portageq reports that only one package owns a file then do
* NOT file a bug report. A bug report is only useful if it identifies at
* least two or more packages that are known to install the same file(s).
* If a collision occurs and you can not explain where the file came from
* then you should simply ignore the collision since there is not enough
* information to determine if a real problem exists. Please do NOT file
* a bug report at http://bugs.gentoo.org unless you report exactly which
* two packages install the same file(s). Once again, please do NOT file
* a bug report unless you have completely understood the above message.
*
* package x11-proto/glproto-1.4.17-r1 NOT merged
*
* Detected file collision(s):
*
* /usr/include/GL/glxtokens.h
* /usr/include/GL/glxproto.h
* /usr/include/GL/glxmd.h
*
* Searching all installed packages for file collisions...
*
_________________________________________________________________
Vi que tem pacotes em colisão estou atrás da solução.
Qualquer ajuda é bem vinda.
Abrax a todos


Bom como eu sei que alguém vai acabar neste post procurando a solução para esse problema ai vai:
Quando isso acontecer se deve remover essas colisões.
Ai vem outra pergunta como faço?
Simples assim: rm /usr/include/.... seja lá qual for o caminho do bendito.
Bom é isso abrax.






Patrocínio

Site hospedado pelo provedor RedeHost.
Linux banner
Linux banner
Linux banner

Destaques

Artigos

Dicas

Tópicos

Top 10 do mês

Scripts