Falta de energia eletrica no meio do Emerge World !!!! [RESOLVIDO]

1. Falta de energia eletrica no meio do Emerge World !!!! [RESOLVIDO]

Sandro Souza
novatterra

(usa Arch Linux)

Enviado em 25/10/2016 - 01:43h

Pois 'e gente, foi isso o que aconteceu, eu tinha terminado de instalar meu ultimo programa da minha listinha de uso pessoal e resolvi partir pro ultimo passo: emerge world, acontece que a energia eletrica foi embora no meio, voltou 10 minutos depois, entao usei o comando: "emerge --resume" e ele continuou, mais uma meia hora e a ***** da energia vai embora de novo (grrrrrr) depois de chamar uns palavroes aqui, fui dormir, de manha, novamente: "emerge --resume" compilou uns 20 ou 30 pacotes deu erro na checagem de arquivos, ai nao foi mais pra frente,
1. qdo faco login em qualquer terminal, coloco o usuario e dou Enter, ao inves do cursor descer pro campo senha, corre umas letras estranhas na tela por uns 10 segundos (como se estivesse compilando em alta velocidade) depois 'e q vai pra senha, eu dou senha, e mais letras, ate o terminal ficar pronto
2. nao posso mais usar o nano, pois qualquer documento vem com as malditas letras de novo, so que paradas.
3. meu relogio foi parar no horario de verao, eu concerto e ele volta pro horario de verao d novo
4. meu teclado foi parar no padrao americano SEM acentos, qdo eu uso us-acentos

eu nao quero ter de instalar tudo do novo, alguem pode me dar alguma dica de como resolver isso tudo?
obrigado desde ja


  


2. Re: Falta de energia eletrica no meio do Emerge World !!!! [RESOLVIDO]

Luiz Santos
luiztux

(usa Gentoo)

Enviado em 25/10/2016 - 08:10h

novatterra escreveu:



Pois 'e gente, foi isso o que aconteceu, eu tinha terminado de instalar meu ultimo programa da minha listinha de uso pessoal e resolvi partir pro ultimo passo: emerge world, acontece que a energia eletrica foi embora no meio, voltou 10 minutos depois, entao usei o comando: "emerge --resume" e ele continuou, mais uma meia hora e a ***** da energia vai embora de novo (grrrrrr) depois de chamar uns palavroes aqui, fui dormir, de manha, novamente: "emerge --resume" compilou uns 20 ou 30 pacotes deu erro na checagem de arquivos, ai nao foi mais pra frente,


Tentou recompilar os pacotes sem usar a opção --resume, apenas emerge -auv @world ou emerge -auvDN @world? Se sim, qual foi a saída que o emerge devolveu?

1. qdo faco login em qualquer terminal, coloco o usuario e dou Enter, ao inves do cursor descer pro campo senha, corre umas letras estranhas na tela por uns 10 segundos (como se estivesse compilando em alta velocidade) depois 'e q vai pra senha, eu dou senha, e mais letras, ate o terminal ficar pronto
2. nao posso mais usar o nano, pois qualquer documento vem com as malditas letras de novo, so que paradas.


Que coisa... já vi isto acontecer, mas no Exherbo... Consegue compartilhar uma imagem com estes problemas? Tentou usar outro editor (vim, algum no modo gráfico)?

3. meu relogio foi parar no horario de verao, eu concerto e ele volta pro horario de verao d novo
4. meu teclado foi parar no padrao americano SEM acentos, qdo eu uso us-acentos


Provavelmente bagunçou seus arquivos de configuração no /etc. Dá uma olhada por lá nos arquivos locale-gen, localtime e no /etc/conf.d/keymaps. Aproveite e veja como estão as configurações com o eselect locale list. Siga novamente as instruções no manual para corrigir estes arquivos. Não terá dificuldades em alterá-los.

eu nao quero ter de instalar tudo do novo, alguem pode me dar alguma dica de como resolver isso tudo?
obrigado desde ja


Você não precisa reinstalar tudo... isto é pensamento de user de distro binária..rsrsrsr.

Brincadeiras à parte o que eu sugiro é:

1. >> Arrume seus arquivos de configuração
2. >> Arrume a data com o comando date. Ex.

# parâmetro do comando: MMDDhhmmYYYY
date 102508002016

# se após reiniciar o sistema a data e hora estiverem errados
# verifique os comandos hwclock e date
# chamando sem nenhum parâmetro
# isto irá mostrar a data e hora, apenas
# ao perceber o erro, conserte a data novamente com o date (caso esteja errada)
# e rode o comando abaixo para tornar a configuração persistente:
hwclock -w # ou --systohc


3. >> Dê uma sincronizada na árvore do Portage após ter certeza de que arrumou os arquivos e data/hora.

Por fim, rode o emerge @world mas com a opção -pv para saber se você precisa realizar algum tipo de alteração/configuração antes. Vai ficar + ou - assim:

emerge -pvauDN @world 


Caso tenha problemas com o terminal pode seguramente fazer chroot e consertar os problemas.

-----------------------------------''----------------------------------

Larry, The Cow, uses Gentoo GNU/Linux

^__^
(oo)
(__)

"If it moves, compile it."


3. Re: Falta de energia eletrica no meio do Emerge World !!!! [RESOLVIDO]

Sandro Souza
novatterra

(usa Arch Linux)

Enviado em 27/10/2016 - 02:43h

ola pessoal,
ola luiz
voltei, andei meio ocupado esses dias, pois bem, eis meus problemas:


Tentou recompilar os pacotes sem usar a opção --resume, apenas emerge -auv @world ou emerge -auvDN @world? Se sim, qual foi a saída que o emerge devolveu?


sim, tentei, mas como eu ja tinha instalado o lxqt e o " emerge -auvDN @world" nem inicia mais pq eu to com uns pacotes do lxqt mascarados aqui, ja tentei desmaracar mas to todo enrolado aqui com eles:


Total: 214 packages (72 upgrades, 2 downgrades, 10 new, 1 in new slot, 129 reinstalls, 1 uninstall), Size of downloads: 368.155 KiB
Conflict: 1 block

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

lxqt-base/liblxqt:0

(lxqt-base/liblxqt-0.11.0-r1:0/0::gentoo, installed) pulled in by
~lxqt-base/liblxqt-0.11.0 required by (lxqt-base/lxqt-qtplugin-0.11.0:0/0::gentoo, installed)
^ ^^^^^^
(and 9 more with the same problem)

(lxqt-base/liblxqt-0.10.0:0/0::gentoo, ebuild scheduled for merge) pulled in by
~lxqt-base/liblxqt-0.10.0 required by (lxqt-base/lxqt-notificationd-0.10.0:0/0::gentoo, installed)
^ ^^^^^^
(and 1 more with the same problem)

dev-lang/perl:0

(dev-lang/perl-5.24.0-r1:0/5.24::gentoo, ebuild scheduled for merge) pulled in by
=dev-lang/perl-5.24* required by (virtual/perl-Getopt-Long-2.480.0:0/0::gentoo, ebuild scheduled for merge)
^ ^^^^^
(and 18 more with the same problem)

(dev-lang/perl-5.22.2:0/5.22::gentoo, installed) pulled in by
dev-lang/perl:0/5.22= required by (sys-apps/texinfo-6.3:0/0::gentoo, installed)
^^^^^^^^
(and 37 more with the same problem)

NOTE: Use the '--verbose-conflicts' option to display parents omitted above
It may be possible to solve this problem by using package.mask to
prevent one of those packages from being selected. However, it is also
possible that conflicting dependencies exist such that they are
impossible to satisfy simultaneously. If such a conflict exists in
the dependencies of two different packages, then those packages can
not be installed simultaneously. You may want to try a larger value of
the --backtrack option, such as --backtrack=30, in order to see if
that will solve this conflict automatically.
For more information, see MASKED PACKAGES section in the emerge man
page or refer to the Gentoo Handbook.


o que acontece, 'e que quase todos os pacotes do Lxqt estao na versao 0.11.0 e uns poucos na 0.10.0
so que o meta (lxqt-meta, esta na 0.10) eu como eu instalei os pacotes um a um, seguindo a lista no porthole, qdo eu instalo o lxqt-meta, ele quer que eu abaixe a versao dos outros pcotes pra 0.10.0, so que se eu fizer, isso, eu nao instalo outros que vieram na 0.11.0, entende? entao consegui instalar quase todos, ate o lxqt-panel, menos o meta, e nao me pergunte como, mas o lxqt esta rodando, sem o meta, mas ta rodando, inclusive estou nele agora.


http://pastebin.com/GDVwbex7


coloquei no pastebin pq 'e muuuuita coisa, nao da nem pra separar entre login e senha pq 'e demais

qto ao relogio, ate deu certo, mas durou so uns dias depois voltou pro horario de verao d novo


Você não precisa reinstalar tudo... isto é pensamento de user de distro binária..rsrsrsr.


cara, adorei saber disso, kkkkkkkk


4. Re: Falta de energia eletrica no meio do Emerge World !!!! [RESOLVIDO]

Luiz Santos
luiztux

(usa Gentoo)

Enviado em 27/10/2016 - 09:14h

novatterra escreveu:



Por hora, acredito que você possa remover do @world todos os pacotes relacionados ao lxqt com o emerge --deselect. Aí você poderá atualizar teu sistema sem estes problemas do lxqt. Quanto ao problema com o Perl, você terá que atualizar os pacotes relacionados para a versão estável mais nova.

Já para o relógio, (re)cheque suas configurações no arquivo localtime, hwclock. Verifique se o serviço hwclock está no runlevel boot com o comando rc-update show -v. Pode ser que você precise ter o arquivo localtime como um link simbólico para o arquivo correto no diretório /usr/share/zoneinfo de acordo com a tua localidade. Você rodando o comando date apresenta as mesmas informações do lxqt? Usando outro ambiente gráfico o problema continua?

Certifique-se de que as opções abaixo, no Kernel, estejam definidas (marcadas com o caractere *):


Device Drivers --->
[*] Real Time Clock --->
[ ] Set system time from RTC on startup and resume
[ ] Set the RTC time based on NTP synchronization
[*] /sys/class/rtc/rtcN (sysfs)
[*] /proc/driver/rtc (procfs for rtc0)
[*] /dev/rtcN (character devices)
<*> PC-style 'CMOS'



Se as opções do Kernel mostradas acima estiverem diferentes, por exemplo, as seguintes opções marcadas:

[*] Set system time from RTC on startup and resume
[*] Set the RTC time based on NTP synchronization


remova o arquivo hwclock do runlevel:

rc-update del hwclock 


Se não adiantar, edite este arquivo conforme segue:


clock_hctosys="YES"
clock_systohc="YES"
# clock="local"


E habilite-o novamente:


rc-service hwclock restart
rc-update add hwclock boot


-----------------------------------''----------------------------------

Larry, The Cow, uses Gentoo GNU/Linux

^__^
(oo)
(__)

"If it moves, compile it."


5. Re: Falta de energia eletrica no meio do Emerge World !!!!

Sandro Souza
novatterra

(usa Arch Linux)

Enviado em 29/10/2016 - 02:47h

ola todos

luiz, estou tentando atualizar o perl, mas ta dando conflito com dependencias, olha so:


emerge -uva dev-lang/perl

* IMPORTANT: 4 config files in '/etc/portage' need updating.
* See the CONFIGURATION FILES and CONFIGURATION FILES UPDATE TOOLS
* sections of the emerge man page to learn how to update config files.

These are the packages that would be merged, in order:

Calculating dependencies... done!

Total: 0 packages, Size of downloads: 0 KiB

WARNING: One or more updates/rebuilds have been skipped due to a dependency conflict:

dev-lang/perl:0

(dev-lang/perl-5.24.0-r1:0/5.24::gentoo, ebuild scheduled for merge) conflicts with
dev-lang/perl:0/5.22= required by (sys-apps/texinfo-6.3:0/0::gentoo, installed)
^^^^^^^^
dev-lang/perl:0/5.22=[-build(-)] required by (dev-perl/HTML-Tagset-3.200.0-r1:0/0::gentoo, installed)
^^^^^^^^
dev-lang/perl:0/5.22= required by (dev-perl/HTML-Parser-3.720.0:0/0::gentoo, installed)
^^^^^^^^
dev-lang/perl:0/5.22=[-build(-)] required by (dev-perl/HTTP-Date-6.20.0-r1:0/0::gentoo, installed)
^^^^^^^^
dev-lang/perl:0/5.22=[-build(-)] required by (dev-perl/HTTP-Cookies-6.10.0:0/0::gentoo, installed)
^^^^^^^^
=dev-lang/perl-5.22* required by (virtual/perl-Data-Dumper-2.158.0:0/0::gentoo, installed)
^ ^^^^^
dev-lang/perl:0/5.22=[-build(-)] required by (dev-perl/Text-Unidecode-1.270.0:0/0::gentoo, installed)
^^^^^^^^
=dev-lang/perl-5.22* required by (virtual/perl-parent-0.232.0:0/0::gentoo, installed)
^ ^^^^^
dev-lang/perl:0/5.22= required by (dev-perl/HTTP-Message-6.110.0:0/0::gentoo, installed)
^^^^^^^^
dev-lang/perl:0/5.22=[-build(-)] required by (dev-perl/LWP-MediaTypes-6.20.0-r1:0/0::gentoo, installed)
^^^^^^^^
dev-lang/perl:0/5.22= required by (dev-perl/URI-1.710.0:0/0::gentoo, installed)
^^^^^^^^
=dev-lang/perl-5.22* required by (virtual/perl-MIME-Base64-3.150.0:0/0::gentoo, installed)
^ ^^^^^
dev-lang/perl:0/5.22=[-build(-)] required by (perl-core/Encode-2.730.0:0/0::gentoo, installed)
^^^^^^^^
dev-lang/perl:0/5.22=[-build(-)] required by (dev-perl/HTTP-Daemon-6.10.0-r1:0/0::gentoo, installed)
^^^^^^^^
dev-lang/perl:0/5.22=[-build(-)] required by (dev-perl/IO-HTML-1.1.0:0/0::gentoo, installed)
^^^^^^^^
=dev-lang/perl-5.22* required by (virtual/perl-Carp-1.360.0:0/0::gentoo, installed)
^ ^^^^^
dev-lang/perl:0/5.22= required by (dev-perl/Encode-Locale-1.50.0:0/0::gentoo, installed)
^^^^^^^^
=dev-lang/perl-5.22* required by (virtual/perl-Time-Local-1.230.0-r2:0/0::gentoo, installed)
^ ^^^^^
dev-lang/perl:0/5.22=[-build(-)] required by (dev-perl/Net-SMTP-SSL-1.30.0:0/0::gentoo, installed)
^^^^^^^^
=dev-lang/perl-5.22* required by (virtual/perl-libnet-3.50.0:0/0::gentoo, installed)
^ ^^^^^
dev-lang/perl:0/5.22=[-build(-)] required by (dev-perl/File-MimeInfo-0.270.0:0/0::gentoo, installed)
^^^^^^^^
dev-lang/perl:0/5.22=[-build(-)] required by (dev-perl/libwww-perl-6.150.0:0/0::gentoo, installed)
^^^^^^^^
=dev-lang/perl-5.22* required by (virtual/perl-Digest-SHA-5.950.0:0/0::gentoo, installed)
^ ^^^^^
=dev-lang/perl-5.22* required by (virtual/perl-IO-1.350.0:0/0::gentoo, installed)
^ ^^^^^
dev-lang/perl:0/5.22=[-build(-)] required by (dev-perl/LWP-Protocol-https-6.60.0:0/0::gentoo, installed)
^^^^^^^^
=dev-lang/perl-5.22* required by (virtual/perl-IO-Compress-2.68.0:0/0::gentoo, installed)
^ ^^^^^
dev-lang/perl:0/5.22= required by (dev-perl/libintl-perl-1.240.0-r2:0/0::gentoo, installed)
^^^^^^^^
dev-lang/perl:0/5.22=[-build(-)] required by (dev-perl/HTTP-Negotiate-6.10.0:0/0::gentoo, installed)
^^^^^^^^
dev-lang/perl:0/5.22=[-build(-)] required by (dev-perl/WWW-RobotRules-6.20.0:0/0::gentoo, installed)
^^^^^^^^
dev-lang/perl:0/5.22=[-build(-)] required by (dev-perl/IO-Socket-SSL-2.24.0:0/0::gentoo, installed)
^^^^^^^^
dev-lang/perl:0/5.22=[-build(-)] required by (dev-perl/Error-0.170.240:0/0::gentoo, installed)
^^^^^^^^
=dev-lang/perl-5.22* required by (virtual/perl-Compress-Raw-Zlib-2.68.0:0/0::gentoo, installed)
^ ^^^^^
dev-lang/perl:0/5.22=[-build(-)] required by (dev-perl/Digest-HMAC-1.30.0-r1:0/0::gentoo, installed)
^^^^^^^^
=dev-lang/perl-5.22.2* required by (virtual/perl-File-Spec-3.560.100:0/0::gentoo, installed)
^ ^^^^^^^
dev-lang/perl:0/5.22=[-build(-)] required by (dev-perl/File-DesktopEntry-0.40.0-r1:0/0::gentoo, installed)
^^^^^^^^
=dev-lang/perl-5.22* required by (virtual/perl-Exporter-5.720.0:0/0::gentoo, installed)
^ ^^^^^
dev-lang/perl:0/5.22=[-build(-)] required by (dev-perl/Unicode-EastAsianWidth-1.330.0-r1:0/0::gentoo, installed)
^^^^^^^^
=dev-lang/perl-5.22* required by (virtual/perl-Scalar-List-Utils-1.410.0:0/0::gentoo, installed)
^ ^^^^^
dev-lang/perl:0/5.22= required by (dev-perl/Net-HTTP-6.90.0:0/0::gentoo, installed)
^^^^^^^^
dev-lang/perl:0/5.22=[-build(-)] required by (dev-perl/Authen-SASL-2.160.0-r1:0/0::gentoo, installed)
^^^^^^^^
dev-lang/perl:0/5.22= required by (dev-perl/Net-SSLeay-1.720.0-r1:0/0::gentoo, installed)
^^^^^^^^
dev-lang/perl:0/5.22=[-build(-)] required by (perl-core/File-Temp-0.230.400-r1:0/0::gentoo, installed)
^^^^^^^^
dev-lang/perl:0/5.22=[-build(-)] required by (dev-perl/File-Listing-6.40.0-r1:0/0::gentoo, installed)
^^^^^^^^
dev-lang/perl:0/5.22=[-build(-)] required by (dev-perl/File-BaseDir-0.30.0-r1:0/0::gentoo, installed)
^^^^^^^^
=dev-lang/perl-5.22* required by (virtual/perl-Compress-Raw-Bzip2-2.68.0:0/0::gentoo, installed)
^ ^^^^^
=dev-lang/perl-5.22* required by (virtual/perl-Digest-MD5-2.540.0:0/0::gentoo, installed)
^ ^^^^^
=dev-lang/perl-5.22* required by (virtual/perl-XSLoader-0.200.0:0/0::gentoo, installed)
^ ^^^^^
dev-lang/perl:0/5.22=[-build(-)] required by (dev-vcs/git-2.10.1:0/0::gentoo, installed)
^^^^^^^^
=dev-lang/perl-5.22* required by (virtual/perl-Test-Harness-3.350.0:0/0::gentoo, installed)



eu add um doc no dir portagepackage.accept_keywords com o seguinte conteudo:
=dev-lang/perl-5.24.0-r1 **

mas parece q nao adiantou muito nao

tive essa ideia pq eu ja fiz isso antes com outro pacote e deu certo
(so nao me pergunte qual, ja instalei e desinstalei tantos aqui, que qdo eu durmo, ate meus sonhos ja estao vindo em codigo binario) kkkkkkkkkkkkkkkk

e se eu tirar o perl do @world igual eu fiz com o lxqt, sera que resolve isso ou vou fazer besteira?


6. Re: Falta de energia eletrica no meio do Emerge World !!!! [RESOLVIDO]

Sandro Souza
novatterra

(usa Arch Linux)

Enviado em 31/10/2016 - 01:56h

ola pessoal, passei aqui pra dizer que resolvi parcialmente o problema

desinstalei todos os pacotes do lxqt pelo terminal e instalei d novo um a um so que pelo Porthole,
resultado: ele instalou a ultima versao de todos os pacotes um a um menos o lxqt-meta, esse nao deu pra instalar pq ta dependendo do pcmanfm-qt-0.11.0, so q a ultima versao q o portage instala 'e a 0.10,.0 entao vou esperar uns dias ate ele atualizar

a unica coisa q ta me incomodando 'e o monte de letras qdo digito login e senha ou tento montar alguma coisa
o emerge world ta rodando legal mesmo entao o resto eu resolvo com o tempo







Patrocínio

Site hospedado pelo provedor RedeHost.
Linux banner
Linux banner
Linux banner

Destaques

Artigos

Dicas

Tópicos

Top 10 do mês

Scripts