Instalação Firebird 3.0

1. Instalação Firebird 3.0

Nathã Campos
ncampos

(usa Debian)

Enviado em 09/08/2016 - 08:51h

Bom dia,
para instalação do Firebird 3 existe alguma necessidade da versao 2 esta instalada? estou efetuando migração e preciso instalar a versao3,porem ao efetuar o download diretamente do Site do FB e ao instalar gera a mensagem abaixo:

root@firebird3:/opt/Firebird-3.0.0.32483-0.amd64# sh install.sh

Firebird 3.0.0.32483-0.amd64 Installation

Press Enter to start installation or ^C to abort
Extracting install data
Please install required library 'tommath' before firebird, after it repeat firebird install
Install aborted: The command ./scripts/preinstall.sh
failed with error code 1




  


2. Ajudando!

Andre Fortunato
fnxxr

(usa Ubuntu)

Enviado em 09/08/2016 - 09:06h

Boa tarde amigo,
traduza o texto...

Please install required library 'tommath' before firebird, after it repeat firebird install
Você precisa instalar a biblioteca 'tommath' antes da instalação....

sudo apt-get install libtommath-dev
repita a instalação.

a Obs o Firebird 3 nao pode ser administrado por softwares 2.5 então vc terá que mudar alguns parâmetros.
Você percebera que o flamerobin não vai conectar e outros tb não.

assim que chegar em casa passo o artigo como fazer para funcionar.


3. Re: Instalação Firebird 3.0

Nathã Campos
ncampos

(usa Debian)

Enviado em 09/08/2016 - 09:31h

fnxxr escreveu:

Boa tarde amigo,
traduza o texto...

Please install required library 'tommath' before firebird, after it repeat firebird install
Você precisa instalar a biblioteca 'tommath' antes da instalação....

sudo apt-get install libtommath-dev
repita a instalação.

a Obs o Firebird 3 nao pode ser administrado por softwares 2.5 então vc terá que mudar alguns parâmetros.
Você percebera que o flamerobin não vai conectar e outros tb não.

assim que chegar em casa passo o artigo como fazer para funcionar.


obrigado,deu certo instalando como "libtommath0".
Sabe me informar uma situação, alterar para modo SuperClassic? efetuei a instalação e ja por default instalou como Superserver. é somente mudar a linha
#ServerMode = Super

para
ServerMode = SuperClassic

?




4. Re: Instalação Firebird 3.0

Andre Fortunato
fnxxr

(usa Ubuntu)

Enviado em 10/08/2016 - 13:13h

Isso mesmo amigo!


5. Re: Instalação Firebird 3.0

Nathã Campos
ncampos

(usa Debian)

Enviado em 10/08/2016 - 13:35h

fnxxr escreveu:

Isso mesmo amigo!


Obrigado novamente.
Aquele artigo ta facil ai? estou com umas dificuldades de configuração para inicia-lo no arranque do SO,acredito que me ajudaria.



6. Re: Instalação Firebird 3.0

Andre Fortunato
fnxxr

(usa Ubuntu)

Enviado em 11/08/2016 - 15:57h

Segue artigo amigo.
so marque meu tópico como melhor resposta para que eu ganhe alguns pontinhos...
https://github.com/FirebirdSQL/jaybird/wiki/Jaybird-and-Firebird-3

valew


7. Re: Instalação Firebird 3.0

Nathã Campos
ncampos

(usa Debian)

Enviado em 12/08/2016 - 11:44h

Obrigado novamente,
Esse artigo nao foca diretamente na instalação do Firebird3, precisava de um conte udo focado na instalação,tanto nas notas quanto documentação do FB pelo menos eu nao achei nada claro.
mas desde ja agradeço.



8. Instalação Firebird 3.0 - Connection not established.

Walfrido Cesar
walfrido

(usa Ubuntu)

Enviado em 27/09/2017 - 22:20h

efetuei a instalacao do Firebird 3 no Ubuntu certinha, mas a conexão remota não funciona:

Connection not established.
Connection rejected by remote interface.

Alguém sabe como resolver?


9. Problema na configuração do servidor firebird

Erivan Alves da Silva
erivan_ftc

(usa Outra)

Enviado em 06/10/2017 - 17:38h

Boa tarde.

Sou novo em banco de dados e estou tendo muitos problemas para instalar o firebird 3 em um servidor debian-7.4.0-amd64.

O problema não é propriamente dito na instalação, mas sim na configuração para servidor via rede.

Baixo o instalador .tar.gz no site da firebird e faço o procedimento de instalação até então tudo normal, dou um start no servidor e ele roda normalmente, porem, não da acesso, aparece o seguinte erro:

Statement failed, SQLSTATE = 08006
Unable to complete network request to host "127.0.0.1".


O mesmo acontece quando tento acessar via ibexpert.

Unsuccessful execution caused by a system error that precludes susccessful execution of subsequent statements.

Com o firebird 2.5 eu instalava e nunca deu esse erro.

Desde jámuito obrigado.






Patrocínio

Site hospedado pelo provedor RedeHost.
Linux banner
Linux banner
Linux banner

Destaques

Artigos

Dicas

Tópicos

Top 10 do mês

Scripts