Firebird 2.5 no CentOS 7

1. Firebird 2.5 no CentOS 7

Julio Lazarotti
mainframedj

(usa Ubuntu)

Enviado em 18/06/2015 - 09:18h

Olá pessoal,
Aqui na empresa, estamos implantando um novo ERP que utiliza o Firebird. Querem instalar um (R)windows.
E eu estou instalando em um CentOS, pois acredito que vai performar melhor, além das vantagens da plataforma opensoure.

Enfim, como usuário básico dos básicos, estou com um problema para resolver. O que está emperrando a minha tentativa de extinguir o (R)windows daqui.

Listo a seguir:

# rpm -ivh FirebirdCS-2.1.7.18553-0.i686.rpm
Preparando... ################################# [100%]
o arquivo / da instalação de FirebirdCS-2.1.7.18553-0.i686 conflita com o arquivo do pacote filesystem-3.2-18.el7.x86_64
o arquivo /usr/lib da instalação de FirebirdCS-2.1.7.18553-0.i686 conflita com o arquivo do pacote filesystem-3.2-18.el7.x86_64

Nem o Google tá me ajudando...

E agora? Quem poderá me defender?


  


2. Muda a versão

Luis Fernando Coutinho da Silva
lewis.cast

(usa Ubuntu)

Enviado em 03/07/2015 - 13:53h

Meu amigo, baixa
http://sourceforge.net/projects/firebird/files/firebird-linux-amd64/2.5.4-Release/FirebirdCS-2.5.4.2... ou se você prefere fazer manualmente como eu http://sourceforge.net/projects/firebird/files/firebird-linux-amd64/2.5.4-Release/FirebirdCS-2.5.4.2....


__________________________________________________________________
O temor do SENHOR é o princípio da sabedoria;
(Salmos 111:10)


3. Re: Firebird 2.5 no CentOS 7

Eris Ribeiro Junior
erisrjr

(usa Outra)

Enviado em 03/07/2015 - 14:04h

mainframedj escreveu:

Olá pessoal,
Aqui na empresa, estamos implantando um novo ERP que utiliza o Firebird. Querem instalar um (R)windows.
E eu estou instalando em um CentOS, pois acredito que vai performar melhor, além das vantagens da plataforma opensoure.

Enfim, como usuário básico dos básicos, estou com um problema para resolver. O que está emperrando a minha tentativa de extinguir o (R)windows daqui.

Listo a seguir:

# rpm -ivh FirebirdCS-2.1.7.18553-0.i686.rpm
Preparando... ################################# [100%]
o arquivo / da instalação de FirebirdCS-2.1.7.18553-0.i686 conflita com o arquivo do pacote filesystem-3.2-18.el7.x86_64
o arquivo /usr/lib da instalação de FirebirdCS-2.1.7.18553-0.i686 conflita com o arquivo do pacote filesystem-3.2-18.el7.x86_64

Nem o Google tá me ajudando...

E agora? Quem poderá me defender?


Nem precisa de google(Acabei de participar de um topico igual, a pesquisa do VOL ja resolveria).
Esta usando o CentOS7 e tentando instalar um pacote de 32Bits, so que o CentOS 7 Apenas existe em 64Bits(Ate seria possivel mas teria outros pacotes a instalar).

Leia meu post, configure o EPEL e instale o firebird via yum:
http://www.vivaolinux.com.br/topico/Firebird/Instalacao-do-Firebird-25-no-CentOS-7

--------------------------------------------
[email protected] ~$ sudo su -
[email protected] ~# find / -iname corrupção -exec rm -rfv {}\ ;



4. Tenta fazer o que pedi!

Luis Fernando Coutinho da Silva
lewis.cast

(usa Ubuntu)

Enviado em 03/07/2015 - 14:45h

erisrjr, eu tava no tópico depois que você postou eu reativei o CentOS 7 com o firebird mesmo a sua dica de atualizar o EPEL não funcionou com a versão "FirebirdCS-2.1.7.18553-0.*" más com a versão " FirebirdCS-2.5.4.26856-0.*" ficou redondo. Funcionou legal, ai eu reativei o CentOS7 e chutei o 6 :-)


________________________________________________________________
O temor do SENHOR é o princípio da sabedoria;
(Salmos 111:10)


5. Re: Firebird 2.5 no CentOS 7

Eris Ribeiro Junior
erisrjr

(usa Outra)

Enviado em 03/07/2015 - 18:11h

lewis.cast escreveu:

erisrjr, eu tava no tópico depois que você postou eu reativei o CentOS 7 com o firebird mesmo a sua dica de atualizar o EPEL não funcionou com a versão "FirebirdCS-2.1.7.18553-0.*" más com a versão " FirebirdCS-2.5.4.26856-0.*" ficou redondo. Funcionou legal, ai eu reativei o CentOS7 e chutei o 6 :-)


________________________________________________________________
O temor do SENHOR é o princípio da sabedoria;
(Salmos 111:10)


Boa noticia legal que funcionou para você também (1 tópico que já serviu para 2).
Se for para instalar um pacote "avulso", salvo eu tenha que compilar localmente prefiro usar um repositório como o EPEL, assim as atualizações futuras ficam mais simples e o yum se encarrega de resolver as dependências para mim.

Com o RHEL complica fazer devido ao suporte (Não poder usar repositórios não oficiais), mas no CentOS da para fazer desde que o repositório seja conhecido, como é o EPEL.


--------------------------------------------
[email protected] ~$ sudo su -
[email protected] ~# find / -iname corrupção -exec rm -rfv {} \;







Patrocínio

Site hospedado pelo provedor RedeHost.
Linux banner
Linux banner

Artigos

Dicas

Tópicos

Top 10 do mês

Scripts