warcraft 3 - erro

1. warcraft 3 - erro

Daniel Gimenes
danielgimenes

(usa Ubuntu)

Enviado em 14/06/2008 - 13:09h

Preciso de ajuda para rodar o War 3 aqui! Instalei ele e o Frozen Throne (expansão) e apliquei o patch mais novo. Porém, quando vou executar no meu Ubuntu 8.04 (Notebook Dell Inspiron 1525), o desktop do Gnome fica preto, lento e no console aparecem várias mensagens, vejam:

[email protected]:~$ wine .wine/drive_c/Warcraft\ III/Frozen\ Throne.exe -window -opengl
fixme:mountmgr:harddisk_ioctl unsupported ioctl 4d004
err:ole:CoCreateInstance apartment not initialised
fixme:advapi:SetSecurityInfo stub
fixme:win:EnumDisplayDevicesW ((null),0,0x33f3a0,0x00000000), stub!
fixme:win:EnumDisplayDevicesW ((null),0,0x33f64c,0x00000000), stub!
[email protected]:~$ err:x11settings:X11DRV_ChangeDisplaySettingsEx No matching mode found 800x600x32 @75! (XRandR)
err:x11settings:X11DRV_ChangeDisplaySettingsEx No matching mode found 800x600x32 @70! (XRandR)
fixme:quartz:AVISplitter_InitializeStreams stream 1: frames found: 2172570, frames meant to be found: 2173350
fixme:win:EnumDisplayDevicesW ((null),0,0x33e028,0x00000000), stub!
fixme:quartz:AsyncReader_QueryInterface No interface for {56a868b5-0ad4-11ce-b03a-0020af0ba770}!
fixme:quartz:Parser_QueryInterface No interface for {56a868b5-0ad4-11ce-b03a-0020af0ba770}!
err:ntdll:RtlpWaitForCriticalSection section 0x13e654 "videorenderer.c: VideoRendererImpl.csFilter" wait timed out in thread 0021, blocked by 0027, retrying (60 sec)

[email protected]:~$ xfixme:dbghelp:dump_system_info fill in CPU vendorID and feature set
err:quartz:AVISplitter_Sample Error sending sample (1)



POR FAVOR, se alguém tiver alguma pista, me ajude! huahuahua

Detalhe: glxgears roda normal. Socorro!!!
Detalhe 2: instalei os 2 pelo wine, ao invés de tentar rodar a instalação do Windows.

Obrigado,
Daniel


  


2. Re: warcraft 3 - erro

Daniel Gimenes
DanielGimenes

(usa Ubuntu)

Enviado em 20/06/2008 - 08:02h

Outra coisa: ele mostra a splash do jogo normalmente, troca a resolução e o esquema de cores, etc.
MAs mesmo executando pelo wine com a opção -opengl (para rodar com opengl) ele não abre o menu do jogo.


SOCORRO! XD


3. VIDEOS

Daniel Gimenes
danielgimenes

(usa Ubuntu)

Enviado em 25/06/2008 - 19:46h

Descobri que se remover os vídeos da pasta Movies (ou a pasta inteira) ele roda! Blz! Único problema é que não consegui jogar via LAN e os gráficos de alguns personagens ficam sem textura.

Alguma idéia?


4. Tenta isso

SLOT
_SL0T_

(usa Slackware)

Enviado em 18/03/2009 - 11:19h

Daniel no final de 2007 escrevi um tuto que fala sobre WINE: ( http://www.vivaolinux.com.br/artigo/Wine-Como-jogar-emular-no-Linux-seus-games-ou-softwares-mais-atu... ) eu sei que faz tempo que você postou mas talves possa ajudar a resolver.

Eu comprei um DELL Inspiron 1525 essa semana ele ainda não chegou mas acredito que vou passar pelo mesmo problema que você teve porque também sou fã desse game.

E ai já resolveu?
Testa ai e me fala...

Quando o meu chegar agente pode tentar resolver junto. =)


5. A long long time ago... XD

Daniel Gimenes
DanielGimenes

(usa Ubuntu)

Enviado em 18/03/2009 - 14:09h

SL0T,

Realmente esse post é bem antigo. Lembro que na época eu não consegui rodar o War3 perfeitamente.

Ainda tenho curiosidade, mas não tenho tempo para jogar. Se sobrar algum vou tentar o que me sugere.

Se quiser contar sobre sua experiência depois que chegar seu note, gostaria de ler.

Boa Sorte.
Daniel






Patrocínio

Site hospedado pelo provedor RedeHost.
Linux banner
Linux banner

Destaques

Artigos

Dicas

Tópicos

Top 10 do mês

Scripts