Zandronum não roda no Debian Linux

1. Zandronum não roda no Debian Linux

Alcides Alves
subzerodebian

(usa Debian)

Enviado em 19/03/2020 - 10:00h

Olá a todos do fórum.
Instalei recentemente o Zandronum no meu PC Linux (Debian GNU / Linux bullseye / sid)
Quando o executo, ele não abre. Eu dei o comando no terminal e a seguinte resposta apareceu:
------------------------------------

Zandronum 3.0.1 - 191013-1938 - SDL version
Compiled on Nov 3 2019
Using video driver x11

M_LoadDefaults: Load system defaults.
Gameinfo scan took 0 ms
W_Init: Init WADfiles.
adding /usr/games/zandronum/zandronum.pk3, 689 lumps
adding /home/alcidesapjr/.config/zandronum/TNT.WAD, 3101 lumps
I_Init: Setting up machine state.
CPU Vendor ID: GenuineIntel
Name: Intel(R) Core(TM) i3 CPU 530 @ 2.93GHz
Family 6, Model 37, Stepping 2
Features: MMX SSE SSE2 SSE3 SSSE3 SSE4.1 SSE4.2
I_InitSound: Initializing FMOD
FMOD Sound System, copyright � Firelight Technologies Pty, Ltd., 1994-2009.
Loaded FMOD version 4.24.16
OSS could not be initialized. Trying ALSA.
corrupted size vs. prev_size in fastbins
Abortado

--------------------------------
Alguém sabe como eu posso resolver esse problema?
Desde já, agradeço a ajuda de todos.


  


2. workaround

radul
radul

(usa Outra)

Enviado em 28/03/2020 - 15:26h

i dont speak portuguese, sorry.

just stumbled across the very same problem and got help from discord:

This has something todo with broken FMOD sound system on newer kernels.

workaround:

start zandronum with -nosound option
Set Sount Output System to SDL in Options
quit game

restart normally

regards






Patrocínio

Site hospedado pelo provedor RedeHost.
Linux banner
Linux banner
Linux banner

Destaques

Artigos

Dicas

Tópicos

Top 10 do mês

Scripts