Não consigo instalar/atualizar nada. Problemas de dependências.

1. Não consigo instalar/atualizar nada. Problemas de dependências.

Gleidson Campos
gadsc

(usa elementary OS)

Enviado em 13/09/2015 - 15:11h

Pessoal, boa tarde!

Um belo dia fui tentar instalar um software no linux e obtive o seguinte erro:
[email protected]:/home/gleidson# apt-get install ginga
Reading package lists... Done
Building dependency tree
Reading state information... Done
You might want to run 'apt-get -f install' to correct these:
The following packages have unmet dependencies:
cpp-4.8 : Depends: gcc-4.8-base (= 4.8.4-1) but it is not going to be installed
dkms : Depends: gcc but it is not going to be installed
gcc-multilib : Depends: gcc (>= 4:4.8.2-1ubuntu6) but it is not going to be installed
Depends: gcc-4.8-multilib (>= 4.8.2-5~) but it is not going to be installed
ginga : Depends: berkelium but it is not going to be installed
Depends: ffmpegext but it is not going to be installed
Depends: libxerces-c3.1 but it is not going to be installed
Depends: nclua but it is not going to be installed
libasan0 : Depends: gcc-4.8-base (= 4.8.4-1) but it is not going to be installed
libatomic1 : Depends: gcc-4.8-base (= 4.8.4-2ubuntu1~14.04) but it is not going to be installed
libc6:i386 : Depends: libgcc1:i386 but it is not going to be installed
libgcc1 : Depends: gcc-4.7-base (= 4.7.2-5) but it is not going to be installed
libgfortran3 : Depends: gcc-4.8-base (= 4.8.4-2ubuntu1~14.04) but it is not going to be installed
libgl1-mesa-dri-lts-utopic:i386 : Depends: libgcc1:i386 (>= 1:4.7) but it is not going to be installed
libglu1-mesa:i386 : Depends: libgcc1:i386 (>= 1:4.1.1) but it is not going to be installed
libgomp1 : Depends: gcc-4.8-base (= 4.8.4-2ubuntu1~14.04) but it is not going to be installed
libitm1 : Depends: gcc-4.8-base (= 4.8.4-2ubuntu1~14.04) but it is not going to be installed
libjack-jackd2-0:i386 : Depends: libgcc1:i386 (>= 1:4.1.1) but it is not going to be installed
libllvm3.5:i386 : Depends: libgcc1:i386 (>= 1:4.1.1) but it is not going to be installed
libmysqlclient18:i386 : Depends: libgcc1:i386 (>= 1:4.1.1) but it is not going to be installed
libqt4-declarative:i386 : Depends: libgcc1:i386 (>= 1:4.1.1) but it is not going to be installed
libqt4-network:i386 : Depends: libgcc1:i386 (>= 1:4.1.1) but it is not going to be installed
libqt4-opengl:i386 : Depends: libgcc1:i386 (>= 1:4.1.1) but it is not going to be installed
libqt4-script:i386 : Depends: libgcc1:i386 (>= 1:4.1.1) but it is not going to be installed
libqt4-scripttools:i386 : Depends: libgcc1:i386 (>= 1:4.1.1) but it is not going to be installed
libqt4-sql:i386 : Depends: libgcc1:i386 (>= 1:4.1.1) but it is not going to be installed
libqt4-sql-mysql:i386 : Depends: libgcc1:i386 (>= 1:4.1.1) but it is not going to be installed
libqt4-xml:i386 : Depends: libgcc1:i386 (>= 1:4.1.1) but it is not going to be installed
libqt4-xmlpatterns:i386 : Depends: libgcc1:i386 (>= 1:4.1.1) but it is not going to be installed
libqtcore4:i386 : Depends: libgcc1:i386 (>= 1:4.1.1) but it is not going to be installed
libqtdbus4:i386 : Depends: libgcc1:i386 (>= 1:4.1.1) but it is not going to be installed
libqtgui4:i386 : Depends: libgcc1:i386 (>= 1:4.1.1) but it is not going to be installed
libqtwebkit4:i386 : Depends: libgcc1:i386 (>= 1:4.1.1) but it is not going to be installed
libquadmath0 : Depends: gcc-4.8-base (= 4.8.4-2ubuntu1~14.04) but it is not going to be installed
libstdc++-4.8-dev : Depends: gcc-4.8-base (= 4.8.4-2ubuntu1~14.04) but it is not going to be installed
Depends: libgcc-4.8-dev (= 4.8.4-2ubuntu1~14.04) but it is not going to be installed
libstdc++6 : Depends: gcc-4.9-base (= 4.9.1-16ubuntu6) but it is not going to be installed
libstdc++6:i386 : Depends: gcc-4.9-base:i386 (= 4.9.1-16ubuntu6) but it is not going to be installed
Depends: libgcc1:i386 (>= 1:4.1.1) but it is not going to be installed
libtsan0 : Depends: gcc-4.8-base (= 4.8.4-2ubuntu1~14.04) but it is not going to be installed
sa-compile : Depends: gcc but it is not going to be installed
simplescreenrecorder-lib:i386 : Depends: libgcc1:i386 (>= 1:4.1.1) but it is not going to be installed
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).


Desde esse dia pra cá nunca mais consegui instalar nada.

Já dei uma busca na internet e tentei alguns mais óbvios como "apt-get install -f", mas sem sucesso.

vocês poderiam salvar uma alma? :DD



  


2. Re: Não consigo instalar/atualizar nada. Problemas de dependências.

leonardo moreira
lSinkz

(usa Debian)

Enviado em 13/09/2015 - 16:44h


dpkg --configure -a




3. Re: Não consigo instalar/atualizar nada. Problemas de dependências.

Gleidson Campos
gadsc

(usa elementary OS)

Enviado em 13/09/2015 - 20:38h

Sinks, obrigado pela ajuda, está é a saída do comando que você pediu para executar:

# dpkg --configure -a
dpkg: dependency problems prevent configuration of cpp-4.8:
cpp-4.8 depends on gcc-4.8-base (= 4.8.4-1); however:
Package gcc-4.8-base is not installed.

dpkg: error processing package cpp-4.8 (--configure):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of gcc-multilib:
gcc-multilib depends on gcc (>= 4:4.8.2-1ubuntu6); however:
Package gcc is not installed.
gcc-multilib depends on gcc-4.8-multilib (>= 4.8.2-5~); however:
Package gcc-4.8-multilib is not installed.

dpkg: error processing package gcc-multilib (--configure):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libasan0:amd64:
libasan0:amd64 depends on gcc-4.8-base (= 4.8.4-1); however:
Package gcc-4.8-base is not installed.

dpkg: error processing package libasan0:amd64 (--configure):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libstdc++6:amd64:
libstdc++6:amd64 depends on gcc-4.9-base (= 4.9.1-16ubuntu6); however:
Package gcc-4.9-base is not installed.

dpkg: error processing package libstdc++6:amd64 (--configure):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libstdc++6:i386:
libstdc++6:i386 depends on gcc-4.9-base (= 4.9.1-16ubuntu6).
libstdc++6:i386 depends on libgcc1 (>= 1:4.1.1).

dpkg: error processing package libstdc++6:i386 (--configure):
dependency problems - leaving unconfigured
Errors were encountered while processing:
cpp-4.8
gcc-multilib
libasan0:amd64
libstdc++6:amd64
libstdc++6:i386



4. Re: Não consigo instalar/atualizar nada. Problemas de dependências.

leonardo moreira
lSinkz

(usa Debian)

Enviado em 13/09/2015 - 22:00h

gadsc escreveu:

Sinks, obrigado pela ajuda, está é a saída do comando que você pediu para executar:

# dpkg --configure -a
dpkg: dependency problems prevent configuration of cpp-4.8:
cpp-4.8 depends on gcc-4.8-base (= 4.8.4-1); however:
Package gcc-4.8-base is not installed.

dpkg: error processing package cpp-4.8 (--configure):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of gcc-multilib:
gcc-multilib depends on gcc (>= 4:4.8.2-1ubuntu6); however:
Package gcc is not installed.
gcc-multilib depends on gcc-4.8-multilib (>= 4.8.2-5~); however:
Package gcc-4.8-multilib is not installed.

dpkg: error processing package gcc-multilib (--configure):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libasan0:amd64:
libasan0:amd64 depends on gcc-4.8-base (= 4.8.4-1); however:
Package gcc-4.8-base is not installed.

dpkg: error processing package libasan0:amd64 (--configure):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libstdc++6:amd64:
libstdc++6:amd64 depends on gcc-4.9-base (= 4.9.1-16ubuntu6); however:
Package gcc-4.9-base is not installed.

dpkg: error processing package libstdc++6:amd64 (--configure):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libstdc++6:i386:
libstdc++6:i386 depends on gcc-4.9-base (= 4.9.1-16ubuntu6).
libstdc++6:i386 depends on libgcc1 (>= 1:4.1.1).

dpkg: error processing package libstdc++6:i386 (--configure):
dependency problems - leaving unconfigured
Errors were encountered while processing:
cpp-4.8
gcc-multilib
libasan0:amd64
libstdc++6:amd64
libstdc++6:i386



O que o comando apt-get install -f retorna?
Esses foram os pacotes que não foram instalandos:
"cpp-4.8
gcc-multilib
libasan0:amd64
libstdc++6:amd64
libstdc++6:i386"

Tente os instalar manualmente. (Não sou muito experiente, sorry)


5. Re: Não consigo instalar/atualizar nada. Problemas de dependências.

Perfil removido
removido

(usa Nenhuma)

Enviado em 13/09/2015 - 22:05h

Boa noite,

Que distro usa? eOS? Você deletou algo aí? As mensagens são de pacotes em falta, dependências....

Coloque o DVD/PEN, dê boot com ele e reinstale ele. Salve seus arquivos antes.


Att,
Jbaf 2015
Mageia 5(KDE), Fedora 21(GNOME)
http://www.mageia.org/pt-br/5/


6. Re: Não consigo instalar/atualizar nada. Problemas de dependências.

Perfil removido
removido

(usa Nenhuma)

Enviado em 14/09/2015 - 01:39h

a resposta está na tela do seu terminal, veja;

You might want to run 'apt-get -f install' to correct these:


Traduzindo. Use o comando a baixo

sudo apt-get install -f 

____________________________________________________
Manjaro Geek: http://www.manjaro-geek.org/
Fórum: http://forum.manjaro-geek.org/index.php
Freenode: #manjaro-geek


7. Re: Não consigo instalar/atualizar nada. Problemas de dependências.

Gleidson Campos
gadsc

(usa elementary OS)

Enviado em 15/09/2015 - 06:37h


Jbaf Uso Elementary OS e quando vi dependência e sim, instalei as versões de gcc pedidas e depois as desinstalei pq não funciou. A ideia é não 'formatar' o pc, só em último caso.

pekman já tentei antes isso e não funciona. Veja a saída do comando:

apt-get install -f
Reading package lists... Done
Building dependency tree
Reading state information... Done
Correcting dependencies... failed.
The following packages have unmet dependencies:
cpp-4.8 : Depends: gcc-4.8-base (= 4.8.4-1) but it is not installed
dkms : Depends: gcc but it is not installed
gcc-multilib : Depends: gcc (>= 4:4.8.2-1ubuntu6) but it is not installed
Depends: gcc-4.8-multilib (>= 4.8.2-5~) but it is not installed
libasan0 : Depends: gcc-4.8-base (= 4.8.4-1) but it is not installed
libatomic1 : Depends: gcc-4.8-base (= 4.8.4-2ubuntu1~14.04) but it is not installed
libc6:i386 : Depends: libgcc1:i386 but it is not installed
libgcc1 : Depends: gcc-4.7-base (= 4.7.2-5) but it is not installed
libgfortran3 : Depends: gcc-4.8-base (= 4.8.4-2ubuntu1~14.04) but it is not installed
libgl1-mesa-dri-lts-utopic:i386 : Depends: libgcc1:i386 (>= 1:4.7) but it is not installed
libglu1-mesa:i386 : Depends: libgcc1:i386 (>= 1:4.1.1) but it is not installed
libgomp1 : Depends: gcc-4.8-base (= 4.8.4-2ubuntu1~14.04) but it is not installed
libitm1 : Depends: gcc-4.8-base (= 4.8.4-2ubuntu1~14.04) but it is not installed
libjack-jackd2-0:i386 : Depends: libgcc1:i386 (>= 1:4.1.1) but it is not installed
libllvm3.5:i386 : Depends: libgcc1:i386 (>= 1:4.1.1) but it is not installed
libmysqlclient18:i386 : Depends: libgcc1:i386 (>= 1:4.1.1) but it is not installed
libqt4-declarative:i386 : Depends: libgcc1:i386 (>= 1:4.1.1) but it is not installed
libqt4-network:i386 : Depends: libgcc1:i386 (>= 1:4.1.1) but it is not installed
libqt4-opengl:i386 : Depends: libgcc1:i386 (>= 1:4.1.1) but it is not installed
libqt4-script:i386 : Depends: libgcc1:i386 (>= 1:4.1.1) but it is not installed
libqt4-scripttools:i386 : Depends: libgcc1:i386 (>= 1:4.1.1) but it is not installed
libqt4-sql:i386 : Depends: libgcc1:i386 (>= 1:4.1.1) but it is not installed
libqt4-sql-mysql:i386 : Depends: libgcc1:i386 (>= 1:4.1.1) but it is not installed
libqt4-xml:i386 : Depends: libgcc1:i386 (>= 1:4.1.1) but it is not installed
libqt4-xmlpatterns:i386 : Depends: libgcc1:i386 (>= 1:4.1.1) but it is not installed
libqtcore4:i386 : Depends: libgcc1:i386 (>= 1:4.1.1) but it is not installed
libqtdbus4:i386 : Depends: libgcc1:i386 (>= 1:4.1.1) but it is not installed
libqtgui4:i386 : Depends: libgcc1:i386 (>= 1:4.1.1) but it is not installed
libqtwebkit4:i386 : Depends: libgcc1:i386 (>= 1:4.1.1) but it is not installed
libquadmath0 : Depends: gcc-4.8-base (= 4.8.4-2ubuntu1~14.04) but it is not installed
libstdc++-4.8-dev : Depends: gcc-4.8-base (= 4.8.4-2ubuntu1~14.04) but it is not installed
Depends: libgcc-4.8-dev (= 4.8.4-2ubuntu1~14.04) but it is not installed
libstdc++6 : Depends: gcc-4.9-base (= 4.9.1-16ubuntu6) but it is not installed
libstdc++6:i386 : Depends: gcc-4.9-base:i386 (= 4.9.1-16ubuntu6) but it is not installed
Depends: libgcc1:i386 (>= 1:4.1.1) but it is not installed
libtsan0 : Depends: gcc-4.8-base (= 4.8.4-2ubuntu1~14.04) but it is not installed
sa-compile : Depends: gcc but it is not installed
simplescreenrecorder-lib:i386 : Depends: libgcc1:i386 (>= 1:4.1.1) but it is not installed
E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.
E: Unable to correct dependencies


Vocês acham que instalando manualmente como o lSinkz sugeriu poderia resolver?


8. Não consigo instalar/atualizar nada. Problemas de dependências.

morvan bliasby
morvan

(usa Fedora)

Enviado em 15/09/2015 - 08:34h

Bom dia.
Você já tentou rodar o seu sistema em Modo de Recuperação (através da própria opção do Grub ou via mídia de instalação) e utilizar, a partir daí, a opção de reparar pacotes [quebrados]? Já tive uma situação similar à sua, quando cuidava de Suporte, e a solução foi essa. No meu caso (ou do cliente, claro) era uma atualização do próprio Kernel que tinha comprometido o Sistema. Funcionou.

Morvan, Usuário GNU-Linux #433640. Seja Legal; seja Livre. Use GNU-Linux.


9. Re: Não consigo instalar/atualizar nada. Problemas de dependências.

Clodoaldo Santos
clodoaldops

(usa Linux Mint)

Enviado em 15/09/2015 - 09:31h

Eu tive problemas com o freya, por isso não recomendo
Teste o voyager-linux que é baseado no xubuntu é leve e funciona muito bem


10. Re: Não consigo instalar/atualizar nada. Problemas de dependências.

Gleidson Campos
gadsc

(usa elementary OS)

Enviado em 16/09/2015 - 15:25h

morvan , o modo de recuperação também apresentou a mesma mensagem: unmet to solve dependencies.

Tenho que fazer isso conectado a um cabo de rede?


11. Não consigo instalar/atualizar nada. Problemas de dependências.

morvan bliasby
morvan

(usa Fedora)

Enviado em 16/09/2015 - 15:38h

gadsc escreveu:
morvan , o modo de recuperação também apresentou a mesma mensagem: unmet to solve dependencies.
Tenho que fazer isso conectado a um cabo de rede?

Eu sempre rodo o Modo de Recuperação e peço para reparar pacotes com o cabo de rede ligado.
Se necessário, rodo o
dhclient 
para pegar IP. Em tese, ele não precisaria baixar nada, pois foi, teoricamente, algum pacote cuja instalação não sucedeu, talvez no momento de descompactar. Está no cache do APT, se tiver sido baixado. Você pode ainda tentar rodar um Kernel anterior, se tiver sido má atualização deste. O modo de Recuperação, se necessário, pedirá para montar a partição do Sistema em modo RW. Confirme, se for o caso.

Morvan, Usuário GNU-Linux #433640. Seja Legal; seja Livre. Use GNU-Linux.


12. Re: Não consigo instalar/atualizar nada. Problemas de dependências.

Perfil removido
removido

(usa Nenhuma)

Enviado em 16/09/2015 - 15:45h

Boa tarde,

O eOS Freya desde o lançamento está bugado!! Se gosta assim desta remasterização, use o antecessor Elementary OS Luna que está 'inteiro'.

Sugestão se dá quando se quer bem!!!

Att,
Jbaf 2015
Fedora 21,22(MATE), Ubuntu LTS(GNOME 2)
https://getfedora.org/pt_BR/






Patrocínio

Site hospedado pelo provedor RedeHost.
Linux banner
Linux banner

Destaques

Artigos

Dicas

Tópicos

Top 10 do mês

Scripts