Terminal não responde a nenhum comando, após eu ter tentado instalar o pyenv [RESOLVIDO]

1. Terminal não responde a nenhum comando, após eu ter tentado instalar o pyenv [RESOLVIDO]

Luan Silva
luan_safe

(usa Ubuntu)

Enviado em 18/01/2022 - 20:52h

Meu terminal começou a não funcionar direito logo após eu dar os seguintes comandos:

$ echo 'export PYENV_ROOT="$HOME/.pyenv"' >> ~/.bashrc
$ echo 'export PATH="$PYENV_ROOT/bin:PATH"' >> ~/.bashrc
$ echo -e 'if command -v pyenv 1>/dev/null 2>&1; then\n eval "$(pyenv init -)"\nfi' >> ~/.bashrc

Eu estava tentando instalar o pyenv através de um tutorial de 2020, mas não obtive sucesso e de quebra ainda não tô conseguindo usar meu terminal, nem um simples 'clear' funciona, alguém poderia dar uma ajuda aí, instalei o linux(UBUNTU 20.04 LTS) tem só 1 semana.
Poderiam utilizar esses mesmos comandos só que revertendo a situação? Sei lá


  


2. Re: Terminal não responde a nenhum comando, após eu ter tentado instalar o pyenv

Marcelo Oliver
msoliver

(usa Debian)

Enviado em 18/01/2022 - 22:28h

luan_safe escreveu:

Meu terminal começou a não funcionar direito logo após eu dar os seguintes comandos:

$ echo 'export PYENV_ROOT="$HOME/.pyenv"' >> ~/.bashrc
$ echo 'export PATH="$PYENV_ROOT/bin:PATH"' >> ~/.bashrc
$ echo -e 'if command -v pyenv 1>/dev/null 2>&1; then\n eval "$(pyenv init -)"\nfi' >> ~/.bashrc

Eu estava tentando instalar o pyenv através de um tutorial de 2020, mas não obtive sucesso e de quebra ainda não tô conseguindo usar meu terminal, nem um simples 'clear' funciona, alguém poderia dar uma ajuda aí, instalei o linux(UBUNTU 20.04 LTS) tem só 1 semana.
Poderiam utilizar esses mesmos comandos só que revertendo a situação? Sei lá

export PATH="/usr/local/bin:/usr/local/sbin:/usr/bin:/usr/sbin"
Depois arrume o .bashrc
Faltou o $ em PATH
No comando:
echo 'export PATH="$PYENV_ROOT/bin:AQUIPATH"' >> ~/.bashrc

______________________________________________________________________
Importante:
lynx --dump https://www.vivaolinux.com.br/termos-de-uso/|sed -nr '/^[ ]+Se/,/dou.$/p'
______________________________________________________________________
Nota de esclarecimento:
O comando: ACIMA, faz parte da minha assinatura.
Att.: Marcelo Oliver
______________________________________________________________________



3. Re: Terminal não responde a nenhum comando, após eu ter tentado instalar o pyenv [RESOLVIDO]

Samuel Leonardo
SamL

(usa XUbuntu)

Enviado em 18/01/2022 - 22:44h

Completando o que o marcelo disse:
também vai ter de editar o .bashrc e consertar o path correto. É lá que tem que colocar o $ antes do nome PATH.


4. Terminal não responde a nenhum comando, após eu ter tentado instalar o pyenv

Luan Silva
luan_safe

(usa Ubuntu)

Enviado em 19/01/2022 - 09:29h

Agr deu certo, pelo menos o terminal tá funcionando, eu só editei essa linha: export PATH="$PYENV_ROOT/bin:$PATH" colocando $

Vcs acham que futuramente pode dar algum erro?