Problemas em atualizar uma biblioteca

1. Problemas em atualizar uma biblioteca

David Fonseca
davidfonseca

(usa Manjaro Linux)

Enviado em 18/04/2014 - 13:31h

Boa tarde pessoal, eu estava testando o Elementary OS pelo live-USB e achei muito bonito e rápido, tudo funcionamento perfeitamente. Quando resolvi instalar ele em um outro pen drive para poder usar em qualquer lugar, após instalação percebi que ficou muito lento, pesquisando um pouco no fórum do Elementary OS percebi que os drivers gráficos precisavam ser atualizados, eu tentei pelo "Addicional Drivers" mas nada, fui no site da intel (uso notebook com placa integrada intel hd 3000 ) e consegui baixar. Na instalação diz:

"Dependency is not satisfiable: libglib2.0-0 (>= 2.37.3)

Beleza, vou no terminal e digito: "sudo apt-get install libglib2.0" e diz que a última versão já está instalada no meu computador (versão 2.32.4), mas resolvi buscar na internet a última versão e vi que existe uma libglib 2.40.0, o problema está justamente aí. Que na hora de instalar diz: "Breaks existing package 'libglib2.0-0-dbg' dependency libglib2.0-0 (=2.32.4-0ubuntu1). Se eu digitar "sudo apt-get remove libglib2.0" diz que removerá mais de 700mb do meu computador e um monte de outros componentes importantes. Mas eu preciso instalar essa biblioteca nova, não queria danificar meu SO de alguma forma além de poder instalar os últimos drivers gráficos.

Como faço pessoal ?

Obrigado!


  


2. Re: Problemas em atualizar uma biblioteca

Josue de Jesus Santos
JJSantos

(usa Gentoo)

Enviado em 18/04/2014 - 19:03h

Os drivers da intel já suportados nativamente pelo kernel linux, sem a necessidade de uma instalação manual.
Você tem dependências cruzadas dessa biblioteca ou seja outros pacotes dependências dela para funcionar corretamente.


3. Re: Problemas em atualizar uma biblioteca

David Fonseca
davidfonseca

(usa Manjaro Linux)

Enviado em 18/04/2014 - 23:56h

Josue, eu entendi que foi isso que ocorreu, mas meu problema é que depois de instalado o Elementary OS, ele ficou extremamente lento, no próprio fórum dizia que era para atualizar os drivers da minha placa de vídeo para melhorar isso. O que ocorreu com um usuário de placa nvidia, é que ele teve que instalar manualmente pois o repositório central não contava com as últimas atualizações do driver dele. Eu percebi que para instalar manualemnte a última atualização do meu driver teria que atualizar esta mesma biblioteca que tem um monte de dependências.

Eu sei que utilizando o comando "apt-get install <pacote>" ele será instalado ou se já estiver instalado, atualizado, mas apenas atualizará se tiver no repositório central, será que dá para atualizar apenas um pacote manualmente já com o pacote no disco rígido ? Pois isso pouparia todos os meus problemas e não precisaria perder mais de 700mb (praticamente todo o sistema operacional) com essa remoção.

Obrigado






Patrocínio

Site hospedado pelo provedor RedeHost.
Linux banner
Linux banner
Linux banner

Destaques

Artigos

Dicas

Tópicos

Top 10 do mês

Scripts