Problema com interfaces de rede

1. Problema com interfaces de rede

Aprendiz - CE
aprendiz_ce

(usa Debian)

Enviado em 23/12/2009 - 09:20h

Tenho um roteador (Debian Lenny) com duas interfaces de rede funcionando certinho. A configuração atual é a seguinte: eth0 conectada com a internet e a eth1 conectada com a rede local. Coloquei mais uma interface (eth2) para conectar um segundo link de internet e fazer redundância de links. O sistema reconheceu a terceira interface na boa e aparentemente está funcionando sem problema algum. Para testa-la conectei o cabo que fica na eth1 nela e a mesma recebeu um endereço da rede na boa via DHCP da rede local. O problema é que quando faço teste de ping com a mesma, ela não pinga para lugar algum, no máximo o ping só tem efeito sobre ela mesma. Fixei o IP da eth1 nessa nova interface (eth2) e repeti o teste de ping e ficou na mesma, ou seja, não pingou!. Agora se conecto o cabo a eth1 (192.168.1.2) e também conecto o cabo a eth2 (192.168.1.3) o ping funciona. O que pode está ocorrendo? Como posso resolver isso? Será problema de rota?

Obrigado a todos e aguardo qualquer orientação.

Abraço.



  


2. Re: Problema com interfaces de rede

Magno Lima
magnolinux

(usa Debian)

Enviado em 23/12/2009 - 09:26h

Amigos posta aí como ta os endereços das suas placas de rede. Lembrando que vc na pode colocar a eth1 e eth2 no mesmo range de IP..

OK...

POste aíi!!!


3. Re: Problema com interfaces de rede

Aprendiz - CE
aprendiz_ce

(usa Debian)

Enviado em 23/12/2009 - 11:53h

Olá,

Segue logo abaixo o meu /etc/network/interfaces:

router:~# cat /etc/network/interfaces
# This file describes the network interfaces available on your system
# and how to activate them. For more information, see interfaces(5).

# The loopback network interface
auto lo
iface lo inet loopback

# The primary network interface
iface eth0 inet static
address 201.xx.xxx.xxx
netmask 255.255.255.248
gateway 201.xx.xxx.xx
auto eth0

# The second network interface
iface eth1 inet static
network 192.168.1.0
broadcast 192.168.1.255
address 192.168.1.2
netmask 255.255.255.0
auto eth1

# The third network interface
iface eth2 inet dhcp
#iface eth2 inet static
# network 192.168.1.0
# broadcast 192.168.1.255
## dns-nameservers 192.168.100.1
# dns-search
# address 192.168.1.2
# netmask 255.255.255.0
# gateway 192.168.100.1
auto eth2

Sobre o range de IP... foi mais para fazer um teste. O meu teste inicial foi colocar o CABO no eth1, tirar e colocar no eth2.


Obrigado e aguardo qualquer orientação.


4. Re: Problema com interfaces de rede

Magno Lima
magnolinux

(usa Debian)

Enviado em 23/12/2009 - 12:24h

que range de ip seu servidor da distribuindo... Seria o mesmo range da eth1?


5. Re: Problema com interfaces de rede

Aprendiz - CE
aprendiz_ce

(usa Debian)

Enviado em 23/12/2009 - 12:58h

Isso mesmo!






Patrocínio

Site hospedado pelo provedor RedeHost.
Linux banner
Linux banner
Linux banner

Destaques

Artigos

Dicas

Tópicos

Top 10 do mês

Scripts