O flatpak não quer executar o Ardour

1. O flatpak não quer executar o Ardour

Leonardo Ferreira da Rocha
leleuxss

(usa Debian)

Enviado em 19/11/2020 - 23:41h

Instalei o Ardour (editor de aúdio) via Flatpak. Trabalho com beat e preciso do programa, mas ele simplesmente não quer abrir. Quando executo <pre>flatpak run org.ardour.Ardour</pre> no terminal, aparece isso:

<pre>WARNING: Your system has a limit for maximum amount of locked memory!
This might cause Ardour to run out of memory before your system runs
out of memory. You can view the memory limit with &apos;ulimit -l&apos;, and it
is normally controlled by /etc/security/limits.conf

WARNING: Could not check your glib-2.0 for mutex locking atomic operations.

Ardour6.3.0 (built using 6.3 and GCC version 10.2.0)
Ardour: [INFO]: Your system is configured to limit Ardour to 1048576 open files
Ardour: [INFO]: Loading system configuration file /app/etc/ardour6/system_config
No protocol specified
Ardour: [ERROR]: ** ERROR ** VSTFX: Failed opening connection to X
Ardour: [ERROR]: could not initialize Ardour.
No protocol specified
</pre>

Algúem pode me ajudar? Desde já agradeço.

Obs: sou iniciante no Linux, então sejam pacientes :p


  


2. Re: O flatpak não quer executar o Ardour

Bilufe
bilufe

(usa XUbuntu)

Enviado em 24/11/2020 - 23:18h

leleuxss escreveu:

Instalei o Ardour (editor de aúdio) via Flatpak. Trabalho com beat e preciso do programa, mas ele simplesmente não quer abrir. Quando executo <pre>flatpak run org.ardour.Ardour</pre> no terminal, aparece isso:

<pre>WARNING: Your system has a limit for maximum amount of locked memory!
This might cause Ardour to run out of memory before your system runs
out of memory. You can view the memory limit with 'ulimit -l', and it
is normally controlled by /etc/security/limits.conf

WARNING: Could not check your glib-2.0 for mutex locking atomic operations.

Ardour6.3.0 (built using 6.3 and GCC version 10.2.0)
Ardour: [INFO]: Your system is configured to limit Ardour to 1048576 open files
Ardour: [INFO]: Loading system configuration file /app/etc/ardour6/system_config
No protocol specified
Ardour: [ERROR]: ** ERROR ** VSTFX: Failed opening connection to X
Ardour: [ERROR]: could not initialize Ardour.
No protocol specified
</pre>

Algúem pode me ajudar? Desde já agradeço.

Obs: sou iniciante no Linux, então sejam pacientes :p


Está usando Wayland como servidor gráfico? O erro parece que não encontrou o servidor X11 rodando.
Nem todos os programas rodam no Wayland. Ele é o substituto do X11, mas ainda faltam muitos desenvolvedores portarem seus aplicativos para funcionarem no Wayland.

Já tentou instalar o Ardour através do APT?
Use o comando: sudo apt install ardour
No entanto, se o programa instalar e não rodar, provavelmente é a questão do Wayland, então terá que rodar o X11.