Maquina virtual java [RESOLVIDO]

1. Maquina virtual java [RESOLVIDO]

Mateus Pereira de Souza Moreira
mateuspsouza

(usa Linux Mint)

Enviado em 30/06/2020 - 14:40h

Olá, galera. Tudo bem? Então, estou com uma duvida sobre a maquina virtual do java. Estou utilizando o BrModelo no linux mint 20, está funcionando bem, pois, estou utilizando um arquivo .jar e ele roda de boa. Usando o software eu percebi uma diferença quando eu executo ele como usuário normal e root. No normal ele roda, mas tem umas pequenas falhas na interface na hora de digitar os atributos e a cor é somente branca. Mas, quando executo como root, ele roda muito bem e não tem essas falhas, a cor dele fica meio azulada. Eu uso o software da seguite maneira, coloquei o arquivo .jar na pasta /opt e criei um .desktop para o brModelo na pasta applications.
Gostaria de saber se tem algum motivo para isso acontecer?


  


2. MELHOR RESPOSTA

Mauricio Ferrari
mauricio123

(usa Slackware)

Enviado em 06/07/2020 - 21:03h


O programa é integrado a interface no seu caso. Aqui no Mate isso no me ocorre.

Talvez é essa integração que esteja dando esse problema.

___________________________________
Conhecimento não se Leva para o Túmulo.

3. Re: Maquina virtual java [RESOLVIDO]

Bilufe
bilufe

(usa KDE Neon)

Enviado em 01/07/2020 - 09:11h

mateuspsouza escreveu:

Olá, galera. Tudo bem? Então, estou com uma duvida sobre a maquina virtual do java. Estou utilizando o BrModelo no linux mint 20, está funcionando bem, pois, estou utilizando um arquivo .jar e ele roda de boa. Usando o software eu percebi uma diferença quando eu executo ele como usuário normal e root. No normal ele roda, mas tem umas pequenas falhas na interface na hora de digitar os atributos e a cor é somente branca. Mas, quando executo como root, ele roda muito bem e não tem essas falhas, a cor dele fica meio azulada. Eu uso o software da seguite maneira, coloquei o arquivo .jar na pasta /opt e criei um .desktop para o brModelo na pasta applications.
Gostaria de saber se tem algum motivo para isso acontecer?


Provavelmente o software está tentando escrever na pasta /opt e não tem acesso.
O ideal é criar uma pasta para aplicativos na sua home e colocá-lo nessa pasta.


4. Re: Maquina virtual java [RESOLVIDO]

Mateus Pereira de Souza Moreira
mateuspsouza

(usa Linux Mint)

Enviado em 02/07/2020 - 17:24h

bilufe escreveu:

mateuspsouza escreveu:

Olá, galera. Tudo bem? Então, estou com uma duvida sobre a maquina virtual do java. Estou utilizando o BrModelo no linux mint 20, está funcionando bem, pois, estou utilizando um arquivo .jar e ele roda de boa. Usando o software eu percebi uma diferença quando eu executo ele como usuário normal e root. No normal ele roda, mas tem umas pequenas falhas na interface na hora de digitar os atributos e a cor é somente branca. Mas, quando executo como root, ele roda muito bem e não tem essas falhas, a cor dele fica meio azulada. Eu uso o software da seguite maneira, coloquei o arquivo .jar na pasta /opt e criei um .desktop para o brModelo na pasta applications.
Gostaria de saber se tem algum motivo para isso acontecer?


Provavelmente o software está tentando escrever na pasta /opt e não tem acesso.
O ideal é criar uma pasta para aplicativos na sua home e colocá-lo nessa pasta.


Opa, valeu caro bilufe, obrigado por responder. Então, sobre a questão de o software estar na home, já fiz esse teste e não faz efeito. Coloquei o brModelo na home em uma pasta chamada App/ e não teve efeito ele executa do mesmo jeito, com aquelas pequenas diferenças como estão nas imagens que coloquei.


5. Re: Maquina virtual java [RESOLVIDO]

Mauricio Ferrari
mauricio123

(usa Slackware)

Enviado em 05/07/2020 - 15:01h


$ sudo chmod +s /opt/brModelo
$ sudo chmod 777 /opt/brModelo

Já tentou isso?

Tem cara de cinnamon a interface. Não sei se isso interfere. Mas com o MATE não vi esse problema. E é o que eu estou usando no Mint 20.

___________________________________
Conhecimento não se Leva para o Túmulo.


6. Re: Maquina virtual java [RESOLVIDO]

Paul Leroy
paul_leroy

(usa Ubuntu)

Enviado em 05/07/2020 - 22:38h

Tenta rodar com 'java -Dswing.defaultlaf=javax.swing.plaf.metal.MetalLookAndFeel brModelo'.


7. Re: Maquina virtual java [RESOLVIDO]

Mauricio Ferrari
mauricio123

(usa Slackware)

Enviado em 06/07/2020 - 00:38h


No meu aqui tá normal instalado no diretório /opt. sem problemas.

___________________________________
Conhecimento não se Leva para o Túmulo.


8. Re: Maquina virtual java [RESOLVIDO]

Mateus Pereira de Souza Moreira
mateuspsouza

(usa Linux Mint)

Enviado em 06/07/2020 - 01:00h

mauricio123 escreveu:


$ sudo chmod +s /opt/brModelo
$ sudo chmod 777 /opt/brModelo

Já tentou isso?

Tem cara de cinnamon a interface. Não sei se isso interfere. Mas com o MATE não vi esse problema. E é o que eu estou usando no Mint 20.

___________________________________
Conhecimento não se Leva para o Túmulo.

Sim, já tentei. E na verdade o problema não e execução, pois, ele está rodando de boa. Só queria saber porque da diferença na interface quando executado com root e usuário normal.



9. Re: Maquina virtual java [RESOLVIDO]

Mateus Pereira de Souza Moreira
mateuspsouza

(usa Linux Mint)

Enviado em 06/07/2020 - 01:10h

mauricio123 escreveu:


No meu aqui tá normal instalado no diretório /opt. sem problemas.

___________________________________
Conhecimento não se Leva para o Túmulo.


Poxa, bacana irmão. No seu ele corta um pedacinho dos atributos como nessa imagem abaixo?


10. Re: Maquina virtual java [RESOLVIDO]

Mauricio Ferrari
mauricio123

(usa Slackware)

Enviado em 06/07/2020 - 21:05h


Qual interface teu sistema está usando?

___________________________________
Conhecimento não se Leva para o Túmulo.


11. Re: Maquina virtual java [RESOLVIDO]

Paulo Jr
Pebis

(usa Debian)

Enviado em 06/07/2020 - 22:08h


Tenta mudar o tema e vê se surte algum efeito.


12. Re: Maquina virtual java [RESOLVIDO]

Mateus Pereira de Souza Moreira
mateuspsouza

(usa Linux Mint)

Enviado em 06/07/2020 - 22:13h

mauricio123 escreveu:


O programa é integrado a interface no seu caso. Aqui no Mate isso no me ocorre.

Talvez é essa integração que esteja dando esse problema.

___________________________________
Conhecimento não se Leva para o Túmulo.


Ahhh, faz sentido. Provavelmente é isso.



01 02



Patrocínio

Site hospedado pelo provedor RedeHost.
Linux banner
Linux banner
Linux banner

Destaques

Artigos

Dicas

Tópicos

Top 10 do mês

Scripts