Acesso ao PJE com Token GD (SAFESIGN) no linux mint 19.3 | CKR_DEVICE_ERROR

1. Acesso ao PJE com Token GD (SAFESIGN) no linux mint 19.3 | CKR_DEVICE_ERROR

Sam Sepiol
samsepiol

(usa Linux Mint)

Enviado em 01/02/2020 - 22:19h

Olá, primeiramente desculpem se o tópico não estiver na área correta, criei a conta somente para tirar esta dúvida e não tenho familiaridade com o fórum, bem como estou migrando do Windows para o código aberto.

Por ser advogado, ainda preciso manter um dualboot para peticionar eletronicamente, obstáculo que tentei superar com os inúmeros tópicos de ajuda, mas sem sucesso, de modo que passo a relatar meu problema específico.

- Versão do Token: GD StarSign Crypto USB
- Certificado: Valid Certificadora Digital
- O sistema Pje 1.0.19 está instalado e atualizado.
- SO Linux (amd64) versão: 5.3.0-28-generic | Linux Mint 19.3 instalado e atualizado.
- Java OPENJDK versão 11.0.6 2020-01-14 instalado e atualizado.
- Pacote Safesign.zip, que inclui o TokenAdmin e o plugin de integração com o firefox, instalado e atualizado.
- Pacotes pcscd libccid libgdbm3_1.8.3-14_amd64.deb libpng* libjpeg* libwxbase* libwxgtk* instalados e atualizados.
- O Token é reconhecido pelo aplicativo do pje, Safesign, token admin e pelo teste online da valid, http://meucertificado.vpki.com.br/certificate-checker/

- A única lib aceita quando da configuração do token no pje foi a "/usr/lib/libaetpkss.so.3.5.4112" , as outras versões(.so / .so.3 / .so.3.5) retornam o erro "Não foi possível encontrar nenhum certificado disponível para o provider selecionado!"
https://pasteboard.co/ISKfVmm.png

- O driver do pkcs#11 está devidamente importado no firefox:
https://pasteboard.co/ISKaD4P.png

- Mensagem de erro ao tentar acessar o sistema:
https://pasteboard.co/ISKcgGi.png
sun.security.pkcs11.wrapper.PKCS11Exception: CKR_DEVICE_ERROR

[Edit1]: Já refiz todo o procedimento mais de uma vez e o erro persiste.
[Edit2]: Já mudei para o java da Oracle (v13)
[Edit3]: O token é reconhecido no teste do PJE da JFPB


  


2. Re: Acesso ao PJE com Token GD (SAFESIGN) no linux mint 19.3 | CKR_DEVICE_ERROR

Andre (pinduvoz)
pinduvoz

(usa Debian)

Enviado em 01/02/2020 - 23:08h

Eu também sou advogado e tentei fazer o PJe funcionar no meu Debian Testing, mas não obtive sucesso. Já o eSAJ roda muito bem nele e sou grato por utilizá-lo em quase 100% do meu trabalho (o PJe seria para uso na Justiça Federal, apenas).

Lembro de uma coisa: o PJe precisa do Java da Oracle, não servindo o Java "aberto". Busque orientação sobre como instalar o Java da Oracle no seu Linux e veja se dá certo.



3. Re: Acesso ao PJE com Token GD (SAFESIGN) no linux mint 19.3 | CKR_DEVICE_ERROR

Andre (pinduvoz)
pinduvoz

(usa Debian)

Enviado em 01/02/2020 - 23:13h

Tem um tópico aqui no VOL sobre o mesmo erro que aparece para você:

https://www.vivaolinux.com.br/topico/PJe/PJeOffice-erro-sunsecuritypkcs11wrapperPKCS11Exception-CKR-...


4. Re: Acesso ao PJE com Token GD (SAFESIGN) no linux mint 19.3 | CKR_DEVICE_ERROR

Sam Sepiol
samsepiol

(usa Linux Mint)

Enviado em 02/02/2020 - 00:25h

pinduvoz escreveu:

Eu também sou advogado e tentei fazer o PJe funcionar no meu Debian Testing, mas não obtive sucesso. Já o eSAJ roda muito bem nele e sou grato por utilizá-lo em quase 100% do meu trabalho (o PJe seria para uso na Justiça Federal, apenas).

Lembro de uma coisa: o PJe precisa do Java da Oracle, não servindo o Java "aberto". Busque orientação sobre como instalar o Java da Oracle no seu Linux e veja se dá certo.


Tem um tópico aqui no VOL sobre o mesmo erro que aparece para você:

https://www.vivaolinux.com.br/topico/PJe/PJeOffice-erro-sunsecuritypkcs11wrapperPKCS11Exception-CKR-....


Acabai de desinstalar o OpenJDK e instalar o Java da Oracle (java version "13.0.2"), porém o erro persiste. :(


5. Re: Acesso ao PJE com Token GD (SAFESIGN) no linux mint 19.3 | CKR_DEVICE_ERROR

Andre (pinduvoz)
pinduvoz

(usa Debian)

Enviado em 02/02/2020 - 01:12h

Tenta uma versão anterior do Java. Já li que é recomendado usar as versões 6, 7 ou 8.


6. Re: Acesso ao PJE com Token GD (SAFESIGN) no linux mint 19.3 | CKR_DEVICE_ERROR

Andre (pinduvoz)
pinduvoz

(usa Debian)

Enviado em 02/02/2020 - 01:15h


https://www.cnj.jus.br/programas-e-acoes/processo-judicial-eletronico-pje/

Tinha guardado o link acima para ler qualquer dia desses... Veja se ajuda.


7. Re: Acesso ao PJE com Token GD (SAFESIGN) no linux mint 19.3 | CKR_DEVICE_ERROR

Sam Sepiol
samsepiol

(usa Linux Mint)

Enviado em 03/02/2020 - 01:42h

Testei com as versões anteriores, mas também não obtive sucesso. Ninguém mais?? :(


8. FUNCIONAMENTO PERFEITO PARA SEMPRE TOKEN OAB PJE TJSP STJ STF ETC

Estevao
carvalhonh

(usa Debian)

Enviado em 04/04/2020 - 11:46h

Tive problemas também
Primeiro apt install libengine-pkcs11-openssl libp11-3 libpcsc-perl libccid libpcsclite1 pcscd pcsc-tools libasedrive-usb opensc libssl1.0.0 openssl libengine-pkcs11-openssl
Porém enviei para pendrive os arquivos descompactados libpng12.so.0 e libwx_gtk2u_core-2.8.so.0 (libwxgtk2.8-0_2.8.12.1+dfsg2-dmo4_amd64.deb libpng12-0_1.2.50-2+deb8u3_amd64.deb)
Depois instalei libwxbase2.8-0_2.8.12.1+dfsg2-dmo4_amd64.deb libjpeg62-turbo_1.5.2-2+b1_amd64.deb libgdbm3_1.8.3-14_amd64.deb libssl1.0.0_1.0.1t-1+deb8u12_amd64.deb são os únicos que instalam e logo em seguida safesignidentityclient_3.0.77-Ubuntu_amd64.deb
pegue aqui: https://www.validcertificadora.com.br/SafeSignLinux
apt update e faltavam os descompactados acima
Então gedit /var/lib/dpkg/status e retire libwxbase2.8-0, libwxgtk2.8-0 e libgdbm3 salve
então apt -f install instalará safesignidentityclient_3.0.77-Ubuntu_amd64.deb porém não abre o utilitário de administração do token para se precisar refazer senha digitadas por três vezes, para quem não precisa está encerrado.
Porém quem entende que é necessário vamos pegar os arquivos descompactados e jogá-los em
cd /tmp/
cp libwx_gtk2u_core-2.8.so.0 /usr/lib/x86_64-linux-gnu/
cd /tmp/
cp libpng12.so.0 /usr/lib/x86_64-linux-gnu/
teste para saber se abrirá: /usr/bin/tokenadmin (veja há falta, acrescente-a ou se tudo ok abrirá)
Uso Linux somente há quinze anos


9. Re: Acesso ao PJE com Token GD (SAFESIGN) no linux mint 19.3 | CKR_DEVICE_ERROR

Bruno Sousa
N1vBruno

(usa Manjaro Linux)

Enviado em 04/04/2020 - 19:20h

pinduvoz escreveu:
Lembro de uma coisa: o PJe precisa do Java da Oracle, não servindo o Java "aberto". Busque orientação sobre como instalar o Java da Oracle no seu Linux e veja se dá certo.

Na verdade não, pinduvoz. Uso o OpenJDK 8 e funciona normalmente tanto o PJe quanto o Shodô.


10. Correção no pacote do PJE

Raphael Pereira de Souza
raphaelsouza

(usa XUbuntu)

Enviado em 27/04/2020 - 07:27h

Depois de muito tentar eu instalei tranquilamente o PJE seguindo o tutorial disponível em https://forum.biglinux.com.br/t/pje-office-no-linux/45.
O único problema que enfrento é a biblioteca PkCS#11 , pois ao acessar o sistema PJE ele responde com o mesmo erro de quem criou o tópico.

Parcial solução: Acesso o sistema do PJE com login e senha e quando vou assinar os documentos funciona perfeitamente. Ou seja, não consigo acessar os sistema PJE com certificado digital, mas assinar eu consigo.

Meu token também é o GD e funciona perfeitamente no e-SAJ, meu SO é Xubunto 18.04.

Estou procurando soluções para resolver o problema totalmente, vou abrir chamados na RF e PJE e se conseguir uma solução posto aqui.






Patrocínio

Site hospedado pelo provedor RedeHost.
Linux banner
Linux banner
Linux banner

Destaques

Artigos

Dicas

Tópicos

Top 10 do mês

Scripts