Habilitar nova versão [RESOLVIDO]

1. Habilitar nova versão [RESOLVIDO]

Manoel Renato Lipi
Lippi

(usa Outra)

Enviado em 30/07/2017 - 10:02h

Meus queridos, bom dia.

Instalei o Ubuntu 17.04, que "trouxe" o Python 2.7.13 e Django 1,11,3, u"final", 0.

Mesmo na condição de iniciante (entusiasmadíssimo), gostaria de já iniciar com versão mais recente, como a 3.6, por exemplo (ou mais, se houver).

Como instalar uma nova versão e deixá-la habilitada, em detrimento da versão anterior (ou seja, deixar a versão anterior inabilitada)?

Desde já. muito obrigado.
Lippi.




  


2. Re: Habilitar nova versão [RESOLVIDO]

Clodoaldo Santos
clodoaldops

(usa Linux Mint)

Enviado em 30/07/2017 - 10:35h

1- se optar por usar ubuntu use versões lts >> veja motivos >> leia também comentários
https://www.vivaolinux.com.br/dica/Qual-Ubuntu-devo-usar

2- se vai usar linux opte sempre por programas disponíveis nos repositórios oficiais para não correr riscos desnecessários
https://www.vivaolinux.com.br/dica/O-que-fazer-apos-instalar-Ubuntu-1604-LTS


***********
Meu Blog
https://dicaslinuxmint.blogspot.com.br/


3. Re: Habilitar nova versão [RESOLVIDO]

Ryuk Shinigami
Ryuk

(usa Nenhuma)

Enviado em 30/07/2017 - 14:12h

Segue os procedimentos, lembre-se de atualizar os links de cada tutorial:
https://tecadmin.net/install-python-3-6-ubuntu-linuxmint/
https://www.digitalocean.com/community/tutorials/how-to-install-the-django-web-framework-on-ubuntu-1...


4. Re: Habilitar nova versão [RESOLVIDO]

Alberto Federman Neto.
albfneto

(usa Sabayon)

Enviado em 30/07/2017 - 17:26h

Olha, lembro de uma coisa.....

Se Ubuntu for igual a Sabayon e Gentoo, não pode deixar só Python 3 instalado... Tem de deixar os dois, Python 3 e Python 2...

Porque tem muitos pacotes que rodam, que foram escritos em Python 2.

Em Sabayon, ativação é auto. Ele tem os dois Python e usa o que precisa.
¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨
Albfneto,
Ribeirão Preto, S.P., Brasil.
Usuário Linux, Linux Counter: #479903.
Distros Favoritas: Sabayon, Gentoo, openSUSE, Mageia e OpenMandriva.


5. Re: Habilitar nova versão [RESOLVIDO]

Lisandro Guerra
Lisandro

(usa Linux Mint)

Enviado em 30/07/2017 - 23:14h

Olá o Ubuntu vem com as versões 2 e 3 de Python instaladas, ois tem muita coisa no sistema que depende delas.
O melhor é não alterar e nem trabalhar nestas versões.
Aconselho a fazer duas coisas:
1) Instalar um gerenciador de versõesque permite ter instaladas e gerenciar várias versões de python na sua máquina:
https://www.vivaolinux.com.br/dica/Verificando-a-versao-do-Python/
https://www.vivaolinux.com.br/dica/Instalando-o-pyenv-no-Linux-Mint-e-Ubuntu
2) Trabalhar com ambientes virtuais que permitem que cada pasta de determinado projeto tenha sua própria versão de python e de módulos, podemos por exemplo ter em uma pasta um projeto com python 3.5 e Django 1.10 e em outra python 3.6 e Django 1.11:
https://www.vivaolinux.com.br/topico/Python/Virtualenv

Alguma literatura grátis:
https://www.vivaolinux.com.br/topico/Python/Recomendacao-de-Livros-gratuitos-sobre-Python

Abraço


6. OK.

Manoel Renato Lipi
Lippi

(usa Outra)

Enviado em 01/08/2017 - 15:19h

Senhores, muito obrigado pelas informações.

A soma de todas elas proporcionam melhor compreensão dos conceitos e procedimentos.

A exemplo dos demais, muito interessante os esclarecimentos quanto às versões LTS, para as quais devemos priorizar.

Entendido o critério para adoção de nova e adequada versão.

Grande abraço a todos.