''APT - GET ''DPKG'' ETC NÃO INSTALA E DA ERRO COMO RESOLVER O PROBLEMA ?

1. ''APT - GET ''DPKG'' ETC NÃO INSTALA E DA ERRO COMO RESOLVER O PROBLEMA ?

Wesley Pinguinzeiro
WesleyID

(usa Ubuntu)

Enviado em 29/12/2019 - 05:57h

gosto muito de atualizações etc sempre que vou usar meu Pc utilizo um '' Sudo apt upgrade'' porem hoje dia 29/12/19 tive o seguinte problema, não consigo instalar ABSOLUTAMENTE NADA por interface grafica ou pelo terminal, procurei sobre e dizem que eu tenho pacotes quebrados dai pensei e so remover os pacotes quebrados e instalar eles novamente certo ?. bem mais ou menos eu fui tentar remover os pacotes dpkg apt e o caramba a 4 e piorou a situação e agora deu outro erro, antes ( 1 ) e dizia o seguinte ( LSB BSD AUTOMOUNTER ), agora não consigo nem se quer remover-los sempre o mesmo maldito erro persiste o erro agora eo de codigo ( 2 ) e diz o seguinte ( dpkg: error: unable to create new file '/var/lib/dpkg/info/format-new': No such file or directory )

Help
me
guys
please
i
need
very
help



[email protected]:~$ sudo apt-get upgrade
Reading package lists... Done
Building dependency tree
Reading state information... Done
Calculating upgrade... Done
The following packages were automatically installed and are no longer required:
diffstat gettext intltool-debian libapt-pkg-perl libarchive-zip-perl
libclone-perl libemail-valid-perl libexporter-tiny-perl libio-pty-perl
libipc-run-perl liblist-moreutils-perl libllvm8:i386 libnet-dns-perl
libnet-domain-tld-perl libnet-ip-perl libnvidia-cfg1-390
libnvidia-common-390 libnvidia-decode-390 libnvidia-decode-390:i386
libnvidia-encode-390 libnvidia-encode-390:i386 libnvidia-fbc1-390
libnvidia-fbc1-390:i386 libnvidia-gl-390 libnvidia-gl-390:i386
libnvidia-ifr1-390 libnvidia-ifr1-390:i386 libperlio-gzip-perl
libtext-levenshtein-perl libwayland-client0:i386 libwayland-server0:i386
libyaml-libyaml-perl libyelp0 patchutils pkg-config screen-resolution-extra
t1utils vlc-bin vlc-l10n vlc-plugin-notify vlc-plugin-qt vlc-plugin-samba
vlc-plugin-skins2 vlc-plugin-video-splitter vlc-plugin-visualization
xserver-xorg-video-nvidia-390 yelp-xsl
Use 'sudo apt autoremove' to remove them.
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
1 not fully installed or removed.
After this operation, 0 B of additional disk space will be used.
Do you want to continue? [Y/n] y
dpkg: error: unable to create new file '/var/lib/dpkg/info/format-new': No such file or directory
E: Sub-process /usr/bin/dpkg returned an error code (2)



  


2. Re: ''APT - GET ''DPKG'' ETC NÃO INSTALA E DA ERRO COMO RESOLVER O PROBLEMA ?

Clodoaldo Santos
clodoaldops

(usa Linux Mint)

Enviado em 29/12/2019 - 07:32h

Vc está usando 1604 1804 1904 ou 1910?

Tente desbloquear o apt
sudo dpkg --configure -a
sudo apt-get -f install
sudo apt-get -f remove
sudo apt-get update
sudo apt-get upgrade



3. Re: ''Clodoaldops''

Wesley Pinguinzeiro
WesleyID

(usa Ubuntu)

Enviado em 30/12/2019 - 00:35h

Eu removi os pacotes dpkg, e meus pacotes de apt-get estão quebrados, no windows havia uma função chamada ''PONTO DE RESTAURAÇÃO'' há algo parecido no linux ?

[email protected]:~$ sudo dpkg --configure -a
[sudo] password for wes:
dpkg: error: unable to create new file '/var/lib/dpkg/info/format-new': No such file or directory



4. Re: ''APT - GET ''DPKG'' ETC NÃO INSTALA E DA ERRO COMO RESOLVER O PROBLEMA ?

augusto
marimbondo

(usa Outra)

Enviado em 30/12/2019 - 07:08h

Rode para ver se esse arq realmente existe:

$ ls -l /var/lib/dpkg/info/format-new 


Se não existir, crie um arquivo (com touch) e depois tente atualizar:

$ sudo touch /var/lib/dpkg/info/format-new  
$ sudo apt update
$ sudo apt upgrade



https://askubuntu.com/questions/1059555/dpkg-error-unable-to-create-new-file-var-lib-dpkg-info-forma...


5. Re: ''APT - GET ''DPKG'' ETC NÃO INSTALA E DA ERRO COMO RESOLVER O PROBLEMA ?

Clodoaldo Santos
clodoaldops

(usa Linux Mint)

Enviado em 30/12/2019 - 11:06h

No Ubuntu também existem pontos de restauração desde vc tenha instalado e configurado o Timeshif

Tente desbloquear
sudo rm /var/lib/apt/lists/lock
sudo rm /var/lib/dpkg/lock
sudo apt-get update
sudo apt-get upgrade