Ajuda: Discord não quer rodar no Deepin

1. Ajuda: Discord não quer rodar no Deepin

Ryuke Shima
Ryuke

(usa Ubuntu)

Enviado em 20/08/2017 - 12:00h

Olá pessoal!

Comece a usar o Deepin e estou amando a distro. Muito intuitiva, além de linda. Porém ao tentar utilizar o software de comunicação Discord, ele não abre. O programa diz que encontrou uma versão mais recente e recomenda baixar. Fiz isso, baixei o pacote .Deb, mas ao tentar instalar o pacote fornece uma mensagem dizendo que uma versão mais atual já está instalada.

Tentei desinstalar tudo e instalar a versão mais recente pelo Synaptic. Porém nesse caso, ao abrir o programa ele fica numa busca eterna por updates, e baixando algumas atualizações, e o programa nunca se inicia.
Segue print 
http://imgur.com/a/qfgYU


Agradeço a atenção de todos vocês, que são o motivo da comunidade Linux crescer a cada dia,
Aguardo resposta




  


2. Re: Ajuda: Discord não quer rodar no Deepin

Douglas Damiani
damiani

(usa Linux Mint)

Enviado em 20/08/2017 - 15:56h

Desinstale tudo:

sudo apt-get remove discord
sudo apt-get autoremove
sudo apt-get purge discord

Depois de tudo desinstalado coloque isto no terminal para reinstalar do zero:

sudo apt-get update
wget "https://discordapp.com/api/download?platform=linux&format=deb" -O discord.deb
sudo dpkg -i discord.deb
sudo apt-get install -f

E veja se funciona.


3. Re: Ajuda: Discord não quer rodar no Deepin

Ryuke Shima
Ryuke

(usa Ubuntu)

Enviado em 21/08/2017 - 10:51h

Fiz o recomendado
Aconteceu o seguinte
[email protected]:~$ sudo apt-get install -f --fix-missing
Lendo listas de pacotes... Pronto
Construindo árvore de dependências
Lendo informação de estado... Pronto
Corrigindo dependências... Pronto
The following additional packages will be installed:
discord
Os pacotes a seguir serão atualizados:
discord
1 pacotes atualizados, 0 pacotes novos instalados, 0 a serem removidos e 0 não atualizados.
1 pacotes não totalmente instalados ou removidos.
É preciso baixar 36,8 MB de arquivos.
Depois desta operação, 16,1 MB de espaço em disco serão liberados.
Você quer continuar? [S/n] s
Obter:1 http://packages.deepin.com/deepin panda/non-free amd64 discord amd64 0.1.6 [36,8 MB]
Err:1 http://packages.deepin.com/deepin panda/non-free amd64 discord amd64 0.1.6
Hash Sum incorreto
Hashes of expected file:
- SHA256:f02394d936928a750b86fee5cb0e73ea6cacc14cf3f106756371b573cfe35903
- SHA1:e8c08d69c24392d53e89d57534dc6ee7b6a029f5 [weak]
- MD5Sum:268ac33ea245038291067094720d8a1a [weak]
- Filesize:36843336 [weak]
Hashes of received file:
- SHA256:89230dba3b545580ce543c19df9521b78c399641f20e2f74933185924ecbe6cc
- SHA1:a2b49839d3eb9c4b20fae79e3b168380ab17258d [weak]
- MD5Sum:a432ce4c9240e35c843252edfdeb62ef [weak]
- Filesize:14982219 [weak]
Last modification reported: Tue, 16 May 2017 09:04:33 +0000
Baixados 12,6 MB em 4min 50s (43,5 kB/s)
Impossível corrigir pacotes faltantes.
E: Falhou ao buscar http://packages.deepin.com/deepin/pool/non-free/d/discord/discord_0.1.6_amd64.deb Hash Sum incorreto
Hashes of expected file:
- SHA256:f02394d936928a750b86fee5cb0e73ea6cacc14cf3f106756371b573cfe35903
- SHA1:e8c08d69c24392d53e89d57534dc6ee7b6a029f5 [weak]
- MD5Sum:268ac33ea245038291067094720d8a1a [weak]
- Filesize:36843336 [weak]
Hashes of received file:
- SHA256:89230dba3b545580ce543c19df9521b78c399641f20e2f74933185924ecbe6cc
- SHA1:a2b49839d3eb9c4b20fae79e3b168380ab17258d [weak]
- MD5Sum:a432ce4c9240e35c843252edfdeb62ef [weak]
- Filesize:14982219 [weak]
Last modification reported: Tue, 16 May 2017 09:04:33 +0000
E: Abortando instalação.
[email protected]:~$



4. Re: Ajuda: Discord não quer rodar no Deepin

Clodoaldo Santos
clodoaldops

(usa Linux Mint)

Enviado em 21/08/2017 - 11:09h

-eu usaria o discord disponível no deepin software center

---------------
clodoaldops
https://dicaslinuxmint.blogspot.com.br/


5. Re: Ajuda: Discord não quer rodar no Deepin

Ryuke Shima
Ryuke

(usa Ubuntu)

Enviado em 21/08/2017 - 11:45h

O Discord disponível no Deepin Software Center não abre. Fica sempre indicando uma mensagem que necessita ser atualizado. Utilizo muito o discord para praticar idiomas estrangeiros com nativos, por isso minha necessidade. Se tudo der errado, pensei em baixar o Genymotion e usar o discord pelo app.


6. Re: Ajuda: Discord não quer rodar no Deepin

Ryuke Shima
Ryuke

(usa Ubuntu)

Enviado em 21/08/2017 - 13:06h

Consegui instalar o programa, na versão 0.0.2, de acordo com os comando passados por você @damiani.
Porém, ao abrir o programa apresenta apenas uma tela preta.
Segue print
http://imgur.com/a/VJB6Y

Alguém saberia o motivo? E uma possível solução?

Muito obrigado!






Patrocínio

Site hospedado pelo provedor RedeHost.
Linux banner
Linux banner

Destaques

Artigos

Dicas

Tópicos

Top 10 do mês

Scripts