openvpn nao carrega

1. openvpn nao carrega

edson nascimento ferreira
edsonferreira

(usa Nenhuma)

Enviado em 12/02/2008 - 17:46h

Segui os passo do tutorial encontrado aqui no viva o linux sobre como instalar e configurar o openvpn( http://www.vivaolinux.com.br/artigos/impressora.php?codigo=4980 ). Fiz tudo do jeito que está no tutorial e não dá certo. Por último, rodei o comando
"/usr/sbin/openvpn --config /etc/openvpn/pilao51.conf --daemon"
e náo dá erro algum. Mas a vpn também não ativa, nem registra no /var/log/message nem levanta a interface tun, ouse ja, não acontece nada.

Estou perdido e preciso de ajuda.



  


2. Re: openvpn nao carrega

Leonardo Macedo Cerqueira
cromado

(usa Debian)

Enviado em 13/02/2008 - 15:46h

Cara segui este tutorial e funcionou:

VPN em Linux com OpenVPN
http://www.vivaolinux.com.br/artigos/verArtigo.php?codigo=2602



Meu arquivo da Matriz ficou assim , e a interface "tun" subiu numa boa , tenta aí.

dev tun
ifconfig 192.168.0.87 192.168.0.76
cd /etc/openvpn
secret chave

simples mesmo.


3. distro

Fernandino Mesquita e Silva
FireBird

(usa Debian)

Enviado em 13/02/2008 - 15:52h

qual distribuição vc usa? e qual kernel?

vc tem de ter o kernel com o modulo tun/tap disponivel senao tera de recompila-lo...

ja vi isso acontecer... ele nao da erro, mas nao sobe o tun... mas pode ver no ps aux que ele ta la rodando...


4. Re: openvpn nao carrega

edson nascimento ferreira
edsonferreira

(usa Nenhuma)

Enviado em 14/02/2008 - 08:36h

meu uname -a retorna o seguinte:
Linux TesteDPC 2.6.18-5-486 #1 Mon Dec 24 16:04:42 UTC 2007 i686 GNU/Linux

to usando do debian etch r2, ele ja tem o tun, eu acho.