internet no debian lenny [RESOLVIDO]

1. internet no debian lenny [RESOLVIDO]

Rodolfo Marcondes Dias
Rodolfo_RR

(usa Ubuntu)

Enviado em 25/02/2010 - 18:48h

Fala pessoal blz

Entao o meu problema é o seguinte, instalei o debian lenny no note aqui em casa e ficou tudo legal mas a internet que eh a net virtua nao pega, sendo que ja configurei o arquivo /etc/network/interfaces e o /etc/resolv.conf, mas ainda sim naum pega, sendo que no vista ela pega normal pois estou agora usando ele =( .... kkkk

alguem pode me ajudar

obrigado


  


2. MELHOR RESPOSTA

Cleber Rocha
cl2b2r

(usa Debian)

Enviado em 26/02/2010 - 13:34h

Amigo, se você está usando o Net Virtua com conexão direta do modem para o seu micro/notebook vc não precisa configurar nada além da placa de rede para receber o IP por DHCP! Isto acontece porque o cable modem do virtua é roteado e distribui de forma automática o IP que lhe é enviado para a máquina que a ele esteja conectada por um esquema de Bridge (seja esta máquina um roteador, um micro, um server ou um notebook). Além disso eu vi erro no seu "intefaces". Veja abaixo como configurar o DHCP:

#ifconfig

Levando em consideração que a interface onde está conectado o cabo de rede vindo do modem seja a eth0, faça o seguinte:

#vi /etc/network/intefaces

auto lo
iface lo inet loopback

auto eth0
iface eth0 inet dhcp

Com isso dê os seguintes comandos

#/etc/init.d/networking restart

#dhclient

Pronto! isto deve funcionar! Mesmo que você tenha um roteador antes do micro, basta que você configure o roteador como servidor DHCP que você pode usar o procedimento descrito acima sem nenhum problema!

Espero ter ajudado. ;)

PS: Se a placa não "pegar" o IP experimente reiniciar o micro.



3. Re: internet no debian lenny [RESOLVIDO]

Rodolfo Marcondes Dias
Rodolfo_RR

(usa Ubuntu)

Enviado em 25/02/2010 - 18:49h

soh colocando as configuraçoes

interfaces

auto lo eth0
iface lo inet loopback



iface eth0 inet static
address 192.168.1.2
netmask 255.255.255.0
network 192.168.1.0
broadcast 192.168.1.255
gateway 192.168.1.1
__________________________________________________
Resolv.conf

nameserver 208.67.222.222
nameserver 208.67.220.220



4. Re: internet no debian lenny [RESOLVIDO]

Fernando Eckhardt Valle
pherde

(usa Slackware)

Enviado em 25/02/2010 - 18:55h

Depois de configurado não esqueça de aplicar as configurações na placa:
#ifup eth1




5. Re: internet no debian lenny [RESOLVIDO]

Rodolfo Marcondes Dias
Rodolfo_RR

(usa Ubuntu)

Enviado em 25/02/2010 - 19:12h

obrigado pela resposta amigo, pois jah usei essa opçao e naum funciona

sera que mais alguem sabe


6. Verificação de placas

Adriano
Ferrerinha

(usa Debian)

Enviado em 25/02/2010 - 19:27h

Executa o comando

# cat /proc/net/dev

Ele vai listar todas suas interfaces de redes disponiveis. Ai posta aqui para que possa tentar te ajudar.
Tenta também separar no arquivo interfaces a linha:

# auto lo eth0

colocando outro dessa maneira

auto lo
iface lo inet loopback


auto eth0 #eth1,eth*
iface eth0 inet static
address 192.168.1.2
netmask 255.255.255.0
network 192.168.1.0
broadcast 192.168.1.255
gateway 192.168.1.1

A o comando para da um start na interface no Debian pode ser também

#ifconfig eth0 up



7. Re: internet no debian lenny [RESOLVIDO]

Rodolfo Marcondes Dias
Rodolfo_RR

(usa Ubuntu)

Enviado em 25/02/2010 - 21:01h

e entaum eu tentei fazer da maneira que vc falou mais naum deu certo, e ainda eu vi que no icone de internet que fica na barra aparece que naum tem dispositivo conectado, sendo que com o comando lspci identifca a placa

o que posso fazer

vlw


8. Re: internet no debian lenny [RESOLVIDO]

Adriano
ferrerinha

(usa Debian)

Enviado em 25/02/2010 - 22:41h

Posta ai o resultado do comando:

# cat /proc/net/dev

Uma pergunta, você desativo e ativo a placa de rede?

Tenta o comando para resetar todas as placas de rede

# /etc/init.d/networking restart




9. Re: internet no debian lenny [RESOLVIDO]

Rodolfo Marcondes Dias
Rodolfo_RR

(usa Ubuntu)

Enviado em 26/02/2010 - 15:19h

vlw pessoal consegui arrumar o meu problema

fiz da seguinte maneira

no arquivo /etc/network/interfaces e deixei essas linhas

auto lo
iface lo inet loopback

e pronto, deu boot no pc e pronto a net jah estava pegando normal ....

agradeço a todos que me ajudaram

vlw


10. Padrão

Cleber Rocha
cl2b2r

(usa Debian)

Enviado em 26/02/2010 - 23:05h

Olá Rodolfo

Você conseguiu resolver porque o Debian configurou sua placa de rede automaticamente para receber a conexão por DHCP, conforme eu havia lhe falado. Deixar em branco ou escrever o arquivo da forma que mostrei dá no mesmo pois o networking entende que se não houver nada escrito ele deve adotar a recepção de IP como padrão, e, não tentar configurar um IP qualquer só para manter a placa habilitada, como acontece no sistema de Redmond. Ou seja, neste caso, quando ele recebe IP o dispositivo funciona, quando não ele mantém o mesmo desabilitado pois entende que ele não está sendo usado naquele momento. Isto também explica o porquê de sua conf. só ter funcionado após você reiniciar o micro: É justo neste momento que o Debian checa o funcionamento de todos os dispositivos e os configura para entrar em operação.

Um grande abraço e espero que esta breve explicação possa ter esclarecido algo a você e a outros que venham a ver sua dúvida como fonte de solução.

OBS: Não esqueça de marcar a melhor resposta, é importante ok ;)


11. Re: internet no debian lenny [RESOLVIDO]

Rodolfo Marcondes Dias
Rodolfo_RR

(usa Ubuntu)

Enviado em 27/02/2010 - 11:08h

certinho cara, levando em consideraçoes sua atençao vou marcar a sua como melhor resposta, mas nunca desmerecendo os outros do VOL, que me ajudaram

flow






Patrocínio

Site hospedado pelo provedor RedeHost.
Linux banner
Linux banner
Linux banner

Destaques

Artigos

Dicas

Tópicos

Top 10 do mês

Scripts