Windows 7 + Samba [RESOLVIDO]

1. Windows 7 + Samba [RESOLVIDO]

igor muzetti
parrera

(usa Debian)

Enviado em 11/08/2011 - 11:41h

Pessoal, como havia pedido em outro tópico, consegui atualizar meu samba para a versão 3.5.8. Porém ainda não consegui ingressar no meu dominio com as maquinas com windows 7, meu samba esta funcionando para o windows xp.

Já segui estas dicas:

http://wiki.samba.org/index.php/Windows7

http://blog.lcmm.info/?p=35

Desabilitei o firewall e nada. Já usei os registros da seguinte maneira também e nada:

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\services\LanmanWorkstation\Parameters]
"DomainCompatibilityMode"=dword:00000001
"DNSNameResolutionRequired"=dword:00000000

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Lsa]
"LmCompatibilityLevel"=dword:00000000

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\services\Netlogon\Parameters]
"RequireSignOrSeal"=dword:00000000
"RequireStrongKey"=dword:00000000

Alguém que já conseguir fazer isto fez algo a mais? Ou podia me alertar para mais alguma coisa?
A compilação do windows 7 é a 7600.

Att,



  


2. Boa tarde!

Rodrigo Namba Dake
shundake

(usa Arch Linux)

Enviado em 11/08/2011 - 13:00h

Olha.. Tive uns problemas com Windows 7 também.... Mas fiz isso e resolveu.. Tenta aí...

Alterações no Linux

1- fazer upgrade do servidor Linux para uma versão que de suporte ao NTLMv2 authentication como o Samba 3.3 ou superior
Alteraçoes no smb.conf:
#####
Level2 oplocks = no
ntlm auth = Yes
lanman auth = Yes
client ntlmv2 auth = Yes
use client driver = Yes
client lanman auth = Yes


Alterações no Windows:

Políticas de Segurançat:

2- alterar as politicas de segurança do Windows 7 rodando o secpol.msc =
Security Settings \ Local Policies \ Security Options \ Network Security: LAN Manager authentication level e altere de "Send NTLMV2 response only" para "Send LM & NTLM - use NTLMV2 session security if negotiated"
em Portugues:
Configuraçoes de Segurança \ Diretivas Locais \ Opçoes de Segurança\
Segurança de rede: Nivel de autenticação LAN Manager e altere para:
“Enviar LM e NTLM – usar segurança da sessão NTLMV2 se negociada”

No Regedit:

Como criar as chaves e valores que não existem:

Provavelmente o que não será definido são os valores DWORD, que são os "ítens" dentro do diretório. Para criá-las basta entrar no diretório onde deverá ficar o valor, clicar com o botão direito em uma área vazia depois novo/valor DWORD coloque o nome da chave conforme informado respeitando maiúsculas e minúsculas, feito isso, clique duas vezes na chave para definir seu valor. Marque a opção Decimal e coloque o valor informado.

Se for necessário criar uma "pastinha" do caminho, clique com o botão direito no diretório pai, clique em Novo e em chave. Dê o nome respeitando maiúsculas e minúsculas e depois crie o valor DWORD conforme solicitado.

Concluído todo o procedimento de alteração do registro o Windows deverá ser REINICIADO.

Dentro da nova janela digite regedit e pressione a tecla enter. Agora que o registro já está aberto você deverá criar as seguintes chaves:

HKLM\System\CurrentControlSet\Services\LanmanWorkstation\Parameters
DWORD DomainCompatibilityMode = 1
DWORD DNSNameResolutionRequired = 0

HKLM\System\CurrentControlSet\Control\Lsa
DWORD LmCompatibilityLevel = 0

Agora o próximo passo será alterar algumas chaves de registro que já existem, são elas:

HKLM\System\ CurrentControlSet\Services\Netlogon\Parameters
DWORD RequireSignOnSeal = 1
DWORD RequireStrongKey = 1

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\Lsa
* Alterar o valor LMCompatibilityLevel de 3 para 0
* 0 corresponde a NTLM e LM

Fechar o editor de registro e reiniciar.

Fazer normalmente o procedimento de adicionar a máquina no dominio.


Qualquer coisa, posta aí!
[]'s

PS: Se der certo eu mando para Dicas!


3. Ainda não...

igor muzetti
parrera

(usa Debian)

Enviado em 11/08/2011 - 14:03h

Opa valeu pela ajuda, mas ainda não deu certo.

Seguinte fiz todas as mudanças como vc escreveu e em:

HKLM\System\ CurrentControlSet\Services\Netlogon\Parameters

Criei a DWORD RequireSignOnSeal = 1, pois existia a DWORD RequireSignOrSeal = 1, é isso mesmo neh? Tem que criar essa 'On'.

Mas mesmo depois de tudo feito, reiniciei a maquina e qnd tento entrar no dominio aparece esta mensagem:

Erro durante a tentativa de ingresso no dominio "nomedodominio"
O servidor especificado não pode executar a operação solicitada.

Alguma dica?


4. versão do windows

igor muzetti
parrera

(usa Debian)

Enviado em 16/08/2011 - 10:20h

Pessoal, estou usando a versão Ultimate do Windows 7.
Em qual versão vcs fizeram estes ajustes no registro? Professional?




5. duvida

igor muzetti
parrera

(usa Debian)

Enviado em 16/08/2011 - 14:07h

Eai dualshoott, valeu. Mas o samba 4 ainda não existe uma versão estavel neh? O que as varias dicas que acompanhei(citadas em uns posts acima) fazem é conseguir adicionar maquinas com windows 7 em algum dominio gerenciado pelo samba (versao >3.2).

Com a dica que vc me deu, não preciso mexer com configuração de serv. wins, registros do windows, isso?

att,


6. mistério

igor muzetti
parrera

(usa Debian)

Enviado em 17/08/2011 - 15:59h

Eai Shundake e galera, formatei a maquina e instalei o windows 7 professional e fiz as configurações como vc propos na dica e adicionando servidor wins, desabilitei firewall, reinicio e depois quando vou tentar ingressar no domínio, a mesma mensagem de erro é exibida. Não sei o que estou deixando de fazer ou então não há como mesmo ingressar em um domínio samba 3.5.8 com windows 7.


7. Correção do regedit

Josir Cardoso Gomes
josir

(usa Ubuntu)

Enviado em 17/08/2011 - 18:33h

O RequireSignOrSeal, RequireStrongKey e LmCompatibilityLevel não é necessário alterar.
Aliás, se alterar não funciona!

Segue o meu "script" para incluir a máquina no Domínio.

1) Executar o registro:

[HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\LanManWorkstation\Parameters]
"DomainCompatibilityMode"=dword:00000001
"DNSNameResolutionRequired"=dword:00000000

[HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Windows\System]
"SlowLinkDetectEnabled"=dword:00000000
"DeleteRoamingCache"=dword:00000001
"WaitForNetwork"=dword:00000000
"CompatibleRUPSecurity"=dword:00000001

2) Executar patch de correção para o Domínio: 416053_intl_i386_zip.exe

3) Entrar no "Painel de Controle" em modo de exibição clássico (Icones pequenos), editar as propriedades do ícone "Sistema". Na seção "Nome do Computador", clicar em "Alterar configurações" e no botão "ID da Rede".

4) Selecionar a opção "Este computador faz parte de uma rede corporativa..." e clicar em "Avançar"

5) Selecionar a opção "Minha empresa usa uma rede com um domínio", clicar em "Avançar" e clicar em "Avançar"

6) Na tela Informações sobre Conta de Usuário e Domínio, digitar no "nome do usuário" um usuário que já exista no Samba, sua senha e o domínio XXXX e clicar em "Avançar"

7) Novamente, digite o usuario já cadastrado, senha e Domínio XXXX

Dá uma lida também em:
http://wiki.samba.org/index.php/Windows7


8. duvida

igor muzetti
parrera

(usa Debian)

Enviado em 18/08/2011 - 10:56h

Ola Josir, restaurei meu registro com um software da GlarySoft e fiz o passo 1 da sua dica. Mas para fazer o passo 2, aonde consigo este patch? Encontrei um na net porém ele necessita de um password para poder descompactar e assim executar os arquivos. Sabe aonde encontro este patch sem pedir o password ou o password para ele?

Att,



9. feito!

igor muzetti
parrera

(usa Debian)

Enviado em 06/09/2011 - 17:00h

Galera consegui entrar no domínio com máquinas windows 7 também.

Os tutorias que mais me ajudaram foram:

http://wiki.samba.org/index.php/Windows7

http://support.microsoft.com/kb/979761/pt-br

valeu!



10. Re: Windows 7 + Samba [RESOLVIDO]

Kleber Cardoso
kleber-rr

(usa Debian)

Enviado em 02/11/2011 - 11:07h

parrera escreveu:

Galera consegui entrar no domínio com máquinas windows 7 também.

Os tutorias que mais me ajudaram foram:

http://wiki.samba.org/index.php/Windows7

http://support.microsoft.com/kb/979761/pt-br

valeu!


parrera, estou nesta luta também... já fiz de tudo, e ainda me aparece aquele erro de relação de confiança... meu windows 7 é x64 e a distro do lenny que uso é x32... será que isso pode estar atrapalhando?

Vlw.



11. smb.conf

igor muzetti
parrera

(usa Debian)

Enviado em 02/11/2011 - 14:45h

opa..cara eu realmente segui estes 2 tutorias que postei, eles são a base maior. porém inseri algumas 4 linhas no meu smb.conf para aceitar windows7(isto vc acha faci no google) de uma olhada tbm. Acredito que o seu debian ser de x32 não atrapalhe. Mas um pergunta, seu servidor não tem mais de 1 core, pq esta usando x32 e não x64?valeu!


12. Re: Windows 7 + Samba [RESOLVIDO]

Kleber Cardoso
kleber-rr

(usa Debian)

Enviado em 02/11/2011 - 19:32h

parrera escreveu:

opa..cara eu realmente segui estes 2 tutorias que postei, eles são a base maior. porém inseri algumas 4 linhas no meu smb.conf para aceitar windows7(isto vc acha faci no google) de uma olhada tbm. Acredito que o seu debian ser de x32 não atrapalhe. Mas um pergunta, seu servidor não tem mais de 1 core, pq esta usando x32 e não x64?valeu!


Olá parrera, blz?

Cara, consegui fazer funcionar. Mas achei o primeiro acesso do usuário criado no samba excessivamente lento...

os logons seguintes ficaram mais rápidos, porém, ainda lentos... Estou pensando em baixar a versão x64 mesmo pra ver no que dá.

Existe algum outro ajuste a ser veito para que ele fique mais rápido no logon?

Valeu pela ajuda.



01 02



Patrocínio

Site hospedado pelo provedor RedeHost.
Linux banner
Linux banner

Artigos

Dicas

Tópicos

Top 10 do mês

Scripts