Teste de Memoria [RESOLVIDO]

1. Teste de Memoria [RESOLVIDO]

Mario Lis
mlisram

(usa Debian)

Enviado em 22/07/2021 - 14:45h

Estou tentando fazer um teste de memoria no Debian 10. Tem como fazer pelo menu de Boot, na inicialização do sistema? Lembro ter feito uma vez pelo Ubuntu mas não encontrei essa opção no Debian.
Tentei fazer pelo Terminal com memtester sem sucesso. segue o print do Terminal.
Obrigado quem puder ajudar.


  


2. MELHOR RESPOSTA

Mauriciodez
Mauriciodez

(usa Debian)

Enviado em 22/07/2021 - 15:02h


mlisram escreveu:

Estou tentando fazer um teste de memoria no Debian 10. Tem como fazer pelo menu de Boot, na inicialização do sistema? Lembro ter feito uma vez pelo Ubuntu mas não encontrei essa opção no Debian.
Tentei fazer pelo Terminal com memtester sem sucesso. segue o print do Terminal.
Obrigado quem puder ajudar.


da uma olhada no manual da sua mobo que tem como testar pelo Setup tb.

v aí se te ajuda >>> https://www.memtest86.com/tech_configuring-grub.html

------------------------------------------------------| Linux User #621728 |------------------------------------------------------

" Nem sempre é amigo aquele que te tira do buraco !!! ( Saddam Hussein )"

------------------------------------------------------| Linux User #621728 |------------------------------------------------------



3. Teste de Memoria

Mario Lis
mlisram

(usa Debian)

Enviado em 22/07/2021 - 15:19h


Mauriciodez escreveu:


mlisram escreveu:

Estou tentando fazer um teste de memoria no Debian 10. Tem como fazer pelo menu de Boot, na inicialização do sistema? Lembro ter feito uma vez pelo Ubuntu mas não encontrei essa opção no Debian.
Tentei fazer pelo Terminal com memtester sem sucesso. segue o print do Terminal.
Obrigado quem puder ajudar.


da uma olhada no manual da sua mobo que tem como testar pelo Setup tb.

v aí se te ajuda >>> https://www.memtest86.com/tech_configuring-grub.html

------------------------------------------------------| Linux User #621728 |------------------------------------------------------

" Nem sempre é amigo aquele que te tira do buraco !!! ( Saddam Hussein )"

------------------------------------------------------| Linux User #621728 |------------------------------------------------------

Obrigado Mauriciodez! Vou tentar. Mais tarde dou retorno!




4. Re: Teste de Memoria [RESOLVIDO]

Mario Lis
mlisram

(usa Debian)

Enviado em 22/07/2021 - 23:00h


mlisram escreveu:


Mauriciodez escreveu:


mlisram escreveu:

Estou tentando fazer um teste de memoria no Debian 10. Tem como fazer pelo menu de Boot, na inicialização do sistema? Lembro ter feito uma vez pelo Ubuntu mas não encontrei essa opção no Debian.
Tentei fazer pelo Terminal com memtester sem sucesso. segue o print do Terminal.
Obrigado quem puder ajudar.


da uma olhada no manual da sua mobo que tem como testar pelo Setup tb.

v aí se te ajuda >>> https://www.memtest86.com/tech_configuring-grub.html

------------------------------------------------------| Linux User #621728 |------------------------------------------------------

" Nem sempre é amigo aquele que te tira do buraco !!! ( Saddam Hussein )"

------------------------------------------------------| Linux User #621728 |------------------------------------------------------

Obrigado Mauriciodez! Vou tentar. Mais tarde dou retorno!

Não achei nada sobre no Manual, é uma ASUS M5A78L LE, com FX6300 e sempre funcionou bem com duas memorias CORSAIR CMZ4GX3M1 A 1600 (1 PRETA E 1 AZUL). Meu filho me entregou uma Corsair CMZ12GX3M3A1600C9 12GB (3x4GB) (1 das 3) porque tinha parado de funcionar no PC dele, como era a mesma configuração que a minha a instalei substituindo e esta, aparentemente funcionando bem, como instalei o DEBIAN 10 justo antes da troca de memoria, fiquei sem saber se os desligamentos do DEBIAN 10 (vi que tem alguns relatos sobre) ou se é da memoria que esta definitivamente pífia. Aguardo por se alguém ainda tiver uma dica, depois vou encerrar o tópico. Obrigado!




5. Re: Teste de Memoria [RESOLVIDO]

Mauriciodez
Mauriciodez

(usa Debian)

Enviado em 22/07/2021 - 23:38h

esse lance de testar a memória no post é o seguinte ... na configuração do BIOS na aba "BOOT" tem uma opção de 'quick boot' .. essa opção habilitada desativa alguns testes de hardware ( entre eles o de RAM ) antes de entregar ao sistema operacional, então se quer teste de RAM no post desabilite o 'quick boot'.

OBS: em alguns BIOS tem até o memtest

algumas coisas vc pode verificar aí no SETUP que pode estar relacionado ao problema ... da uma olhada nas tensões da fonte, tb é uma de vc abaixar o clock das memórias ( as vezes acontece de a RAM estar com defeito e quando abaixa o clock dela ele funciona beleza ).

Tb é uma de passar uma borracha branca nos contatos da memória para tirar a oxidação.

Como a RAM é 1600 ( o máximo suportado da mobo ) , é uma de ver se o CPU não está com OC, pois se tiver o OC no CPU aumenta tb automaticamente o clock da RAM,.

enfim, são algumas variantes que pode dar problemas !!!


------------------------------------------------------| Linux User #621728 |------------------------------------------------------

" Nem sempre é amigo aquele que te tira do buraco !!! ( Saddam Hussein )"

------------------------------------------------------| Linux User #621728 |------------------------------------------------------




6. Re: Teste de Memoria

Marcelo Oliver
msoliver

(usa Debian)

Enviado em 23/07/2021 - 03:32h

mlisram escreveu:

Estou tentando fazer um teste de memoria no Debian 10. Tem como fazer pelo menu de Boot, na inicialização do sistema? Lembro ter feito uma vez pelo Ubuntu mas não encontrei essa opção no Debian.
Tentei fazer pelo Terminal com memtester sem sucesso. segue o print do Terminal.
Obrigado quem puder ajudar.

Boa noite.
Baixe o Slitaz, tem o "memtest" na opção de boot.
A iso tem por volta de 60M
https://www.slitaz.org/pt/
http://mirror.slitaz.org/iso/rolling/slitaz-rolling-core64.iso

______________________________________________________________________
Importante: lynx --dump goo.gl/a9KeFc|sed -nr '/^[ ]+Se/,/dou.$/p'
Att.: Marcelo Oliver
______________________________________________________________________



7. Re: Teste de Memoria

Buckminster
Buckminster

(usa Debian)

Enviado em 23/07/2021 - 03:38h

Desinstala o memtester e instala de novo.
apt-get --purge remove memtester
apt-get update
apt-get install memtester

Veja o total de memória em Mem na saída do comando
free -m
na coluna free da linha Mem veja o número ali.

Execute
memtester xxxx y

Substitua xxxx pelo número que apareceu em Mem/free na saída do free.
Substitua y com o número de vezes que deseja executar o teste. Aconselho começar com 1 vez.
Por exemplo, aqui tem 8GB (8192MB), coloquei
memtester 7647 1

Coloque somente o total de memória livre. Caso tu colocar o total de RAM, por exemplo, 8192 (8G), pode acontecer de travar, pois o memtester tentará testar também a memória ocupada pelo sistema.

E deixe rodar sem mexer sequer no mouse, de preferência nem respire muito forte perto do computador.
Aqui demorou uns 3 minutos.
Caso der uma mensagem no final: trying mlock ... Morto
Diminua um pouco o total, por exemplo, de 7647 coloque 7600 e tente de novo até dar a saída
Loop 1/1:
Stuck Address : Ok
Random Value : Ok
etc, são várias opções que aparecerão.

Para maior precisão, reinicie o computador e teste de novo com 2 vezes, mas não coloque mais do que 2 vezes porque se tua memória estiver meio baleada muitos loops podem terminar de f**** a memória.

Aqui tem umas dicas boas também:
https://mateusmuller.me/2017/09/28/como-rodar-um-teste-de-memoria-com-memtester-no-linux/

E outra coisa, tu tem um repositório ppa do Ubuntu na sources do Debian?


8. Re: Teste de Memoria [RESOLVIDO]

Mario Lis
mlisram

(usa Debian)

Enviado em 23/07/2021 - 17:39h


Mauriciodez escreveu:

esse lance de testar a memória no post é o seguinte ... na configuração do BIOS na aba "BOOT" tem uma opção de 'quick boot' .. essa opção habilitada desativa alguns testes de hardware ( entre eles o de RAM ) antes de entregar ao sistema operacional, então se quer teste de RAM no post desabilite o 'quick boot'.

OBS: em alguns BIOS tem até o memtest

algumas coisas vc pode verificar aí no SETUP que pode estar relacionado ao problema ... da uma olhada nas tensões da fonte, tb é uma de vc abaixar o clock das memórias ( as vezes acontece de a RAM estar com defeito e quando abaixa o clock dela ele funciona beleza ).

Tb é uma de passar uma borracha branca nos contatos da memória para tirar a oxidação.

Como a RAM é 1600 ( o máximo suportado da mobo ) , é uma de ver se o CPU não está com OC, pois se tiver o OC no CPU aumenta tb automaticamente o clock da RAM,.

enfim, são algumas variantes que pode dar problemas !!!


------------------------------------------------------| Linux User #621728 |------------------------------------------------------

" Nem sempre é amigo aquele que te tira do buraco !!! ( Saddam Hussein )"

------------------------------------------------------| Linux User #621728 |------------------------------------------------------

Mauriciodez, fiz tudo, de fato o quick Boot estava ativado, desativei e ainda assim continua sem fazer o teste. Este print do Terminal foi depois de desativar o quick boot.




9. Re: Teste de Memoria [RESOLVIDO]

Mario Lis
mlisram

(usa Debian)

Enviado em 23/07/2021 - 18:06h


Buckminster escreveu:

Desinstala o memtester e instala de novo.
apt-get --purge remove memtester
apt-get update
apt-get install memtester

Veja o total de memória em Mem na saída do comando
free -m
na coluna free da linha Mem veja o número ali.

Execute
memtester xxxx y

Substitua xxxx pelo número que apareceu em Mem/free na saída do free.
Substitua y com o número de vezes que deseja executar o teste. Aconselho começar com 1 vez.
Por exemplo, aqui tem 8GB (8192MB), coloquei
memtester 7647 1

Coloque somente o total de memória livre. Caso tu colocar o total de RAM, por exemplo, 8192 (8G), pode acontecer de travar, pois o memtester tentará testar também a memória ocupada pelo sistema.

E deixe rodar sem mexer sequer no mouse, de preferência nem respire muito forte perto do computador.
Aqui demorou uns 3 minutos.
Caso der uma mensagem no final: trying mlock ... Morto
Diminua um pouco o total, por exemplo, de 7647 coloque 7600 e tente de novo até dar a saída
Loop 1/1:
Stuck Address : Ok
Random Value : Ok
etc, são várias opções que aparecerão.

Para maior precisão, reinicie o computador e teste de novo com 2 vezes, mas não coloque mais do que 2 vezes porque se tua memória estiver meio baleada muitos loops podem terminar de f**** a memória.

Aqui tem umas dicas boas também:
https://mateusmuller.me/2017/09/28/como-rodar-um-teste-de-memoria-com-memtester-no-linux/

E outra coisa, tu tem um repositório ppa do Ubuntu na sources do Debian?


Buckminster, obrigado pela atenção! Eliminei os repositórios do Ubuntu! (mais uma que aprendi! kkk) e refiz todos os passos novamente, de novo não deu certo! Esse link do Tutorial que tu enviou, do Mateus Muller foi o primeiro que encontrei e segui antes de recorrer ao Fórum. o PC fufa tranquilo, só estou achando muito demorado para abrir abas do Firefox (poderia ser a Internet também, não sei) vou encerrar este topico. Vou trocar as memorias novamente, colocar a minha original e ver se o PC se comporta do mesmo jeito ou melhora. Valeu turma! Muito obrigado!




10. Re: Teste de Memoria

Buckminster
Buckminster

(usa Debian)

Enviado em 24/07/2021 - 01:18h

Vamos tentar mais uma coisa.
Execute:
apt-get update
aptitude safe-upgrade << se pedir para digitar y, digite.
Espere terminar e entre com
echo $PATH
e veja o que aparece.
Se aparecer algo diferente disso
/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin
é porque tu está logado como um usário root, mas sem certos privilégios.
Se for esse o caso dê exit e feche o terminal.
Abra o terminal de novo e execute:
su -l <<< éle minúsculo.
Digite a senha.
Dê echo $PATH
e veja o que aparece.
E tente dar um memtester.
Também pode usar os comandos
which memtester
e
whereis memtester
para ver os caminhos.

E se o problema é somente o Firefox lento para abrir então provavelmente o problema é com o Firefox. Desinstale e instale de novo. Às vezes com o sources bagunçado dá esses problemas de atualização, upgrade, instalação, etc.



11. Re: Teste de Memoria [RESOLVIDO]

Mario Lis
mlisram

(usa Debian)

Enviado em 24/07/2021 - 12:55h


Buckminster escreveu:

Vamos tentar mais uma coisa.
Execute:
apt-get update
aptitude safe-upgrade << se pedir para digitar y, digite.
Espere terminar e entre com
echo $PATH
e veja o que aparece.
Se aparecer algo diferente disso
/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin
é porque tu está logado como um usário root, mas sem certos privilégios.
Se for esse o caso dê exit e feche o terminal.
Abra o terminal de novo e execute:
su -l <<< éle minúsculo.
Digite a senha.
Dê echo $PATH
e veja o que aparece.
E tente dar um memtester.
Também pode usar os comandos
which memtester
e
whereis memtester
para ver os caminhos.

E se o problema é somente o Firefox lento para abrir então provavelmente o problema é com o Firefox. Desinstale e instale de novo. Às vezes com o sources bagunçado dá esses problemas de atualização, upgrade, instalação, etc.


Buckminster, Valeu cara! consegui! Duas coisas estavam erradas, o aptitude não estava instalado (não sei porque!...precisa instalar manual depois da instalação do Sistema?) e verdadeiramente estava logado errado depois de seguir tuas dicas deu tudo certo. Fiz o memtester nas memorias minhas, esta tudo ok, vou fazer com o pente do meu filho e vejo o que vai dar. Obrigado! vou esperar o resultado para encerrar o tópico. Só que vou conseguir apenas no final do dia. Vai um print do sensor na hora do teste. Abraços!


12. Re: Teste de Memoria [RESOLVIDO]

Mario Lis
mlisram

(usa Debian)

Enviado em 24/07/2021 - 15:28h


mlisram escreveu:


Buckminster escreveu:

Vamos tentar mais uma coisa.
Execute:
apt-get update
aptitude safe-upgrade << se pedir para digitar y, digite.
Espere terminar e entre com
echo $PATH
e veja o que aparece.
Se aparecer algo diferente disso
/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin
é porque tu está logado como um usário root, mas sem certos privilégios.
Se for esse o caso dê exit e feche o terminal.
Abra o terminal de novo e execute:
su -l <<< éle minúsculo.
Digite a senha.
Dê echo $PATH
e veja o que aparece.
E tente dar um memtester.
Também pode usar os comandos
which memtester
e
whereis memtester
para ver os caminhos.

E se o problema é somente o Firefox lento para abrir então provavelmente o problema é com o Firefox. Desinstale e instale de novo. Às vezes com o sources bagunçado dá esses problemas de atualização, upgrade, instalação, etc.


Buckminster, Valeu cara! consegui! Duas coisas estavam erradas, o aptitude não estava instalado (não sei porque!...precisa instalar manual depois da instalação do Sistema?) e verdadeiramente estava logado errado depois de seguir tuas dicas deu tudo certo. Fiz o memtester nas memorias minhas, esta tudo ok, vou fazer com o pente do meu filho e vejo o que vai dar. Obrigado! vou esperar o resultado para encerrar o tópico. Só que vou conseguir apenas no final do dia. Vai um print do sensor na hora do teste. Abraços!

Este o memtester com a memoria do meu filho...deu uma pequena diferença, mas tudo OK





01 02