Quase apaguei completamente o Python ( quase resolvido )! E acho que perdi o Grub! [RESOLVIDO]

1. Quase apaguei completamente o Python ( quase resolvido )! E acho que perdi o Grub! [RESOLVIDO]

Marcos Souza
FazedorDeM****

(usa Debian)

Enviado em 07/09/2017 - 14:35h

Boa tarde, bom fiz uma besteira muito grande, eu queria apagar o vim, que já estava cheio de plugins, estava com preguiça, fiz besteira no .vimrc e no .vim e queria limpar logo tudo, mas eu antes estava mexendo com python, aí eu coloquei:
sudo apt remove python 
invés de
sudo apt remove vim; rm -r .vim; rm .vimrc 
.
Eu consegui parar, por muita sorte, perdi alguns programas com certeza, mas não perdi tudo.
Já reconfigurei o dpkg, já instalei as dependencias necessárias, mas ainda tenho este aviso:
$ sudo apt install python3
Lendo listas de pacotes... Pronto
Construindo árvore de dependências
Lendo informação de estado... Pronto
python3 is already the newest version (3.5.3-1).
Os seguintes pacotes foram instalados automaticamente e já não são necessários:
albatross-gtk-theme ant ant-optional blackbird-gtk-theme bluebird-gtk-theme
coinor-libcbc3 coinor-libcgl1 coinor-libclp1 coinor-libcoinmp1v5
coinor-libcoinutils3v5 coinor-libosi1v5 dmz-cursor-theme dns-root-data
dnsmasq-base engrampa engrampa-common eom eom-common espeak-ng-data
ffmpegthumbnailer fonts-crosextra-caladea fonts-crosextra-carlito
fonts-linuxlibertine fonts-roboto-hinted fonts-sil-gentium
fonts-sil-gentium-basic freepats galculator gimp-data gir1.2-atspi-2.0
gir1.2-wnck-3.0 gnome-accessibility-themes gnome-keyring gnome-orca
gnome-themes-standard gnome-themes-standard-data greybird-gtk-theme
gstreamer1.0-libav gstreamer1.0-plugins-bad gstreamer1.0-plugins-ugly
gtk2-engines gtk2-engines-murrine hyphen-en-us iputils-arping
kio-extras-data kodi-visualization-spectrum libabw-0.1-1 libamd2
libao-common libao4 libapache-poi-java libapache-pom-java libatk-adaptor
libbabl-0.1-0 libbase-java libbcmail-java libbcpkix-java libbcprov-java
libbonobo2-0 libbonobo2-common libbonoboui2-common libbrlapi0.6 libbsh-java
libcamd2 libccolamd2 libcdr-0.1-1 libcec4 libchm1 libcholmod3 libcolamd2
libcommons-codec-java libcommons-collections3-java libcommons-logging-java
libcommons-parent-java libcrossguid0 libde265-0 libdom4j-java libdotconf0
libe-book-0.1-1 libehcache-java libespeak-ng1 libetonyek-0.1-1 libexempi3
libffmpegthumbnailer4v5 libflute-java libfonts-java libformula-java
libfreehand-0.1-1 libgdata-common libgdata22 libgegl-0.3-0 libgimp2.0
libgnome-keyring-common libgnome-keyring0 libgnomecanvas2-0
libgnomecanvas2-common libgnomeui-common libgoa-1.0-0b libgoa-1.0-common
libgstreamer-plugins-bad1.0-0 libgtkspell0 libhsqldb1.8.0-java
libimage-magick-perl libimage-magick-q16-perl libisorelax-java libitext-java
libjaxen-java libjcommon-java libjdom1-java libjs-iscroll libkf5dnssd-data
libkf5dnssd5 libkf5khtml-bin libkf5khtml-data libkf5khtml5 liblayout-java
liblightdm-gobject-1-0 libloader-java liblog4j1.2-java libmagick++-6.q16-7
libmail-java libmatedict6 libmbim-glib4 libmbim-proxy libmetis5
libmicrohttpd12 libmjpegutils-2.1-0 libmm-glib0 libmpeg2encpp-2.1-0
libmplex2-2.1-0 libmspub-0.1-1 libmsv-java libmwaw-0.3-3 libndp0 libnfs8
libnm0 libnma0 liboauth0 libofa0 liborbit-2-0 liborcus-0.11-0
libp8-platform2 libpagemaker-0.0-0 libpam-gnome-keyring libpcaudio0
libpcrecpp0v5 libpentaho-reporting-flow-engine-java libpixie-java
libpodofo0.9.4 libpotrace0 libpq5 libqmi-glib5 libqmi-proxy
librelaxng-datatype-java libreoffice libreoffice-avmedia-backend-gstreamer
libreoffice-base libreoffice-base-core libreoffice-base-drivers
libreoffice-calc libreoffice-draw libreoffice-gtk3 libreoffice-help-en-us
libreoffice-impress libreoffice-java-common libreoffice-librelogo
libreoffice-math libreoffice-nlpsolver libreoffice-ogltrans
libreoffice-pdfimport libreoffice-report-builder
libreoffice-report-builder-bin libreoffice-script-provider-bsh
libreoffice-script-provider-js libreoffice-script-provider-python
libreoffice-sdbc-hsqldb libreoffice-sdbc-postgresql
libreoffice-wiki-publisher libreoffice-writer librepository-java libsac-java
libsaxonhe-java libserializer-java libservlet3.1-java libsidplay1v5
libspandsp2 libspeechd2 libsrtp0 libssh-4 libsuitesparseconfig4 libteamdctl0
libumfpack5 libvisio-0.1-1 libvo-aacenc0 libvo-amrwbenc0 libwildmidi-config
libwildmidi2 libwpd-0.10-10 libwpg-0.3-3 libwps-0.4-4 libxerces2-java
libxml-commons-external-java libxml-commons-resolver1.1-java libxml-java
libxmlbeans-java libxom-java libxpp2-java libxpp3-java libzbar0 lightdm
lightdm-gtk-greeter lp-solve mate-backgrounds mate-icon-theme-faenza
mate-power-manager mate-power-manager-common mate-screensaver
mate-screensaver-common mate-themes mate-utils mate-utils-common
mobile-broadband-provider-info modemmanager murrine-themes mythes-en-us
network-manager network-manager-gnome p11-kit p11-kit-modules python3-brlapi
python3-louis python3-pyatspi python3-speechd python3-xdg speech-dispatcher
speech-dispatcher-audio-plugins speech-dispatcher-espeak-ng xbrlapi
Utilize 'sudo apt autoremove' para os remover.
0 pacotes atualizados, 0 pacotes novos instalados, 0 a serem removidos e 0 não atualizados.

E bom, eu jamais vou apagar tudo isso, como faço pra isso sair dos "não necessários"?

Grato estou desde já pelas respostas.


  


2. Re: Quase apaguei o Python!

Marcos Souza
FazedorDeM****

(usa Debian)

Enviado em 07/09/2017 - 15:18h

Boa tarde, já conegui arrumar algumas coisas, abri meu Synaptic, e instalei os programas pertencentes ao filtro "Recomendações faltando", e dei um "sudo apt install grub2", agora a saída é a seguinte:
$ sudo apt install python3
Lendo listas de pacotes... Pronto
Construindo árvore de dependências
Lendo informação de estado... Pronto
python3 is already the newest version (3.5.3-1).
Os seguintes pacotes foram instalados automaticamente e já não são necessários:
efibootmgr fonts-roboto-hinted grub-efi-amd64-bin
kodi-visualization-spectrum libbonobo2-0 libbonobo2-common
libbonoboui2-common libcec4 libchm1 libcrossguid0 libefiboot1 libefivar1
libgnomecanvas2-0 libgnomecanvas2-common libgnomeui-common libgtkspell0
libimage-magick-perl libimage-magick-q16-perl libjs-iscroll
libmagick++-6.q16-7 libmicrohttpd12 liborbit-2-0 libp8-platform2
libpcrecpp0v5 libpodofo0.9.4 libpotrace0
Utilize 'sudo apt autoremove' para os remover.
0 pacotes atualizados, 0 pacotes novos instalados, 0 a serem removidos e 0 não atualizados.


Suspeito que quebrei meu Grub, alguém pode me dar uma luz pra arrumar?

Na vida temos uma única certeza...

Todos nós já quebramos um sistema.



3. Re: Quase apaguei completamente o Python ( quase resolvido )! E acho que perdi o Grub! [RESOLVIDO]

Marcos Souza
FazedorDeM****

(usa Debian)

Enviado em 07/09/2017 - 15:24h

Bom, consegui arrumar mais um pouco novamente, peguei os programas que estavam "desnecessários", e deu um "apt install" neles. Ficando assim:
 sudo apt install efibootmgr fonts-roboto-hinted grub-efi-amd64-binkodi-visualization-spectrum libbonobo2-0 libbonobo2-commonlibbonoboui2-common libcec4 libchm1 libcrossguid0 libefiboot1 libefivar1libgnomecanvas2-0 libgnomecanvas2-common libgnomeui-common libgtkspell0libimage-magick-perl libimage-magick-q16-perl libjs-iscrolllibmagick++-6.q16-7 libmicrohttpd12 liborbit-2-0 libp8-platform2libpcrecpp0v5 libpodofo0.9.4 libpotrace0
Lendo listas de pacotes... Pronto
Construindo árvore de dependências
Lendo informação de estado... Pronto
E: Impossível encontrar o pacote grub-efi-amd64-binkodi-visualization-spectrum
E: Impossível encontrar o pacote libbonobo2-commonlibbonoboui2-common
E: Impossível encontrar o pacote libefivar1libgnomecanvas2-0
E: Impossível encontrar o pacote libgtkspell0libimage-magick-perl
E: Impossível encontrar o pacote libjs-iscrolllibmagick++-6.q16-7
E: Couldn't find any package by glob 'libjs-iscrolllibmagick++-6.q16-7'
E: Não foi possível encontrar o pacote através da expressão regular 'libjs-iscrolllibmagick++-6.q16-7'
E: Impossível encontrar o pacote libp8-platform2libpcrecpp0v5

Agora ficou assim, os "desnecessários":
$ sudo apt install python3
Lendo listas de pacotes... Pronto
Construindo árvore de dependências
Lendo informação de estado... Pronto
python3 is already the newest version (3.5.3-1).
Os seguintes pacotes foram instalados automaticamente e já não são necessários:
kodi-visualization-spectrum libbonobo2-0 libbonobo2-common libbonoboui2-common libcec4 libchm1
libcrossguid0 libgnomecanvas2-0 libgnomecanvas2-common libgnomeui-common libgtkspell0
libimage-magick-perl libimage-magick-q16-perl libjs-iscroll libmagick++-6.q16-7 libmicrohttpd12
liborbit-2-0 libp8-platform2 libpcrecpp0v5 libpodofo0.9.4 libpotrace0
Utilize 'sudo apt autoremove' para os remover.
0 pacotes atualizados, 0 pacotes novos instalados, 0 a serem removidos e 0 não atualizados.


Agora preciso consertar os erros acima, saber o motivo disso:
E: Impossível encontrar o pacote grub-efi-amd64-binkodi-visualization-spectrum
E: Impossível encontrar o pacote libbonobo2-commonlibbonoboui2-common
E: Impossível encontrar o pacote libefivar1libgnomecanvas2-0
E: Impossível encontrar o pacote libgtkspell0libimage-magick-perl
E: Impossível encontrar o pacote libjs-iscrolllibmagick++-6.q16-7
E: Couldn't find any package by glob 'libjs-iscrolllibmagick++-6.q16-7'
E: Não foi possível encontrar o pacote através da expressão regular 'libjs-iscrolllibmagick++-6.q16-7'
E: Impossível encontrar o pacote libp8-platform2libpcrecpp0v5

E arrumar o Grub.
Na vida temos uma única certeza...

Todos nós já quebramos um sistema.



4. Re: Quase apaguei o Python!

skjdeecedcnfncvnrfcnrncjvnjrnfvjcnjrjvcjrvcj
Londreslondres

(usa Parabola)

Enviado em 07/09/2017 - 15:34h

@FazedorDeM****, seu nick ficou bem criativo.


5. Re: Quase apaguei completamente o Python ( quase resolvido )! E acho que perdi o Grub! [RESOLVIDO]

Marcos Souza
FazedorDeM****

(usa Debian)

Enviado em 07/09/2017 - 15:36h

Londreslondres escreveu:

@FazedorDeM****, seu nick ficou bem criativo.


Obrigado kkkkkk, o pior ainda é que eu confirmei a remoção do python, pensando que eu estava apagando o vim, só percebi quando vi que estava desinstalando programas como o atom, controladores de áudio e outros.

Na vida temos uma única certeza...

Todos nós já quebramos um sistema.



6. UP

Marcos Souza
FazedorDeM****

(usa Debian)

Enviado em 07/09/2017 - 17:14h

UP
Na vida temos uma única certeza...

Todos nós já quebramos um sistema.



7. UP

Marcos Souza
FazedorDeM****

(usa Debian)

Enviado em 07/09/2017 - 22:48h

UP
Acabei de tomar coragem e reiniciei, não perdi o Grub, porém continuo com aquelas bibliotecas e outros pro autoremove.
Na vida temos uma única certeza...

Todos nós já quebramos um sistema.



8. Re: Quase apaguei completamente o Python ( quase resolvido )! E acho que perdi o Grub! [RESOLVIDO]

Marcos Souza
FazedorDeM****

(usa Debian)

Enviado em 07/09/2017 - 23:41h

Dei logo um autoremove reinstalei pelo filtro dos recomendados o que era importante no synaptics
Na vida temos uma única certeza...

Todos nós já quebramos um sistema.







Patrocínio

Site hospedado pelo provedor RedeHost.
Linux banner
Linux banner

Destaques

Artigos

Dicas

Tópicos

Top 10 do mês

Scripts