Problemas com audio [RESOLVIDO]

1. Problemas com audio [RESOLVIDO]

Mauriciodez
Mauriciodez

(usa Debian)

Enviado em 18/06/2024 - 11:47h

Pessoas ... a saída de som está com microfonia ( barulho tipo quando as caixas não estão espetadas ). quando estão espetadas as caixas de som de pc o ruído é imperceptível mas quando está espetado meu microsystem o ruído é insuportável.

*** Essa microfonia só se mostra quando não tem nada sendo reproduzido, aí ela cessa tipo 1s antes e volta uns 3s depois do termino da reprodução.
*** Essa microfonia não se mostra em windows e nem no debian stretch ... em todos os outros linux o problema acontece ... testei em manjaro, biglinux, mint, endeavour e linuxlite !!!
*** Tentei usar a blacklist do modprob para cessar/parar/purgar o driver de áudio para tentar instalar manualmente mas ou não funcionou ou eu que não soube fazer.

Aceito qualquer sugestão:

O sistema é Debian 12 + cinnamon , a mobo é uma biostar a520mt + CPU ryzen3 3200g

EDIT: eu falei que o barulho é microfonia mas pode ser barulho do tipo de falta de aterramento, eu que não estou sabendo o nome realmente deste maldito




  


2. MELHOR RESPOSTA

Xerxes
xerxeslins

(usa BigLinux)

Enviado em 18/06/2024 - 16:29h


Olá!

Seu problema talvez tenha solução, ou pelo menos alguma pista para solução, neste link:

https://itsfoss.com/buzzing-noise-speaker-linux/

Se funcionar, ficará registrado para outros que tiverem o mesmo problema.

--



3. Re: Problemas com audio

rafael
ogro33

(usa Debian)

Enviado em 18/06/2024 - 12:05h

Uma coisa... isso aconteceu após alguma atualização de sistema ou você ter mudado alguma coisa de lugar onde fica o PC ou perto dele?

Edit:
Se você tiver como testar com outro cabo, de preferência de boa qualidade, seria uma boa também. Caso não tenha outro cabo, tente reposicionar o mesmo... passando ele por outro caminho.

Fontes elétricas costumam causar esse tipo de interferência. Por exemplo: fonte do PC, lâmpada, aquecedor elétrico, micro-ondas, etc...


4. Re: Problemas com audio [RESOLVIDO]

Mauriciodez
Mauriciodez

(usa Debian)

Enviado em 18/06/2024 - 12:40h


ogro33 escreveu:
Uma coisa... isso aconteceu após alguma atualização de sistema ou você ter mudado alguma coisa de lugar onde fica o PC ou perto dele?
...


não ... eu montei esse computador tem pouco mais de 1 mês e sempre teve essa chatisse !!!

OBS: vc recebeu o e-mail que te mandei ???

------------------------------------------------------| Linux User #621728 |------------------------------------------------------

" Nem sempre é amigo aquele que te tira do buraco !!! ( Saddam Hussein )"

------------------------------------------------------| Linux User #621728 |------------------------------------------------------




5. Re: Problemas com audio [RESOLVIDO]

rafael
ogro33

(usa Debian)

Enviado em 18/06/2024 - 12:42h

Recebi teu e-mail Maurício.
Tranquilo mano.

Cara, eu acho que não entendi errado não. Esse tipo de interferência parece-me realmente com interferência eletromagnética. Já tive esse problema em um som automotivo que montei. Só que no carro era.pior ainda, pois a interferência vinha da bobina do veículo e toda vez que acelerava o carro a interferência aumentava.

Tente reposicionar os cabos. Ou trocar por cabos de melhor qualidade.

Só acho estranho estar acontecendo somente com um sistema.

Se tu estiveres usando uma entrada p2 no PC, tenta colocar um celular bem em cima de onde fica atualmente conectado o cabo no PC e só troca do PC pro celular o cabo e vê se a interferência continua.





6. Re: Problemas com audio

Mauriciodez
Mauriciodez

(usa Debian)

Enviado em 18/06/2024 - 13:01h

ogro33 escreveu:
Tente reposicionar os cabos. Ou trocar por cabos de melhor qualidade.

Só acho estranho estar acontecendo somente com um sistema.

Se tu estiveres usando uma entrada p2 no PC, tenta colocar um celular bem em cima de onde fica atualmente conectado o cabo no PC e só troca do PC pro celular o cabo e vê se a interferência continua.


Por isso que eu disse que vc entendeu errado ... não acontece só em 1 sistema ... só NÃO acontece nos windows e no debian antigo que testei que foi o stretch entendeu ?
e o barulho quando alguma midia vai ser reproduzida ele cessa um pouco antes de começar e retorna um pouco depois do fim da reprodução !!!

o barulho é bem parecido do barulho de caixas de som desplugadas mas é mais grave e muito mais baixo, porém quando espeto o aparelho de som o maldito fica irritante !!!

Quanto a testar trocar os cabos é impossível pois meu som fica na sala o pc no quarto !!!

como eu disse antes ... nas caixinhas do pc o barulho é imperceptível, mas se colar o ouvido nelas da para escutar o barulho lá no fundo ... ou seja ... não tem nada a ver com cabos nem com os periféricos ... pra mim isso é coisa de driver !!!

------------------------------------------------------| Linux User #621728 |------------------------------------------------------

" Nem sempre é amigo aquele que te tira do buraco !!! ( Saddam Hussein )"

------------------------------------------------------| Linux User #621728 |------------------------------------------------------




7. Re: Problemas com audio [RESOLVIDO]

Sidnei Serra
Tocagano

(usa Arch Linux)

Enviado em 18/06/2024 - 13:08h

Esse "huuuuuuuummmmm" no aparelho de som é interferência de entrada, ponha um fone de ouvido na saída do seu PC e veja se o ruído aparece nele. Se aparecer é do sistema, aqui no meu Debian 12 uso a saída de som ligado em um microsystem da Aiwa e o plugue de som tem "posição" no PC para ficar ligado senão fica "huuuuuuummmmm"-zando...

>>> NÃO visite este canal, o cara pensa que sabe alguma coisa! <<<
https://www.youtube.com/channel/UCRgokKtNlttdmg2RJEa2VYw


8. Re: Problemas com audio [RESOLVIDO]

Mauriciodez
Mauriciodez

(usa Debian)

Enviado em 18/06/2024 - 13:21h


Tocagano escreveu:

Esse "huuuuuuuummmmm" no aparelho de som é interferência de entrada, ponha um fone de ouvido na saída do seu PC e veja se o ruído aparece nele...


Não citei antes pq como tinha citado que tinha testado nas caixinhas de barata para pc achei que não precisava ... mas o barulho tb rola com fones ... só não acontece nos windows e no debian 9 ... não testei no 10 e 11.
Imagino que seja driver pois o lspci do debian 9 é bem diferente dos outros linux ...

------------------------------------------------------| Linux User #621728 |------------------------------------------------------

" Nem sempre é amigo aquele que te tira do buraco !!! ( Saddam Hussein )"

------------------------------------------------------| Linux User #621728 |------------------------------------------------------




9. Re: Problemas com audio

Mauriciodez
Mauriciodez

(usa Debian)

Enviado em 18/06/2024 - 13:24h


Outra coisa que esqueci de citar ... se estiver nas configurações de som do sistema o barulho tb desaparece ... então se eu quiser espetar meu som e usar linux eu tenho que fazer essa gambiarra , deixar a config de som como dizem "ablada" ... v se pode ... kkkkkkkkkkkkkkkk


------------------------------------------------------| Linux User #621728 |------------------------------------------------------

" Nem sempre é amigo aquele que te tira do buraco !!! ( Saddam Hussein )"

------------------------------------------------------| Linux User #621728 |------------------------------------------------------




10. Re: Problemas com audio [RESOLVIDO]

rafael
ogro33

(usa Debian)

Enviado em 18/06/2024 - 13:26h


Mauriciodez escreveu:

ogro33 escreveu:
Tente reposicionar os cabos. Ou trocar por cabos de melhor qualidade.

Só acho estranho estar acontecendo somente com um sistema.

Se tu estiveres usando uma entrada p2 no PC, tenta colocar um celular bem em cima de onde fica atualmente conectado o cabo no PC e só troca do PC pro celular o cabo e vê se a interferência continua.


Por isso que eu disse que vc entendeu errado ... não acontece só em 1 sistema ... só NÃO acontece nos windows e no debian antigo que testei que foi o stretch entendeu ?
e o barulho quando alguma midia vai ser reproduzida ele cessa um pouco antes de começar e retorna um pouco depois do fim da reprodução !!!

o barulho é bem parecido do barulho de caixas de som desplugadas mas é mais grave e muito mais baixo, porém quando espeto o aparelho de som o maldito fica irritante !!!

Quanto a testar trocar os cabos é impossível pois meu som fica na sala o pc no quarto !!!

como eu disse antes ... nas caixinhas do pc o barulho é imperceptível, mas se colar o ouvido nelas da para escutar o barulho lá no fundo ... ou seja ... não tem nada a ver com cabos nem com os periféricos ... pra mim isso é coisa de driver !!!

------------------------------------------------------| Linux User #621728 |------------------------------------------------------

" Nem sempre é amigo aquele que te tira do buraco !!! ( Saddam Hussein )"

------------------------------------------------------| Linux User #621728 |------------------------------------------------------



Agora entendi direito.

Cara, o fato do cabo ser longo só aumenta minha suspeita. Mas por outro lado, o problema aparece também com as caixas perto do PC. Muito estranho...

Pode ser que a fonte de ruídos seja no próprio PC.

É um desktop? Se sim, tenta ajeitar os cabos da fonte de formar a ficarem o mais longe possível da.placa de som.

Se tu já tiver 100% de certeza de que seja driver, trocar o pulseaudio pelo pipewire altera alguma coisa?

Fez o teste de baixar o volume no PC e aumentar no microsystem e depois fazer o inverso? Mudou alguma coisa?

Eu estou indo por tentativa e erro aqui na esperança de ajudar, mas realmente não tenho certeza alguma do que pode ser.




11. Re: Problemas com audio [RESOLVIDO]

rafael
ogro33

(usa Debian)

Enviado em 18/06/2024 - 13:28h


Mauriciodez escreveu:


Outra coisa que esqueci de citar ... se estiver nas configurações de som do sistema o barulho tb desaparece ... então se eu quiser espetar meu som e usar linux eu tenho que fazer essa gambiarra , deixar a config de som como dizem "ablada" ... v se pode ... kkkkkkkkkkkkkkkk


------------------------------------------------------| Linux User #621728 |------------------------------------------------------

" Nem sempre é amigo aquele que te tira do buraco !!! ( Saddam Hussein )"

------------------------------------------------------| Linux User #621728 |------------------------------------------------------



Com essa informação nova definitivamente tem algo relacionado a software aí...
Esquece o que eu falei antes sobre os testes envolvendo parte de hardware.




12. Re: Problemas com audio [RESOLVIDO]

Sidnei Serra
Tocagano

(usa Arch Linux)

Enviado em 18/06/2024 - 13:36h

Digita aí " pactl info " e veja qual o servidor de som você está usando...

>>> NÃO visite este canal, o cara pensa que sabe alguma coisa! <<<
https://www.youtube.com/channel/UCRgokKtNlttdmg2RJEa2VYw



01 02



Patrocínio

Site hospedado pelo provedor RedeHost.
Linux banner

Destaques

Artigos

Dicas

Tópicos

Top 10 do mês

Scripts