Problema na instalação do Debian [RESOLVIDO]

1. Problema na instalação do Debian [RESOLVIDO]

Emmanuel Rodrigues
neo_emmanuel

(usa Debian)

Enviado em 02/10/2017 - 10:52h

Olá!

Sou usuário de Debian 9 e estou com um problema... A inicialização do sistema e rodar o sistema fora da interface gráfica apresenta uma série de mensagens como a seguinte:

[10611.602822] pcieport 0000:00:1c.4: PCIe Bus Error: severity=Corrected, type=Data Link Layer, id=00e4(Transmitter ID)
[10611.602949] pcieport 0000:00:1c.4: device [8086:9d14] error status/mask=00001000/00002000
[10611.603041] pcieport 0000:00:1c.4: [12] Replay Timer Timeout


Tive um monte de problema com o firmware quando fui instalar o SO, que instalei com a "ISO não-oficial", já com os firmwares. Consegui fazer funcionar o wireless, mas, percebo, há ainda algo a configurar. Já tentei uma série de coisas e não consegui... Alguém pode me dar uma luz do que devo fazer?

Meu pc é um Dell Inspiron i7 e abaixo trago a saída do "lshw - short"

~$ sudo lshw -short
H/W path Device Class Description
====================================================
system Inspiron 7460 (0781)
/0 bus 09WC1G
/0/0 memory 64KiB BIOS
/0/2f memory 16GiB System Memory
/0/2f/0 memory 8GiB SODIMM DDR4 Synchronous Unbuffered (Unregistered) 2400 MHz (0.4 ns)
/0/2f/1 memory 8GiB SODIMM DDR4 Synchronous Unbuffered (Unregistered) 2400 MHz (0.4 ns)
/0/33 memory 128KiB L1 cache
/0/34 memory 512KiB L2 cache
/0/35 memory 4MiB L3 cache
/0/36 processor Intel(R) Core(TM) i7-7500U CPU @ 2.70GHz
/0/100 bridge Intel Corporation
/0/100/2 display Intel Corporation
/0/100/4 generic Skylake Processor Thermal Subsystem
/0/100/14 bus Sunrise Point-LP USB 3.0 xHCI Controller
/0/100/14/0 usb1 bus xHCI Host Controller
/0/100/14/0/2 input USB OPTICAL MOUSE
/0/100/14/0/5 multimedia Integrated_Webcam_HD
/0/100/14/0/6 generic USB2.0-CRW
/0/100/14/0/8 communication Bluetooth wireless interface
/0/100/14/1 usb2 bus xHCI Host Controller
/0/100/14.2 generic Sunrise Point-LP Thermal subsystem
/0/100/15 generic Sunrise Point-LP Serial IO I2C Controller #0
/0/100/15.1 generic Sunrise Point-LP Serial IO I2C Controller #1
/0/100/16 communication Sunrise Point-LP CSME HECI #1
/0/100/17 storage Sunrise Point-LP SATA Controller [AHCI mode]
/0/100/1c bridge Intel Corporation
/0/100/1c/0 display GM108M [GeForce 940MX]
/0/100/1c.4 bridge Sunrise Point-LP PCI Express Root Port #5
/0/100/1c.4/0 wlp2s0 network QCA6174 802.11ac Wireless Network Adapter
/0/100/1c.5 bridge Sunrise Point-LP PCI Express Root Port #6
/0/100/1c.5/0 enp3s0 network RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller
/0/100/1f bridge Intel Corporation
/0/100/1f.2 memory Memory controller
/0/100/1f.3 multimedia Intel Corporation
/0/100/1f.4 bus Sunrise Point-LP SMBus
/0/1 scsi0 storage
/0/1/0.0.0 /dev/sda disk 1TB ST1000LM035-1RK1
/0/1/0.0.0/1 /dev/sda1 volume 511MiB Windows FAT volume
/0/1/0.0.0/2 /dev/sda2 volume 27GiB EXT4 volume
/0/1/0.0.0/3 /dev/sda3 volume 19GiB EXT4 volume
/0/1/0.0.0/4 /dev/sda4 volume 8524MiB Linux swap volume
/0/1/0.0.0/5 /dev/sda5 volume 875GiB EXT4 volume
/1 power DELL Y3F7Y6B


Aqui é o meu "/etc/apt/sources.list"

# deb cdrom:[Debian GNU/Linux 9.1.0 _Stretch_ - Official amd64 NETINST 20170722-11:28]/ stretch contrib main non-free
# deb cdrom:[Debian GNU/Linux 9.1.0 _Stretch_ - Official amd64 NETINST 20170722-11:28]/ stretch contrib main non-free
deb http://ftp.br.debian.org/debian/ stretch main contrib non-free
deb-src http://ftp.br.debian.org/debian/ stretch main contrib non-free

deb http://security.debian.org/debian-security/ stretch/updates main contrib non-free
deb-src http://security.debian.org/debian-security/ stretch/updates main contrib non-free

# stretch-updates, previously known as 'volatile'
deb http://ftp.br.debian.org/debian/ stretch-updates main contrib non-free
deb-src http://ftp.br.debian.org/debian/ stretch-updates main contrib non-free

deb http://http.debian.net/debian/ stretch-backports main


É um problema na placa de vídeo, confere? Como resolver?

Agradeço demais as ajudas que vocês pudessem me dar, gente =)


  


2. Re: Problema na instalação do Debian [RESOLVIDO]

Xerxes Lins
xerxeslins

(usa Void Linux)

Enviado em 02/10/2017 - 12:12h

Já instalou o "firmware-linux"?

Se for problema de falta de algum algum driver tente instalar o "firmware-linux".

# apt install firmware-linux

E reinicie. Veja se isso resolve.

--
If it ain't broke, fix it until it is.


3. Re: Problema na instalação do Debian [RESOLVIDO]

Clodoaldo Santos
clodoaldops

(usa Linux Mint)

Enviado em 02/10/2017 - 15:09h

-eu também tive problemas na instalação do dbeian-9 usando live-iso mas não tive problemas com dvd-install-1


4. CONSEGUI RESOLVER!!!!

Emmanuel Rodrigues
neo_emmanuel

(usa Debian)

Enviado em 04/10/2017 - 21:24h

Consegui usando o que fala nesse link:

https://askubuntu.com/questions/771899/pcie-bus-error-severity-corrected

Através das informações desse outro link aqui:

https://askubuntu.com/questions/19486/how-do-i-add-a-kernel-boot-parameter

=)

Basicamente, incluí nos parâmetros de boot a entrada
pci=noaer 
.

Consegui e vim de imediato falar aqui, agora vou dar uma estudada mais sobre ;)

VLWWW!


5. Causa do erro

Henrique
henriqueqc

(usa Ubuntu)

Enviado em 22/01/2018 - 22:04h

Estou tento o mesmo erro na minha maquina Dell Inspiron 14 7460:


$ dmesg



[ 1802.207179] pcieport 0000:00:1c.4: AER: Corrected error received: id=00e4
[ 1802.207184] pcieport 0000:00:1c.4: PCIe Bus Error: severity=Corrected, type=Data Link Layer, id=00e4(Transmitter ID)
[ 1802.207186] pcieport 0000:00:1c.4: device [8086:9d14] error status/mask=00001000/00002000
[ 1802.207188] pcieport 0000:00:1c.4: [12] Replay Timer Timeout


Mesmo erro id=00e4.

Mesmo dispositivo PCI 0000:00:1c.4:

$ lspci | grep 1c.4



00:1c.4 PCI bridge: Intel Corporation Sunrise Point-LP PCI Express Root Port #5 (rev f1)


Parece que nosso hardware é semelhante e estamos vendo o mesmo erro ocorrer.

Desabilitar o AER faz com que o erro pare de ser reportado, isso não significa que ele parou de ocorrer. Você chegou a investigar o que é a causa raiz do problema?
Vou investigar um pouco mais e atualizo aqui.


6. Hardware info

Henrique
henriqueqc

(usa Ubuntu)

Enviado em 22/01/2018 - 22:23h

Atualizando com informações do meu sistema. Estou usando Ubuntu 17.10 amd64


$ sudo lshw -short
H/W path Device Class Description
=====================================================
system Inspiron 7460 (0781)
/0 bus 09WC1G
/0/0 memory 64KiB BIOS
/0/2f memory 16GiB System Memory
/0/2f/0 memory 8GiB SODIMM DDR4 Synchronous Unbuffere
/0/2f/1 memory 8GiB SODIMM DDR4 Synchronous Unbuffere
/0/33 memory 128KiB L1 cache
/0/34 memory 512KiB L2 cache
/0/35 memory 4MiB L3 cache
/0/36 processor Intel(R) Core(TM) i7-7500U CPU @ 2.70G
/0/100 bridge Intel Corporation
/0/100/2 display Intel Corporation
/0/100/4 generic Skylake Processor Thermal Subsystem
/0/100/14 bus Sunrise Point-LP USB 3.0 xHCI Controll
/0/100/14/0 usb1 bus xHCI Host Controller
/0/100/14/0/2 generic FT232R USB UART
/0/100/14/0/3 input USB Receiver
/0/100/14/0/5 multimedia Integrated Webcam
/0/100/14/0/6 generic USB2.0-CRW
/0/100/14/0/8 communication Bluetooth wireless interface
/0/100/14/1 usb2 bus xHCI Host Controller
/0/100/14.2 generic Sunrise Point-LP Thermal subsystem
/0/100/15 generic Sunrise Point-LP Serial IO I2C Control
/0/100/15.1 generic Sunrise Point-LP Serial IO I2C Control
/0/100/16 communication Sunrise Point-LP CSME HECI #1
/0/100/17 storage Sunrise Point-LP SATA Controller [AHCI
/0/100/1c bridge Intel Corporation
/0/100/1c/0 generic Illegal Vendor ID
/0/100/1c.4 bridge Sunrise Point-LP PCI Express Root Port
/0/100/1c.4/0 wlp2s0 network QCA6174 802.11ac Wireless Network Adap
/0/100/1c.5 bridge Sunrise Point-LP PCI Express Root Port
/0/100/1c.5/0 enp3s0 network RTL8111/8168/8411 PCI Express Gigabit
/0/100/1f bridge Intel Corporation
/0/100/1f.2 memory Memory controller
/0/100/1f.3 multimedia Intel Corporation
/0/100/1f.4 bus Sunrise Point-LP SMBus
/0/1 scsi0 storage
/0/1/0.0.0 /dev/sda disk 1TB WDC WD10SPZX-75Z
/0/1/0.0.0/1 /dev/sda1 volume 931GiB EXT4 volume
/0/2 scsi2 storage
/0/2/0.0.0 /dev/sdb disk 128GB LITEON CV3-8D128
/0/2/0.0.0/1 /dev/sdb1 volume 190MiB Windows FAT volume
/0/2/0.0.0/2 /dev/sdb2 volume 119GiB Extended partition
/0/2/0.0.0/2/5 /dev/sdb5 volume 25GiB EXT4 volume
/0/2/0.0.0/2/6 /dev/sdb6 volume 93GiB EXT4 volume
/1 power DELL Y3F7Y6B



Aparentemente, o dispositivo que esta conectado na porta #5 (1c.4) é o adaptador wireless:


/0/100/1c.4 bridge Sunrise Point-LP PCI Express Root Port
/0/100/1c.4/0 wlp2s0 network QCA6174 802.11ac Wireless Network Adap


Em pelo menos uma rede wireless, minha maquina perde a conexão com o roteador rotineiramente. Esse sintoma pode estar relacionado. Você esta vendo instabilidade com o Wireless na sua maquina?






Patrocínio

Site hospedado pelo provedor RedeHost.
Linux banner
Linux banner
Linux banner

Destaques

Artigos

Dicas

Tópicos

Top 10 do mês

Scripts