Pq que isto está acontecendo?

1. Pq que isto está acontecendo?

Hudson Orsine Assumpção
brevleq

(usa Slackware)

Enviado em 27/08/2007 - 20:05h

./flashplayer-installer
bash: ./flashplayer-installer: /bin/sh: bad interpreter: Permissão negada

Não entendo?? O arquivo é executável e naum consigo fazer ele funcionar!!


  


2. Re: Pq que isto está acontecendo?

Odalberto Oliveira Neto
odalberto

(usa Outra)

Enviado em 27/08/2007 - 20:59h

Você precisa verificar se esta logado como root

tenta sudo ./flashplayer-installer

abraços!!!!!


3. Re: Pq que isto está acontecendo?

Tiago Barros
richerbarros

(usa Slackware)

Enviado em 27/08/2007 - 22:52h

Verifique se está como Root, se o arquivo tem permissão de execução e depois tente isso aqui:
sh flashplayer-installer.sh
flw


4. permissões

Juliao Junior
juliaojunior

(usa Debian)

Enviado em 27/08/2007 - 23:48h

o q acontece é q vc não tem permissão para executar o sistema. o conceito de permissão é simples e fabuloso, pois dá ao administrador o controle sobre a ação dos usuários dentro do sistema. o q vc deve fazer é alterar as permissões, concedendo a vc o direito de executar tal arquivo.
qq coisa, dê uma pesquisa aqui mesmo no VOL sobre permissões. vc encontrará bons artigos com ótimas explicações sobre o tema.


5. me expliquem isso entaum!!

Hudson Orsine Assumpção
brevleq

(usa Slackware)

Enviado em 28/08/2007 - 13:06h

Eu tô ligado sobre as permissões, entaum vou dar outro exemplo:

brevleq:/home/brevleq/downloads/backup# chown root.root instala_ati.run
brevleq:/home/brevleq/downloads/backup# ./instala_ati.run
bash: ./instala_ati.run: Permissão negada
brevleq:/home/brevleq/downloads/backup# chmod +x instala_ati.run
brevleq:/home/brevleq/downloads/backup# ./instala_ati.run
bash: ./instala_ati.run: Permissão negada
brevleq:/home/brevleq/downloads/backup# ls -l instala_ati.run
-rwxr-xr-x 1 root root 53449730 2007-06-17 12:53 instala_ati.run
brevleq:/home/brevleq/downloads/backup# sh instala_ati.run
Created directory fglrx-install.jk4438
Verifying archive integrity... All good.
Uncompressing ATI Proprietary Linux Driver-8.37.6..................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................
instala_ati.run: ./ati-installer.sh: /bin/sh: bad interpreter: Permissão negada
Removing temporary directory: fglrx-install.jk4438

entenderam?? O debian simplesmente não reconhece o comando "./" !!!


6. Re: Pq que isto está acontecendo?

Cleber Rocha
cl2b2r

(usa Debian)

Enviado em 28/08/2007 - 13:18h

o comando certo seria:
# chown -R root:root instala_ati.run

Tenta com isso e vê se funciona


7. Re: Pq que isto está acontecendo?

Fernando Dettoni
fdettoni

(usa Arch Linux)

Enviado em 28/08/2007 - 13:33h

Cada arquivo tem um usuario e um grupo "dono" deste arquivo. Isso significa que apenas esse dono, e quem ele definir, poderão executar este arquivo.

Usando o comando chown vc muda o dono deste arquivo. No caso, com chown root.root vc está dizendo que o dono deste arquivo é o root, então para vc ter permissão para executá-lo precisa ser root usando o comando su e digitando a senha de root.

Se por acaso vc está como root, então o arquivo pode estar danificado ou ocorreu um erro muito grave.

[]'s


8. Re: Pq que isto está acontecendo?

Willians Cesar Franco Ribeiro
crashover

(usa Slackware)

Enviado em 29/08/2007 - 07:39h

ele está acusando erro no interpretador de comando...
além do sh temos o bash e mais uma porção....se atente a isso!

olhe a mensagem: bash: ./flashplayer-installer: /bin/sh: bad interpreter: Permissão negada


9. Re: Pq que isto está acontecendo?

Willians
icefusion

(usa Debian)

Enviado em 29/08/2007 - 09:23h

problemas de permissão ou algum problema em relação ao interpretador!!






Patrocínio

Site hospedado pelo provedor RedeHost.
Linux banner
Linux banner

Destaques

Artigos

Dicas

Tópicos

Top 10 do mês

Scripts