Não consigo instalar o Sublime

1. Não consigo instalar o Sublime

Shmuel Rothschild Trachtenberg
shmuelrothschild

(usa Debian)

Enviado em 20/11/2020 - 05:51h

Olá,

Como faço para instalar a versão estável do Sublime 3 no Debian 10? Assim sendo, quando estou instalando mostra que o GPG está bloqueado.

Fico no aguardo,

Obrigado!


  


3. Re: Não consigo instalar o Sublime

Stanislaus K
StanislausK

(usa FreeBSD)

Enviado em 20/11/2020 - 17:27h

Ola,

você ja tentou usar as instruçoes desse tutorial?

Como instalar Sublime Text 3 no Linux
https://sempreupdate.com.br/como-instalar-sublime-text-3-no-linux/


4. Re: Não consigo instalar o Sublime

Shmuel Rothschild Trachtenberg
shmuelrothschild

(usa Debian)

Enviado em 20/11/2020 - 17:31h



Olá,

Eu tentei mas não consigo instalar. No primeiro comando mostra um erro, veja:

wget -qO - https://download.sublimetext.com/sublimehq-pub.gpg | apt-key add -
bash: wget: command not found
gpg: no valid OpenPGP data found.



5. Re: Não consigo instalar o Sublime

Shmuel Rothschild Trachtenberg
shmuelrothschild

(usa Debian)

Enviado em 20/11/2020 - 17:32h

StanislausK escreveu:

Ola,

você ja tentou usar as instruçoes desse tutorial?

Como instalar Sublime Text 3 no Linux
https://sempreupdate.com.br/como-instalar-sublime-text-3-no-linux/


Olá,

Eu tentei mas não consigo instalar. No primeiro comando mostra um erro, veja:

wget -qO - https://download.sublimetext.com/sublimehq-pub.gpg | apt-key add -
bash: wget: command not found
gpg: no valid OpenPGP data found.



6. Re: Não consigo instalar o Sublime

Ryuk Shinigami
Ryuk

(usa Nenhuma)

Enviado em 20/11/2020 - 17:37h


shmuelroth11 escreveu:
Olá,

Eu tentei mas não consigo instalar. No primeiro comando mostra um erro, veja:

wget -qO - https://download.sublimetext.com/sublimehq-pub.gpg | apt-key add -
bash: wget: command not found
gpg: no valid OpenPGP data found.


O wget não está instalado. Instale-o:
sudo apt install wget 



7. Re: Não consigo instalar o Sublime

Shmuel Rothschild Trachtenberg
shmuelrothschild

(usa Debian)

Enviado em 20/11/2020 - 17:49h

Ryuk escreveu:


shmuelroth11 escreveu:
Olá,

Eu tentei mas não consigo instalar. No primeiro comando mostra um erro, veja:

wget -qO - https://download.sublimetext.com/sublimehq-pub.gpg | apt-key add -
bash: wget: command not found
gpg: no valid OpenPGP data found.


O wget não está instalado. Instale-o:
sudo apt install wget 


Eu vou continuar instalando mas apareceu isso:

Reading package lists... Done
Building dependency tree
Reading state information... Done
The following NEW packages will be installed:
wget
0 upgraded, 1 newly installed, 0 to remove and 0 not upgraded.
Need to get 902 kB of archives.
After this operation, 3.335 kB of additional disk space will be used.
Get:1 http://deb.debian.org/debian buster/main amd64 wget amd64 1.20.1-1.1 [902 kB]
Fetched 902 kB in 1s (916 kB/s)
Selecting previously unselected package wget.
(Reading database ... 240229 files and directories currently installed.)
Preparing to unpack .../wget_1.20.1-1.1_amd64.deb ...
Unpacking wget (1.20.1-1.1) ...
Setting up wget (1.20.1-1.1) ...
Processing triggers for man-db (2.8.5-2) ...




8. Re: Não consigo instalar o Sublime

Shmuel Rothschild Trachtenberg
shmuelrothschild

(usa Debian)

Enviado em 20/11/2020 - 17:56h

No ultimo comando não consegui instalar, veja:

[email protected]:/home/shmuelroth# echo "deb https://download.sublimetext.com/">https://download.sublimetext.com/ apt / stable /" | sudo tee /etc/apt/sources.list.d/sublime-text.list
deb https://download.sublimetext.com/">https://download.sublimetext.com/ apt / stable /
[email protected]:/home/shmuelroth# sudo apt install apt-transport-https
Reading package lists... Done
Building dependency tree
Reading state information... Done
apt-transport-https is already the newest version (1.8.2.1).
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
[email protected]:/home/shmuelroth# apt update
Hit:1 http://deb.debian.org/debian buster InRelease
Hit:2 http://security.debian.org/debian-security buster/updates InRelease
Hit:3 http://deb.debian.org/debian buster-updates InRelease
Ign:4 http://ppa.launchpad.net/webupd8team/sublime-text-3/ubuntu hirsute InRelease
Ign:5 https://download.sublimetext.com apt InRelease
Err:6 http://ppa.launchpad.net/webupd8team/sublime-text-3/ubuntu hirsute Release
404 Not Found [IP: 2001:67c:1560:8008::15 80]
Get:7 https://download.sublimetext.com apt/stable/ InRelease [2.562 B]
Err:8 https://download.sublimetext.com apt Release
404 Not Found [IP: 104.236.0.104 443]
Err:7 https://download.sublimetext.com apt/stable/ InRelease
The following signatures couldn't be verified because the public key is not available: NO_PUBKEY F57D4F59BD3DF454
Reading package lists... Done
E: The repository 'http://ppa.launchpad.net/webupd8team/sublime-text-3/ubuntu hirsute Release' does not have a Release file.
N: Updating from such a repository can't be done securely, and is therefore disabled by default.
N: See apt-secure(8) manpage for repository creation and user configuration details.
E: The repository 'https://download.sublimetext.com apt Release' does not have a Release file.
N: Updating from such a repository can't be done securely, and is therefore disabled by default.
N: See apt-secure(8) manpage for repository creation and user configuration details.
W: GPG error: https://download.sublimetext.com apt/stable/ InRelease: The following signatures couldn't be verified because the public key is not available: NO_PUBKEY F57D4F59BD3DF454
E: The repository 'https://download.sublimetext.com apt/stable/ InRelease' is not signed.
N: Updating from such a repository can't be done securely, and is therefore disabled by default.
N: See apt-secure(8) manpage for repository creation and user configuration details.
[email protected]:/home/shmuelroth# apt install sublime-text
Reading package lists... Done
Building dependency tree
Reading state information... Done
E: Unable to locate package sublime-text
[email protected]:/home/shmuelroth#



9. Re: Não consigo instalar o Sublime

Shmuel Rothschild Trachtenberg
shmuelrothschild

(usa Debian)

Enviado em 20/11/2020 - 18:25h

Ryuk escreveu:

$ su -
# wget -qO - https://download.sublimetext.com/sublimehq-pub.gpg">https://download.sublimetext.com/sublimehq-pub.gpg | apt-key add -
# echo "deb https://download.sublimetext.com/ apt/stable/" | tee /etc/apt/sources.list.d/sublime-text.list
# apt install apt-transport-https
# apt update
# apt install sublime-text



O comando Su - não funciona sendo que a senha está correta. Mas entrei pelo SUDO SU.
Após o primeiro comando fica assim por muito tempo é normal?

[email protected]:~$ wget -qO - https://download.sublimetext.com/sublimehq-pub.gpg">https://download.sublimetext.com/sublimehq-pub.gpg">https://download.sublimetext.com/sublimehq-pub.gpg">https://download.sublimetext.com/sublimehq-pub.gpg | apt-key add -
>



10. Re: Não consigo instalar o Sublime

11. Re: Não consigo instalar o Sublime

Shmuel Rothschild Trachtenberg
shmuelrothschild

(usa Debian)

Enviado em 20/11/2020 - 19:34h



Não está funcionando, veja:

[email protected]:~$ wget -qO - https://download.sublimetext.com/">https://download.sublimetext.com/sublimehq-pub.gpg">https://download.sublimetext.com/">https://download.sublimetext.com/sublimehq-pub.gpg | sudo apt-key add -
[sudo] senha para shmuelroth:
OK
[email protected]:~$ wget -qO - https://download.sublimetext.com/">https://download.sublimetext.com/sublimehq-pub.gpg">https://download.sublimetext.com/">https://download.sublimetext.com/sublimehq-pub.gpg | sudo apt-key add -
OK
[email protected]:~$ echo "deb https://download.sublimetext.com/">https://download.sublimetext.com/ apt/stable/" | sudo tee /etc/apt/sources.list.d/sublime-text.list
deb https://download.sublimetext.com/">https://download.sublimetext.com/ apt/stable/
[email protected]:~$ sudo apt-get update
Atingido:1 http://security.debian.org/debian-security buster/updates InRelease
Atingido:2 http://deb.debian.org/debian buster InRelease
Obter:3 http://deb.debian.org/debian buster-updates InRelease [51,9 kB]
Ign:4 http://ppa.launchpad.net/webupd8team/sublime-text-3/ubuntu hirsute InRelease
Err:5 http://ppa.launchpad.net/webupd8team/sublime-text-3/ubuntu hirsute Release
404 Not Found [IP: 2001:67c:1560:8008::15 80]
Obter:6 https://download.sublimetext.com apt/stable/ InRelease [2.562 B]
Obter:7 https://download.sublimetext.com apt/stable/ Packages [1.026 B]
Lendo listas de pacotes... Pronto
E: The repository 'http://ppa.launchpad.net/webupd8team/sublime-text-3/ubuntu hirsute Release' does not have a Release file.
N: Updating from such a repository can't be done securely, and is therefore disabled by default.
N: See apt-secure(8) manpage for repository creation and user configuration details.
W: Target Packages (Packages) is configured multiple times in /etc/apt/sources.list.d/sublime-text.list:1 and /etc/apt/sources.list.d/sublimetext.list:1
W: Target Translations (pt_BR) is configured multiple times in /etc/apt/sources.list.d/sublime-text.list:1 and /etc/apt/sources.list.d/sublimetext.list:1
W: Target Translations (pt) is configured multiple times in /etc/apt/sources.list.d/sublime-text.list:1 and /etc/apt/sources.list.d/sublimetext.list:1
W: Target Translations (en) is configured multiple times in /etc/apt/sources.list.d/sublime-text.list:1 and /etc/apt/sources.list.d/sublimetext.list:1
W: Target Packages (Packages) is configured multiple times in /etc/apt/sources.list.d/sublime-text.list:1 and /etc/apt/sources.list.d/sublimetext.list:1
W: Target Translations (pt_BR) is configured multiple times in /etc/apt/sources.list.d/sublime-text.list:1 and /etc/apt/sources.list.d/sublimetext.list:1
W: Target Translations (pt) is configured multiple times in /etc/apt/sources.list.d/sublime-text.list:1 and /etc/apt/sources.list.d/sublimetext.list:1
W: Target Translations (en) is configured multiple times in /etc/apt/sources.list.d/sublime-text.list:1 and /etc/apt/sources.list.d/sublimetext.list:1
[email protected]:~$ apt-get install sublime-text
E: Não foi possível abrir arquivo de trava /var/lib/dpkg/lock-frontend - open (13: Permissão negada)
E: Unable to acquire the dpkg frontend lock (/var/lib/dpkg/lock-frontend), are you root?
[email protected]:~$



12. Re: Não consigo instalar o Sublime

edps
edps

(usa Slackware)

Enviado em 20/11/2020 - 19:54h


Caso não consiga instalar via gerenciador de pacotes, vai de modo manual:


$ cd
$ wget https://download.sublimetext.com/sublime_text_3_build_3211_x64.tar.bz2
$ tar xf sublime_text_3_build_3211_x64.tar.bz2; rm -fv sublime_text_3_build_3211_x64.tar.bz2
$ cd sublime_text_3
$ ./sublime_text


Isso apenas para testar, se gostar pode ajustar as coisas e deixá-las de modo decente.

O Sr. edita o arquivo sublime_text.desktop contido nesta pasta e deixa-o assim:


[Desktop Entry]
Version=1.0
Type=Application
Name=Sublime Text
GenericName=Text Editor
Comment=Sophisticated text editor for code, markup and prose
Exec=/home/edps/sublime_text_3/sublime_text %F
Terminal=false
MimeType=text/plain;
Icon=sublime-text
Categories=TextEditor;Development;
StartupNotify=true
Actions=Window;Document;

[Desktop Action Window]
Name=New Window
Exec=/home/edps/sublime_text_3/sublime_text -n
OnlyShowIn=Unity;

[Desktop Action Document]
Name=New File
Exec=/home/edps/sublime_text_3/sublime_text --command new_file
OnlyShowIn=Unity;


Basta substituir o tal do "edps" acima pelo seu nome de usuário.

Em seguida e não menos importante, copie ou mova o tal arquivo .desktop para ~/.local/share/applications:

$ cp sublime_text.desktop ~/.local/share/applications 


Isso fará com que o ícone do tal programa seja visto em Menu/Desenvolvimento.

Divirta-se!




01 02