Make bzImage impossivel

1. Make bzImage impossivel

William Marques
williamarques

(usa Debian)

Enviado em 25/02/2017 - 21:11h

~/chronos/linux-3.0.24-chromos# sudo make bzImage
/root/chronos/linux-3.0.24-chromos/arch/x86/Makefile:81: stack protector enabled but no compiler support
make: chronosgcc: Comando não encontrado
CHK include/linux/version.h
CHK include/generated/utsrelease.h
CC kernel/bounds.s
/bin/sh: 1: chronosgcc: not found
/root/chronos/linux-3.0.24-chromos/./Kbuild:35: recipe for target 'kernel/bounds.s' failed
make[1]: *** [kernel/bounds.s] Error 127
Makefile:985: recipe for target 'prepare0' failed
make: *** [prepare0] Error 2


nao consigo passa dessa etapa... oque devo fazer pessoal?


  


2. Re: Make bzImage impossivel

Josue de Jesus Santos
JJSantos

(usa Gentoo)

Enviado em 25/02/2017 - 23:20h

Pode postar todo o procedimento que você fez até aí, e postar o código com indentação.


3. Re: Make bzImage impossivel

William Marques
williamarques

(usa Debian)

Enviado em 27/02/2017 - 06:03h

JJSantos escreveu:

Pode postar todo o procedimento que você fez até aí, e postar o código com indentação.


O amigo vou deixa o guia de instalação fica mais facil pra vê

http://chronoslinux.org/wiki/Installation_Guide

Fiz tudo isso, so nao consigo da o make bzImage... ta difícil


4. Re: Make bzImage impossivel

Josue de Jesus Santos
JJSantos

(usa Gentoo)

Enviado em 27/02/2017 - 08:44h

Tem o gcc instalado, se sim qual versão?


5. Re: Make bzImage impossivel

William Marques
williamarques

(usa Debian)

Enviado em 27/02/2017 - 13:12h

JJSantos escreveu:

Tem o gcc instalado, se sim qual versão?


Tenho sim amigo, nao sei te dizer qual versão precisamente... mas e 6.0 ou alguma coisa... estou no trabalho agora



6. Re: Make bzImage impossivel

Josue de Jesus Santos
JJSantos

(usa Gentoo)

Enviado em 27/02/2017 - 15:28h

williamarques escreveu:


~/chronos/linux-3.0.24-chromos# sudo make bzImage
/root/chronos/linux-3.0.24-chromos/arch/x86/Makefile:81: stack protector enabled but no compiler support
make: chronosgcc: Comando não encontrado
CHK include/linux/version.h
CHK include/generated/utsrelease.h
CC kernel/bounds.s
/bin/sh: 1: chronosgcc: not found
/root/chronos/linux-3.0.24-chromos/./Kbuild:35: recipe for target 'kernel/bounds.s' failed
make[1]: *** [kernel/bounds.s] Error 127
Makefile:985: recipe for target 'prepare0' failed
make: *** [prepare0] Error 2


nao consigo passa dessa etapa... oque devo fazer pessoal?


Faça a gentileza de postas as informações abaixo.

$ sudo history
$ uname -a
$ ls /usr/src/
$ sudo dpkg --get-selections | grep build-essential
$ sudo dpkg --get-selections | grep libncurses5-dev
$ sudo dpkg --get-selections | grep gcc
$ sudo dpkg --get-selections | grep make
$ sudo dpkg --get-selections | grep autoconf



7. Re: Make bzImage impossivel

William Marques
williamarques

(usa Debian)

Enviado em 27/02/2017 - 22:02h

JJSantos escreveu:

williamarques escreveu:


~/chronos/linux-3.0.24-chromos# sudo make bzImage
/root/chronos/linux-3.0.24-chromos/arch/x86/Makefile:81: stack protector enabled but no compiler support
make: chronosgcc: Comando não encontrado
CHK include/linux/version.h
CHK include/generated/utsrelease.h
CC kernel/bounds.s
/bin/sh: 1: chronosgcc: not found
/root/chronos/linux-3.0.24-chromos/./Kbuild:35: recipe for target 'kernel/bounds.s' failed
make[1]: *** [kernel/bounds.s] Error 127
Makefile:985: recipe for target 'prepare0' failed
make: *** [prepare0] Error 2


nao consigo passa dessa etapa... oque devo fazer pessoal?


Faça a gentileza de postas as informações abaixo.

$ sudo history
$ uname -a
$ ls /usr/src/
$ sudo dpkg --get-selections | grep build-essential
$ sudo dpkg --get-selections | grep libncurses5-dev
$ sudo dpkg --get-selections | grep gcc
$ sudo dpkg --get-selections | grep make
$ sudo dpkg --get-selections | grep autoconf



root@SEC-REBOT:~# sudo history
sudo: history: comando não encontrado
root@SEC-REBOT:~# uname -a
Linux SEC-REBOT 4.9.0-kali2-amd64 #1 SMP Debian 4.9.10-1kali1 (2017-02-20) x86_64 GNU/Linux
root@SEC-REBOT:~# ls /usr/src/
linux-headers-4.8.0-kali2-amd64 linux-kbuild-4.8
linux-headers-4.8.0-kali2-common linux-kbuild-4.9
linux-headers-4.9.0-kali2-amd64 virtualbox-5.1.12
linux-headers-4.9.0-kali2-common volatility-tools
root@SEC-REBOT:~# sudo dpkg --get-selections | grep build-essential
build-essential install
root@SEC-REBOT:~# sudo dpkg --get-selections | grep libncurses5-dev
libncurses5-dev:amd64 install
root@SEC-REBOT:~# sudo dpkg --get-selections | grep gcc
gcc install
gcc-4.8-base:amd64 install
gcc-4.9-base:amd64 install
gcc-5 install
gcc-5-base:amd64 install
gcc-6 install
gcc-6-base:amd64 install
gcc-mingw-w64-base install
gcc-mingw-w64-i686 install
gccxml install
libgcc-5-dev:amd64 install
libgcc-6-dev:amd64 install
libgcc1:amd64 install
linux-compiler-gcc-5-x86 install
linux-compiler-gcc-6-x86 install
root@SEC-REBOT:~# sudo dpkg --get-selections | grep make
make install
qt4-qmake install
root@SEC-REBOT:~# sudo dpkg --get-selections | grep autoconf
root@SEC-REBOT:~#




8. Re: Make bzImage impossivel

Josue de Jesus Santos
JJSantos

(usa Gentoo)

Enviado em 27/02/2017 - 22:17h

williamarques escreveu:

JJSantos escreveu:

williamarques escreveu:


~/chronos/linux-3.0.24-chromos# sudo make bzImage
/root/chronos/linux-3.0.24-chromos/arch/x86/Makefile:81: stack protector enabled but no compiler support
make: chronosgcc: Comando não encontrado
CHK include/linux/version.h
CHK include/generated/utsrelease.h
CC kernel/bounds.s
/bin/sh: 1: chronosgcc: not found
/root/chronos/linux-3.0.24-chromos/./Kbuild:35: recipe for target 'kernel/bounds.s' failed
make[1]: *** [kernel/bounds.s] Error 127
Makefile:985: recipe for target 'prepare0' failed
make: *** [prepare0] Error 2


nao consigo passa dessa etapa... oque devo fazer pessoal?


Faça a gentileza de postas as informações abaixo.

$ sudo history
$ uname -a
$ ls /usr/src/
$ sudo dpkg --get-selections | grep build-essential
$ sudo dpkg --get-selections | grep libncurses5-dev
$ sudo dpkg --get-selections | grep gcc
$ sudo dpkg --get-selections | grep make
$ sudo dpkg --get-selections | grep autoconf



root@SEC-REBOT:~# sudo history
sudo: history: comando não encontrado
Veja bem no primeiro post você estava escalando privilégios com [sudo], não faz sentido você tentar escalar privilégios
se você já está logado como [root]


Não vai funcionar, este pacote que você quer compilar não está disponível para este [kernel], outro sim
ele foi destinado a uso no Ubuntu, se tivesse informado no principio que se tratava do Kali e não do Ubuntu, já
haveríamos encerrado.

root@SEC-REBOT:~# uname -a
Linux SEC-REBOT 4.9.0-kali2-amd64 #1 SMP Debian 4.9.10-1kali1 (2017-02-20) x86_64 GNU/Linux
root@SEC-REBOT:~# ls /usr/src/
linux-headers-4.8.0-kali2-amd64 linux-kbuild-4.8
linux-headers-4.8.0-kali2-common linux-kbuild-4.9
linux-headers-4.9.0-kali2-amd64 virtualbox-5.1.12
linux-headers-4.9.0-kali2-common volatility-tools

root@SEC-REBOT:~# sudo dpkg --get-selections | grep build-essential
build-essential install
root@SEC-REBOT:~# sudo dpkg --get-selections | grep libncurses5-dev
libncurses5-dev:amd64 install
root@SEC-REBOT:~# sudo dpkg --get-selections | grep gcc
gcc install
gcc-4.8-base:amd64 install
gcc-4.9-base:amd64 install
gcc-5 install
gcc-5-base:amd64 install
gcc-6 install
gcc-6-base:amd64 install
gcc-mingw-w64-base install
gcc-mingw-w64-i686 install
gccxml install
libgcc-5-dev:amd64 install
libgcc-6-dev:amd64 install
libgcc1:amd64 install
linux-compiler-gcc-5-x86 install
linux-compiler-gcc-6-x86 install
root@SEC-REBOT:~# sudo dpkg --get-selections | grep make
make install
qt4-qmake install
root@SEC-REBOT:~# sudo dpkg --get-selections | grep autoconf
root@SEC-REBOT:~#




Veja as respostas em negritos, e leia manpage do projeto:
http://chronoslinux.org/wiki/Downloading_ChronOS_Linux
http://chronoslinux.org/wiki/Installation_Guide
http://chronoslinux.org/wiki/Main_Page



The current stable version of ChronOS is ChronOS 3.0 which is based on Linux kernel 3.0.24 and the CONFIG_PREEMPT_RT patch.
Try out our new beta version of ChronOS ChronOS 3.4.1 which is based on Linux kernel 3.4.82




9. Re: Make bzImage impossivel

William Marques
williamarques

(usa Debian)

Enviado em 28/02/2017 - 07:02h

JJSantos escreveu:

williamarques escreveu:

JJSantos escreveu:

williamarques escreveu:


~/chronos/linux-3.0.24-chromos# sudo make bzImage
/root/chronos/linux-3.0.24-chromos/arch/x86/Makefile:81: stack protector enabled but no compiler support
make: chronosgcc: Comando não encontrado
CHK include/linux/version.h
CHK include/generated/utsrelease.h
CC kernel/bounds.s
/bin/sh: 1: chronosgcc: not found
/root/chronos/linux-3.0.24-chromos/./Kbuild:35: recipe for target 'kernel/bounds.s' failed
make[1]: *** [kernel/bounds.s] Error 127
Makefile:985: recipe for target 'prepare0' failed
make: *** [prepare0] Error 2


nao consigo passa dessa etapa... oque devo fazer pessoal?


Faça a gentileza de postas as informações abaixo.

$ sudo history
$ uname -a
$ ls /usr/src/
$ sudo dpkg --get-selections | grep build-essential
$ sudo dpkg --get-selections | grep libncurses5-dev
$ sudo dpkg --get-selections | grep gcc
$ sudo dpkg --get-selections | grep make
$ sudo dpkg --get-selections | grep autoconf



root@SEC-REBOT:~# sudo history
sudo: history: comando não encontrado
Veja bem no primeiro post você estava escalando privilégios com [sudo], não faz sentido você tentar escalar privilégios
se você já está logado como [root]


Não vai funcionar, este pacote que você quer compilar não está disponível para este [kernel], outro sim
ele foi destinado a uso no Ubuntu, se tivesse informado no principio que se tratava do Kali e não do Ubuntu, já
haveríamos encerrado.

root@SEC-REBOT:~# uname -a
Linux SEC-REBOT 4.9.0-kali2-amd64 #1 SMP Debian 4.9.10-1kali1 (2017-02-20) x86_64 GNU/Linux
root@SEC-REBOT:~# ls /usr/src/
linux-headers-4.8.0-kali2-amd64 linux-kbuild-4.8
linux-headers-4.8.0-kali2-common linux-kbuild-4.9
linux-headers-4.9.0-kali2-amd64 virtualbox-5.1.12
linux-headers-4.9.0-kali2-common volatility-tools

root@SEC-REBOT:~# sudo dpkg --get-selections | grep build-essential
build-essential install
root@SEC-REBOT:~# sudo dpkg --get-selections | grep libncurses5-dev
libncurses5-dev:amd64 install
root@SEC-REBOT:~# sudo dpkg --get-selections | grep gcc
gcc install
gcc-4.8-base:amd64 install
gcc-4.9-base:amd64 install
gcc-5 install
gcc-5-base:amd64 install
gcc-6 install
gcc-6-base:amd64 install
gcc-mingw-w64-base install
gcc-mingw-w64-i686 install
gccxml install
libgcc-5-dev:amd64 install
libgcc-6-dev:amd64 install
libgcc1:amd64 install
linux-compiler-gcc-5-x86 install
linux-compiler-gcc-6-x86 install
root@SEC-REBOT:~# sudo dpkg --get-selections | grep make
make install
qt4-qmake install
root@SEC-REBOT:~# sudo dpkg --get-selections | grep autoconf
root@SEC-REBOT:~#




Veja as respostas em negritos, e leia manpage do projeto:
http://chronoslinux.org/wiki/Downloading_ChronOS_Linux
http://chronoslinux.org/wiki/Installation_Guide
http://chronoslinux.org/wiki/Main_Page



The current stable version of ChronOS is ChronOS 3.0 which is based on Linux kernel 3.0.24 and the CONFIG_PREEMPT_RT patch.
Try out our new beta version of ChronOS ChronOS 3.4.1 which is based on Linux kernel 3.4.82




o amigao... desculpa minha ignorancia, entao no caso essa versao que estou tentando instalar e para ubunt, ou seja tenho que pega uma versao para linux... é existe essa versao certo?, a outra coisa caso nao de certo.. saberia me indica um outro real time



10. Re: Make bzImage impossivel

Josue de Jesus Santos
JJSantos

(usa Gentoo)

Enviado em 28/02/2017 - 12:20h

williamarques escreveu:
o amigao... desculpa minha ignorancia, entao no caso essa versao que estou tentando instalar e para ubunt, ou seja tenho que pega uma versao para linux... é existe essa versao certo?, a outra coisa caso nao de certo.. saberia me indica um outro real time




Ubuntu, Kali, Parrot, Arch, Slackware, OpenSuse tudo isso é GNU/Linux.
O que eu disse é que esse software que você quer instalar não vai funcionar pois não tem suporte ao kernel e ao headers do kernel que você está utilizando.
Outro sim este software é recomendado para uso no Ubuntu.

Resumo da ópera não vai funcionar no Kali, se quiser testar isto baixe o Debian, Ubuntu equivalente, instale os pacotes de compilação que citei aqui, compile o kernel recomendado pelo projeto, atualize as entradas do carregador de inicialização, de boot pelo kernel compilado, aplique o patch do projeto no kernel, depois compile o software e instale.
Basicamente é isso!




11. Re: Make bzImage impossivel

William Marques
williamarques

(usa Debian)

Enviado em 28/02/2017 - 15:29h

JJSantos escreveu:

williamarques escreveu:
o amigao... desculpa minha ignorancia, entao no caso essa versao que estou tentando instalar e para ubunt, ou seja tenho que pega uma versao para linux... é existe essa versao certo?, a outra coisa caso nao de certo.. saberia me indica um outro real time




Ubuntu, Kali, Parrot, Arch, Slackware, OpenSuse tudo isso é GNU/Linux.
O que eu disse é que esse software que você quer instalar não vai funcionar pois não tem suporte ao kernel e ao headers do kernel que você está utilizando.
Outro sim este software é recomendado para uso no Ubuntu.

Resumo da ópera não vai funcionar no Kali, se quiser testar isto baixe o Debian, Ubuntu equivalente, instale os pacotes de compilação que citei aqui, compile o kernel recomendado pelo projeto, atualize as entradas do carregador de inicialização, de boot pelo kernel compilado, aplique o patch do projeto no kernel, depois compile o software e instale.
Basicamente é isso!




obrigado amigao... tiro todas minhas duvidas.







Patrocínio

Site hospedado pelo provedor RedeHost.
Linux banner
Linux banner
Linux banner

Destaques

Artigos

Dicas

Tópicos

Top 10 do mês

Scripts