Instalar pacotes [RESOLVIDO]

1. Instalar pacotes [RESOLVIDO]

Leandro
leandrocastor

(usa Debian)

Enviado em 28/06/2011 - 16:28h

Estou utilizando o debian 6 e ao executar o comando abaixo:

apt-get install libapache2-mod-auth-mysql php5-mysql phpmyadmin

(Aparece a seguinte mensagem):

Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
php5-mysql : Depends: libmysqlclient16 (>= 5.1.21-1) but it is not installable
phpmyadmin : Depends: php5-mcrypt but it is not going to be installed
Depends: libjs-mootools (>= 1.2.4.0~debian1-1) but it is not installable
E: Broken packages

(O Meu sourcelist):

# deb cdrom:[Debian GNU/Linux 6.0.0 _Squeeze_ - Official i386 DVD Binary-1 20110205-17:27]/ squeeze contrib main



#deb cdrom:[Debian GNU/Linux 6.0.0 _Squeeze_ - Official i386 DVD Binary-1 20110205-17:27]/ squeeze contrib main

deb http://sft.if.usp.br/debian/ lenny main contrib non-free
deb-src http://sft.if.usp.br/debian/ lenny main

deb http://security.debian.org/ lenny/updates main contrib
deb-src http://security.debian.org/ lenny/updates main contrib



# Line commented out by installer because it failed to verify:
#deb http://security.debian.org/ squeeze/updates main contrib
# Line commented out by installer because it failed to verify:
#deb-src http://security.debian.org/ squeeze/updates main contrib



deb http://security.debian.org/ stable/updates main non-free contrib
deb http://security.debian.org/ stable/updates main contrib

deb http://www.backports.org/debian sarge-backports main contrib non-free



# Line commented out by installer because it failed to verify:
#deb ://volatile.debian.org squeeze-updates main contrib
# Line commented out by installer because it failed to verify:
#deb-src ://volatile.debian.org squeeze-updates main contrib





  


2. Re: Instalar pacotes [RESOLVIDO]

Eriton Almeida
eritonalmeida

(usa Debian)

Enviado em 28/06/2011 - 16:31h

já tentou apt-get -f install, para corrigir as dependencias?


3. Re: Instalar pacotes [RESOLVIDO]

Leandro
leandrocastor

(usa Debian)

Enviado em 28/06/2011 - 16:48h

Tentei agora e deu a mesma mensagem:


[email protected]:~# apt-get -f install libapache2-mod-auth-mysql php5-mysql phpmyadmin
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
php5-mysql : Depends: libmysqlclient16 (>= 5.1.21-1) but it is not installable
phpmyadmin : Depends: php5-mcrypt but it is not going to be installed
Depends: libjs-mootools (>= 1.2.4.0~debian1-1) but it is not installable
E: Broken packages



4. Re: Instalar pacotes [RESOLVIDO]

Ricardo Libanio
riesdra

(usa Debian)

Enviado em 28/06/2011 - 20:44h

Leandro,

você menciona usar debian 6, e seu sources busca lenny que é 5 sarge que se não me engano é 3,
a unica coisa que vi ali buscando o squeeze é o repositório de segurança.

faz uma coisa altere seu source por este abaixo, depois de um update e tente fazer a instalação.

deb http://ftp.br.debian.org/debian/ squeeze main contrib non-free
deb-src http://ftp.br.debian.org/debian/ squeeze main contrib non-free
deb http://security.debian.org/ squeeze/updates main contrib non-free
deb http://ftp.br.debian.org/debian/ squeeze-proposed-updates main contrib non-free
deb-src http://security.debian.org/ squeeze/updates main contrib non-free
deb-src http://ftp.br.debian.org/debian/ squeeze-proposed-updates main contrib non-free
deb http://backports.debian.org/debian-backports squeeze-backports main
deb http://www.debian-multimedia.org stable main non-free

poste o resultado depois.


5. Re: Instalar pacotes [RESOLVIDO]

j g meinhardt
meinhardt_jgbr

(usa Debian)

Enviado em 28/06/2011 - 22:53h

Tem um outro post em resposta a pergunta a respeito dos repositórios ideais para o Debian Squeeze, onde o companheiro edps (Edinaldo) faz algumas sugestões bem interessantes com referencia a listas dos repositórios a usar e novo conteúdo para o arquivo /etc/sources.list
O ponto muito interessante no sources.list sugerido está na inclusão dos comandos e endereços necessários para carregar as chaves publicas (pubkey) de cada um dos repositórios. Basta dar uma busca por repositórios para Debian Squeeze aqui no VOL e devem aparecer não só a sugestão do edps como outras.


6. boa noite pessoal

Perfil removido
removido

(usa Nenhuma)

Enviado em 28/06/2011 - 23:18h

esse é o sources.list que uso (parte dele rsrss):

### Debian 6.0.1a Squeeze/Stable.
### ------------------------------
### Chave GPG: sudo apt-get install debian-archive-keyring debian-keyring
### deb cdrom:[Debian GNU/Linux 6.0.1a _Squeeze_ - Official i386 CD Binary-1 20110322-15:11]/ squeeze main
deb http://mirrors.geeks.org/debian/">http://mirrors.geeks.org/debian/ squeeze main contrib non-free
deb http://mirror.rit.edu/debian/">http://mirror.rit.edu/debian/ squeeze main contrib non-free

### Debian 6.0.1a Squeeze/Stable 'Updates'.
deb http://security.debian.org/ squeeze/updates main contrib non-free
deb http://ftp.br.debian.org/debian-security/ squeeze/updates main contrib non-free

### Debian 6.0.1a Squeeze/Stable 'Volatile'.
deb http://mirrors.geeks.org/debian/">http://mirrors.geeks.org/debian/ squeeze-updates main contrib non-free
deb http://mirror.rit.edu/debian/">http://mirror.rit.edu/debian/ squeeze-updates main contrib non-free

### Debian 6.0.1a Squeeze/Stable 'Proposed Updates'.
### deb http://mirrors.geeks.org/debian/">http://mirrors.geeks.org/debian/ squeeze-proposed-updates main contrib non-free
### deb http://mirror.rit.edu/debian/">http://mirror.rit.edu/debian/ squeeze-proposed-updates main contrib non-free

### Debian 6.0.1a Squeeze/Stable 'Backports'.
### Chave GPG: gpg --keyserver hkp://subkeys.pgp.net --recv-keys 16BA136C && gpg --export 16BA136C | apt-key add -
deb http://backports.debian.org/debian-backports squeeze-backports main contrib non-free
deb http://ftp.br.debian.org/debian-backports/ squeeze-backports main contrib non-free

### Debian 6.0.1a Squeeze/Stable 'Multimedia'.
### Chave GPG: apt-get update && apt-get install debian-multimedia-keyring && apt-get update
deb http://www.debian-multimedia.org squeeze main non-free
deb http://ftp.br.debian.org/debian-multimedia squeeze main non-free


onde lê-se:

deb http://mirrors.geeks.org/debian
deb http://mirror.rit.edu/debian

é porque são os mirrors mais rápidos para mim, caso queiram basta adaptar pelo padrão ( http://ftp.br.debian.org/debian/ ) ou se quiserem testar o mais rápido para vocês:

$ sudo apt-get install netselect-apt
$ sudo netselect-apt --arch <arquitetura> --nonfree --outfile sources.list squeeze

* daí copiem o arquivo gerado para seu sources.list

** exemplo nessa screenshot:

http://www.vivaolinux.com.br/screenshot/Gnome-Dica-de-Espelho-para-Debian/


Observações:

ontem as mídias do Debian Squeeze foram atualizadas, agora é Squeeze 6.0.2.

O Debian já adotou o LibreOffice em detrimento ao OpenOffice, para obtê-lo no Debian Squeeze basta deixar o repositório Debian Backports aivado e instalar assim:

$ sudo apt-get -t squeeze-backports nstall libreoffice libreoffice-l10n-pt-br

ou se quiserem incrementar mais:

$ sudo apt-get -t squeeze-backports install aspell-pt-br myspell-pt-br ibrazilian iportuguese wportuguese libreoffice libreoffice-l10n-pt-br


para o caso do kernel 2.6.38 do Debian Backports talvez seja necessário atualizar o GCC pelo do Debian Testing, caso eu não esteja enganado é requerimento do linux-headers, para instalar o kernel do Backports:

$ sudo apt-get -t squeeze-backports install linux-image-2.6.38-bpo.2-ARQUITETURA linux-headers-2.6.38-bpo.2-ARQUITETURA



7. Re: Instalar pacotes [RESOLVIDO]

j g meinhardt
meinhardt_jgbr

(usa Debian)

Enviado em 28/06/2011 - 23:57h

O Edinaldo foi rápido no gatilho e até poupou a você o trabalho de fazer a busca e ler o conteúdo dos posts. Basta seguir as dicas acima e o problema deve ser resolvido. Tenho usado o mesmo sources.list sugerido pelo Edinaldo e não apareceram mais as mensagens de erro anteriores, logico que depois de fazer a inclusão das chaves publicas necessárias.


8. Re: Instalar pacotes [RESOLVIDO]

Leandro
leandrocastor

(usa Debian)

Enviado em 29/06/2011 - 09:42h

Perfeito pessoal agora deu certo , obrigado pela agilidade nas respostas.


9. Re: Instalar pacotes [RESOLVIDO]

Perfil removido
removido

(usa Nenhuma)

Enviado em 06/07/2011 - 18:07h

Lendo listas de pacotes... Pronto
W: Erro GPG: http://ftp.br.debian.org squeeze Release: As assinaturas a seguir não puderam ser verificadas devido à chave pública não estar disponível: NO_PUBKEY 07DC563D1F41B907
W: Erro GPG: http://www.debian-multimedia.org squeeze Release: As assinaturas a seguir não puderam ser verificadas devido à chave pública não estar disponível: NO_PUBKEY 07DC563D1F41B907
[email protected]:/home/ricardo#
não consigo resolver esse problema podem me ajudar ok


10. @rmixirica

Perfil removido
removido

(usa Nenhuma)

Enviado em 06/07/2011 - 18:19h

são 3 passos simples:

# apt-get update
# apt-get install debian-archive-keyring debian-keyring debian-multimedia-keyring -y --force-yes
# apt-get update

da próxima vez abra um tópico a respeito!


11. Re: Instalar pacotes [RESOLVIDO]

Perfil removido
removido

(usa Nenhuma)

Enviado em 06/07/2011 - 18:28h

Desculpe mas sou novo no mundo Debian ok, ainda está dando

[email protected]:/home/ricardo# apt-get install debian-archive-keyring debian-keyring debian-multimedia-keyring -y --force-yes
Lendo listas de pacotes... Pronto
Construindo árvore de dependências
Lendo informação de estado... Pronto
debian-archive-keyring já é a versão mais nova.
Você deve querer executar 'apt-get -f install' para corrigí-los:
Os pacotes a seguir têm dependências desencontradas:
google-chrome-unstable : Depende: libcurl3 mas não será instalado
E: Dependências desencontradas. Tente 'apt-get -f install' sem nenhum pacote (ou especifique uma solução).
[email protected]:/home/ricardo#


12. sempre tem um caroço no angú...

Perfil removido
removido

(usa Nenhuma)

Enviado em 06/07/2011 - 19:01h

O sistema diz que você está tentando instalar o Google Chrome que tem como dependência a ' libcurl3 '

e isso impede os passos que passei para você, sugestão:

remova o ' google-chrome-unstable '

# apt-get --purge remove google-chrome-unstable
# apt-get autoremove --purge

ou faça o que o sistema lhe orienta:

# apt-get -f install
# apt-get install libcurl3


E se quiser instale o Chromium que já existe nos repositórios Debian:

# apt-get install chromium-browser chromium-browser-l10n



01 02