Erro em linkagem de biblioteca [RESOLVIDO]

1. Erro em linkagem de biblioteca [RESOLVIDO]

Zephyrus (formerly mkmastersys)
Zephyr

(usa Outra)

Enviado em 30/12/2014 - 07:52h

Bom dia.

Estou usando uma distribuição linux baseada no Debian.
A distro se chama SparkyLinux.

Segue abaixo dados da versão:

#################################################################
Distributor ID: Debian
Description: Debian GNU/Linux testing (jessie)
Release: testing
Codename: jessie

Linux 3.10-3-486 #1 Debian 3.10.11-1 (2013-09-10) i686 GNU/Linux
##################################################################

O problema que estou tendo é o seguinte:

Quando tento executar o nmap, doscan e alguns outros programas recebo a seguinte mensagem de erro:


Inconsistency detected by ld.so: dl-version.c: 224: _dl_check_map_versions: Assertion `needed != ((void *)0)' failed!

Já procurei no google e em vários outros sites a solução. Encontrei vários que afirmam(ram) ter o mesmo problema. Aqui mesmo no vivaolinux encontrei um tópico narrando o mesmo problema.

Infelizmente nenhuma das soluções apresentadas funcionaram para mim até agora. Mesmo as soluções que foram efetivas para outros usuários não funcionaram no meu sistema.

Se alguém souber de algo que possa me ajudar eu agradeço.

Desde já agradeço a atenção de vocês.

Até mais.


  


2. Re: Erro em linkagem de biblioteca [RESOLVIDO]

Buckminster
buckminster

(usa Debian)

Enviado em 30/12/2014 - 08:11h

Tua placa de vídeo é Nvídia?

O tópico que tu vistes é este?

http://www.vivaolinux.com.br/topico/Nmap/Erro-ao-executar-Nmap


3. Re: Erro em linkagem de biblioteca [RESOLVIDO]

Zephyrus (formerly mkmastersys)
Zephyr

(usa Outra)

Enviado em 30/12/2014 - 08:30h

buckminster escreveu:

Tua placa de vídeo é Nvídia?

O tópico que tu vistes é este?

http://www.vivaolinux.com.br/topico/Nmap/Erro-ao-executar-Nmap


Exato.

Foi este tópico mesmo. A solução encontrada pelo @ivanofx não funcionou por aqui. Fiz o redirecionameto da $LD_LIBRARY_PATH, verifiquei os pacotes instalados, e fiz outras dicas apresentadas mas até o momento não consegui um solução.

Vou continuar tentando.



4. Re: Erro em linkagem de biblioteca [RESOLVIDO]

Geraldo Albuquerque
aprendinolinux

(usa Ubuntu)

Enviado em 30/12/2014 - 09:49h

Dúvida: @mkmastersys , foi você que fez a compilação dos pacotes ?

Caso não esteja fazendo a compilação dos pacotes, pode tentar baixar novamente ?

O Debian parece que congelou as versões esta semana.
Deixe-me saber.

ps: Falo destes pacotes via Debian ok ?


5. Re: Erro em linkagem de biblioteca [RESOLVIDO]

Buckminster
buckminster

(usa Debian)

Enviado em 30/12/2014 - 13:49h

Tua placa de vídeo é Nvídia?


6. Solução

Zephyrus (formerly mkmastersys)
Zephyr

(usa Outra)

Enviado em 01/01/2015 - 19:14h

Boa tarde colegas.

Acabei encontrando a solução depois de tanto fuçar. :=D

Solução:

Atualizei várias bibliotecas e pacotes via apt-get. Atualizei os pacotes do apache2 e com toda a atualização a biblioteca do libpcre3 também foi reinstalada/atualizada.
O próprio sistema refez as linkagens e como por milagre os erros sumiram...

Valeu aos colegas que deram atenção ao problema.

Até mais.






Patrocínio

Site hospedado pelo provedor RedeHost.
Linux banner
Linux banner

Destaques

Artigos

Dicas

Tópicos

Top 10 do mês

Scripts