Erro ao executar sudo apt-get update no Debian [RESOLVIDO]

1. Erro ao executar sudo apt-get update no Debian [RESOLVIDO]

Welllington Moreno
wellingtonmoreno

(usa Debian)

Enviado em 25/12/2013 - 16:22h

Quando dou sudo apt-get update no Debian Wheezy 64 bits, exibe isso:
No final do apt-get exibe alguns erros que não sei eliminar

root@debian:/home/luciane# sudo apt-get update
Atingido http://ftp.br.debian.org wheezy Release.gpg
Atingido http://security.debian.org wheezy/updates Release.gpg
Atingido http://ftp.br.debian.org wheezy-updates Release.gpg
Atingido http://security.debian.org wheezy/updates Release
Atingido http://ftp.br.debian.org wheezy Release
Atingido http://security.debian.org wheezy/updates/main Sources
Atingido http://ftp.br.debian.org wheezy-updates Release
Ign http://ppa.launchpad.net wheezy Release.gpg
Atingido http://security.debian.org wheezy/updates/contrib Sources
Atingido http://ftp.br.debian.org wheezy/main Sources
Atingido http://security.debian.org wheezy/updates/non-free Sources
Atingido http://ftp.br.debian.org wheezy/non-free Sources
Atingido http://security.debian.org wheezy/updates/main amd64 Packages
Atingido http://ftp.br.debian.org wheezy/contrib Sources
Atingido http://security.debian.org wheezy/updates/contrib amd64 Packages
Atingido http://ftp.br.debian.org wheezy/main amd64 Packages
Atingido http://security.debian.org wheezy/updates/non-free amd64 Packages
Ign http://ppa.launchpad.net wheezy Release.gpg
Atingido http://ftp.br.debian.org wheezy/non-free amd64 Packages
Atingido http://security.debian.org wheezy/updates/main i386 Packages
Atingido http://ftp.br.debian.org wheezy/contrib amd64 Packages
Atingido http://security.debian.org wheezy/updates/contrib i386 Packages
Atingido http://ftp.br.debian.org wheezy/main i386 Packages
Atingido http://security.debian.org wheezy/updates/non-free i386 Packages
Atingido http://ftp.br.debian.org wheezy/non-free i386 Packages
Atingido http://security.debian.org wheezy/updates/contrib Translation-en
Ign http://ppa.launchpad.net wheezy Release
Atingido http://ftp.br.debian.org wheezy/contrib i386 Packages
Atingido http://security.debian.org wheezy/updates/main Translation-en
Atingido http://ftp.br.debian.org wheezy/contrib Translation-en
Atingido http://security.debian.org wheezy/updates/non-free Translation-en
Ign http://www.debian-multimedia.org sid Release.gpg
Atingido http://ftp.br.debian.org wheezy/main Translation-pt_BR
Atingido http://ftp.br.debian.org wheezy/main Translation-pt
Ign http://ppa.launchpad.net wheezy Release
Atingido http://ftp.br.debian.org wheezy/main Translation-en
Atingido http://ftp.br.debian.org wheezy/non-free Translation-en
Atingido http://ftp.br.debian.org wheezy-updates/main Sources
Atingido http://ftp.br.debian.org wheezy-updates/contrib Sources
Atingido http://ftp.br.debian.org wheezy-updates/non-free Sources
Atingido http://ftp.br.debian.org wheezy-updates/main amd64 Packages/DiffIndex
Atingido http://ftp.br.debian.org wheezy-updates/contrib amd64 Packages
Atingido http://ftp.br.debian.org wheezy-updates/non-free amd64 Packages
Atingido http://ftp.br.debian.org wheezy-updates/main i386 Packages/DiffIndex
Atingido http://ftp.br.debian.org wheezy-updates/contrib i386 Packages
Atingido http://ftp.br.debian.org wheezy-updates/non-free i386 Packages
Atingido http://ftp.br.debian.org wheezy-updates/contrib Translation-en
Atingido http://ftp.br.debian.org wheezy-updates/main Translation-en/DiffIndex
Atingido http://ftp.br.debian.org wheezy-updates/non-free Translation-en
Ign http://www.debian-multimedia.org sid Release
Err http://www.debian-multimedia.org sid/main amd64 Packages
404 Not Found
Ign http://www.debian-multimedia.org sid/main Translation-pt_BR
Err http://ppa.launchpad.net wheezy/main Sources
404 Not Found
Err http://ppa.launchpad.net wheezy/main amd64 Packages
404 Not Found
Err http://ppa.launchpad.net wheezy/main i386 Packages
404 Not Found
Ign http://ppa.launchpad.net wheezy/main Translation-pt_BR
Ign http://ppa.launchpad.net wheezy/main Translation-pt
Ign http://ppa.launchpad.net wheezy/main Translation-en
Err http://ppa.launchpad.net wheezy/main Sources
404 Not Found
Err http://ppa.launchpad.net wheezy/main amd64 Packages
404 Not Found
Err http://ppa.launchpad.net wheezy/main i386 Packages
404 Not Found
Ign http://ppa.launchpad.net wheezy/main Translation-pt_BR
Ign http://ppa.launchpad.net wheezy/main Translation-pt
Ign http://ppa.launchpad.net wheezy/main Translation-en
W: Falhou ao buscar http://ppa.launchpad.net/stebbins/handbrake-releases/ubuntu/dists/wheezy/main/source/Sources 404 Not Found

W: Falhou ao buscar http://ppa.launchpad.net/stebbins/handbrake-releases/ubuntu/dists/wheezy/main/binary-amd64/Packages 404 Not Found

W: Falhou ao buscar http://ppa.launchpad.net/stebbins/handbrake-releases/ubuntu/dists/wheezy/main/binary-i386/Packages 404 Not Found

W: Falhou ao buscar http://ppa.launchpad.net/venerix/pkg/ubuntu/dists/wheezy/main/source/Sources 404 Not Found

W: Falhou ao buscar http://ppa.launchpad.net/venerix/pkg/ubuntu/dists/wheezy/main/binary-amd64/Packages 404 Not Found

W: Falhou ao buscar http://ppa.launchpad.net/venerix/pkg/ubuntu/dists/wheezy/main/binary-i386/Packages 404 Not Found

W: Falhou ao buscar http://www.debian-multimedia.org/dists/sid/main/binary-amd64/Packages 404 Not Found

E: Falhou o download de alguns ficheiros de índice. Foram ignorados ou os antigos foram usados em seu lugar.
root@debian:/home/luciane#



  


2. Re: Erro ao executar sudo apt-get update no Debian [RESOLVIDO]

Leomar de Oliveira
leo CCB

(usa Slackware)

Enviado em 25/12/2013 - 18:50h

então cara, vc tá tentando usar o ubuntu que é um sistema operacional com o wheezy, que é debian, outro SO (Sistema Operacional)

http://ppa.launchpad.net/stebbins/handbrake-releases/ubuntu/dists/wheezy/main/binary-amd64/Packages

se vc visitar o link acima, vai ver que ele não existe, por isso dá erro;

Já se vc for em

ttp://ppa.launchpad.net/stebbins/handbrake-releases/ubuntu/dists/

vai ver que não existe a subpasta wheezy, mas sim outras (quantal, raring, etc, que são atualizações do ubuntu)

para resolver, basta em um terminal acessar o source.lst, (arquivo de endereços para atualizações) e editálo:

sudo SEUEDITOR /etc/apt/sources.lst

aconselho a usar a tecla TAB para autocompletar os comandos-endereços, pois não direito se é source ou sources

Quando entrar no editor de textos, basta deletar os endereços que dão erros ou comentá-los (colocar um sustenido # na frente)

Paz


3. Aqui esta minha sources.list

Welllington Moreno
wellingtonmoreno

(usa Debian)

Enviado em 25/12/2013 - 22:36h

# deb cdrom:[Debian GNU/Linux 7.2.0 _Wheezy_ - Official amd64 DVD Binary-1 20131012-14:05]/ wheezy contrib main
Não constam da sources.list os erros com ppa.launchpad.net
Eu acho que tem que excluir tambem mas não de onde
Segue abaixo minha sources.list completa:

deb http://ftp.br.debian.org/debian/ wheezy main non-free contrib
deb-src http://ftp.br.debian.org/debian/ wheezy main non-free contrib

deb http://security.debian.org/ wheezy/updates main contrib non-free
deb-src http://security.debian.org/ wheezy/updates main contrib non-free

# wheezy-updates, previously known as 'volatile'
deb http://ftp.br.debian.org/debian/ wheezy-updates main contrib non-free
deb-src http://ftp.br.debian.org/debian/ wheezy-updates main contrib non-free

deb http://www.debian-multimedia.org sid main



Exclui a linha agora essa abaixo no sources.list acima e diminuiu alguns erros:

deb http://www.debian-multimedia.org sid main

Mas ainda exibem algum erros

Entendi agora sobre as linhas sobre o Ubuntu
Acho que adicione erroneamente via terminal os comandos mas não sei como desfaze-las agora


4. Re: Erro ao executar sudo apt-get update no Debian [RESOLVIDO]

Carlos Adean
c4rl

(usa CentOS)

Enviado em 25/12/2013 - 23:27h

Esses repositórios costumam ficam num arquivo em separado dentro do diretório /etc/apt/sources.list.d/.

Então bastaria voce remover o arquivo deste diretório.

Uma opção mais elegante é você remover utilizando um dos aplicativos da família apt.

Sintaxe:
$ sudo add-apt-repository --remove ppa:<repositório>

Exemplo:
sudo add-apt-repository --remove ppa:jbicha/dev


Não esqueça que depois disso é preciso executar apt-get update.


Abc


5. Consegui (RESOLVIDO)

Welllington Moreno
wellingtonmoreno

(usa Debian)

Enviado em 06/01/2014 - 02:02h

Consegui arrumar
Topico encerrado






Patrocínio

Site hospedado pelo provedor RedeHost.
Linux banner
Linux banner
Linux banner

Destaques

Artigos

Dicas

Tópicos

Top 10 do mês

Scripts