[Erro] Erro ao instalar packages via APT

1. [Erro] Erro ao instalar packages via APT

elias weslley da silva ferreira
sudoweeb

(usa Debian)

Enviado em 12/12/2019 - 22:44h

Olá! recentemente estou tendo um erro que ocorre logo após de eu atualizar a distro, e isso não me permite mais instalar pacotes via apt.

exemplo:
usuario@polilinux:~$ sudo apt-get install synaptic
[sudo] senha para usuario:
Lendo listas de pacotes... Pronto
Construindo árvore de dependências
Lendo informação de estado... Pronto
Você pode querer executar 'apt --fix-broken install' para corrigí-los.
Os pacotes a seguir têm dependências desencontradas:
grub-efi-amd64 : Depende: grub-common (= 2.02~beta3-5+deb9u2) mas 2.02~beta3-5+deb9u1 está para ser instalado
grub-efi-amd64-bin : Depende: grub-common (= 2.02~beta3-5+deb9u2) mas 2.02~beta3-5+deb9u1 está para ser instalado
grub2-common : Depende: grub-common (= 2.02~beta3-5+deb9u2) mas 2.02~beta3-5+deb9u1 está para ser instalado
synaptic : Depende: libept1.5.0 mas não será instalado
E: Dependências desencontradas. Tente 'apt --fix-broken install' sem nenhum pacote (ou especifique uma solução).
usuario@polilinux:~$



  


2. Re: [Erro] Erro ao instalar packages via APT

niquelnausea
niquelnausea

(usa Arch Linux)

Enviado em 12/12/2019 - 22:54h

tentou o que a saída do comando sugeriu?
apt --fix-broken install



3. Re: [Erro] Erro ao instalar packages via APT

elias weslley da silva ferreira
sudoweeb

(usa Debian)

Enviado em 12/12/2019 - 23:16h

niquelnausea escreveu:

tentou o que a saída do comando sugeriu?
apt --fix-broken install



ele retorna mais um erro, dessa vez no dpkg:
usuario@polilinux:~$ sudo apt --fix-broken install
[sudo] senha para usuario:
Lendo listas de pacotes... Pronto
Construindo árvore de dependências
Lendo informação de estado... Pronto
Corrigindo dependências... Pronto
The following additional packages will be installed:
grub-common
Pacotes sugeridos:
multiboot-doc grub-emu
Os pacotes a seguir serão atualizados:
grub-common
1 pacotes atualizados, 0 pacotes novos instalados, 0 a serem removidos e 81 não atualizados.
3 pacotes não totalmente instalados ou removidos.
É preciso baixar 0 B/2.174 kB de arquivos.
Depois desta operação, 0 B adicionais de espaço em disco serão usados.
Você quer continuar? [S/n] s
Lendo logs de mudanças... Feito
(Lendo banco de dados ... 176545 ficheiros e directórios actualmente instalados.)
A preparar para desempacotar .../grub-common_2.02~beta3-5+deb9u2_amd64.deb ...
A descompactar grub-common (2.02~beta3-5+deb9u2) sobre (2.02~beta3-5+deb9u1) ...
dpkg: erro ao processar o arquivo /var/cache/apt/archives/grub-common_2.02~beta3-5+deb9u2_amd64.deb (--unpack):
a tentar sobre-escrever '/etc/grub.d/05_debian_theme', que também está no pacote oem 1.0.20
dpkg-deb: erro: o subprocesso colar foi morto pelo sinal (Pipe quebrado)
Erros foram encontrados durante o processamento de:
/var/cache/apt/archives/grub-common_2.02~beta3-5+deb9u2_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)







Patrocínio

Site hospedado pelo provedor RedeHost.
Linux banner
Linux banner
Linux banner

Destaques

Artigos

Dicas

Tópicos

Top 10 do mês

Scripts