Debian 7.2 (Wheezy) não reconhece wireless após instalação. [RESOLVIDO]

1. Debian 7.2 (Wheezy) não reconhece wireless após instalação. [RESOLVIDO]

Douglas
DouglasJC

(usa Arch Linux)

Enviado em 03/12/2013 - 13:12h

Olá pessoal, é o seguinte:

Após instalar o Debian 7.2 (Wheezy), 32 bits, no meu notebook (minha primeira vez com Debian puro) notei que o wireless dele não funciona.
Pesquisei na net e, pelo que parece, é um problema com um firmware ausente. E de fato, durante a inicialização do sistema aparece um aviso semelhante a isso:

rtlwifi/rtl8192cfw.bin (not found)

Partindo da ideia de que pode ser esse o problema, fiz o download do dito arquivo .bin, mas agora não faço a mínima ideia de como instalá-lo. Pesquisei na net mas não encontrei nenhum resultado. Algum de vocês pode me ajudar?

Desde já eu agradeço!




  


2. MELHOR RESPOSTA

Luís Fernando C. Cavalheiro
lcavalheiro

(usa Slackware)

Enviado em 03/12/2013 - 13:34h

DougApollyon escreveu:

Olá pessoal, é o seguinte:

Após instalar o Debian 7.2 (Wheezy), 32 bits, no meu notebook (minha primeira vez com Debian puro) notei que o wireless dele não funciona.
Pesquisei na net e, pelo que parece, é um problema com um firmware ausente. E de fato, durante a inicialização do sistema aparece um aviso semelhante a isso:

rtlwifi/rtl8192cfw.bin (not found)

Partindo da ideia de que pode ser esse o problema, fiz o download do dito arquivo .bin, mas agora não faço a mínima ideia de como instalá-lo. Pesquisei na net mas não encontrei nenhum resultado. Algum de vocês pode me ajudar?

Desde já eu agradeço!



E não vai reconhecer mesmo, meu filho! Os drivers para wireless geralmente estão no non-free. Faz assim: esquece esse [*****] de .bin e vamos fazer direito.

1) Plugue o computador em algum cabo de rede conectado à internet;
2) Como root, edite o arquivo /etc/apt/sources.list, acrescentando as palavras "contrib non-free" após cada ocorrência de "main". Vai ficar assim: "main contrib non-free";
3) Salve o arquivo;
4) Como root, rode os comandos
# apt-get update
# apt-get upgrade
# apt-get install linux-headers-3.2.0(dê um TAB aqui para dar o autocompletar) firmware-realtek

Reinicie o computador e seja feliz

3. Re: Debian 7.2 (Wheezy) não reconhece wireless após instalação. [RESOLVIDO]

Douglas
DouglasJC

(usa Arch Linux)

Enviado em 03/12/2013 - 14:13h

Meio caminho andado!

Os procedimentos acima funcionaram com excelência. Minha máquina já deixou de apresentar aquela mensagem durante a inicialização e o item "Sem fio" também apareceu nas configurações de rede. Porém, ele aparece como "não gerenciado". Como devo proceder agora?

E muito obrigado pela ajuda até agora.


4. Re: Debian 7.2 (Wheezy) não reconhece wireless após instalação. [RESOLVIDO]

Luís Fernando C. Cavalheiro
lcavalheiro

(usa Slackware)

Enviado em 03/12/2013 - 14:18h

DougApollyon escreveu:

Meio caminho andado!

Os procedimentos acima funcionaram com excelência. Minha máquina já deixou de apresentar aquela mensagem durante a inicialização e o item "Sem fio" também apareceu nas configurações de rede. Porém, ele aparece como "não gerenciado". Como devo proceder agora?

E muito obrigado pela ajuda até agora.


Não gerenciado significa (se eu me lembro bem) que não tem nenhuma configuração padrão pra wlan0 em /etc/network/interfaces. Seu gerenciador de redes (se você usa o GNOME é o NetworkManager, por exemplo) é quem terá que dar as configurações da placa wireless.
Não se preocupe, isso é o correto.

Se for o NetworkManager, dê um clique com o botão esquerdo do mouse no ícone do gerenciador de redes, procure o nome da sua rede wireless, clique nele e então coloque sua senha.


5. Re: Debian 7.2 (Wheezy) não reconhece wireless após instalação. [RESOLVIDO]

Douglas
DouglasJC

(usa Arch Linux)

Enviado em 03/12/2013 - 14:30h

Não funcionou...

Nas configurações de rede apenas aparece:

Sem fio - Não gerenciável
Endereço físico: (mac-address)
Segurança: (nada presente no campo)
Nome da Rede: (um <select> com uma única opção chamada "Outro")

Aí abaixo tem:

Um botão: Usar como Hotspost
E um outro botão desativado: Opções...

Não sei se tem algo a ver, mas a saída do iwconfig deu isso:

lo no wireless extensions.

wlan0 IEEE 802.11bgn ESSID:off/any
Mode:Managed Access Point: Not-Associated Tx-Power=0 dBm
Retry long limit:7 RTS thr=2347 B Fragment thr:off
Encryption key:off
Power Management:on

eth0 no wireless extensions.

E do ifconfig consta apenas a interface eth0 e a lo.





6. Re: Debian 7.2 (Wheezy) não reconhece wireless após instalação. [RESOLVIDO]

Douglas
DouglasJC

(usa Arch Linux)

Enviado em 03/12/2013 - 14:44h

Aqui, deu mais ou menos certo. Eu segui o seguinte tutorial:

------------------------------------------------------------------------

Após entrar com um dos comandos acima (para mim foi: wicd-client -n), deverá aparecer a interface gráfica wicd Network Manager.

Vá em: Preferences &#8594; General Settings

Coloque as devidas interfaces wireless (wlan0) e wired (com fio - eth0 ou deixe em branco).

Em External Programs, marque a opção "dhclient", e dê OK.

Ao escolher a rede a qual você irá conectar, deverá abrir a janela pedindo senha automaticamente.

Caso contrário, na janela principal, vá em "Propriedades" da rede que você quer, e se a opção "Usar encriptação" não estiver marcado, marque-a. Depois escolha "WPA 1/2 (Passphrase)" e em "Key", coloque a senha da rede Wireless.

* Lembre-se que a senha deverá ter entre 8 e 63 caracteres.

Dê OK. Na janela principal, marque a opção "Conectar automaticamente a esta rede" e pode fechá-la.

Assim, cada vez que iniciar, seu Debian Squeeze conectará automaticamente na rede Wireless.

-----------------------------------------------------------------------

Apareceu a minha rede dome&#347;tica, eu inseri a chave e o wicd retornou que a conexão foi estabelecida. Porém, nas configurações de rede daqui do GNOME continua a mensagem de "Sem fio - não gerenciável" e não consigo carregar nenhuma página. O que pode ser isso?


7. Re: Debian 7.2 (Wheezy) não reconhece wireless após instalação. [RESOLVIDO]

Luís Fernando C. Cavalheiro
lcavalheiro

(usa Slackware)

Enviado em 03/12/2013 - 14:45h

Posta o conteúdo do arquivo /etc/network/interfaces


8. Re: Debian 7.2 (Wheezy) não reconhece wireless após instalação. [RESOLVIDO]

Luís Fernando C. Cavalheiro
lcavalheiro

(usa Slackware)

Enviado em 03/12/2013 - 14:46h

Outra coisa: você tem o comando nm-applet? O wicd só faz cagada com a rede...


9. Re: Debian 7.2 (Wheezy) não reconhece wireless após instalação. [RESOLVIDO]

Douglas
DouglasJC

(usa Arch Linux)

Enviado em 03/12/2013 - 14:57h

Seguinte, agora estou conseguindo navegar normalmente na net utilizando o wireless. Porém, nas configurações de rede padão do Gnome continua constando como "Sem fio - Não gerenciável". Olha, acredito que o meu problema está resolvido. Mas, se não fosse encomodar demais, teria como me responder se há algum jeito de mudar isso?

A saída do /etc/network/interfaces (as duas últimas linhas eu que adicionei):

# This file describes the network interfaces available on your system
# and how to activate them. For more information, see interfaces(5).

# The loopback network interface
auto lo
iface lo inet loopback
allow-hotplug wlan0
iface wlan0 inet dhcp

O que é o nm-applet? Nunca tinha ouvido falar. E por que não é recomendado utilizar o wicd? Desculpe minha ignorância, sou novo nessa área.









10. Re: Debian 7.2 (Wheezy) não reconhece wireless após instalação. [RESOLVIDO]

Luís Fernando C. Cavalheiro
lcavalheiro

(usa Slackware)

Enviado em 04/12/2013 - 02:34h

DougApollyon escreveu:

Seguinte, agora estou conseguindo navegar normalmente na net utilizando o wireless. Porém, nas configurações de rede padão do Gnome continua constando como "Sem fio - Não gerenciável". Olha, acredito que o meu problema está resolvido. Mas, se não fosse encomodar demais, teria como me responder se há algum jeito de mudar isso?

A saída do /etc/network/interfaces (as duas últimas linhas eu que adicionei):

# This file describes the network interfaces available on your system
# and how to activate them. For more information, see interfaces(5).

# The loopback network interface
auto lo
iface lo inet loopback
allow-hotplug wlan0
iface wlan0 inet dhcp

O que é o nm-applet? Nunca tinha ouvido falar. E por que não é recomendado utilizar o wicd? Desculpe minha ignorância, sou novo nessa área.








Comenta (isto é, coloca um # no início) as duas últimas linhas e reinicia o computador.

O nm-applet é o daemon do NetworkManager. Rode o comando
 $ nm-applet & 

para iniciá-lo. O NM é muito mais confiável do que o wicd (eu pelo menos nunca consegui fazer o wicd funcionar).


11. Re: Debian 7.2 (Wheezy) não reconhece wireless após instalação. [RESOLVIDO]

Douglas
DouglasJC

(usa Arch Linux)

Enviado em 04/12/2013 - 14:06h

Finalmente! Deu certo!

Fiz o procedimento de comentar as duas últimas linhas do /etc/network/interfaces e reiniciei a máquina. Quando ligou, o network manager deixou de mostrar o status "Não gerenciável", porém eu não conseguia me conectar na minha rede doméstica pelo fato de os campos para inserção da chave estarem desativados. Então, rodei o comando "nm-applet &" no terminal e logo apareceu a tela de ativação da rede e consegui me conectar naturalmente. Agora, ao que tudo indica, está funcionando perfeitamente.

Muito obrigado pelo ajuda, meu amigo. Sem você eu jamais teria conseguido resolver esse empecilho. Mais uma vez, muito obrigado!



12. Re: Debian 7.2 (Wheezy) não reconhece wireless após instalação. [RESOLVIDO]

Luís Fernando C. Cavalheiro
lcavalheiro

(usa Slackware)

Enviado em 04/12/2013 - 15:06h

DougApollyon escreveu:

Finalmente! Deu certo!

Fiz o procedimento de comentar as duas últimas linhas do /etc/network/interfaces e reiniciei a máquina. Quando ligou, o network manager deixou de mostrar o status "Não gerenciável", porém eu não conseguia me conectar na minha rede doméstica pelo fato de os campos para inserção da chave estarem desativados. Então, rodei o comando "nm-applet &" no terminal e logo apareceu a tela de ativação da rede e consegui me conectar naturalmente. Agora, ao que tudo indica, está funcionando perfeitamente.

Muito obrigado pelo ajuda, meu amigo. Sem você eu jamais teria conseguido resolver esse empecilho. Mais uma vez, muito obrigado!


Disponha, meu querido. Depois você verifica se o nm-applet está marcado para inicializar automaticamente (no Debian eu não sei onde é, mas uma pesquisinha rápida te diz o que fazer.

Agora um bizu: aqui no VOL tem o recurso de marcar a "melhor resposta", isto é, aquela indicação que foi na mosca pra te orientar e resolver sua vida. Assim, outras pessoas que passarem o mesmo que você e pesquisarem encontrarão orientações precisas. Marque a resposta que resolveu sua vida como melhor resposta e tudo fica lindo!






Patrocínio

Site hospedado pelo provedor RedeHost.
Linux banner
Linux banner

Destaques

Artigos

Dicas

Tópicos

Top 10 do mês

Scripts